Copyright © 2021 Vizrt. All rights reserved.

No part of this software, documentation or publication may be reproduced, transcribed, stored in a retrieval system, translated into any language, computer language, or transmitted in any form or by any means, electronically, mechanically, magnetically, optically, chemically, photocopied, manually, or otherwise, without prior written permission from Vizrt. Vizrt specifically retains title to all Vizrt software. This software is supplied under a license agreement and may only be installed, used or copied in accordance to that agreement.

Disclaimer

Vizrt provides this publication "as is" without warranty of any kind, either expressed or implied. This publication may contain technical inaccuracies or typographical errors. While every precaution has been taken in the preparation of this document to ensure that it contains accurate and up-to-date information, the publisher and author assume no responsibility for errors or omissions. Nor is any liability assumed for damages resulting from the use of the information contained in this document. Vizrt’s policy is one of continual development, so the content of this document is periodically subject to be modified without notice. These changes will be incorporated in new editions of the publication. Vizrt may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time. Vizrt may have patents or pending patent applications covering subject matters in this document. The furnishing of this document does not give you any license to these patents.

Technical Support

For technical support and the latest news of upgrades, documentation, and related products, visit the Vizrt web site at www.vizrt.com.

Created on
2021/12/10
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Introduction</td>
<td>10</td>
</tr>
<tr>
<td>1.1</td>
<td>Feedback and Suggestions</td>
<td>10</td>
</tr>
<tr>
<td>1.2</td>
<td>Graphic Hub Log Files</td>
<td>10</td>
</tr>
<tr>
<td>1.2.1</td>
<td>Graphic Hub Component Logs</td>
<td>11</td>
</tr>
<tr>
<td>1.2.2</td>
<td>Graphic Hub REST Log Files</td>
<td>11</td>
</tr>
<tr>
<td>1.2.3</td>
<td>Graphic Hub ImEx Log Files</td>
<td>11</td>
</tr>
<tr>
<td>2</td>
<td>Graphic Hub Administrator Guide</td>
<td>12</td>
</tr>
<tr>
<td>2.1</td>
<td>System Installation</td>
<td>12</td>
</tr>
<tr>
<td>2.1.1</td>
<td>Installation Prerequisites</td>
<td>12</td>
</tr>
<tr>
<td>2.1.2</td>
<td>System Requirements</td>
<td>14</td>
</tr>
<tr>
<td>2.1.3</td>
<td>Installing Graphic Hub Applications</td>
<td>24</td>
</tr>
<tr>
<td>2.1.4</td>
<td>Licensing Graphic Hub</td>
<td>34</td>
</tr>
<tr>
<td>2.2</td>
<td>Overview</td>
<td>37</td>
</tr>
<tr>
<td>2.2.1</td>
<td>Graphic Hub Applications</td>
<td>38</td>
</tr>
<tr>
<td>2.2.2</td>
<td>Graphic Hub Modes</td>
<td>40</td>
</tr>
<tr>
<td>2.2.3</td>
<td>Selecting a Graphic Hub Mode</td>
<td>42</td>
</tr>
<tr>
<td>2.2.4</td>
<td>General Database Information</td>
<td>43</td>
</tr>
<tr>
<td>2.2.5</td>
<td>Graphic Hub Naming Service</td>
<td>46</td>
</tr>
<tr>
<td>2.3</td>
<td>Startup and Shutdown</td>
<td>47</td>
</tr>
<tr>
<td>2.3.1</td>
<td>Graphic Hub Startup</td>
<td>48</td>
</tr>
<tr>
<td>2.3.2</td>
<td>Graphic Hub Shut Down</td>
<td>50</td>
</tr>
<tr>
<td>2.3.3</td>
<td>Graphic Hub Emergency Shutdown</td>
<td>53</td>
</tr>
<tr>
<td>2.4</td>
<td>Database Management</td>
<td>55</td>
</tr>
<tr>
<td>2.4.1</td>
<td>Main and Replication Servers with Failover</td>
<td>55</td>
</tr>
<tr>
<td>2.4.2</td>
<td>User and Group Management</td>
<td>57</td>
</tr>
<tr>
<td>2.4.3</td>
<td>Test a Replication Server</td>
<td>65</td>
</tr>
<tr>
<td>2.4.4</td>
<td>Data Errors</td>
<td>67</td>
</tr>
<tr>
<td>2.4.5</td>
<td>Import External Images</td>
<td>71</td>
</tr>
<tr>
<td>2.4.6</td>
<td>Locate Duplicate Files</td>
<td>74</td>
</tr>
<tr>
<td>2.4.7</td>
<td>Add Metadata</td>
<td>75</td>
</tr>
<tr>
<td>2.4.8</td>
<td>Replace File References</td>
<td>86</td>
</tr>
<tr>
<td>2.4.9</td>
<td>Direct Deploy Copy</td>
<td>88</td>
</tr>
<tr>
<td>2.4.10</td>
<td>Graphic Hub Search</td>
<td>95</td>
</tr>
<tr>
<td>2.4.11</td>
<td>Server Information</td>
<td>105</td>
</tr>
<tr>
<td>2.4.12</td>
<td>Daily Backup Using a Second Graphic Hub</td>
<td>119</td>
</tr>
</tbody>
</table>
2.4.13 Detect and Solve Server Differences ......................................................... 122
2.5 Viz Pilot Database Management ................................................................. 125
  2.5.1 Important Pre-installation Information ..................................................... 126
  2.5.2 Schema Changes .................................................................................... 128
  2.5.3 Key Features and Workflow of Graphic Hub 3 as Viz Pilot Back-end System ......................................................................................... 129
  2.5.4 Main and Replication Servers .................................................................. 136
  2.5.5 Import Viz Pilot Data Schema .................................................................. 137
  2.5.6 Resolve Viz Pilot Data Differences Between Graphic Hubs ................... 143
2.6 Graphic Hub Archives .................................................................................. 149
  2.6.1 Archives View ........................................................................................ 150
  2.6.2 Search View ............................................................................................ 154
  2.6.3 Contents View ........................................................................................ 155
  2.6.4 Details View ............................................................................................ 156
  2.6.5 Archive Folders ....................................................................................... 157
  2.6.6 Import Archives ....................................................................................... 157
  2.6.7 Export Archives ....................................................................................... 161
  2.6.8 Import Viz 2.x Data and Archives .............................................................. 165
2.7 Troubleshooting ............................................................................................ 170
  2.7.1 Known Limitations, Problems and Workarounds ....................................... 170
  2.7.2 Drivers for HASP Runtime Installation Fails ............................................. 174
  2.7.3 Troubleshooting Networks, Virtual Adapters and Session Disconnects ...... 175
  2.7.4 Restoring Corrupted Files ....................................................................... 176
  2.7.5 Graphic Hub Manager and Viz Artist Troubleshooting .............................. 177
  2.7.6 Replication Troubleshooting ................................................................. 178
  2.7.7 Deploy Troubleshooting ......................................................................... 180
  2.7.8 Graphic Hub Terminal Server Startup Issues .......................................... 183
  2.7.9 Pilot Clients Have No Database Connection ............................................. 183
  2.7.10 Troubleshooting Graphic Hub REST ...................................................... 184
  2.7.11 Legacy Dongle Troubleshooting ............................................................ 185
  2.7.12 Browser Troubleshooting ...................................................................... 185
  2.7.13 List of Ports Used for Graphic Hub Network Connectivity ...................... 186
  2.7.14 Frequently Asked Questions .................................................................. 187
3 Graphic Hub Deploy Agent ............................................................................. 189
  3.1 Deploy Agent Modes ................................................................................... 189
    3.1.1 Standard Mode Supported Options ....................................................... 189
    3.1.2 Direct Deploy Copy Mode Supported Options ......................................... 190
    3.1.3 Additional Information on Data Modes .................................................. 191
### 3.1.4 Standard and DDC Supported Options ......................................................... 191

### 3.2 Deploy Agent Properties ............................................................................... 192

#### 3.2.1 Properties of a Deploy Agent ................................................................... 192

#### 3.2.2 Configuration Panel ................................................................................ 196

#### 3.2.3 Version Info Panel .................................................................................. 198

#### 3.2.4 High Availability Panel ............................................................................ 198

### 3.3 Rebuild Original Structure ............................................................................. 199

#### 3.3.1 To Create a New File Based Deploy Task .................................................. 199

#### 3.3.2 Behavior .................................................................................................... 203

### 3.4 Copy to Target Folder Only ............................................................................ 205

### 3.5 Schedule a Deploy Task ................................................................................ 207

#### 3.5.1 To Add a Deploy Agent for Use ................................................................. 207

#### 3.5.2 To Schedule a Deploy Task ......................................................................... 209

### 3.6 Maintain Deploy Agents and Tasks ................................................................. 213

#### 3.6.1 To View Deploy Tasks ............................................................................... 214

#### 3.6.2 To Modify a Deploy Task ........................................................................... 214

#### 3.6.3 To Search Scheduled Deploy Tasks ........................................................... 216

#### 3.6.4 To Search Finished Deploy Tasks ............................................................... 217

#### 3.6.5 To Maintain Deploy Agents ....................................................................... 217

### 4 Graphic Hub ImEx Agent .................................................................................. 222

#### 4.1 Supported Import Media Types ..................................................................... 223

#### 4.2 Notable Limitations ....................................................................................... 223

#### 4.3 User Interface ................................................................................................ 223

#### 4.4 Initial Setup .................................................................................................... 225

##### 4.4.1 Quick Start ................................................................................................. 225

##### 4.4.2 Configure ImEx for Media Staging .......................................................... 230

##### 4.4.3 Basic Media Sequencer Configuration ...................................................... 230

#### 4.5 Configuration .................................................................................................. 233

##### 4.5.1 Webserver Configuration .......................................................................... 234

##### 4.5.2 Connection Settings ................................................................................ 234

##### 4.5.3 Import Settings .......................................................................................... 235

##### 4.5.4 Log Settings ............................................................................................... 235

### 4.6 Manage Imports .............................................................................................. 236

#### 4.6.1 Import Behavior .......................................................................................... 236

#### 4.6.2 Manage Destination Directories ................................................................. 237

#### 4.6.3 Manage Watchfolders ............................................................................... 240

#### 4.6.4 Manage GH REST Hosts ............................................................................. 243
4.6.5 Manage Pre-Authenticated Hosts ................................................................. 246
4.7 Monitor the Asset Import .............................................................................. 249
  4.7.1 Monitor Distribution Plans ........................................................................ 249
  4.7.2 Monitor Availability Report ...................................................................... 251
4.8 Log and Report ............................................................................................ 253
  4.8.1 To View ImEx Agent Logs ........................................................................ 254
  4.8.2 To Manage Reports .................................................................................. 254
  4.8.3 To Create a Report ................................................................................... 255
4.9 Load Balancing ............................................................................................ 256
  4.9.1 ImEx Agent Related Configuration ......................................................... 256
  4.9.2 GH REST Related Configuration .............................................................. 257
4.10 Troubleshooting GH ImEx Agent ............................................................... 257
  4.10.1 Unable to Connect to GH ImEx Agent Service ....................................... 258
  4.10.2 Status Box Displays an Error ................................................................. 259
  4.10.3 Status Box Displays a Warning .............................................................. 260
  4.10.4 Media Staging Status Shows an Error .................................................... 261
  4.10.5 Media Staging Status Shows a Warning ................................................ 264
5 Graphic Hub Manager ..................................................................................... 266
  5.1 Main Menu ................................................................................................... 266
    5.1.1 Server Menu .......................................................................................... 267
    5.1.2 View Menu ........................................................................................... 268
    5.1.3 Tools Menu ........................................................................................... 269
    5.1.4 Extra Menu ........................................................................................... 270
    5.1.5 Pilot Menu ............................................................................................. 271
    5.1.6 Info Menu ............................................................................................. 271
  5.2 Preferences .................................................................................................. 271
    5.2.1 General .................................................................................................. 272
    5.2.2 Import .................................................................................................... 278
    5.2.3 Viz ......................................................................................................... 279
    5.2.4 Monitor Servers ..................................................................................... 279
    5.2.5 Agents ................................................................................................... 280
    5.2.6 Archives ................................................................................................. 281
  5.3 Explorer ........................................................................................................ 286
    5.3.1 Explorer Columns .................................................................................. 287
    5.3.2 Column Headings .................................................................................. 287
    5.3.3 Explorer Icons ....................................................................................... 288
    5.3.4 Tool Bar ................................................................................................. 289
<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.3.5</td>
<td>Display Files as Icons</td>
<td>290</td>
</tr>
<tr>
<td>5.4</td>
<td>Servers and Folders</td>
<td>291</td>
</tr>
<tr>
<td>5.4.1</td>
<td>Folders</td>
<td>293</td>
</tr>
<tr>
<td>5.4.2</td>
<td>Tree Structure</td>
<td>294</td>
</tr>
<tr>
<td>5.4.3</td>
<td>Working with Folders</td>
<td>294</td>
</tr>
<tr>
<td>5.4.4</td>
<td>Folder Properties</td>
<td>297</td>
</tr>
<tr>
<td>5.4.5</td>
<td>Working with Files</td>
<td>301</td>
</tr>
<tr>
<td>5.4.6</td>
<td>File Properties</td>
<td>309</td>
</tr>
<tr>
<td>5.4.7</td>
<td>Folder and File Expiration Dates</td>
<td>315</td>
</tr>
<tr>
<td>5.4.8</td>
<td>Illegal Characters</td>
<td>317</td>
</tr>
<tr>
<td>5.5</td>
<td>Graphic Hub Login and Log Out</td>
<td>318</td>
</tr>
<tr>
<td>5.5.1</td>
<td>Single Server Login Start Up</td>
<td>318</td>
</tr>
<tr>
<td>5.5.2</td>
<td>Multiple Server Login Start-up</td>
<td>319</td>
</tr>
<tr>
<td>5.5.3</td>
<td>Replication Server Login</td>
<td>321</td>
</tr>
<tr>
<td>5.5.4</td>
<td>Auto Login</td>
<td>322</td>
</tr>
<tr>
<td>5.5.5</td>
<td>Logout</td>
<td>325</td>
</tr>
<tr>
<td>5.6</td>
<td>Add-ons Panel</td>
<td>326</td>
</tr>
<tr>
<td>5.7</td>
<td>Journal Panel</td>
<td>328</td>
</tr>
<tr>
<td>5.7.1</td>
<td>Journal Tool Bar</td>
<td>329</td>
</tr>
<tr>
<td>5.7.2</td>
<td>Search the Journal</td>
<td>330</td>
</tr>
<tr>
<td>5.7.3</td>
<td>Automatic Journal Backup</td>
<td>331</td>
</tr>
<tr>
<td>5.7.4</td>
<td>Export and Import of Journal Entries</td>
<td>332</td>
</tr>
<tr>
<td>5.8</td>
<td>Alerts</td>
<td>334</td>
</tr>
<tr>
<td>5.8.1</td>
<td>Server Alerts</td>
<td>334</td>
</tr>
<tr>
<td>5.8.2</td>
<td>To Configure Send E-mail</td>
<td>334</td>
</tr>
<tr>
<td>5.8.3</td>
<td>Importing and Exporting Alert Settings</td>
<td>336</td>
</tr>
<tr>
<td>5.9</td>
<td>Archives Panel</td>
<td>336</td>
</tr>
<tr>
<td>5.10</td>
<td>Action Log</td>
<td>337</td>
</tr>
<tr>
<td>5.10.1</td>
<td>Action Log Parameters</td>
<td>338</td>
</tr>
<tr>
<td>5.10.2</td>
<td>To Add Additional Files</td>
<td>338</td>
</tr>
<tr>
<td>5.10.3</td>
<td>To Action the Operation</td>
<td>339</td>
</tr>
<tr>
<td>5.11</td>
<td>Graphic Hub License</td>
<td>339</td>
</tr>
<tr>
<td>5.11.1</td>
<td>To Apply a License</td>
<td>339</td>
</tr>
<tr>
<td>5.12</td>
<td>Graphic Hub Manager Customization</td>
<td>340</td>
</tr>
<tr>
<td>5.12.1</td>
<td>Default Layouts</td>
<td>341</td>
</tr>
<tr>
<td>5.12.2</td>
<td>Layout Maintenance</td>
<td>342</td>
</tr>
<tr>
<td>5.12.3</td>
<td>Layout Procedures</td>
<td>343</td>
</tr>
<tr>
<td>7.4.1</td>
<td>Service Discovery Settings .................................................................</td>
<td>399</td>
</tr>
<tr>
<td>7.4.2</td>
<td>Journal/Logging Settings ......................................................................</td>
<td>404</td>
</tr>
<tr>
<td>7.4.3</td>
<td>E-mail Configuration ...........................................................................</td>
<td>405</td>
</tr>
<tr>
<td>7.4.4</td>
<td>Scheduled Tasks ..................................................................................</td>
<td>407</td>
</tr>
<tr>
<td>7.4.5</td>
<td>Advanced Settings ...............................................................................</td>
<td>410</td>
</tr>
<tr>
<td>7.4.6</td>
<td>Change Terminal Password ....................................................................</td>
<td>411</td>
</tr>
<tr>
<td>7.5</td>
<td>Help and About ..................................................................................</td>
<td>411</td>
</tr>
<tr>
<td>7.5.1</td>
<td>Graphic Hub License ...........................................................................</td>
<td>412</td>
</tr>
<tr>
<td>7.6</td>
<td>System Status Panel ...........................................................................</td>
<td>415</td>
</tr>
<tr>
<td>7.7</td>
<td>Event Log Panel ..................................................................................</td>
<td>416</td>
</tr>
</tbody>
</table>
1 Introduction

This is the Graphic Hub Administrator Guide, which provides the information needed to configure and operate the Graphic Hub.

This page contains the following topics:

- Feedback and Suggestions
- Graphic Hub Log Files
  - Graphic Hub Component Logs
  - Graphic Hub REST Log Files
  - Graphic Hub ImEx Log Files

1.1 Feedback And Suggestions

We encourage suggestions and feedback about our products and documentation. To give feedback and/or suggestions, please contact your local Vizrt customer support team at www.vizrt.com.

1.2 Graphic Hub Log Files

A Graphic Hub overall report, which contains all Graphic Hub log files and additional system information, can be generated in the Graphic Hub Terminal.

All services installed on the same machine will be included in the export.

If there is no Graphic Hub terminal running on the workstation where the Graphic Hub Deploy Agent is running select and generate these log files:

- Graphic Hub Log files
  - Location: <current Graphic Hub data directory>/LogFiles
  - Purpose: Graphic Hub runtime and error information.
- System Event Log
  - Location: Start > Run... > eventvwr.exe > Event Viewer > Windows Logs
  - Name: System
  - Purpose: Information from the current windows system.
  - To create: Right click on System and select Save all Events as...
- Application Event Log
  - Location: Start > Run... > eventvwr.exe > Event Viewer > Windows Logs
  - Name: Application
  - Purpose: Windows crash information of programs
  - To create: Right click on Application and select Save all Events as...
- Vizrt Event Log
  Graphic Hub Deploy Agent system log (only exists if Graphic Hub Deploy Agent is installed).
  - Location: Start > Run... > eventvwr.exe > Event Viewer > Applications and Services Logs
  - Name: Vizrt
• **Purpose:** Deploy agent event log.
• **To create:** Right click on Vizrt and select **Save all Events as...**

### 1.2.1 Graphic Hub Component Logs

In general, all Graphic Hub Components log files containing important information:

- **Location:** %PROGRAMDATA%\vizrt\COMPONENTNAME
- **Purpose:** Configuration and logs of the Graphic Hub component

### 1.2.2 Graphic Hub REST Log Files

A Graphic Hub REST report, which contains all relevant log files and additional system information according to Graphic Hub REST, can be generated in the Graphic Hub REST web interface.

If this is not possible select and generate these log files:

- **Location:** %ProgramData%\vizrt\Viz GH Rest\logs
- **Purpose:** Connection, error and event logs of the Graphic Hub REST.

### 1.2.3 Graphic Hub ImEx Log Files

A Graphic Hub ImEx Report, which contains all relevant log files and additional system information according to Graphic Hub ImEx, can be generated in the Graphic Hub ImEx web interface.

If this is not possible select and generate these log files:

- **Location:** %ProgramData%\vizrt\Viz GH ImEx Agent\logs
- **Purpose:** Connection, error and event logs of the Graphic Hub ImEx Agent.
2 Graphic Hub Administrator Guide

This is the Graphic Hub Administrator Guide, it covers the information needed to configure and operate the Graphic Hub and its related components:

- Graphic Hub Administrator Guide
- Graphic Hub Deploy Agent
- Graphic Hub ImEx Agent
- Graphic Hub Manager
- Graphic Hub REST
- Graphic Hub Terminal

2.1 System Installation

The Graphic Hub can be installed in a Cluster, a Multi User (see Server Requirements) or a Single installation mode (see Workstation Requirements). For more information on the different installation options, see Which Graphic Hub Mode. The initial mode selection is performed during installation. The Graphic Hub mode can also be changed and configured, once the Graphic Hub Terminal has been started (see Graphic Hub Modes).

All Graphic Hub configurations are installed from one installation bundle, which includes the Graphic Hub and the Graphic Hub Terminal.

This section contains information on the following topics:

- Installation Prerequisites
- System Requirements
- Installing Graphic Hub Applications
- Licensing Graphic Hub

2.1.1 Installation Prerequisites

Before installing, upgrading or removing the Graphic Hub, make sure that you have gone through this check-list:

- Shut down the Graphic Hub, and stop the GH Terminal service.
- Optional: When upgrading create a backup of the data directory by copying it. The cluster solution is the only server setup with real-time data replication capabilities. For all other system configurations, backup procedures must be executed manually.

**Note:** Backup operations can only be done when the server is shut down.

- When upgrading Graphic Hub, make sure that there are no open transactions on either of the existing systems (see Check There are no Open Transactions).

**Note:** The Open Transactions setting is only available for servers in a Cluster environment.
In a Cluster configuration, the Graphic Hub version number must be identical on the Main and Replication machines. Mixed versions of Graphic Hub are not supported. Failure to heed this can lead to serious system failure and data loss.

In a Cluster configuration, the Main and Replication machines must be started in mode Main or Replication. Mixed Graphic Hub modes in a cluster are not supported. Failure to heed this can lead to serious system failure and data loss.

Make sure that the data directories of the main and replication servers are exclusive, so that no other Graphic Hub or process uses these directories.

Do not use Windows Remote Desktop to install and/or work with Graphic Hub on versions below 3.0.0. Instead, use another remote tool, for example VNC.

Make sure that no other applications on the server workstations can cause performance problems. Some examples of situations when databases should not be installed are:
- The general CPU usage is above normal.
- Viz Artist is used on the same machine.
- Other databases run on the same machine.
- The network traffic is extensive.

⚠️ **Note:** Running a virus scanner on the Graphic Hub machine can decrease the performance of the database.

The performance of the database depends upon the performance of the physical machine the database runs on. As system performance increases, so does the database performance. This is why it is highly recommended to use a server with high performance.

**Check Open Transactions**

From Graphic Hub 3.0, the status of open transactions is shown in the GH Terminal main screen:

⚠️ **Warning:** Do not proceed with an upgrade if there are any open transactions!

If required, the Graphic Hub Console can also be opened to check for open transactions. In the Graphic Hub Terminal, click **Report > Graphic Hub Console**.

For all previous Graphic Hub versions, use the following procedure:

1. Open Graphic Hub Manager on both the machines (Main and Replication).
2. From the main menu, select **Tools > Monitor Servers**.
3. Check that Open Transactions are at zero.
2.1.2 System Requirements

This section details the requirements for multiple clients to access a Graphic Hub (installations with more than one server), which includes Multi User, Main Server and Replication Server configurations, as described in the Graphic Hub Modes section.

**Note:** Support for any specific operating system or service pack version is only provided by Vizrt as long as it is officially supported by Microsoft. Support end dates are announced in the release notes for new versions of all Graphic Hub components. Other Vizrt products may be supported on other platforms and the documentation and release notes for the product in question should be consulted separately.

This page contains the following topics:

- Graphic Hub Requirements
- Graphic Hub as Viz Pilot Backend System
  - Small Installations
  - Medium Installations
  - Large Installations
- Deploy Agent Requirements
- Graphic Hub REST Requirements
- ImEx Agent Requirements
- Workstation Requirements
  - Hardware Requirements
  - Deploy Agent Requirements
  - Graphic Hub REST Requirements
  - Graphic Hub ImEx Agent Requirements
- Service Dependencies

**Graphic Hub Requirements**

These are the minimum requirements for the Graphic Hub:

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Microsoft Windows Server™ 2012 R2 (64-bit)</td>
</tr>
<tr>
<td></td>
<td>Microsoft Windows Server™ 2016 (64-bit)</td>
</tr>
<tr>
<td></td>
<td>Microsoft Windows Server™ 2019 (64-bit)</td>
</tr>
<tr>
<td></td>
<td>The above operating systems as virtual machine on ESXi 6.0 Update 2 (build 3620759) or higher.</td>
</tr>
<tr>
<td></td>
<td>No other applications may be installed on the server machine.</td>
</tr>
<tr>
<td></td>
<td>Anti-virus software without endpoint protection and excluding the following Graphic Hub processes:</td>
</tr>
<tr>
<td></td>
<td>- VizGH.exe</td>
</tr>
<tr>
<td></td>
<td>- VizGHNamingservice.exe</td>
</tr>
</tbody>
</table>
## Component Requirements

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Component</strong></td>
<td><strong>Minimum Requirement</strong></td>
</tr>
<tr>
<td>VizGHTerminalService.exe</td>
<td></td>
</tr>
</tbody>
</table>

### IMPORTANT! All data directories must be excluded from anti-virus scan operations and monitoring.

#### Browser

Browser requirements (minimum and recommended versions):
- Google Chrome (recommended): 45+ (tested with 91)
- Mozilla Firefox: 41+ (tested with 89)
- Microsoft Internet Explorer: 10+ (tested with 21H1)

#### CPU

Eight cores with 2.4 GHz base frequency

#### RAM

8 GB DDR4-1866

#### HDD

Hard disk performance has a noticeable impact on the overall performance of the Graphic Hub. Therefore, the recommended hard disk setup is a RAID 10 configuration over all disks, with indexing service disabled for the directory containing the Graphic Hub data:
- **Expand priority**: Medium
- **Rebuild priority**: High
- **Cache Usage**: 50% Read, 50% Write

The amount of disk space depends on the amount of data to be stored, but should be at least 400 GB for data.

In addition, 40 GB is required as a separate Operating System partition.

---

**Note:** It is not possible to use mapped network drives for the Graphic Hub data directory for performance and data integrity reasons.

**Warning:** Running the Graphic Hub on a system without enough available hard disk space can cause warnings, unexpected behavior, and data loss. Make sure to stay well within the limits as described in Warning and Error Thresholds.

#### Network

A redundant (teamed) setup with two Gigabit network adapters is recommended.

#### Power Supply

A redundant power supply is highly recommended.
Graphic Hub as Viz Pilot Backend System

When the Graphic Hub is used as the data back end for Viz Pilot, the following requirements need to be considered in addition to the Graphic Hub Requirements. In general, the CPU, RAM and hard disk requirements are highly dependent on the amount of graphics, Pilot data (VCP data elements, templates, variants and concepts) the database contains, and how many parallel clients (Viz Artist/Viz Engine, VCP/ActiveX, Viz Story, Viz Pilot Edge) are active.

For a the list of compatible versions, see Viz Pilot Database Management.

Small Installations

Small setups run on a single machine with all the necessary components installed: Graphic Hub 5/4 Free, Graphic Hub REST, Data Server and Media Sequencer. Such an installation can serve up to five Viz Artist/Engine clients based on IP, and up to three VCP/ActiveX clients. Depending on the hardware specifications, performance is limited by the amount of VCP data elements, templates, variants and concepts.

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU</td>
<td>Eight cores with 3 GHz base frequency.</td>
</tr>
<tr>
<td>RAM</td>
<td>16 GB DDR4-1866</td>
</tr>
<tr>
<td>HDD</td>
<td>The amount of disk space depends on the amount of data to be stored.</td>
</tr>
</tbody>
</table>
**Medium Installations**

Medium Installations run Graphic Hub in Multiuser mode and Graphic Hub REST on one physical server.

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU</td>
<td>12 cores with 3 GHz base frequency.</td>
</tr>
<tr>
<td>RAM</td>
<td>16 GB DDR4-1866</td>
</tr>
<tr>
<td>HDD</td>
<td>The amount of disk space depends on the amount of data to be stored.</td>
</tr>
</tbody>
</table>
Large Installations

For customers with larger installations, it is required to run Graphic Hub and Graphic Hub REST on separate and more powerful hardware. If performance issues occur, the Graphics and VCP content should also be separated. For an optional failsafe system, at least two instances of Graphic Hub REST and an HTTP Proxy are required.
Minimum suggested configuration:

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU</td>
<td>16 cores with 3 GHz base frequency</td>
</tr>
<tr>
<td>RAM</td>
<td>32 GB DDR4-1866</td>
</tr>
<tr>
<td>HDD</td>
<td>The amount of disk space depends on the amount of data to be stored.</td>
</tr>
</tbody>
</table>

This is an illustration of an example installation scenario, of a Graphic Hub cluster with redundant Graphic HUB REST service. The HTTP proxies are optional, and only needed for complete redundancy of the Graphic Hub REST service.

**IMPORTANT!** The hardware configuration for a large installation needs to be defined in collaboration with Vizrt based on the individual customer’s requirements.

**Note:** This illustration covers redundancy of Graphic Hub and Graphic Hub REST only. It does not cover redundancy for Viz Pilot or Media Sequencer.

Deploy Agent Requirements

This section details the requirements for the Deploy Agent:
<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum Requirement</th>
</tr>
</thead>
</table>
| **System** | · Microsoft Windows Server™ 2012 R2 (64-bit)  
· Microsoft Windows Server™ 2016 (64-bit)  
· Microsoft Windows Server™ 2019 (64-bit)  
· The above operating systems as virtual machine on ESXi 6.0 Update 2 (build 3620759) or higher.  
· Anti-virus software without endpoint protection and excluding the Deploy Agent process: VizGHDeployAgentService.exe. |
| **CPU** | Four cores with 2.4 GHz base frequency. |
| **RAM** | 4 GB DDR4-1866 |
| **HDD** | 80 GB of free disk space for data.  
In addition, 40 GB is required as a separate Operating System partition. |

⚠️ **Note:** Support for any specific operating system or service pack version will only be provided by Vizrt as long as it is officially supported by Microsoft. Support end dates will be announced in the release notes for new versions of Graphic Hub. Other Vizrt products may be supported on other platforms, however, and the documentation and release notes for the product in question should be consulted separately.

### Graphic Hub REST Requirements

This section details the requirements for the Graphic Hub REST:

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum Requirement</th>
</tr>
</thead>
</table>
| **System** | · Microsoft Windows Server™ 2012 R2 (64-bit)  
· Microsoft Windows Server™ 2016 (64-bit)  
· Microsoft Windows Server™ 2019 (64-bit)  
· The above operating systems as virtual machine on ESXi 6.0 Update 2 (build 3620759) or higher.  
· Anti-virus software without endpoint protection and excluding the Graphic Hub REST process: VizGHERestService.exe.  
No other applications, except the Graphic Hub in 5/4 Free or Localhost configurations, may be installed on the server machine. |
<p>| <strong>Browser</strong> | Browser requirements (minimum and recommended versions): |</p>
<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum Requirement</th>
</tr>
</thead>
</table>
|           | Google Chrome (recommended): 45+ (tested with 91)  
|           | Mozilla Firefox: 41+ (tested with 89)  
|           | Microsoft Internet Explorer: 10+ (tested with 21H1) |

**CPU**

Eight cores with 2.4 GHz base frequency.

**RAM**

4 GB DDR4-1866

**HDD**

400 GB of free disk space for data. In addition, 40 GB is required as a separate Operating System partition.

⚠️ **Note:** If you also want to run this machine as your general web server, Vizrt cannot make specific recommendations regarding hardware requirements.

### ImEx Agent Requirements

This section details the requirements for the ImEx Agent:

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum Requirement</th>
</tr>
</thead>
</table>
| System    | Microsoft Windows Server™ 2012 R2 (64-bit)  
|           | Microsoft Windows Server™ 2016 (64-bit)  
|           | Microsoft Windows Server™ 2019 (64-bit)  
|           | The above operating systems as virtual machine on ESXi 6.0 Update 2 (build 3620759) or higher.  
|           | Anti-virus software without endpoint protection and excluding the ImEx Agent process:  
|           | VizGHImExAgentService.exe |

**CPU**

Four cores with 2.4 GHz base frequency.

**RAM**

4 GB DDR4-1866

**HDD**

5 GB of free disk space for temporary data on the operating system partition.

### Workstation Requirements

This section details the requirements for installations on laptops and desktop workstations running the Graphic Hub in Localhost or 5/4 Free mode or for demonstration purposes.
Hardware Requirements

The following hardware is required:

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td>· Microsoft Windows® 10 IoT Enterprise 2019 LTSC (64-bit)</td>
</tr>
</tbody>
</table>
| Browser   | Browser requirements (minimum and recommended versions):  
· Google Chrome (recommended): 45+ (tested with 91)  
· Mozilla Firefox: 41+ (tested with 89)  
· Microsoft Internet Explorer: 10+ (tested with 21H1) |
| CPU       | Two cores with 2.4 GHz base frequency. |
| RAM       | 4 GB DDR4-1866 |
| HDD       | The amount of disk space depends on the amount of data to be stored, but should be at least 50 GB for data.  
In addition, 40 GB is required as a separate Operating System partition. |

Deploy Agent Requirements

The following hardware is required for the Deploy Agent:

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td>· Microsoft Windows® 10 IoT Enterprise 2019 LTSC (64-bit)</td>
</tr>
<tr>
<td>CPU</td>
<td>Two cores with 2.4 GHz base frequency.</td>
</tr>
<tr>
<td>RAM</td>
<td>4 GB DDR4-1866</td>
</tr>
</tbody>
</table>
| HDD       | The amount of disk space depends on the amount of data to be stored, but should be at least 5 GB for data.  
In addition, 40 GB is required as a separate Operating System partition. |

Graphic Hub REST Requirements

The following are required for the Graphic Hub REST:
Component | Minimum Requirement
--- | ---
**System** | · Microsoft Windows® 10 IoT Enterprise 2019 LTSC (64-bit)

**Browser** | Browser requirements (minimum and recommended versions):
 · Google Chrome (recommended): 45+ (tested with 91)
 · Mozilla Firefox: 41+ (tested with 89)
 · Microsoft Internet Explorer: 10+ (tested with 21H1)

**CPU** | Two cores with 2.4 GHz base frequency.

**RAM** | 4 GB DDR4-1866

**HDD** | 200 GB of free disk space for data.
In addition, 40 GB is required as a separate Operating System partition.

**Graphic Hub ImEx Agent Requirements**
The following are required for the Graphic Hub ImEx Agent:

 Component | Minimum Requirement
--- | ---
**System** | · Microsoft Windows® 10 IoT Enterprise 2019 LTSC (64-bit)

**Browser** | Browser requirements (minimum and recommended versions):
 · Google Chrome (recommended): 45+ (tested with 91)
 · Mozilla Firefox: 41+ (tested with 89)
 · Microsoft Internet Explorer: 10+ (tested with 21H1)

**CPU** | Two cores with 2.4 GHz base frequency

**RAM** | 4 GB DDR4-1866

**HDD** | 5 GB of free disk space for temporary data on the operating system partition.

**Service Dependencies**
The different components of the Graphic Hub depend on certain system services. If the services are not running during installation, a notification appears with information about the required services. The services are enabled by default on pre-configured systems, but may have been disabled to comply with your organizations IT policy.
The following table lists the service dependencies for each Graphic Hub component:
### 2.1.3 Installing Graphic Hub Applications

This page contains the following topics and procedures:

- To Install a Graphic Hub
- Graphic Hub REST Installation
- GH Deploy Agent Installation
- Graphic Hub Manager Installation
- Graphic Hub ImEx Agent Installation
- Unattended Installation of Graphic Hub Applications

This section details the installation of the Graphic Hub, including a Cluster configuration, which installs a Main and a Replication server.

Please be aware that:

- Multiuser, Main and Replication modes require a license dongle.
- To setup a cluster configuration capable of handling failover situations, a combination of Main and Replication servers must be configured.

#### To Install a Graphic Hub

To install the Graphic Hub with the **MSI installer** use in the following installation order:
2. `vcredist_x64.exe` Visual C++ 2015 Redistributable (x64)
3. `openslp_2.0.0.0_x64.msi` Service location protocol daemon
4. `VizGraphicHub_64bit-XX.msi`
5. *optional*: `HASPUserSetup.exe` Dongle driver (required for GH Multiuser, Main and Replication modes)

To install the Graphic Hub with the **bundle installer** (installs 2-5 listed above) use in the following installation order:

2. `VizGraphicHubBundle-x64-XX.exe`

- The installation wizard reports the version and build number of the bundle about to be installed. If an existing Graphic Hub installation is located, the installer reports the version and build number of the existing installation as well.

⚠️ **Note:** During upgrade installations, the currently installed mode and data directory are suggested automatically by the installer.

- Select the mode and data directory for the Graphic Hub installation.
- If required, click **Additional Settings** to install the Graphic Hub to a custom location or with a custom HTTP port for the Graphic Hub Terminal.

![Additional Settings](image)

- For first time installations, the **OpenSLP**, **Sentinel Runtime** and **CodeMeter Runtime** checkboxes are automatically checked. In the event that any of these packages have been installed on the system previously, it is not possible to select them for installation.
- The installation wizard also automatically installs the Microsoft C++ Redistributable Package.
- After the installation has completed successfully, the Graphic Hub Terminal opens in the default web browser. The contents of the Graphic Hub Terminal window depends
on the selected Graphic Hub configuration.

- Optional: Silent installation
  - The -s or -silent option means that there is no user interaction necessary. The Bundle window is still displayed.

**Cluster Server Installation**

To use a Graphic Hub in a Cluster configuration (Main and Replication servers), two separate servers must be available and a Graphic Hub dongle must be applied to each machine.

The Main server is installed and configured on one machine. The Replication server is installed and configured on the other.

**IMPORTANT!** When the Graphic Hub is upgraded from a different mode the same content must be used (data directory). As such, the underlying data directory must be copied first to both machines (see also Graphic Hub Mode Configurations).

**To Install And Configure A Graphic Hub Cluster**

1. Install the Graphic Hub on both servers as described above in To Install a Graphic Hub. Select Main Server as mode for the server which is intended to run as Main, and Replication Server for the other one.
2. When the installation finishes, the Graphic Hub Terminal automatically opens on both servers. Select the servers that will act as **GH Main Server** and **GH Replication Server** from the
3. Enter the configuration for the Main Server:

- **Graphic Hub**: Enter the **Server name** and set the **Data directory**.
- **Connections settings**: Select the **Port**, **Network Adapter** and **Server Port**.

**Note**: If the Graphic Hub has been installed previously, the new installation defaults to the same data directory, unless a new one is selected during installation or configuration.
4. Click **Next** and enter the configuration for the replication server, then click **Finish**.

![Configuration Interface](image)

- If required, click **Configuration** to change any settings.
- If required, click **Automatically start of partner server** to automatically start the Replication server.

5. Click **Start Server** for both the Main and Replication servers.

### Graphic Hub Cluster Upgrade

```
IMPORTANT! When upgrading a Graphic Hub cluster, make sure that all connections to the Graphic Hub are closed by checking active sessions and that there are no open transactions.
```

```
Note: Graphic Hub clients and servers are designed to be inter-operable between versions, but may lack new features. This means old clients work on older and newer Graphic Hub versions and there is usually no need to upgrade clients when upgrading the Graphic Hub, except when certain features are required or critical bugs have been fixed.
```

1. Shut down Deploy Agent or Agents.
2. Shut down the Graphic Hub Cluster.
3. Remove Deploy Agent or Agents.
4. Install new version of the Deploy Agent or Agents (see GH Deploy Agent Installation).
5. Install new version of Graphic Hub on the Main and Replication Server (see Graphic Hub Installations).
6. Optional: Remove all occurrences of the Graphic Hub Manager. Install new version of the Graphic Hub Manager (see Graphic Hub Manager Installation).
7. Start the Graphic Hub Cluster.
8. Start any Deploy Agents.
Graphic Hub REST Installation
This section details the installation of the Graphic Hub REST.
The Graphic Hub REST is a web-service for Graphic Hub. It is an interface to retrieve and send data to and from Graphic Hub via HTTP requests.

Important Before Installation

- Graphic Hub REST requires Graphic Hub 2.3.1 or higher.
- Graphic Hub REST requires Graphic Hub 3.0.0 (recommended 3.0.2) or higher for Pilot data access (see Viz Pilot Database Management for details).
- For performance reasons, do not install Graphic Hub REST on a Main server in a Graphic Hub cluster environment.

For best performance and compatibility, use Google Chrome version 28 or higher to configure Graphic Hub REST. The Graphic Hub REST Web-UI also works with:

<table>
<thead>
<tr>
<th>Recommended Browser</th>
<th>Version Requirement (minimum and recommended)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Google Chrome™</td>
<td>(Recommended) 28, 45+</td>
</tr>
<tr>
<td>Mozilla Firefox™</td>
<td>25, 41+</td>
</tr>
<tr>
<td>Microsoft Edge</td>
<td>96+</td>
</tr>
<tr>
<td><strong>Also Tested on</strong></td>
<td></td>
</tr>
<tr>
<td>Microsoft Internet Explorer™</td>
<td>9, 10+</td>
</tr>
<tr>
<td>Apple Safari™</td>
<td>5, 6</td>
</tr>
<tr>
<td>Opera™</td>
<td>15, 36+</td>
</tr>
</tbody>
</table>

**IMPORTANT!** Any other web browser or versions older than the ones listed above are not officially supported.

To Install the Graphic Hub REST
Follow this installation order to install Graphic Hub REST:

2. vcredist_x64.exe Visual C++ 2015 Redistributable (x64)
3. openslp_2.0.0_0_x64.msi Service location protocol daemon
4. VizGHREST_64bit.XX.msi
   - Optional: Check the details for:
     - Graphic Hub Naming Service
     - Graphic Hub Server Name
• Graphic Hub Port
• Graphic Hub REST HTTP Port
• Optional: Silent installation
  • The -s or -silent option means that there is no user interaction necessary. The Bundle window is still displayed.
• Optional: Enable the SSL configuration:
  • Check the **Enable SSL Encryption** checkbox.
  • Enter the location of the **Certificate** and **Private Key** files.
  • Enter the password.

**IMPORTANT!** The certificate files must be configured during the installation of GH REST.

• After the installation has completed successfully, the Graphic Hub REST Web-UI opens in the default web browser.

**Note:** Make sure that the browser type and version is supported by Graphic Hub REST (see Important Before Installation).

### GH Deploy Agent Installation

This section details the installation of the Graphic Hub Deploy Agent. The Deploy Agent is required to run scheduled Deploy Tasks. This is useful to replicate data for safekeeping or distribution on a regular basis.

To install the Graphic Hub Deploy Agent use in the following installation order:

2. vcredist_x64.exe Visual C++ 2015 Redistributable (x64)
3. VizGHDeployAgent_64bit.XX.msi

This creates two Deploy Agent icons in the Start menu, under **Programs > Vizrt > Viz Graphic Hub > Deploy Agent**.

The Deploy Agent is now configurable with the Graphic Hub Manager.

### Graphic Hub Manager Installation

This section details the installation of the Graphic Hub Manager.

To Install the Graphic Hub Manager

To install the Graphic Hub Manager use in the following installation order:

2. vcredist_x64.exe Visual C++ 2015 Redistributable (x64)
3. VizGHManager_64bit.XX.msi
Graphic Hub ImEx Agent Installation

This section details the installation of the Graphic Hub ImEx Agent.

The Graphic Hub ImEx Agent is a media asset (image) import service from HTTP sources for the Graphic Hub.

Important Before Installation

Before installing the Graphic Hub ImEx Agent, make sure to familiarize yourself with the Service Dependencies. Also, observe the following requirements:

<table>
<thead>
<tr>
<th>Dependencies</th>
<th>Required Components</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphic Hub</td>
<td>3.0.1 or newer</td>
</tr>
<tr>
<td>GH REST</td>
<td>2.0.1 or newer</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Recommended Browser</th>
<th>Version Requirement (minimum and recommended)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Google Chrome™</td>
<td>(Recommended) 28, 45+</td>
</tr>
<tr>
<td>Mozilla Firefox™</td>
<td>25, 41+</td>
</tr>
<tr>
<td>Microsoft Edge</td>
<td>96+</td>
</tr>
</tbody>
</table>

Also Tested on

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Internet Explorer™</td>
<td>9, 10+</td>
</tr>
<tr>
<td>Apple Safari™</td>
<td>5, 6</td>
</tr>
<tr>
<td>Opera™</td>
<td>15, 36+</td>
</tr>
</tbody>
</table>

⚠️ IMPORTANT! Any other web browser or versions older than the ones listed above are not supported.

To Install the Graphic Hub ImEx Agent

To install the Graphic Hub ImEx Agent use in the following installation order:

2. vcredist_x64.exe Visual C++ 2015 Redistributable (x64)
3. VizGHImexAgent_64bit.XX.msi

Optional: Configure IMEX HTTP port. The default port number is 19390. The port number can also be changed in the configuration of the Graphic Hub ImEx Agent after installation.
When the installation completes, the web-based user interface opens in the default browser, for initial Graphic Hub ImEx Agent configuration.

### Recommended Browser

<table>
<thead>
<tr>
<th>Browser</th>
<th>Version Requirement (minimum and recommended)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Google Chrome™</td>
<td>(Recommended) 28, 45+</td>
</tr>
<tr>
<td>Mozilla Firefox™</td>
<td>25, 41+</td>
</tr>
<tr>
<td>Microsoft Edge</td>
<td>96+</td>
</tr>
</tbody>
</table>

### Also Tested on

<table>
<thead>
<tr>
<th>Browser</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Internet Explorer™</td>
<td>9, 10+</td>
</tr>
<tr>
<td>Apple Safari™</td>
<td>5, 6</td>
</tr>
<tr>
<td>Opera™</td>
<td>15, 36+</td>
</tr>
</tbody>
</table>

### Unattended Installation of Graphic Hub Applications

### Installation Parameters

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Default Value</th>
<th>Available values</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>VizGraphicHub MSI</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>INSTALLDIR_GH</td>
<td>%\Program Files\Vizrt\VizGH\</td>
<td></td>
</tr>
<tr>
<td>DATADIR_DB</td>
<td>C:\VizGHData\</td>
<td></td>
</tr>
<tr>
<td>TERMINAL_HTTP_PORT</td>
<td>19399</td>
<td></td>
</tr>
<tr>
<td>GH_MODE</td>
<td>2</td>
<td>1, 2, 3, 4, 5</td>
</tr>
<tr>
<td>PLATFORMTYPE</td>
<td>54free</td>
<td>&quot;localhost&quot;, &quot;54free&quot;, &quot;multiuser&quot;, &quot;mainserver&quot;, &quot;replicationserver&quot;</td>
</tr>
<tr>
<td><strong>VizGHREST MSI</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>INSTALLDIR_REST</td>
<td>%\Program Files\Vizrt\VizGH\REST\</td>
<td></td>
</tr>
<tr>
<td>REST_NAMING_SERVICE</td>
<td>LOCALHOST</td>
<td></td>
</tr>
<tr>
<td>REST_SERVER_NAME</td>
<td>VizDbServer</td>
<td></td>
</tr>
</tbody>
</table>
REST_SERVER_PORT | 19396
REST_HTTP_PORT    | 19398
SSL_ACTIVE        | No      | yes
SSL_CERTIFICATE_FILE | null   
SSL_PKEY_FILE     | null    
SSL_PKEY_PASSWORD | null    

VizGHImexAgent MSI

INSTALLDIR_AGENT  | %Program Files%\Vizrt\VizGH\ImexAgent\ 
IMEX_HTTP_PORT    | 19390 

VizGHManager MSI

INSTALLDIR_MANAGER | %Program Files%\Vizrt\VizGH\Manager\ 
DO_LAUNCHAPPONEXIT | 0   | 1

VizGHDeployAgent

INSTALLDIR_AGENT  | %Program Files%\Vizrt\VizGH\DeployAgent\ 

Example

<table>
<thead>
<tr>
<th>Description</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Install Graphic Hub silently with no UI using the <strong>msi in Multiusers</strong> mode</td>
<td>msiexec /i VizGraphicHub.msi PLATFORMTYPE=&quot;multiuser&quot; INSTALLDIR_GH=&quot;C:\Vizrt\GH&quot; DATADIR_DB=&quot;D:\Vizrt\GHDataDir&quot; TERMINAL_HTTP_PORT=&quot;19300&quot; /lv c:\Temp\instgh_mode.log /qn</td>
</tr>
<tr>
<td>• Install Graphic Hub to path <code>C:\Vizrt\GH</code></td>
<td>VizGraphicHubBundle-x64.exe --silent --GraphicHub=&quot;PLATFORMTYPE=localhost INSTALLDIR_GH='C:\temp'&quot;</td>
</tr>
<tr>
<td>• GH Data Directory configured to <code>D:\Vizrt\GHDataDir</code></td>
<td></td>
</tr>
<tr>
<td>• GH terminal service to run on port <code>19300</code></td>
<td></td>
</tr>
<tr>
<td>• Installation log in verbose mode named <code>instgh_mode.log</code> and deployed to path <code>C:\Temp</code></td>
<td></td>
</tr>
</tbody>
</table>

• Install Graphic Hub silently using the Graphic Hub bundle installer in **localhost** mode
• Install Graphic Hub to path `C:\Temp`
2.1.4 Licensing Graphic Hub

There are five possible modes to run Graphic Hub (see Graphic Hub Modes):

- Modes working without a license
  - Viz Graphic Hub Localhost
  - Viz Graphic Hub 5/4 Free
- Modes that require a Dongle/License
  - Viz Graphic Hub Multiuser
  - Viz Graphic Hub Main Server
  - Viz Graphic Hub Replication Server

This section describes how to license Graphic Hub using a Graphic Hub Sentinel license dongle or WIBU License, which is required for Graphic Hubs running in Multiuser, Main or Replication mode.

For more information on how to apply licenses, check the Vizrt Licensing Guide in the Vizrt documentation center or for details on how to setup which licensing system will be used by Graphic Hub.

This page contains the following topics and procedures:

- Using a Graphic Hub Sentinel License Dongle on Physical Machines
- Using a Graphic Hub Sentinel License Dongle on an ESXi Virtual Machine
- Using a Graphic Hub Sentinel License Dongle on a Virtual Machine Workstation
- Using WIBU Licensing of Graphic Hub on Physical Machines or Virtual Environments

Using a Graphic Hub Sentinel License Dongle on Physical Machines

1. Connect the USB dongle to the machine.
2. Install Graphic Hub with the dongle driver.
3. Choose the Sentinel system in GH Terminal Configuration > ADVANCED SETTINGs > License Settings.

Using a Graphic Hub Sentinel License Dongle on an ESXi Virtual Machine

1. Connect the USB dongle to the machine where the ESXi is running.
2. From vSphere client, right click on the virtual machine where Graphic Hub is going to be installed.
3. Click on Edit Settings, in Hardware tab click add, another window pops up, choose USB controller and click next, click next in the next window and finally click finish in the window after.
4. From Hardware tab click Add, another window pops up, choose USB device and click next, the USB dongle appears in the next window, choose it and click Next, then click Finish in the next window.
5. Install Graphic Hub with the dongle driver.
6. Choose the Sentinel system in GH Terminal Configuration > ADVANCED SETTINGS > License Settings.

Using a Graphic Hub Sentinel License Dongle on a Virtual Machine Workstation

1. Connect the USB dongle to the machine where the virtual machine workstation is running.
2. Once the dongle is connected, a window pops up in the VMware workstation window stating that the connected dongle can be connected to the virtual machine, click OK.
3. Install Graphic Hub with the dongle driver.
4. Choose the Sentinel system in GH Terminal Configuration > ADVANCED SETTINGS > License Settings.

Using WIBU Licensing of Graphic Hub on Physical Machines or Virtual Environments

Graphic Hubs can be licensed with a special WIBU License. The required WIBU Runtime Software (CodeMeter Runtime Kit v7.21a) comes with the Graphic Hub Bundle installer and is mandatory for the modes Multiuser, Main and Replication.

If a WIBU License is found and bound it sticks to this license container and can only be changed by a restart of the Graphic Hub. The same applies for switching to the Sentinel dongle, which also can only be done by restarting Graphic Hub.

License expiration messages are logged to the Graphic Hub Journal as usual (alerts, expiration warning 30 days prior to expiration and if license is expired or invalid). The WIBU license information (license id, license server, container id) is logged to the Graphic Hub log file upon status changes and the Graphic Hub WIBU license application ID is 1300000.

1. Setup a WIBU license container as described in the Vizrt Licensing Guide in the Vizrt documentation center.
2. Install the Graphic Hub with the CodeMeter Runtime.
3. Choose the WIBU system and the appropriate location of the license container in GH Terminal Configuration > ADVANCED SETTINGS > License Settings.

To verify if the license is applied correctly, please check either the:
• GH Terminal Graphic Hub license information (reached via About > Graphic Hub License in GH Terminal):

![Graphic Hub License Information](image1)

• GH Terminal Graphic Hub log file (reached via Show GH Log in GH Terminal):

![Graphic Hub Log File](image2)
• GH Manager license information (reached via Info > License Info... in GH Manager):

![License info for server 'VizDbServer@GHDEMO']

- License details:
The license info shown below is that of a non server dongle!

- Serial Number: 11.00 00 00 00 00 00 00
- Key Number: 0
- Product expiry date: 30.11.2017 (expires in 24 days)
- Feature expiry date: 30.11.2017 (expires in 24 days)
- Features:
  - User Management: Expiry date: 30.11.2017 (expires in 24 days)
- License string: License cannot be set, because the connected dongle is not a server dongle!

• GH Manager monitor (reached via Tools > Monitor servers... in GH Manager):

![Monitor server]

Note: License changes (e.g. setting a new license key) are not supported for WIBU Licenses. Setting a new license string does not work in GH Terminal and GH Manager, since these changes must be performed in the CodeMeter Runtime.

2.2 Overview

The Graphic Hub is a database solution where all Viz Artist elements are stored. Files can be Scenes, Geometries, Images, Materials, Fonts, and so on.

To start Viz Artist successfully, a Graphic Hub must be running. The Graphic Hub can either be a local instance, where only one User can log in, or it can be a Multi-User database as described in Graphic Hub Modes.

This section contains the following topics:

• Graphic Hub Applications
• Graphic Hub Modes
• Selecting a Graphic Hub Mode
2.2.1 Graphic Hub Applications

The Graphic Hub solution consists of these applications:

- Graphic Hub
- Graphic Hub Terminal
- Graphic Hub Manager
- Graphic Hub REST
- Graphic Hub Deploy Agent
- Graphic Hub ImEx Agent
- Graphic Hub Naming Service

Graphic Hub

The physical back end server where the database content is stored (see General Database Information).

Graphic Hub makes the database available to clients in a network. To log in and work with Viz Artist, a User must connect to a running Graphic Hub, on a machine in the network. In normal circumstances a Graphic Hub is started through the Graphic Hub Terminal, and shut down, logged in to or logged out of, from the Graphic Hub Manager.

Various parameters can be defined in the Graphic Hub Terminal before a Graphic Hub is started, for example the name and the data directory to where the database should have its root folder.

The integrated multi-user database serves as the central point for storing all assets of a standalone machine or for all machines. This asset management database provides efficient file-handling while maintaining data consistency.

- **Consistent data storage**: Objects are always aware of their references and stay consistent where ever you move them. Accidental deletions of objects are prevented and scenes remain usable.
- **Reference model**: Guarantees that changes of a special object/type affects all scenes using it, such as a corporate logo or font-style.
- **Flexible data organization**: Organizing scenes and all relevant objects together in projects, simplifies the task of handling complex designs.
- **Data locking**: Exclusive access to scenes or objects is assured by applying a lock.
- **Audio**: Supports audio streaming.
- **Administrative tool Graphic Hub Manager**: Serves to migrate archives and data pools from version 2.x. Graphic Hub Manager also serves as a tool for adding users, keywords, permissions, statistical information regarding disk usage, connected users and server traffic as well as assisting the user in finding duplicates.
- **User management**: Enables you to protect crucial assets and track changes.
- **Search functionality**: All object properties can serve as search criteria and new search keywords can be included.
• **Messaging/notification**: Broadcast information to all connected clients via a customized notification system and/or online collaboration between single users.

**Graphic Hub Terminal**

The Graphic Hub Terminal is the user interface used to configure, start, stop and restart both Graphic Hub and the Graphic Hub Naming Service. See [Graphic Hub Terminal](#).

A Graphic Hub Terminal is installed along with every Graphic Hub and provides the following functionality:

- Starting, stopping and monitoring Graphic Hub and the Graphic Hub Naming Service processes.
- Configuring Graphic Hub.
- Status Display and monitoring.
- Execution of scheduled tasks: shutdown (with automated backup), deletion of Journal Entries, deletion of expired items, cleanup of Viz Pilot data elements, cleanup of Viz Pilot changelog.
- Backup and Restore.
- Emailing.
- Report generation.

**Graphic Hub Manager**

The Graphic Hub Manager is used to administer one or more Graphic Hubs. For example, the server files and access levels for users and groups can be managed from this application. See [Graphic Hub Manager](#).

Graphic Hub Manager serves to:

- Migrate Viz Pilot data from Oracle to Graphic Hub.
- Migrate archives and data pools from version 2.x.
- As a tool for adding users, keywords, permissions, statistical information regarding disk usage, connected users and server traffic as well as assisting the user in finding duplicate.

When you are running in a Main/Replication Cluster, you can check Server differences and Copy via DDC from one server to another.

**Graphic Hub REST**

The Graphic Hub REST is a web-service for a Graphic Hub. It is an interface to retrieve and send data to and from a Graphic Hub through HTTP requests. See [Graphic Hub REST](#).

Supports browsing, administration, simple manipulation of datasets, monitoring, deploy agents, and much more. It provides the access to all data on a Graphic Hub. A client is able to retrieve any kind of metadata from Scenes, Images, etc., like Owner, Creation Date, etc. Also, all metadata, like Users, Types, Keywords, can be retrieved.

Graphic Hub REST is also an open HTTP API to Graphic Hub. Any skilled web developer and designer can build an application based upon the Graphic Hub Interface Agent. For example, if a scene from the Super Bowl contains an image of the quarterback, this image can be retrieved by an
external application, like a blog, by a search on the Graphic Hub Interface Agent. The blogger is also able to insert this in an article and publish to the web.

**Graphic Hub Deploy Agent**

Upgrades the Graphic Hub solution with a powerful service to copy directories/projects/files with all necessary data (referenced directories/projects/files) from one server to another. See [Graphic Hub Deploy Agent](#).

Graphic Hub Deploy Agent upgrades your Graphic Hub solution with a powerful Service to copy directories/projects/files with all necessary data (referenced files, directories/projects) from one server to another with different options of deployment. It is possible to have more than one agent running in your network environment. To copy between your servers, you can create tasks in Graphic Hub Manager. In these tasks you define the source and destination servers and properties of the deploy task.

It is possible to deploy to multiple destination servers. Every task can have different schedule modes. These modes are Once, Recurring, Recurring forever and Real-Time. So it is possible to distribute your Graphic Hub content according to schedule to all your servers automatically day by day.

**Graphic Hub ImEx Agent**

The Graphic Hub ImEx Agent (Import / Export agent) is a service that imports image media assets from file-system folders or HTTP sources to Graphic Hub. See [Graphic Hub ImEx Agent](#).

Graphic Hub ImEx Agent upgrades your Graphic Hub solution with a powerful Service to stage (import) external media assets (images) available through HTTP through the Media Sequencer (MSE) to Graphic Hub through Graphic Hub REST. It is possible to have more than one agent running in your network environment that can utilize multiple Graphic Hub RESTs.

Dedicated destination directories can be configured. The import can be parallel on multiple Graphic Hub RESTs bound to the same Graphic Hub.

**Graphic Hub Naming Service**

The Graphic Hub Naming Service monitors all applied servers in the network. See [Graphic Hub Naming Service](#).

**See Also**

- Graphic Hub Modes
- General Database Information
- Graphic Hub Naming Service

### 2.2.2 Graphic Hub Modes

Graphic Hub Terminal can operate in these modes:

- Localhost
- 5/4 Free
- Multiuser
- Main Server
• **Replication Server**

**Localhost**

Localhost is a single connection to a Graphic Hub (no dongle required). See Localhost, 5/4 Free, and Multiuser Configuration.

**5/4 Free**

The 5/4 Free configuration provides five concurrent TCP/IP connections to a Graphic Hub (no dongle required, five TCP/IP connections excluding GH Terminal, GH Manager, GH Deploy Agent connections). See Localhost, 5/4 Free, and Multiuser Configuration.

**Multiuser**

The Multiuser configuration provides multiple concurrent connections to a Graphic Hub (dongle required). See Localhost, 5/4 Free, and Multiuser Configuration.

**Main Server**

The Main Server, as with the Multiuser configuration, provides multiple concurrent connections to a Graphic Hub. The difference is that the Main Server provides a mirror service to a running a Replication Server. In a failover situation, the system automatically redirects all clients from the Main server to a Replication server (dongle required). See Cluster Configuration.

**Replication Server**

The Replication Server is use with the installation of a Main Server. A Replication Server is a duplication of the Main server. See Cluster Configuration.

Replications in a Graphic Hub mean that every transaction on the primary server is immediately mirrored on a Replication Server. In a failover situation, where the main server becomes unavailable, the system automatically redirects all clients from the Main Server to the Replication Server.

A failover situation occurs when one of the servers become unavailable due to hardware failure, software errors, power loss, etc. A Main server crash results in a failover situation, where the Main server switches to a Replication Server, in real-time.

On the Main server machine, the Graphic Hub Terminal shows **Cluster Not Connected**, and if the E-mail functionality is enabled, one or more error E-mails are sent.

Usually, a Graphic Hub in a Cluster configuration runs in real-time replication. In cases of a network overload, loss of another server in the Cluster, or other serious system instabilities, the Graphic Hub automatically switches to Recovery Mode. This means that one server buffers all necessary transactions, for example, saving files. The Graphic Hub then deploys these files to the other server in the Cluster when the resources are available again. After 15 seconds of no incoming transactions, the Graphic Hub switches to real-time replication again, and the data structure is updated, so that it is reflected on both servers.

If clients were directed to another server than the primary, during the down-time, the clients are re-directed to the primary server again.
2.2.3 Selecting a Graphic Hub Mode

When a Graphic Hub is installed a mode must be selected. This section details information on the different modes, to help with the selection. Depending on the mode which is to be installed, a Graphic Hub license dongle may be required.

The Graphic Hub can be installed for a Cluster, Multi User or Single User:

- Cluster
- Multi User
- Single User

Cluster

A Cluster installation is an installation with multiple servers for multiple clients to access a Graphic Hub. To install a Graphic Hub as a Cluster, use the Main Server and Replication Server modes.

Multi User

The 5/4 Free and Multiuser configurations give access to multiple concurrent TCP/IP connections to a Graphic Hub.

- **5/4 Free** provides up to five connections and is recommended for sharing content in small Viz Artist work-groups. For example, installations on laptops and single workstations. This mode does not require a license dongle.
- **Multiuser** provides up to 800 (if required) connections (dongle required) and is recommended for all scalable Viz Artist work-groups. This mode requires a license dongle.

Single User

A Localhost configuration is a single connection to a Graphic Hub. This mode is for local Viz Artist installations, without a permanent network connection, and without the requirement of a license dongle. For example, installations on laptops and single workstations.

See Also

- Graphic Hub Terminal
- Graphic Hub Applications
- Graphic Hub Modes
- General Database Information
- Graphic Hub Naming Service
2.2.4 General Database Information

Viz Artist uses a database to store Elements that clients work with. The Elements can be of these types, among others:

- Scenes
- Geometries
- Materials
- Advanced materials
- Images
- Fonts
- Audio files

**Note:** For more information about the various element types, see the Viz Artist User Guide.

The individual elements are stored in the Graphic Hub data directory as files.

The database manages the files in terms of properties and Universally Unique Identifiers (UUIDs). These are visualized in Graphic Hub Manager as folders and projects. These folders and projects are only virtual, and cannot be treated in the same way as folders in Microsoft Windows.

Clients can work with and organize files through Viz Artist in a logical project and folder structure provided by the database. Although each file can be listed in/referenced from more than one folder, it resides in the database in a single instance. A checksum is calculated for each file, so that duplicate files can be easily found (see Locate Duplicate Files).

This page contains the following topics:

- File Properties
- Projects and Folders
- Links and References
- Folder Links
- File References
- File Links
- Keywords
- Data Locking
- Session Lock
- Check Out
- Access Rights

File Properties

Various properties are associated to each individual file in the database, for example:

<table>
<thead>
<tr>
<th>Properties</th>
<th>Properties (continued)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td></td>
</tr>
<tr>
<td>Path</td>
<td></td>
</tr>
<tr>
<td>File type</td>
<td></td>
</tr>
<tr>
<td>File size</td>
<td></td>
</tr>
<tr>
<td>Checksum</td>
<td></td>
</tr>
<tr>
<td>UUID</td>
<td>Rights</td>
</tr>
<tr>
<td></td>
<td>Keywords</td>
</tr>
<tr>
<td></td>
<td>File-links</td>
</tr>
<tr>
<td></td>
<td>References</td>
</tr>
</tbody>
</table>
For more information about the properties, see Working with Files.

Projects and Folders
The database is able to maintain a logical structure composed of projects and folders. This helps Viz Artist users to keep an overview of the files they work on. The tree of folders is only virtual, the files are not actually stored on the hard disk with such a structure. All the folders a file is shown in, are stored in the properties of the file. The main benefit of this virtual structure is that the file itself is stored only once in the database, with links to it. The hard disk space is then kept low and the administration of files is much easier.

Links and References
In the database, files are linked and referenced. Every file knows which folder it is placed in, which other files it uses, and also by which other files it is used. For example, in a scene, fonts and images are used. If one of the files that are used in the scene changes, the scene uses the file in its new state. Every file holds a list of links and references in its properties.

Three types of links and references are handled by the database: folder-links, file-references, and file-links.

Folder Links
Every file in the database holds information about the folders it is placed in. These entries are called folder-links. Each file can hold as many folder-links as necessary. The file is physically stored in the database only once, but it can be virtually available in various folders. The UUID of the file is identical in all folders. If a file is deleted within a folder, only the folder-link to this folder is removed. The file remains in the database, unless every folder-link is removed. When the last folder-link is removed, the file is deleted from the database.

In the Explorer, a file that holds more than one folder-link is shown as an icon with an arrow.

File References
In everyday use, it is necessary for a file to reference other files. For example, a scene can contain images. The root file must be linked to all the files it uses. The file-reference feature keeps track of all other files being used by this file.

File Links
In everyday use, it is also necessary for a file to be referenced by other files. The root file must be linked to all the files it is used by. The file-links feature keeps track of all other files the file is used by.

Keywords
To help users organize their work, keywords can be applied to files. Up to 20 keywords can be applied to each file. Every file holds a list of keywords in its properties.
Data Locking

Three different types of data locking exist within the database: session lock, check out, and access rights.

Session Lock

As long as the session lock is active, only the user who has locked the file is able to save it in the database. Other users can only view the file. A locked file is marked in Viz Artist and Graphic Hub Manager (if the files view type is set to icons) with a keyhole icon.

A session lock is automatically applied to a file when a user opens it in Viz Artist. The session lock is removed once the file is closed. A session lock is valid as long as the user who has locked the file is connected to the server. When the user disconnects, the lock is opened. To end a session lock, the user who locked it, or the administrator, can manually unlock it.

Check Out

As long as the check out is active, only the user who has checked out the file is able to save it in the database. Other users can just view the file. A checked out file is marked in Viz Artist and Graphic Hub Manager (if the files view type is set to icons) with a stop icon.

Every file in the database can be checked out. The check out of a file is valid until it is checked in again. Check in can be performed by the user who checked out the file, or the check out can be canceled by the administrator.

Access Rights

The database is able to maintain rights on files and folders. Individual rights for user, group, and world can be set either to allow or disallow reading and/or writing rights.

**IMPORTANT!** Viz Artist 3.3.x cannot handle access rights. It is strongly inadvisable to make changes in the server that may impact work on the clients.

- **User:** Sets the rights for the owner of a file or folder.
- **Group:** Sets the rights for all the members of the group the owner belongs to.
- **World:** Sets the rights for all database users.

See Also

- User and Group Management
- Graphic Hub Applications
- Graphic Hub Modes
- Graphic Hub Naming Service
2.2.5 Graphic Hub Naming Service

There can be many Graphic Hubs running on the same network. A Graphic Hub Naming Service is used to monitor and keep track of all servers on the network. The Graphic Hub server cannot run without a Naming Service.

A Naming Service can be started together with a server, or the Graphic Hub server can connect to a naming service on the network. When a server configured with this naming server is started, the remote Naming Service is informed. The Naming Service is aware that the Graphic Hub server is available for client connections.

The Naming Service application is started and shut down from the Graphic Hub Terminal. The port used for the communication between the Naming Service and the clients can be defined in the terminal before startup.

When a Graphic Hub server is bound to an already running Naming Service, the server name must be unique. If a server with the same name is already running, the Graphic Hub exits with an error. The exit code and error message are written to the log file.

⚠️ Note: Server names are case sensitive.

To avoid having a single point of failure for Main and Replication server configurations, each instance must have its own separate Naming Service.

⚠️ IMPORTANT! The server’s network adapter statuses and IP addresses cannot be changed while the Graphic Hub or the Naming Service are running.

Supported Configurations

Both the Graphic Hub Naming Service and a Graphic Hub can run independently of each other, even on separate physical machines. The following two configuration scenarios are supported:

- Each Server Connected to its own Naming Service
- Multiple Servers Connected to one Naming Service

Each Server Connected to its own Naming Service

In this type of configuration, the clients are able to connect to only one server. Such a configuration is used when working in single-user mode. In single-user mode, the server, Naming Service, and all other Viz 3 products that connect to the database must be installed on the same physical machine. As the server is working on the “localhost” in this configuration, other clients cannot see the Naming Service or server.

⚠️ IMPORTANT! Although a localhost can never be accessed from client applications such as Viz Artist, it is possible to monitor and start/stop localhost servers/naming services by enabling this in the Graphic Hub Manager.

This type of configuration is typically used when working on a stand-alone computer.
Multiple Servers Connected to one Naming Service

In this type of configuration, the clients are able to connect to all servers managed by the defined Naming Service. In multi-user mode, the server and Naming Service are available to all clients in the network. The Naming Service uses the host name of the computer it runs on as its name. By default, the name of the server is Graphic Hub, but this can be modified in Graphic Hub Terminal before startup (see Graphic Hub Terminal).

See Also

- Graphic Hub Applications
- Graphic Hub Modes
- General Database Information

2.3  Startup And Shutdown

This section details the startup and shutdown procedures for the Graphic Hub, the Graphic Hub Manager and servers.

This section contains information on the following topics:

- Graphic Hub Startup
- Graphic Hub Shut Down
- Graphic Hub Emergency Shutdown
2.3.1 Graphic Hub Startup

This section details the procedures to start and shutdown the Graphic Hub and the startup of a configured Graphic Hub database. All Graphic Hub configurations are started through the Graphic Hub Terminal.

To log in and use a Graphic Hub, see Graphic Hub Login and Log Out.

To Start a Graphic Hub

1. Open the Graphic Hub Terminal:
   - Click Start > All Programs > Vizrt > Graphic Hub > GH Terminal, or
   - Double-click the Graphic Hub Terminal desktop icon. The Graphic Hub Terminal opens in the default web browser.

   ![Note: Each time the Viz GH Terminal desktop icon is double-clicked a new Graphic Hub Terminal instance is opened.]

2. Start a Graphic Hub Server:
   a. The last used server configuration is available.
   b. Click Start Server.
   or
   c. Click Mode.
   d. Select the required Graphic Hub mode (see Graphic Hub Modes and Selecting a Graphic Hub Mode).
   e. Click Load and run configuration > Select configuration.

   ![Note: From the same menu, select Load Configuration to load and modify a configuration. Then start that configuration.]
Localhost, 5/4 Free and Multiuser Startup Screen

Cluster Startup Screen
2.3.2 Graphic Hub Shut Down

This section details the options for shut down of one or more Graphic Hubs, without the requirement to log off completely or exit the Graphic Hub Manager.

Shutdown options are:

- **A normal shutdown**: Through the Graphic Hub Manager.
- **A scheduled normal shutdown**: A scheduled shutdown can be configured in the Graphic Hub Terminal or the Graphic Hub Manager.
- **A Cluster configuration shutdown**: For system maintenance or network configuration work in a Cluster system, the best type of shutdown operation is to shut down the Cluster, through the Graphic Hub Manager.
  
  It is also possible to Limit and Shut Down Sessions.

A Graphic Hub is shut down from the Graphic Hub Manager.

⚠️ **Note:** In **emergency situations**, you can shut down the Graphic Hub using the Graphic Hub Terminal (see **Graphic Hub Emergency Shutdown**).

A normal shutdown operation takes much longer than an Emergency Shutdown, but is far safer for data retention.

This page contains the following topics and procedures:

- To Do a Normal Shutdown
- To Schedule a Server Shutdown Using Graphic Hub Terminal
- To Schedule a Server Shutdown Using Graphic Hub Manager
- To Shut Down a Cluster
  - Limit and Shut Down Sessions
  - To Limit the Number of Sessions
  - To Disconnect a Selected Session

**To Do a Normal Shutdown**

1. In the Graphic Hub Manager open the Server Shutdown panel:
   - Click **Server > Shutdown...** or press **CTRL + W** or **F10**.
2. In the **Server** drop-down box, select the server to shutdown.
3. Option: Send a message to all users of the server:
   - In the **Message** field write a message to all users of this server to inform them that the server is about to be shut down.
   - Click **Send**.
4. Click **Shutdown**.
5. Click **Yes**.
6. Click **Close**.
To Schedule a Server Shutdown Using Graphic Hub Terminal

1. Open Graphic Hub Terminal and go to Options > Scheduled Tasks.
2. Select the Shutdown task.
3. Check the Schedule shutdown box.
4. Select a Mode:
   - Once.
   - Recurring.
   - Recurring forever.
5. Select a Start at and End after date.

⚠️ Note: A shutdown task cannot be started in the past.

6. If Mode is set to Recurring or Recurring forever, set the interval in Each.
7. Set a Notification time. Options are:
   - Do not notify at all.
   - Just notify five minutes before shutdown.
   - Notify 15 minutes before - every five minutes.
   - Notify 30 minutes before - every 10 minutes (but at least five minutes before).
   - Notify 60 minutes before - every 15 minutes (but at least five minutes before).

The Info line confirms the next scheduled shutdown time.

To Schedule a Server Shutdown Using Graphic Hub Manager

1. In the Graphic Hub Manager open the Server Shutdown panel:
   - Click Server > Shutdown, or
   - Press CTRL + W or F10.
2. Click Schedule...

3. In the Mode drop down box, select one of these options:
   - Once.
   - Recurring.
   - Recurring forever.
4. In the Start at drop down box, click to select a date from the calendar.
5. If required, adjust the time.
6. If **Recurring** is selected:
   a. In the **End after** drop down box, click to select a date from the calendar.
   b. If required set a time.
7. Select a **Notification** option. Options are:
   - Do not notify at all.
   - Just notify five minutes before shutdown.
   - Notify 15 minutes before - every five minutes.
   - Notify 30 minutes before - every 10 minutes (but at least five minutes before).
   - Notify 60 minutes before - every 15 minutes (but at least five minutes before).
8. Click **OK**.

**To Shut Down a Cluster**

1. In the Graphic Hub Manager, log in to the Main server.
2. Open the Server Shutdown panel:
   - Click **Server > Shutdown**, or
   - Press **CTRL + W** or **F10**.
3. Click **Shutdown Cluster**.

**Limit and Shut Down Sessions**

Active sessions on the server can be limited by the limitation of the number and/or shut down of individual sessions. If a Graphic Hub is to be shutdown, clients can be notified (message, email, walk-in, etc.) and then not allow them to reconnect (no new connections = nobody is removed, but nobody new can come in).

A limit of one connection can be set, if only a Deploy Agent is used.

A disconnect stops client access immediately.

**To Limit the Number of Sessions**

1. In the Graphic Hub Manager open the Server Shutdown panel:
   - Click **Server > Shutdown**, or
   - Press **CTRL + W** or **F10**.
2. Select a server in the **Server** drop-down box.
3. Click **Modify**...

   ![Session limit for server](image)

4. Select one of the following options:
   - System default
   - User defined (and enter a numerical value)
   - No new connections

**Note:** Schedule tasks can not begin the past.
• No new connections (except Graphic Hub Deploy)

5. Click **OK**.

**To Disconnect a Selected Session**

1. In the Graphic Hub Manager open the Server Shutdown panel:
   • Click **Server > Shutdown**, or
   • Press **CTRL + W** or **F10**.
2. Select a session, or sessions, in the **Sessions** list.
3. Right-click and select **Disconnect selected sessions**...
4. Click **Disconnect**.
5. Click **Close**.

### 2.3.3 Graphic Hub Emergency Shutdown

A Graphic Hub emergency shutdown terminates a Graphic Hub almost immediately. If the Graphic Hub server is a Main server in a Replication environment, the emergency shutdown causes a failover to the Replication server.

**Warning:** Index re-organization and vacuum of tables is skipped when performing an emergency shutdown. Please perform a normal shutdown through GH Manager to avoid performance reduction and to free disk space.

Emergency shutdowns can only be executed from the Graphic Hub Terminal, and should be used sparingly.
To Do an Emergency Shutdown

1. In the Graphic Hub Terminal main window, click **Emergency Shutdown**.

2. To continue with the emergency shutdown, click **Yes**.

   ![Emergency Shutdown Dialogue](image)

   **Note**: If an automatic backup has been configured this warning message shows. Check the checkbox to disable an automatic backup on this emergency shutdown.

**See Also**
- Graphic Hub Startup
2.4 Database Management

**Note:** For Pilot data back end systems using Deploy Agent 2.2.0 or later and GH Manager 5.2.0 or later, it is recommended to backup Pilot data using Pilot data deploy tasks, see [Resolve Viz Pilot Data Differences Between Graphic Hubs](#).

This section contains information on the following topics:

- Main and Replication Servers with Failover
- User and Group Management
- Test a Replication Server
- Data Errors
- Import External Images
- Locate Duplicate Files
- Add Metadata
- Replace File References
- Direct Deploy Copy
- Graphic Hub Search
- Server Information
- Daily Backup Using a Second Graphic Hub
- Detect and Solve Server Differences

### 2.4.1 Main and Replication Servers with Failover

Adding failover servers adds another level of redundancy to the Graphic Hub cluster. This is useful in situations in which the cluster becomes unavailable, for example due to maintenance or hardware failure. This section describes how to configure a Graphic Hub cluster with an arbitrary number of failover servers in multiuser mode, and contains the following information:
To Configure a Cluster with Failover Servers

- Perform a Cluster Server Installation, setting up both the Main and Replication server.
- Install the number of Graphic Hubs to act as failover server in multiuser mode. The failover server has to be able to handle the number of clients connected to the cluster, in case the cluster becomes unavailable.
- Set up one or more Deploy Agents with real-time deployment from the Main server to the failover server(s).
- Create a corresponding amount of real-time deploy tasks from the cluster to the failover servers to keep them in sync. In setups using multiple failover servers, the recommended configuration is to deploy from the Main server in the cluster to the first failover server, then from the first failover server to the second failover server, etc.
- In the Deploy Agent Properties, open the Configuration Panel and configure enable emergency pause of real-time tasks in the case of deletion of 1% of all objects or 1 item. This prevents the deploy task on the cluster from accidentally deleting content created while the cluster has been unavailable, in case the cluster becomes available again.
Configure the clients, such as Viz Artist or GH REST, to use one or multiple of the failover multiuser servers. If the cluster becomes available, the clients only connect to the failover servers if the client is configured correctly. For details on configuring the client for failover, refer to the respective product documentation.

To Check Client Connections

1. Log on to the cluster and the failover server(s) with Graphic Hub Manager.
2. Open the Active sessions window. This provides an overview of all logged in users and active sessions, and to which host they are connected.

Resume Normal Operation after Failure of Main or Whole Cluster

After a failure of the main server, all clients are automatically redirected to the replication server. When the cluster has returned to real time replication mode, the clients are automatically returned to the Main server.

After a failure of the cluster, all clients are automatically redirected to the failover server(s). However, they do not automatically return to the cluster once the cluster has been brought back online. Before bringing the clients back to the cluster, a manual merge of the data from the failover server is needed to re-synchronize the cluster. This is required in order to avoid possible loss of data created by the clients during the cluster downtime period.

Before restarting the Deploy Agent service after the cluster is back up, make sure that the server differences have been successfully merged, and that all clients are back on the cluster again.

See Also
- System Installation
- Graphic Hub Terminal
- Graphic Hub Manager
- Graphic Hub Deploy Agent

2.4.2 User and Group Management

From the Administer Users and Administer Groups windows it is possible to manage all the users and groups in Graphic Hub.

Every user that works with the Graphic Hub, either directly or from a client application, must:
- Have their own user profile.
- Belong to a Group.

The User and Group management system monitors who creates files, who owns files, and who has rights to modify the various files in the Graphic Hub.

The permission settings on group level are the default settings for all assigned users, but it is possible to change the permission on user level afterwards. It is possible that one specific user has
more or less permissions as the original defined base permission settings of the underlying group
(like a super-user or restricted user).
User and Group permission settings are always related to a folder or file permission setting.

Example: User 1 of Group A has, on User and Group level, ‘no world write rights’ activated. This means that it is not possible to override or delete a file or folder which is owned by another User from a different Group.

Example: User 2 of Group A has, on Group level, 'group write rights' activated but not on User level (restricted user). This means that User 2 is only permitted to overwrite or delete their own files in their own folder structure.

Groups

To Open the Administer Groups Window

- Click **Tools > Administer Users and Groups > Administer groups**.

  **Note:** All Graphic Hub Manager users can view Users and Groups. Only an administrator can create new Users or Groups, or modify existing ones.

To Create a New Group

1. Open the **Administer Groups** window.
2. Select **New**... or right click and select **Create new group**... from the context menu.

![New group 'NewGroup' on server 'VizDbServer@GHSERVER(Admin)'](image)

- **Server**: VizDbServer@GHSERVER(Admin)
- **ID**: [autogenerated]
- **Active**: Active group
- **Name**: NewGroup
- **Access rights**:
  - **User rights**: Read, Write
  - **Group rights**: Read, Write
  - **World rights**: Read, Write

3. Select the destination server from the **Server** drop down box.

   **Note**: If the group-list is filtered, the server cannot be changed.

4. The new group **ID** value is automatically generated.
5. Check or uncheck the **Active** box to make the new group active or inactive.

   **Note**: If a group is inactive, no members can be added.

6. In the **Name** box give the new group a unique name.
7. Specify the user account access rights:
   - **User rights**: User may overwrite their files and create files.
   - **Group rights**: User can overwrite files which belong to the group, of which they are a member of.
   - **World rights**: User may overwrite files which belong to anyone.
8. Click **OK**.

**To Edit a Group**

- **Note**: Only available with administrator privileges and with a single server selected.

1. Open the Administer Groups window.
2. Right click and select **Edit selected group**... from the context menu.
3. Check the **Active** box to make the new group active, if required. If changed from active to inactive or inactive to active the modified check box is checked. If the modified check box is unchecked, the change is ignored.

   **Note**: You cannot add members to inactive groups.
4. In the Name box enter a new unique group name, if required. If changes are made in the text box the modified check box is checked. If the modified check box is unchecked, the change is ignored.

5. Specify the user account access rights, if required:
   - **User rights:** User may overwrite their files and create files.
   - **Group rights:** User can overwrite files which belong to the group, of which they are a member of.
   - **World rights:** User may overwrite files which belong to anyone.

6. Click the View member button to see all the group members
7. Click OK.

**To Delete One or Multiple Groups**

Administrators can delete groups that do not contain members.

1. Open the Administer Groups window.
2. Select the Group or Groups to be delete. Select a Group, or hold CTRL to select multiple groups.
3. Press Delete.
4. Click OK.

**To View a Group**

![Note: Only available if logged in with no Administration rights or if there are multiple users, over different servers.]

1. Open the Administer Groups window.
2. Click on the group or groups to be viewed.
3. Right click and select View selected group... from the context menu.
4. The Group window opens. No files can be edited.
5. Click the View member button to see all the group members
6. Click Close.

**Users**

**To Open the Administer Users Window**

- Click Tools > Administer Users and Groups > Administer users..., or
- Press CTRL + F9, or
- Press CTRL + U.

The Users window shows all available users on all active servers.

![Note: To narrow the users list first select a Server then select a Group from the Server and Group drop down boxes.]
To Create a New User Account

1. Open the Administer Users window.
2. Select either:
   - New...
   - Right click, and click Create new user... from the context menu,
   - Press F6 or Insert.
3. Select the destination server from the Server drop down box.

   ![New user window]

   **Note:** If the user list shows users of one server only, the server is preset and cannot be changed.

4. The new group ID value is automatically generated.
5. Check or uncheck the Active box to make the new user account active or inactive.
6. In the **Group** box select which group the new user belong too.

   **Note:** If user list is filtered to show only users of a specific group, this group is preset and cannot be changed.

7. In the **Nickname** box, give the new user a unique nickname.
8. In the **Full name** box, enter the new user’s full name.
9. Enter a user **Password**. Repeat the password in the **Re-enter the password** box.

   **Note:** Leave both the Password and Re-enter password boxes empty if no password is required.

10. Specify the new user account access rights:
    - **User rights:** User may overwrite their files and create files.
    - **Group rights:** User can overwrite files which belong to the group, of which they are a member of.
    - **World rights:** User may overwrite files which belong to anyone.

11. Click **OK**.

To Edit a User Account

   **Note:** Only available with administrator privileges.

1. Open the **Administer Users** window.
2. Select **Edit**... or right click and select **Edit selected user**... from the context menu.

3. The user account **Server** cannot be changed.
4. The user account **ID** value cannot be changed.
5. Check or uncheck the **Active** box to make the new user account active or inactive, if required.

   ![User account settings](image)

   **Access rights:**
   - **User rights:** check **Read** and check **Write**
   - **Group rights:** check **Read**
   - **World rights:** check **Read**

   **Note:** If user account is inactive, the user cannot log in or work with the files in the database.

6. In the **Group** box select the group the user account belongs too, if required.
7. In the **Nickname** box give the user a new unique nickname, if required.
8. In the **Full name** box change the user’s full name, if required.
9. Enter a new user **Password**, if required. Repeat the password in the **Re-enter the password** box.

   **Note:** Leave both the Password and Re-enter password boxes empty if no password is required.

10. Change the user account access rights, if required:
    - **User rights:** User may overwrite their files and create files.
    - **Group rights:** User can overwrite files which belong to the group, of which they are a member of.
11. If required, click the Delete viz user settings button to delete the user account settings which are, by default, saved together with the user profile.

Note: Delete viz user settings is only available if one user is to be edited. If more than one user is selected, this button does not show.

12. Click OK.

To Delete a User Account

Note: Only available with administrator privileges.

Note: The built-in administrator cannot be deleted.

1. Open the Administer Users window.
2. Click the User(s) to be deleted (press CTRL and click to multi select).

Note: Users on multiple servers cannot be deleted in one step.

3. Select either:
   - Delete...
   - Right-click on the selection and click Delete selected users..., or
   - Press DELETE.

4. Click OK.
   A User cannot be deleted if they own an object(s) in the Graphic Hub. If a User to be deleted owns any objects the Choose user... window opens when OK is clicked on. Use this window to transfer object ownership to another User.

   ![Choose user window](image)

   The user ‘Guest’ still owns objects (projects, folders/files) on server ‘VizDbServer@GHSERVER’.
   Before you can delete ‘Guest’, you must change the ownership of those objects to another user.

   Select the user, who will gain ownership of all objects, belonging to user ‘Guest’.

   Select: Admin

   Note: An action-log window will open to perform this owner change.

   IMPORTANT: You need to execute and close the set-owner action-log before you can proceed with deleting the user ‘Guest’!

   ![OK and Cancel buttons](image)

5. In the Choose user... window select the User to be assigned the object(s), from the drop down box.
6. Click **OK** to open the **Setting owner...** window.

   ![Setting owner window](image)

   **IMPORTANT!** The **Choose user...** window puts all objects, of the selected User, in an Action Log window (**Setting owner...**), where ownership changes.

7. Click **Set owner**.
8. Click **Close**.

   **IMPORTANT!** The owner change must be done before delete can continue. If the User still owns an object(s), the delete fails.

### To View a User Account

**Note:** Only available if logged in with no Administration rights or if there are multiple users, over different servers.

1. Open the **Administer Users** window.
2. Click on the user or user's accounts to be viewed.
3. Select either:
   - **View...** or
   - Right click and select **View selected user...** from the context menu, or
   - Click on a user account and press **F4**.
4. The User window opens. No files can be edited.

### 2.4.3 Test a Replication Server

This section details how to check a running replication server, including failover. It is strongly recommended that the replication server is tested in a production environment.
To Test a Replication Server

1. From a third computer, start the Graphic Hub Manager and log on to both the Main and Replication server as administrator.

   ![General properties of the data directory on both machines](image)

2. Open the properties of the data directory on both machines (right-click the `data` folder, and then from the menu that shows, select `Properties`), and make sure that the UUIDs on both machines are identical. If they are not identical, shut down the servers.

   a. If the data directories on both the Main and Replication servers are empty, delete both data directories. Use the Graphic Hub Terminal to create new data directories on both servers, then start the cluster.

   b. If the data directory is not empty, delete the data directory on the Replication server only. Copy the data directory from the Main server to the Replication server. Use the Graphic Hub Terminal to configure the copied data directory as a new data directory for the Replication server, then start the server. To use the data directory on the Replication server as data directory for the cluster, repeat the above steps copying the data directory from the Replication server to the Main server, and configure the main

   ***IMPORTANT!*** Before a test, make sure that no clients are working on any of the servers in the Cluster. Also, check that the Graphic Hub solution is a fresh setup of a Replication Cluster.
3. In Graphic Hub Manager, select **Tools > Monitor Servers**. Check that the Health LED is green.

4. From the main menu, select **View > Messages (Chat)**.

5. Unplug the network cable on the main machine, and then wait for a few seconds.

   The Graphic Hub Manager chat panel should show that the main server is down and that the replication server has automatically taken over.

   The main server name in the **Servers and Folders** should also be colored red.

6. Plug the network cable in on the main machine again. To prevent data loss and configuration corruptions in the cluster environment, the main server should shut down. Wait for the shutdown to complete, and then start the main server from the Graphic Hub Terminal.

7. If no users have been working with the system while the main server was down, proceed to the next step. Otherwise, wait a minute or two for the system to refresh.

   The Graphic Hub Manager chat panel should now show that the main server is up and running again, and that the main server has automatically taken over as the primary server in the cluster.

   If the steps above have been carried through correctly, the cluster configuration has been tested sufficiently and is ready to work in a real production environment.

8. Query the Journal log for replication-related errors.

### 2.4.4 Data Errors

Like the Check Disk feature in Windows, Graphic Hub Manager allows the database administrator to search for and repair data errors in the Graphic Hub.
The **Server Check** menu is used to scan for errors and inconsistencies in the server’s internal structure. Various checks are available, and can be set on or off as required. Any errors discovered during the check are displayed with a description of the errors and how they possibly can be resolved. Some types of errors must be fixed manually, while others can be fixed automatically. This is displayed in the list of errors.

After finishing or canceling a server check, results can be exported to a file or copied to the clipboard from the error list context menu. If the process is paused, it is not possible to check the file properties, or to copy or export the results.

⚠️ **Note:** Server Check requires Administrator user rights.

### To Find Data Errors

1. Open the Check Server window.
2. In the **Servers and Folder** panel, right-click the server to be checked and select **Check server** `<server name>`.
3. In the left panel, choose the options to check for.

⚠️ **Note:** If this window was opened with **Server > Check**, select the server to be checked from the **Server** drop-down box.

Options are:
- Check folder links
- Check file links
- Check references
4. Click the **Check** button. You are advised that checking for data errors can be time consuming and resource heavy, and should not be done at peak hours.

**Note:**

Checking the database stresses the server and therefore should not be performed at critical times.

Also be aware that the check routine may take a long time (depending on the database size and the check options you selected.)

You may though pause or cancel the server check at any time.

Are you sure you want to check this server now?
5. Click **Yes** to proceed. Any errors found are shown in the right panel. Clicking on an error shows more detailed information in the bottom panel.

To Fix Data Errors

1. If you do not require a log of errors that have been fixed, check **Automatically remove fixed entries**.

2. Click the **Fix all!** button.

**Note:** You also have the option of selecting only certain errors in the right panel, right-clicking, and fixing only the selected entries or trying to Verify and Restore files.
3. Any errors that cannot be fixed remain in the right panel. Click the entry and follow the instructions in the bottom panel.

![Error List Example]

**Note:** Checksum 11 means that a client failed (disconnected/crashed) during a Save operation. The Graphic Hub still has the old content and clients can load this old content, but to indicate that the scene was not saved correctly the checksum is set to 11. To reset this state and clean up temporary data of the failed Save operation, open the affected file in Viz Artist and save it.

### 2.4.5 Import External Images

External images can be imported from Windows Explorer directly into a connected Graphic Hub using Graphic Hub Manager. It is recommended that imported images are of sufficient quality to be worked on in Viz Artist. However, you do have the option to compress images when they are imported.

**To Import External Images**

1. Select one or more images in Windows Explorer.
2. Drag the selected images to a folder or the explore panel.

3. Select the import settings:

   ![Import images](image)

   **Image Compression**: Set the default image compression during import. The following options are available:
   - **None**: No compression.
   - **Select automatically**: If the source image has an alpha channel, DXT5 is used. If the source image does not have an alpha channel, DXT1 is used.
   - **DXT1**: Works best on images without an alpha channel.
   - **DXT5**: Works best on images with an alpha channel.
   - **Import quality**: The quality defines the compression for `.png` and `.jpg` images.

   - **Import bilevel matte type images as RGBA**: Applies to monochrome images only. When set, the luminance of monochrome images is treated as an alpha channel. When disabled, the alpha channel is treated as RGBA, while images without alpha channel are treated as RGB.

   - **Overwrite existing images (with same name)**: Check this checkbox to overwrite images with duplicate file names in
the target directory during import. Otherwise, an extension to the file name is added to the newly imported images.

1. Click **Import**. This opens the **Import external files** window:

   ![Import external files window](image)

   Click **Import** to perform the operation.

   After the import process has finished, the results can be investigated in the main section of the import window. Any files that failed to import are marked with a red cross next to the path. If an image fails to import, verify that it is among the supported image formats for import.

2. Set the desired options for the import by checking the appropriate checkboxes, and click **Import** to perform the operation.

3. After the import process has finished, the results can be investigated in the main section of the import window. Any files that failed to import are marked with a red cross next to the path. If an image fails to import, verify that it is among the supported image formats for import.

   **Tip:** Importing images to the Graphic Hub using Viz Artist support a wider range of file formats.

4. Click **Close** to close the import window.

### Graphic Hub Manager Supported Image Formats for Import

The following image formats are supported for direct import using the Graphic Hub Manager and GH REST upload:

<table>
<thead>
<tr>
<th>File Type</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>.bmp</td>
<td></td>
</tr>
<tr>
<td>.gif</td>
<td></td>
</tr>
</tbody>
</table>
### File Type

<table>
<thead>
<tr>
<th>File Type</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>.jpg</td>
<td></td>
</tr>
<tr>
<td>.png</td>
<td></td>
</tr>
<tr>
<td>.tga</td>
<td>No alpha 32</td>
</tr>
<tr>
<td>.tiff</td>
<td>No CMYK and LAB</td>
</tr>
<tr>
<td>.exr</td>
<td></td>
</tr>
<tr>
<td>.hdr</td>
<td></td>
</tr>
</tbody>
</table>

### 2.4.6 Locate Duplicate Files

When files are copied from one folder to another, such as when creating linked or duplicate files, the copy exists as a duplicate of the original file. As long as neither the original file nor the copy is modified, they remain duplicates, since the checksum of both objects is the same.

**Tip:** The files can be renamed, and still remain duplicates.

To Locate Duplicates in a Graphic Hub

1. Click **View > Duplicates**, or press **CTRL + N**, or **CTRL + F5**. The duplicates window is shown.

   ![Duplicates Window](image)

   The duplicates window lists all the duplicates in the selected server, sorted by the names of the files. If duplicates carry different names, this is also shown.

2. Right-click a duplicate for more information about it. This will open a menu with the following options:
- **Open Containing Folder in Explorer**: Jumps to the folder in the Servers and Folders, where the selected file is placed.
- **Properties**: Opens the File Properties window, which shows detailed information about the selected file.

### 2.4.7 Add Metadata

Graphic Hub supports keywords and add-ons that work like metadata, to help you to dynamically organize your files better and enhance search capabilities.

#### Keywords

Up to 20 keywords can be assigned to any file, to enhance search capabilities.

- Select **Tools > Administer Keywords** to open the **Administer Keywords** window.

![Administer Keywords window](image)

**To View Files which Use a Selected Keyword**

1. Open the **Administer Keywords...** window.
2. Click on a keyword(s).
3. Double click a keyword to view files assigned to it.
4. All files assigned with the selected keywords show in the right side panel.

**To Create a Keyword**

1. Open the **Administer Keywords** window.
2. **Click the New button.** In the left panel, a new keyword is created.

3. **Enter a name for the new keyword, and press** **ENTER.**

**To Delete a Keyword**

A keyword can only be deleted if it is not assigned to a file or folder. Look in the **No. of Obj.** field to verify how many files or folders the keyword(s) are assigned to.

⚠️ **Note:** If multiple keywords are selected, only the keywords with no assigned files or folders are deleted.

1. Open the **Administer keywords** window.
2. In the left panel, click on the keyword(s) to delete.
3. Click the **Delete** button.
4. Click **Yes** in the delete confirm window.

**To Assign a Keyword to a File**

1. Right-click a file in the **File panel** and select **Properties** from the context menu.
2. Click on **Keywords** in the **Properties for <file name>** window that opens.

3. Select/find a keyword(s) to assign to the file:
   a. Enter a keyword name in the search box.
   b. Click on **Search**, or **Show All** to see all available keywords

   ![Keywords window](image)

   **Tip:** Wildcards such as * or ? are allowed in the keywords search string.

4. Click a keyword, in the **Assignable keywords** panel, to select it.
5. Click the **< Add** button.
6. Click **OK**.

**To Assign a Keyword with the File Context Menu**

To assign a keyword(s) with the file context menu is better for on-the-fly keyword additions, but does not show any other data about the keyword(s) which are assigned.

1. Right-click a file in the File panel to open the file context menu and select **Add keywords...**
2. Search for available keywords by entering the name of a specific keyword, or asterisk (*) to show all available keywords.
3. Select the required keyword(s).
4. Click **Add...**
5. Click **Add** in the Add keywords... window.
6. Click **Close**.
To Remove a Keyword from a File

With this procedure a keyword(s) is first selected then the file(s). The advantage to that method is greater visibility of information regarding each keyword and where it is used.

1. Open the Administer Keywords... window.
2. Click on a keyword(s) in the list of available keywords.
3. Double click a keyword to view the files assigned to the selected keyword. All files assigned with the selected keyword(s) show in the right side panel.
4. Right-click on the file(s) from which the keyword is to be removed.
5. Click Remove keyword(s).
6. Click Remove... in the Remove keywords from <file name>... window.
7. Click Remove in the Remove keywords... window.
8. Click Close.

To Remove a Keyword with the File Context Menu

To remove a keyword(s) with the file context menu is better for on-the-fly keyword removal, but does not show any other data about the keyword(s) which are to be deleted.

1. Right-click a file in the File panel to open the file context menu, and select Remove Keywords...
2. Select the keyword(s) to be removed.
3. Click Remove....
4. Click Remove in the Remove keywords... window
5. Click Close

Add-ons

Add-ons are a solution for creating templates to assign custom metadata to objects in the Graphic Hub. This provides another dimension for searching, tagging and organizing objects. Add-ons work similarly to Keywords, but are actually more extensible.

Simple Add-on Use Case and Conceptional Workflow

Images of people need to be tagged with the first name, last name, gender, and age.

1. Add-on template with corresponding fields is created and published. Only published add-ons can be assigned to files.
2. The add-on is assigned to a file and the values wanted are entered.
3. Afterwards, the search grants the ability to view this information, for example, all files with a specific add-on or gender male assigned are retrieved.

**Tip:** Add-ons assigned to files are exportable and importable through Archives and are deployed with Graphic Hub Manager and the Deploy Agent.

A typical add-on assigned on a specific file could look like:

- **Add-On:** Vizrt Meta Data
  - **Title:** My Metadata Element 01
  - **Alternative title:** Add-on Example 01
  - **Synopsis:** Add-on use case
  - **Rights:** Rights reserved and held by creator and contributors
  - **Date:** 20-02-2018
  - **Language Code:** ENGLISH
  - **Media Type:** Production Element
  - **Creators:** various

Add-ons are administered from the Add-ons window. They are assigned from the Add-ons Panel.
Each add-on can have several entries. Entries can be numbers, strings, UUID, date and XML (for use by external applications). Each entry also has a Proposal, which sets out the options for the add-on in an eventual drop down box. You can also add informational text for a tool tip, which is shown when you mouse over the region of its name in the add-ons window.

One use case for add-ons is approval states. You can create an add-on with the parameters of Draft, Pending, and Approved. If an art director does not want any scene on the design cluster to be make it to the playout engine, they can use the Import External Images functionality to take all new scenes, assign the add-on, and then only deploy scenes that he has personally approved to the playout engine.

To Create a New Add-on

1. Open the Graphic Hub Manager
2. Open the Administer add-ons window:
   - Click Tools > Administer add-ons..., or
3. Open the **Create add-on** window:

- Press **CTRL + SHIFT + F8**.
- From the **Administer add-ons** window, click the **Create new add-on...** button, or right-click in the Add-ons quadrant and select **Create new add-on...**

4. In the **Name** field, enter a name for the add-on.
5. From the **Group** drop down box, select from:
   - **ungrouped**: The new add-on is not in a group.
   - **<group name>**: Select a group to put the new add-on.
6. Check the **Allow transfer via DDC**, if required (when checked, the add-on is transferred through DDC (Direct Deploy Copy)).
7. Check the **Allow transfer via archive export/import**, if required (when checked, the add-on may be transferred via Archives (exported/imported)).
8. Click the **Add...** button. The **Create entry of add-on** window is shown.

   ![Create entry of add-on window](image)

9. In the **Name** field, enter a name for the add-on entry.

10. From the **Data Type** drop down box, select one of the following options:
   - **Number**: Only manual proposals supported.
   - **String**: Supports manual proposals and having all registered users as a proposal option.
   - **Date**: No proposals supported, namely selecting a date from a calendar.
   - **UUID**: No proposals supported.
   - **XML**: No proposals supported.

11. Check the **Mandatory** check box for it to be mandatory for this entry to have a value. Uncheck it for the entry to be optional.

12. From Proposal drop down box, make sure **Manual** is selected.

   ![](image)

   **Note:** If the Data Type is String, the option of selecting `<all users>` as the Proposal is available. In this case, no further Proposal configuration is required.

13. In the **Add** field, enter an option that is available for selection and click the **Add** button. Repeat for as many options as you want to have in your proposal. You can also remove options by clicking the **Remove** button, as well as changing the order in which options appear by clicking the **Up**, **Down**, **Top** and **Bottom** buttons.

14. Check the **Restrict** check box to restrict the proposal entries to what you have added above. Uncheck it to allow user-defined entries in addition to your proposal options.

15. From the **Default value** drop down box, select one of the following options:
   - **<none>**: There is no default value assigned. Not available if the entry is restricted.
   - **<user defined>**: The value is defined when assigning the add-on. Not available if the entry is restricted.
16. In the Info field, enter any text that you wish to appear as a tool tip when mousing over the add-on once it has been published.

> Caution: Any text you enter in this field is exposed to end users.

17. Click OK.

**To Create an Add-on Group**

1. Open the Graphic Hub Manager.
2. Open the Administer add-ons window:
   - Click Tools > Administer add-ons...
3. Open the Create add-on group window:
   - In the Administer add-ons window click the Create new add-on group... button, or right-click in the Add-ons quadrant and select Create new add-on group...

   ![Create add-on group window]

   Name: [Enter a name for the add-on group]

   ![Create add-on group window]

   Click the OK button. The new Add-on group shows in the Add-ons quadrant.

   Note: Make sure that the new Group name is unique.

5. Click the OK button. The new Add-on group shows in the Add-ons quadrant.

   Note: Add-ons can be dragged from group to group as required.

**To Publish an Add-on**

> IMPORTANT! Add-ons are automatically saved during the creation process and can be modified as required. But the Add-on cannot be assigned until it has been published. As long as the Add-on is assigned to any file on the server, it cannot be deleted. If the Add-on is not (no longer) assigned to any file on the server, it can be deleted.

1. In the Add-ons quadrant of the Add-ons window, right-click the add-on and select Publish add-on. You are queried if you are sure you want to publish this add-on.
2. If the add-on is ready for use, click Yes.
To Filter Add-ons by Type

- In the Add-ons quadrant of the Add-ons window, from the Filter by type drop down box, select one of the following options:
  - **All**: All add-ons.
  - **User-defined**: All add-ons created by any users.
  - **Viz**: External metadata created by another Viz application.
  - **System**: All Graphic Hub server-delivered add-ons.

To Filter Add-ons by Stage

- In the Add-ons quadrant of the Add-ons window, from the Filter by stage drop down box, select one of the following options:
  - **All**: All add-ons.
  - **Draft**: Unpublished add-ons.
  - **Published**: Published add-ons.
  - **Retired**: Add-ons retired from active use (because they can be withdrawn from service but not deleted from the system).
  - **Imported**: Metada exported to Graphic Hub by other Viz applications.
  - **Copied**: Transferred in a deploy operation.
  - **From archive**: Add-ons exported by Viz Engine and re-imported from a Viz Artist archive to the Graphic Hub.

To Sort Add-ons and Add-on Groups

1. Click **Tools > Administer add-ons...** to open the Administer add-ons window.
2. In the Add-ons panel, select on an Add-on or an Add-on Group.
3. Drag the Add-on or an Add-on Group to its new location.

To Assign an Add-on

1. Enable the Add-ons Panel.
2. Select one or more files and drag them into the add-ons header. To remove a file from the add-ons header, click it and press **Delete**.
3. Click the **Edit** tab. Add-ons available for assignment are shown.

4. Click the button to the left of an add-on to expand it.
5. Check the check box beside the add-on to select it.
6. Do *one* of the following:
   - Select a value from the proposals drop down box.
   - Enter a value in the field (allowed only if the add-on is unrestricted).
   - Click the **E** button to the right of the add-on to edit the proposals (allowed only if the add-on is unrestricted).
7. Click **Apply**.

To Retire an Add-on

1. In the Add-ons quadrant of the Add-ons window, right-click the add-on and select **Retire add-on**. You are queried if you are sure you want to publish this add-on.
2. If the add-on is ready for use, click **Yes**. The add-on is no longer available for use.

### 2.4.8 Replace File References

By replacing references it is possible to replace, for example, Images or Fonts referenced by Scenes or Geometries, with different Images or Fonts. It is only possible to replace an Image with an Image, or a Font with a Font.

To replace references is practical, for example, when rebranding a corporate identity.

**Caution:** Do not replace references at random. Make sure that the replacement files are compatible in terms of size, scale, color, and other Viz Artist properties used for playout. Research and test before replacing references.
To Replace References

1. In the Graphic Hub Manager, right-click the required file or files and select Replace References...
   The Replace References wizard opens.

2. Optional: In the Filter panel select which type of object to replace from the drop down box.
   Options are:
   - All
   - Image
   - Font
   - Geometry
   - Audio

Caution: Use the replace file references feature with care, as it can potentially be harmful. For example, if the image to be replaced is in a Scene which is currently on-air.

Warning: There is no UNDO to this procedure. Be very careful, and try this procedure first on one or two Scenes only.

Note: References in one file must be unique. It is not possible to replace multiple references with the same file (UUID). If multiple references (e.g. fonts) need to be replaced with the same file then this needs to be done in Viz Artist.

Caution: Use the replace file references feature with care, as it can potentially be harmful. For example, if the image to be replaced is in a Scene which is currently on-air.

Warning: There is no UNDO to this procedure. Be very careful, and try this procedure first on one or two Scenes only.

Note: References in one file must be unique. It is not possible to replace multiple references with the same file (UUID). If multiple references (e.g. fonts) need to be replaced with the same file then this needs to be done in Viz Artist.
3. Click **Next**.

4. Drag replacement files onto the listed files of the same type.

5. Click **Finish**. The **Action Log** for replacing references is shown.

6. Click **Replace**.

### 2.4.9 Direct Deploy Copy

The Direct Deploy Copy (DDC) function deploys one or more folders/projects/files:

- **Multi Server Deploy**: Deploys one or more folders/projects/files in exactly the same folder structure to two or more selected servers.

- **Server to Server Deploy**: Deploys one or more folders/projects/files to another server using one of three methods:
  - Rebuild the original structure.
  - Copy the folders/projects/files to the target folder.
  - Rebuild the structure under the target folder.

For Multi server deploy, rebuilding the original structure is the only available method.

Direct Deploy Copy (DDC) tasks can also be scheduled and run, as and when required (see **Graphic Hub Deploy Agent**).
Multi Server Deploy

Multi Server Deploy deploys one or more folders/projects/files in exactly the same folder structure to two or more selected servers.

To Replicate on Multiple Servers

1. In Graphic Hub Manager, log on to two or more servers.
2. Right-click a folder, project, or file, in the Servers and Folders or Files panel, and select Deploy.
3. In the list, select the target servers where the folders/projects/files should be deployed.

**Tip:** The servers can be sorted by clicking the Top, Up, Down, or Bottom buttons. This increases/decreases the priority level of a specific server.

4. Enable/disable the following options:
   - Overwrite existing objects (does not apply to referenced files).
   - Overwrite existing references.
   - Overwrite owner.
   - Overwrite creation date.
5. Select one of the following processing options:
   - Deploy all files to the first target server, then the next server in the queue, and so on.
   - Deploy one file to all target servers, then the next file in the queue, and so on.

   **Tip:** You can predefine the options in Steps 4 and 5 by clicking **Tools > Edit Preferences > Deploy Direct Copy**. Once defined, these preferences are set as defaults for every deploy operation you configure. Note, however, that **Rebuild original structure** cannot be redefined for Multi server deploy.

6. Click the **Continue** button. The **Action Log** for deploying files is activated.

7. Click **Deploy**. The folders/projects/files are then deployed. When the deploy process is finished, check the **Action Log** for possible errors, and if necessary, attempt to redeploy any unsuccessful files.

**Server to Server Deploy**

Server to Server Deploy deploys one or more folders, projects, and files, to another server using one of three methods:

- Rebuild the original structure.
- Copy the folders/projects/files to the target folder.
- Rebuild the structure under the target folder.

**To Replicate on One Target Server**

1. In Graphic Hub Manager, log in to two servers.
2. In the Explorer panel, select source files/folders/files, and then drag them to the target folder in the required server.

✅ **Tip:** For single folder or project deployment, the Servers and Folders panel can also be used.
The Deploy Direct Copy window opens and the analysis process begins.
3. Select one of these options:
   - **Rebuild Original Structure**: Copies an exact replicate of all selected folders/projects/files and its references from source to destination server.
   - **Copy to Target Folder Only**: Copies all selected folders/projects/files and its references from the source server to the destination folder on the destination server.
   - **Rebuild structure under target folder**: Copies an exact replicate of all selected folders/projects/files and its references from the source server to the destination folder on the destination server.

4. Enable/disable these options:
   - Overwrite existing objects (does not apply to referenced files).
   - Overwrite existing references.
   - Overwrite owner.
   - Overwrite creation date.
   - Overwrite modification date.
5. Click the **Continue** button. The **Action Log** for deploying files is activated.

6. Click **Deploy**. The folders/projects/files are then deployed.
7. When the deploy process is finished, check the **Action Log** for possible errors, and if necessary, attempt to redeploy any unsuccessful files.

2.4.10 **Graphic Hub Search**

The Graphic Hub Manager's search functions can search for files, folders, and projects, on one or more servers.
There are two primary types of searches available in the Graphic Hub Manager: Free text search (which includes a Quick search), and Standard search. In addition, it is possible to search for files in the available databases by universally unique identifiers (UUIDs).

If the search panel is not open, enable it under View > Panels > Search. Search results are shown in the Results panel and results can be filtered per server, if the search included more than one server.

Free Text Search

The free text search searches for files, folders or projects and can include any or all of these search strings:

- File names
- Folder names
- File owners
- File UUID (on Graphic Hub version 2.3.2 and higher)
- File type (geometry, font, images, etc.)
- Assigned keywords
- Created time
- Modified time
- Add-ons (metadata)
To Search Using Free Text Search

1. In the Search panel, select **Freetext** in the **Name / Freetext** drop-down list:

2. Enter the search parameters in the **Freetext** field. To achieve the best search results, refer to the **Search string syntax**.

3. The **Type** drop-down list is used to narrow the search to a specified set of file types only. The type field can be used to include or exclude one or more of the following types:
   - **Any type**: the default mode, all elements are included.
   - **AUDIO_CLIP**
   - **BASE_FONT**
   - **FONT**
   - **FONT FACE and FONT Files** (for Viz Engine 4.x and higher)
   - **GEOM**
   - **IMAGE**
   - **MATERIAL**
   - **MATERIAL_ADVANCED** (for Viz Engine 4.x and higher)
   - **SCENE**
   - **SHARED_MEMORY_MAP**
   - **SUBSTANCE**
   - **VIDEO_CLIP**

   Right clicking the type excludes it from the search, identified by a dimmed check mark. For example, here the **BASE_FONT** type is explicitly excluded, while the **FONT** type is included in
4. Select where to search in the **Where** drop-down list:
   - Everywhere (objects and Add-ons)
   - In objects (files and folders only)
   - In add-ons (metadata only)

5. If the GH Manager is logged on to more than one server, the **Search on checked servers only** box can be used to specify which server(s) the search is performed on. If checked, at least one server needs to be selected for the search to run.

6. If the GH Manager is logged on to only one server, or if multiple servers are logged on to and only one is selected in Search on checked servers only, the folder which is to be searched can be specified as required:
   a. Check the **Search in specified folder** check box.
   b. Select the folder to be searched.
   c. Check the **Search in Sub-folders** check box to run a recursive search.

7. To search by last modified date or date of creation, check the **Search by advanced properties** check box. The search by date approach can be narrowed further by specifying **from** date,
until date, and between dates:

8. Press **ENTER** or click on the search icon 🔍 to run the search.

**Note:** Click on the icon to expand or collapse the search criteria selection for each category.

Search using all available search criteria can only be performed on one server at a time.

**Quick Search**

The Quick Search function gives a quick means to search for a file, folder or project.

**To View the Quick Search Bar**

1. In the main toolbar click on **View > Toolbars > Quick search**.
2. Click on Quick search to open or close the Quick search toolbar.

**To Use the Quick Search Function**

1. In the Quick search toolbar click in the Servers drop down list and select the server or all servers to be searched.
2. In the text field enter the search string.
3. Press **ENTER** or click on the search icon 🔍.

**Deploy Search Results**

The Freetext search results can be used to create a deploy task. This can be useful for creating deploy tasks for daily additions or modifications, for example.
1. Perform a Free text search.
2. In the search results, select the result that matches the requirements for the deploy task and press **CTRL + D**, or right click and select **Deploy**.
3. Proceed to **Create a New File Based Deploy Task**.

### Standard Search

The Standard search searches for files with more detailed search options. Search by one or a combination of different search criteria.

#### To Search with Standard Search

1. In the Search panel, select **Name** in the Name / Freetext field.
   
   ![Search Panel](image)

2. In the **Name** field enter name search parameters, if required.
3. From the **Type** drop down box, select the file type to be searched for.
4. Click on the check boxes to add search criteria as required.

   ![Note](image)

   **Note:** If more than one server is open or selected, only the Advanced Properties criteria is available.

   - To Search by Specified Folder
   - To Search by Advanced Properties
   - To Search by Selected Keywords
   - To Search by References

5. Press **ENTER** or click on the search icon 🔍.

   ![Note](image)

   **Note:** To open or hide search criteria, click on the 🔍 icon to the right of each search criteria.

   If **Search on checked servers only** is checked, at least one server must be selected.

#### To Search By Specified Folder

1. Check the **Search in specified folder** check box.
2. Select a folder to search in.
3. If required, check the **Search in subfolders** check box.
4. If required, add more search criteria.
5. Press **ENTER** or click on the search icon 🔍 to search.

#### To Search By Advanced Properties

1. Check the **Search by Advanced Properties** check box.
2. Enter search parameters as required:
• **Size:** Searches for files that are either at least, at most, or between the defined size(s) in KB.
• **Created:** Searches for files created either after, before, or between the defined date(s).
• **Modified:** Searches for files modified either after, before, or between the defined date(s).
• **Expiration:** Search for files expired either after, before, or between the defined date(s).
• **Use group instead of users:** If selected, the next four options apply to groups instead of users.

⚠️ **Note:** Only registered users/groups are available from the lists.

• **Owned by:** Searches for files owned by user.
• **Modified by:** Searches for files that was last modified by the defined user.
• **Checked out by:** Searches for files checked out by the defined user.
• **Search by access rights:** If selected, searches for files that have write permission either on user (UW), group (GW), or world (WW) level.

3. If required, add more search criteria.
4. Press **ENTER** or click on the search icon 🔍 to search.

**To Search By Selected Keywords**

1. Check the **Search by selected keywords** check box.
2. In the upper field enter the first characters of the keyword, or enter *** to list all available keywords.
3. A list of available keywords that match the characters then shows in the keywords list.
4. Select one or more keywords that match the search criteria.
5. Check or uncheck the **All** checkbox:
   • **Checked:** Search for Scenes or Geometries which contain all search files.
   • **Not checked:** Search for Scenes and Geometries which contain at least one of the search files.
6. If required, add more search criteria.
7. Press **ENTER** or click on the magnifying glass 🔍 to search.
To Search By References

1. Check the **Search by Referenced/Referencing Files** check box.

   ![Search by Referenced/Referencing Files](image)

   Drag files from Explorer-Details or from Search-Result and drop them here!

2. Drag and drop a file or files into the drop area.

3. Make sure that the Reference check box is checked.

4. Check or uncheck the **All** check box:
   - **Checked:** Search for Scenes or Geometries which contain all search files.
   - **Not checked:** Search for Scenes and Geometries which contain at least one of the search files.
5. If required, add more search criteria.
6. Press **ENTER** or click on the search icon 🕵️‍♂️ to search.

Tip: Use **Search by References** to search and replace Images or Fonts referenced by several Scenes or Geometries, with different Images or Fonts. For example, if a company logo changes, search for the image references, select each required Scene and replace the image (see Replace File References).

Search by UUID

The Graphic Hub keeps track of all items in the database by assigning Universally Unique Identifiers (UUIDs). This also applies to deployed items, which means that if an item is deployed from one server to another, it has the same UUID on both servers. When the UUID of an item is known, it can be looked up very quickly using the Search UUID on server.

To Search by UUID on Server

1. Open Graphic Hub Manager, and log on to the server(s) that is to be searched.
2. From the Tools menu, select **Search by UUID...**. This opens the **Search by UUID on server** window.

   ![Search by UUID on server](image)

3. If you have logged on to more than one server, select the server to perform the search on in the **Server** drop-down list.
4. Enter the UUID in the editable text field. This text field accepts valid alphanumeric characters only. Valid input are digits in the range 0–9, and letters in the range A–F. The search is not case sensitive, and dashes are added automatically:

   ![Search by UUID on server](image)

5. Click **Properties...** to perform the search.
If an item with the provided UUID is found, its Properties page opens.
If no item on the database matches the provided UUID, you are alerted by a popup window.

Search String Syntax
Free text search string syntax is very similar to the search string syntax of other comparable web search engines.

**Example 1:** zebra scene -project -folder
In example 1, the search is conducted on any file names, file owners, UUIDs, file types, and keywords that include the string zebra and scene. This search excludes projects and folders, plus any of the other searched files that include the words project and folder.

**Example 2:** giraffe -image -geometry
In example 2, the search is conducted on any file names, file owners, UUIDs, file types and keywords that include the string giraffe. This search excludes images and geometries, plus any of the other searched files that include the words image and geometry.

Wildcard Text Description
If the full Name is not known then text Wildcards can be used to make a search:

- `*`: Match any characters. For example: El?me?t
- `?`: Match any single character. For example: El?me?t
- `[ ]`: Match a range or a list of characters. For example:
  - Elem[b-g]nt
  - Elem[shje]nt
- `< >` or `{ }`: Match a specific project, folder or file:
  - Searching for a specific UUID, for example `<6E6D3467-0A37-4D35-B80683B3A929772D>` or `{6E6D3467-0A37-4D35-B80683B3A929772D}`, returns the specific UUID.
  - Searching for a partial UUID, for example `<6E6D`, also includes the underlying UUID.

Best Practices for Searches
The Graphic Hub Manager search capabilities are powerful enough to replace the need to browse for files in the server tree. This is meant to make your Graphic Hub work faster and easier.

**Example 1:** If a Scene has been created on the design cluster, and saved as soccer, search for scene soccer. From the search results, drag the scene to deploy it to a Graphic Hub for the Viz Engine.

**Example 2:** Use the search feature to clean up a server. If the tree structure is complex, it can be cumbersome to find all the correct scenes. In this case, create a new and elegant tree structure and then find all the scenes in the old tree structure with a search by date and size. In this way, the new structure can be populated with relevant objects, in a logical order, and files that are too old or too large, etc., can be removed.
To Export Search Results

To export or copy search results for external use one can:

- Copy (CTRL + C) from explorer view (files and folder/projects) and search results (explorer and archive search) to the clipboard to be able to paste it to external applications (for example, Excel).

> **Information:** The Copy/Paste option is only available on a certain server, not on the "All Servers Tab"

- Export CSV search result (explorer and archive search) by right clicking into search result view and selecting **Export search result...** and selecting the location where the .csv file should be written to.

2.4.11 Server Information

This page details the different methods to monitor a server and its details.

- Terminals Monitor
- Active Sessions
- Monitor Servers
- Server Properties
- Chat with Artists
- Object Types

Terminals Monitor

The Terminals monitor window provides an interface to view all on line terminals within the network. A terminal is the physical machine where the Graphic Hub Terminal application is running.
To Open the Terminals Window

- Click **Server > Terminals**. The following columns are available:
  - **Terminal**: Shows the hostname of the physical machine where the Naming Service and/or server are installed. An icon represents the status of the server and Naming Service:
    - 🔄 Both the Naming Service and server are down.
    - 🔄 The Naming Service is running, but the server is down.
    - 🔄 The Naming Service is down, but the server is running.
    - 🔄 Both the Naming Service and server are running.
  - **Server info**: Shows `<Graphic Hub Server>@<Graphic Hub Naming Service>:@<port the naming service is listening to>`. A plus sign is added if you are logged on to the displayed server.
  - **Naming Service info**: Shows `<Graphic Hub Naming Service>:@<port the naming service is listening to>`.
  - **Connection**: Shows if Graphic Hub Manager has a valid connection to the Graphic Hub Terminal.
  - **Server**: Shows the name of the server.
  - **S. host**: Shows the hostname of the physical machine where the server is installed.
  - **S. port**: Shows the port number the server communicates through.
  - **S. up**: Shows if the server is running. This is also indicated by the icon in the Terminal column.
  - **S. in**: Shows if you are logged into this server.
  - **Naming Service**: Shows the name of the Naming Service.
  - **Ns. port**: Shows the port number the Naming Service communicates through.
  - **Ns. up**: Shows if the Naming Service is running. This is also indicated by the icon in the Terminal column.
  - **T. TCP-port**: Shows the TCP port number, which can be used to start the server remotely from Graphic Hub Manager.
  - **Terminal host network IP**: Shows the IP address of the Terminal machine.

The following additional options are available:
• **Show single user servers on other computers**: If selected, also shows servers/naming services in the network that are running in single-user mode (localhost).

• **Advanced options**: Open the Terminals Advanced Options window. Alternatively, press **ALT + A**.
  
  • **UDP-Port**: Set the UDP port where Graphic Hub Manager searches for Terminals (default: 19394).
  
  ![](warning.png)

  **Note**: The terminals window can only be used with pre-web-based Graphic Hub Terminal (version 2.4.2 or older). The UDP port must be the same as the port that the Graphic Hub Terminal listens to. To check the port number, go to the Graphic Hub Terminal and check in **Naming Service**, which UDP port is set.

• **Timeout**: Define how long the Graphic Hub Manager should listen for Terminals before timing out. The value is set in milliseconds.

• **Refresh**: Updates the list. Alternatively, press **ALT + R**.

• **Login**: To log in to a server, select the required server from the list, and then click the Login button. Alternatively, press **ALT + L**. This opens the Login window.

  ![](warning.png)

  **Note**: It is not possible to log into a Graphic Hub installation by remote in single-user mode (localhost) from other physical machines.

• **Start server**: If the server on a listed Terminal is not running, it is possible to start the server from this window. To do so, select the required server from the list, and click the **Start Server** button. Alternatively, press **ALT + S**.

• **Start Naming Service**: If the Naming Service on a listed Terminal is not running, it is possible to start the Naming Service from this window. To do so, select the required server from the list, and click the **Start Naming Service** button. Alternatively, press **ALT + N**.

**Active Sessions**

From the Active Sessions window it is possible to monitor all logged in users and active sessions. When faced with network or connection problems, checking active sessions can provide important clues. Likewise, performance problems in general are easy to spot in the Active Sessions window, since you can see hosts and servers. In sum, for a good clue as to where to find connection, network and performance problems, look in the Active Sessions window.
To Open the Active Sessions Window

Click **View > Active Sessions**. The following options are available:

- **Server**: If logged in to more than one server, select which server to monitor from the Server list.
- **Running since**: Shows how long the selected server has been running, counting upwards in hours, minutes, and seconds.

**Tip:** The time relates to the system time on the server machine.

- **Started at**: Shows the time and date when the server was started.
- **Refresh interval**: Defines the interval for when information should be refreshed. It can be set to a value between one and ten seconds.
- **Message**: To send a message to all clients that are logged in to the selected server, type a text in the Message box, and then click the **Send** button.

The Sessions list shows detailed information about the sessions that are active on the selected server. The following columns are available in the Sessions list:

- **User**: Shows the name of the user that activated the session.
- **Host**: Shows the host name of the machine that the session was started from.
- **Application**: Describes the application and operation that the session belongs to.
- **Logged in since**: Shows how long the user has been logged in to the server, counting upwards in hours, minutes, and seconds.
- **Last activity before**: Shows the last time an operation was performed in the session.
- **No. of open files**: Shows the number of files that are open in the system.
- **No. of locked files**: Shows the number of files that are session locked.
- **Login time**: Shows the time and date when the user logged in to the server.
- **Last activity**: Shows the time and date of the last time an operation was performed in the session.
• **Priority**: Set the priority of the sessions for the correct load balancing.
• **Session rights**: Shows the access (read/write) rights for the session.
• **Notifications**: Description used by the clients, for example to inform that files have been created.

### Monitor Servers
From the Monitor servers window it is possible to view and analyze all servers that are currently logged in to.

#### To Open the Monitor Servers Window
- Click **Tools > Monitor Servers**. The left part of the Monitor Servers window lists all available servers.

The right part of the window shows details about one or more selected servers. If all the available servers are working within the required parameters, this overview is hidden. If one or more servers are in warning state, the overview for these servers open automatically.

#### To View Server Details
- Double-click the server in the **Overview** panel or right-click the server, and select **Open Overview**.
- Select **Open All Overviews** to show details of all available servers.

### Overview
The Overview frame shows a quick overview of all the parameters. A green light next to the parameter indicates that all systems are normal. A yellow light indicates that there are non-critical problems. A red light indicates that system limitations have been reached or there are serious errors.

The overview shows this basic information for the following parameters:
License
The License frame shows the status of the Graphic Hub license.

The status shows license limitations or remaining number of days until the license expires. If your license expires, you receive instant chat messages with increasing frequency to that effect.

Disk
The Disk frame shows the status of the currently used partition where the data directory is located on the hard disk of the physical machine.

The status shows total, used, and free disk space, and also the warning limit. If the free disk space reaches this limit, you receive an Alerts to this effect. The warning is also logged in the Journal Panel. The warning limit is defined in the Preferences window.

Memory
The Memory frame shows an overview of the physical memory of the server both in numeric values and over time.

Health
The Health frame shows various Graphic Hub status parameters.
- **Deadlocks**: Shows the number of deadlocks in the system. Any deadlocks necessitate a restart of Graphic Hub.
- **Active sessions**: Shows the number of current sessions.
- **File opens**: Shows the total number of opened files.
- **Files**: Shows the total number of files stored in the system.
- **Files in memory**: Shows the number of currently open files. If it remains greater than 1 for an extended period of time, this may indicate locked files. In such cases, refer to the following procedures:
  - Restoring Corrupted Files
  - Graphic Hub Manager and Viz Artist Troubleshooting
- **Open transactions**: These are transactions that need to be deployed to the other server in the replication environment. If the number is too high, stop working until it is back to zero.

**Cluster**

If you are logged into both main and replication servers, you are presented with a Monitor Servers screen that reflects this.

- **Title bar**: Shows each server’s title bar shows its current status.
- **Cluster**: Shows if the cluster is connected and healthy.
- **Open transactions**: These are transactions that need to be deployed to the other server in the replication environment. If the number is too high, stop working until it is back to zero.
Activity

The Activity frame shows an overview of the server activity both in numeric values and over time.

<table>
<thead>
<tr>
<th>Activity</th>
<th>Calls: 41,692</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Calls/sec: 3.40</td>
</tr>
<tr>
<td></td>
<td>Peak: 3.90</td>
</tr>
<tr>
<td></td>
<td>Ø calls/sec: 3.45</td>
</tr>
<tr>
<td></td>
<td>Ø peak: 3.45</td>
</tr>
</tbody>
</table>

- **Calls**: Shows the total number of calls made by any application to the Graphic Hub Server.
- **Calls/sec**: Shows the average number of calls per second.
- **Peak**: Shows the highest amount of calls during one second.
- **Ø calls/sec**: Shows the average number of calls during one second for the total run time of the server.
- **Ø peak**: Shows the highest amount of calls during one second for the total run time of the server.

Server Details

This window shows information about the folders and files stored in the Graphic Hub and loaded into the memory.

**To View Server Details**

- In the Monitor servers window, click the **Details** button.
- From the **Refresh Rate** drop down box it is possible to set the interval of when the information should be updated.
- Selecting the **Show Functions** check box shows additional information used for debugging purposes.

⚠️ **Note**: Only users with administrator rights can access this window.
The Total frame shows the following information:

- **Projects**: Shows the total number of projects in the Graphic Hub.
- **Folders**: Shows the total number of folders in the Graphic Hub.
- **Files**: Shows the total number of files in the Graphic Hub.
- **Size**: Shows the amount of storage space used by the data.
- **Memory**: The memory pane displays the currently open files, counted per type.

### Warning and Error Thresholds

Certain conditions that may cause problems or lead to errors are signaled by the Graphic Hub when certain thresholds are crossed. An orange or red signal in the **Overview** indicates an issue that should be investigated by the administrator as soon as possible. In addition, the Graphic Hub provides a warning on shutdown, if one or more of the following conditions apply:

- Less than 1,600 MB hard disk space is available.
- More than 99 % physical memory is used.
- Less than 100 MB virtual memory is available.
In the **Overview**, **Warning** level issues are indicated by an orange parameter light, and suggests that a **restart is recommended**. **Critical** level issues are indicated by a red parameter light, and suggests that a **restart is necessary**. Check the log files for further details. The following table lists the most critical limits and warnings:

<table>
<thead>
<tr>
<th>Hardware Limit</th>
<th>Mode</th>
<th>Usage Limit, Journal Warning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Less than 1,000 MB free disk space</td>
<td>Localhost, 5/4 Free, Multiuser</td>
<td>Critical disk space error. Only read access, no write operations permitted</td>
</tr>
<tr>
<td>Less than 10,000 MB free disk space</td>
<td>Main/Replication</td>
<td>Critical disk space error. Only read access, no write operations permitted</td>
</tr>
<tr>
<td>Less than 2 % free disk space or less than 5 % free disk space if 1 % of total disk space is less than 10,000 MB</td>
<td>All</td>
<td>Journal warning: Hard disk limit almost reached</td>
</tr>
<tr>
<td>95 % or more physical memory used</td>
<td>All</td>
<td>Journal Warning: Suggests a restart is recommended</td>
</tr>
<tr>
<td>100 % Physical memory used</td>
<td>All</td>
<td>Journal Fatal Error: Suggests a restart is necessary</td>
</tr>
<tr>
<td>250 MB or less virtual memory available</td>
<td>All</td>
<td>Journal Warning: Suggests a restart is recommended</td>
</tr>
<tr>
<td>100 MB or less virtual memory available</td>
<td>All</td>
<td>Journal Fatal Error: Suggests a restart is necessary</td>
</tr>
</tbody>
</table>

In addition to the situations described in the above table, the following conditions produce a journal warning:

- 25 or more main/replication server switchbacks have occurred.
- 250,000 or more total open transactions have been processed.
- 7,500,000 or more critical calls have occurred (file created, truncated, written, replaced, copied, references changed).
- 9,000 or more total number of files (index information) in memory
- 48,000,000 or more total file opens.
- 2,000,000,000 or more total calls.
- Main, folder, keyword or file index data file size exceeds 1,536 MB.

The following conditions produce a journal critical error:

- 30 or more main/replication server switchbacks have occurred
- 500,000 or more total open transactions have been processed
- 8,000,000 or more critical calls occurred (file created, truncated, written, replaced, copied, references changed).
- 10,000 or more total number of file (index information) in memory.
- 50,000,000 or more total file opens.
- 2,100,000,000 or more total calls.
- A deadlock has been detected.
- Main, folder, keyword or file index data file size exceeds 1,740 MB.

**Server Properties**

The Server Properties window shows the following types of information:

- General server information.
- Checksum information. To view **Server Properties**, right-click the server and select **Properties** from the Servers and Folders panel.
General Server Information

In addition to the server's name, type and version, general server information includes:

- License
- Disk
- Memory
- Health
- Server details

Checksum Information

View the checksum when you want to compare two or more Graphic Hub servers to see how identical they are. This is useful after having performed replication operations or when you have a real-time Deploy Agent. Empty servers have a checksum of 00.
Use the **Refresh** button to update the checksum information for the servers currently logged on to. Checksum information includes:

- Total server checksum
- Folder structure (including file data)
- File data only
- File references only
- Pilot tables

Empty servers have a checksum of 00. When logged on to more than one server, right-clicking in the checksum information window brings up the contextual menu, which gives access to:

- **Open differences...**: Opens the Server Diff window. From this window, it is possible to detect differences between the servers (see Detect and Solve Server Differences).
- **Open differences and execute...**: Opens the Server Diff window and executes the **Diff all** operation.

**Note:** Execution time of **Diff all** varies depending on the database size and the amount of differences between the servers being compared.

- **Open Pilot differences...**: Opens the Pilot data differences window. See Resolve Viz Pilot Data Differences Between Graphic Hubs. This option only appears when connected to a server that contains Pilot data.
- **Properties**: Opens the General server information window for the selected server.
Chat with Artists

Users can communicate with each other while logged in to Graphic Hub. This chat functionality is also used to receive global messages from Graphic Hub, such as information about a system shutdown. The messages that are sent and received are saved throughout the session. If your dongle expires or is otherwise invalid, you receive messages in the chat panel with increasing frequency until you renew it.

**Tip:** The chat feature is available from both Graphic Hub Manager and Viz Artist.

![Chat Panel](image)

**To Open the Chat Panel**

- Click **View > Messages (Chat)**.

**Note:** If receiving a message while the Chat panel is hidden, the panel automatically opens.

**To Send an Instant Message**

1. Open the Chat panel.
2. Select the recipient from the left side of the panel.
3. Type a message text in the text box, and press **ENTER**. The message is sent to the selected Graphic Hub Manager and/or Viz Artist user(s).

**Tip:** Messages sent to **Global Message** are delivered to everyone. Messages sent to a group are delivered to every group member currently logged in.

**Object Types**

From this window you can view all the folders and file types on a selected server.
To View Objects

- Click **View > Object Types**.

1. If logged in to more than one server, select which database to monitor from the Server list.
2. Each folder or file type is shown with its corresponding ID. Once an object is in the database, its type is added to the object types list. The type remains in the list even if all files of that type is deleted later on.

### 2.4.12 Daily Backup Using a Second Graphic Hub

Adding a backup server adds another level of redundancy to the Graphic Hub server. This section describes how to configure and restore from a Graphic Hub backup server in running in 5/4 Free mode.
To Configure a Graphic Hub Backup Server

1. Install a Graphic Hub server in 5/4 Free mode on an extra machine.
2. Open **Backup Configuration** in the **Graphic Hub Terminal**, by clicking **Backup** and selecting **Show configuration** from the **Backup and Restore** menu.
3. Configure the server To Do an Internal Backup or To Do an External Backup.
4. Make sure to check both the **Automatic backup after successful shutdown** and **Start after backup** checkboxes.

5. Start the backup server.
6. Using **Graphic Hub Terminal**, **Graphic Hub Manager** or **Graphic Hub REST**, configure a shutdown task to shutdown the Graphic Hub periodically, for example once per day or once per week, depending on the requirement.
7. Install a **Graphic Hub Deploy Agent** on the failover system. If there is no failover system in place, the replication server should be used.
8. Create a real time deploy task from the cluster towards the backup server, without emergency pausing.

**Caution:** Because of the resource requirements for the Deploy Agent, it is **not** recommended to install the Deploy Agent on a cluster’s main server.

---

**To Restore from Graphic Hub Backup Server**

1. Pause the deploy task on the cluster.
2. Perform an emergency shut down of the backup system. Make sure to check the **Temporary disable backup after shutdown** checkbox:

![Emergency Shutdown](image)

**Warning:** If the backup after shutdown task is not disabled, the backup task runs and restarts the server afterwards, which can result in possible loss of data.

3. To go back to a specific backup, create a restore data directory from the Graphic Hub Terminal restore points. Then configure the Graphic Hub backup server to start using that data directory.

4. Log on to the cluster and backup servers with Graphic Hub Manager.

5. Click **Server** in the main menu and select **Differences...** to open the **Server diff** window. Deploy all differences from the backup server to the cluster.

![Tip](image)

**Tip:** Use the Manager to search for specific files and copy them from the backup server to the cluster, if not all differences are to be restored.

### 2.4.13 Detect and Solve Server Differences

If a Graphic Hub in a Cluster environment switches from real-time replication to recovery mode, or the replication server has been performing a cluster rebuild, the data on the servers may differ. In such situations, the Graphic Hub may be unable to do an automatic rebuild.

**To Detect and Solve Server Differences**

1. Make sure that the Main and Replication servers are up and running.
2. Open Graphic Hub Manager on a third machine, and log on to the Main and Replication servers. The user account on the Replication server must be an administrator user. Check
3. From the main menu, select **Server > Differences**.

4. In the Server Diff window, click **Diff All**. This scans all files on the selected servers.

5. Sort the entries on both servers by size (click the **Size** columns), and then delete all files with a size of 0.00 KB.

6. Click **Diff All** again.
7. Now sort the entries by type, and then select all entries of type **Scene**, where the row on the opposite side is labeled **missing**.

8. Right-click the scene entries, and then from the menu that appears, select **DDC To** or **Verify/restore**...

9. In the Deploy Direct Copy window that opens, click **Continue**. Or analog to this click **Verify** in the Verify/restore... window.

10. The **Action Log** for deploying files is activated. In the resulting window that opens, click the **Move** button.
The entries are deployed from one server to the other.

11. Repeat steps 7-10, and this time sort the entries by type **Geom**.
12. Repeat steps 8-10 for all other entry types.

## 2.5 Viz Pilot Database Management

This chapter describes management of Viz Pilot databases when the Graphic Hub is used as a Pilot data back end server.

In this section, you find the following information:

- **Important Pre-installation Information**
- **Schema Changes**
### 2.5.1 Important Pre-installation Information

Before setting up Graphic Hub as a back end database for Viz Pilot, observe the following:

- The server must meet the minimum hardware requirements for Graphic Hub as Viz Pilot back end system which may vary depending on the size of the installation.
- Viz Pilot requires Graphic Hub REST. The server running the GH REST service needs to meet the Graphic Hub REST Requirements.

The schema version is bound to the Graphic Hub version:

<table>
<thead>
<tr>
<th>Graphic Hub Version</th>
<th>Pilot Schema Version</th>
<th>Import Using</th>
</tr>
</thead>
<tbody>
<tr>
<td>Graphic Hub 3.6.0</td>
<td>6, 7, 8.0, 8.3.0, 8.4.0 and 8.7.0</td>
<td><strong>Graphic Hub Manager</strong></td>
</tr>
<tr>
<td></td>
<td><strong>⚠️ Use Graphic Hub REST 2.6.0 or</strong></td>
<td><strong>version 5.6.0</strong></td>
</tr>
<tr>
<td></td>
<td><strong>later to expose all 8.7.0 schema</strong></td>
<td><strong>changes.</strong></td>
</tr>
<tr>
<td>Graphic Hub 3.4.0 - 3.5.2</td>
<td>6, 7, 8.0, 8.3.0 and 8.4.0</td>
<td><strong>Graphic Hub Manager</strong></td>
</tr>
<tr>
<td></td>
<td><strong>⚠️ Use Graphic Hub REST 2.4.2 or</strong></td>
<td><strong>version 5.4.2 through 5.5.2</strong></td>
</tr>
<tr>
<td></td>
<td><strong>later, as 2.4.0 and 2.4.1 fail to</strong></td>
<td><strong>expose all 8.4.0 schema</strong></td>
</tr>
<tr>
<td></td>
<td><strong>changes.</strong></td>
<td></td>
</tr>
<tr>
<td>Graphic Hub 3.2.0 and 3.3.0</td>
<td>6, 7, 8.0 and 8.3.0</td>
<td><strong>Graphic Hub Manager</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>version 5.2.0 or 5.3.0</strong></td>
</tr>
<tr>
<td>Graphic Hub 3.0.2 - 3.1.1</td>
<td>6, 7 and 8</td>
<td><strong>Graphic Hub Manager</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>versions 5.0.2 through 5.1.1.</strong></td>
</tr>
<tr>
<td>Graphic Hub 3.0.0 and 3.0.1</td>
<td>6 and 7</td>
<td><strong>Graphic Hub Manager</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.0.1</strong></td>
</tr>
<tr>
<td>Graphic Hub 3.4.0 - 3.4.2</td>
<td>To clean the schema</td>
<td><strong>Graphic Hub Manager</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.4.2, 5.4.1 or 5.4.0</strong></td>
</tr>
<tr>
<td>Graphic Hub 3.2.0 and 3.3.0</td>
<td>To clean the schema</td>
<td><strong>Graphic Hub Manager</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.2.0 or 5.3.0</strong></td>
</tr>
<tr>
<td>Graphic Hub 3.0.2 - 3.1.0</td>
<td>To clean the schema</td>
<td><strong>Graphic Hub Manager</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.1.0 or 5.0.2</strong></td>
</tr>
<tr>
<td>Graphic Hub 3.0.0 and 3.0.1</td>
<td>To clean the schema</td>
<td><strong>Graphic Hub Manager</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>5.0.1</strong></td>
</tr>
</tbody>
</table>

- All Pilot data is stored in the configured data directory. It is included in the Graphic Hub Terminal internal backup, and when the data directory is copied.
The schema is automatically upgraded when the Graphic Hub is started on a data directory.

### Graphic Hub Version | Upgrade to Schema
--- | ---
Graphic Hub 3.6.0 | 8.7.0
Graphic Hub 3.4.0 - 3.5.2 | 8.4.0
Graphic Hub 3.2.0 and 3.3.0 | 8.3.0
Graphic Hub 3.0.2 - 3.1.0 | 8
Graphic Hub 3.0.0 and 3.0.1 | 7

In general, old Pilot clients can work on newer Graphic Hub and Graphic Hub REST versions, but newer Pilot clients cannot work on older versions.
- Schema 7 clients (VCP 7, 7.1, 7.2) and 8 clients (VCP 8, Pilot Edge) can work on GH REST 2.0.2/GH 3.0.2 and higher.
- Schema 8 clients (VCP 8, Pilot Edge) can not work on GH REST 2.0.1/GH 3.0.1 and lower.
- Schema 8.3.0 clients can work on GH REST 2.2.0/GH 3.2.0 and higher.
- Starting with PDS 8.4 and Pilot 8.5, all future Pilot releases will be able to work with all future GH versions greater than version 3.3.0, with potentially reduced functionality when used with older GH/GHREST versions. Therefore it is recommended to keep the versions aligned.

**Important!** Make sure to have the documentation for Graphic Hub and Viz Pilot at hand before proceeding with the installation. The latest documentation is available at [www.vizrt.com](http://www.vizrt.com).
2.5.2 Schema Changes

The following schema changes are performed automatically on Graphic Hub startup.

7.0.0 (Graphic Hub 3.0.0, 3.0.1) to 8.0.0 (Graphic Hub 3.0.2 or higher)

Adds three additional columns to the templates table:

- authored_model STRING NULL WITH DEFAULT NULL
- master_template_modified DATE NULL WITH DEFAULT NULL
- authored_model_modified DATE NULL WITH DEFAULT NULL

8.0.0 (Graphic Hub 3.0.2 to 3.1.1) to 8.3.0 (Graphic Hub 3.2.0 or higher)

Adds an additional column to the templates table:

- template_kind SHORT NOT NULL WITH DEFAULT = 0

8.3.0 (Graphic Hub 3.2.0 or 3.3.0) to 8.4.0 (Graphic Hub 3.4.0 or higher)

Adds an additional column to the templates table:

- master_template_xml STRING NULL WITH DEFAULT NULL

Important: Always use the correct versions as listed above. Do not import Pilot data or clean the schema on Graphic Hub 3.0.2 or higher with GH Manager 5.0.1 or 5.0.0, as this writes the wrong schema version to the Graphic Hub.

Manager 5.0.0 with Graphic Hub 3.0.2 or higher:
- Clean: Sets schema version number to 7.0.0.
- Import: Sets schema version number to 6.0.0.

Manager 5.0.1 with Graphic Hub 3.0.2 or higher:
- Clean: Sets schema version number to 7.0.0.
- Import: Does not overwrite present schema version.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Pilot Client Version</td>
<td>8.3.0, Pilot 8.3.0, Pilot Edge using 8.3.0 schema</td>
<td>3.2.0 or 3.3.0</td>
<td>2.2.0 or 2.3.0</td>
</tr>
<tr>
<td>8.0.0, Pilot 8, Pilot Edge using 8.0.0 schema</td>
<td>3.0.2 through 3.1.1</td>
<td>2.0.2 through 2.1.1</td>
<td>5.1.1 or 5.0.2, can import schema 6, 7, 8</td>
</tr>
<tr>
<td>7.0.0, Pilot 7, Pilot 7.1, 7.2</td>
<td>3.0.0 or 3.0.1</td>
<td>2.0.0 or 2.0.1</td>
<td>5.0.1, can import schema 6, 7</td>
</tr>
</tbody>
</table>
Adds additional columns to the `template_concepts` table:

- `template_thumbnail_type` SHORT NOT NULL WITH DEFAULT = 0
- `template_thumbnail_text` STRING NULL WITH DEFAULT NULL
- `thumbnail_last_modified` DATE NULL FOREIGN KEY WITH DEFAULT NULL

8.7.0 (Graphic Hub 3.6.0 or higher)

Adds an additional `template_script_html` table with the following columns:

- `template_id` BIGINT NOT NULL PRIMARY KEY
- `type_script` STRING NULL
- `java_script` STRING NULL
- `created` DATE NULL WITH DEFAULT SYSDATETIME
- `created_by` STRING NULL WITH DEFAULT = 'PILOT'
- `modified` DATE NULL WITH DEFAULT SYSDATETIME FOREIGN KEY,
- `modified_by` STRING NULL WITH DEFAULT = 'PILOT' FOREIGN KEY

See Also

- Viz Pilot official documentation
- Pilot Clients Have No Database Connection

2.5.3 Key Features and Workflow of Graphic Hub 3 as Viz Pilot Backend System

Key Features and Workflow of Graphic Hub 3 as Viz Pilot Backend System

- Centralized storage for both Viz Engine graphics and Viz Pilot data.
- Easy setup of main and replication in terms of redundancy and fail-over.
- Easy installation without any extensive database knowledge or upgrade procedures.
- Easy import of data from Oracle to Graphic Hub using GH Manager.
- Cloud-ready back end based on REST. Note regarding security: GH REST supports SSL. Key creation and certificate distribution is not handled by the Graphic Hub, and is the responsibility of the customer.
- Easy UI-driven import from a running Oracle database on Viz Pilot schema version 6, 7 or 8 to the Graphic Hub via the Graphic Hub Manager. The import only has to be done one time in the transition phase. Note that re-import deletes all previously imported data and all changes.
- The feel of working with data on a Graphic Hub is exactly the same as using the back end database on Oracle.

Notable Limitations

- Graphic Hub as pilot back end requires Graphic Hub REST and specific versions (see Viz Pilot Database Management).
• One schema per Graphic Hub instance. Graphic Hub can run a single Pilot schema on same instance as graphics data, as opposed to Oracle, which can run multiple.
• The schema version is bound to the Graphic Hub version.
• No support for master-to-master replication through Graphic Hub Deploy Agent. A manual backup solution is possible with Graphic Hub manager (see Data backup solution). Since Deploy Agent 2.2.0, it is possible to schedule deploy tasks which automatically backup Pilot data to other Graphic Hub instances.
• VOS (Viz Object Store) is not supported in Graphic Hub.

Basic Setup

These are the steps to set up Viz Pilot with Graphic Hub as back end with existing Pilot data schema version 6, 7 or 8:

1. Install Graphic Hub (see To Install a Graphic Hub. You may configure a new and empty data directory or use an existing one.
2. Install Graphic Hub REST (see To Install the Graphic Hub REST.
3. When both installations are complete, the configuration windows for Graphic Hub Terminal and Graphic Hub REST open automatically in the browser.
4. In the Graphic Hub Terminal window, click Start Server to start the Graphic Hub server.
5. Switch to the Graphic Hub REST configuration window. Select the local Graphic Hub (if desired) as Graphic Hub server, and click Apply.
6. Log on to the Graphic Hub as Admin. The default password is VizDb:

![Login to Graphic Hub](image)

7. Install the Graphic Hub Manager and start the application from the Start menu when the installation has finished.

8. Log on to the Graphic Hub server running on LOCALHOST as Admin:

![Login to Graphic Hub Server](image)

9. Go to Pilot > Import...

![Import Viz Pilot Data Schema](image)

11. All data from Oracle is now in the Graphic Hub. Click **Finish**.
12. Install Viz Pilot Data Server.
13. In the installer select Graphic Hub as database connection and enter the connection details of GH REST.

⚠️ **Note:** Requires that the Pilot data schema is at least version 6, 7 or 8, depending on the software versions in use.

⚠️ **Note:** The specified **User ID** must be a Graphic Hub user without a password, and minimum **Write** user rights.
14. **Add Graphic Hub REST as search provider in the Data server settings.**

15. **Set disable_built_in_vos_search.**

   This enables the Director to search the Graphic Hub for media.
16. Install Viz Pilot 7 or newer. When the installation finishes, the Pilot configuration opens. Select **GH** as **Database** and enter the connection details for the Graphic Hub REST.

17. Configure the other options, such as Preview, as required.

18. Install Media Sequencer 4 or newer.

19. Install Preview Server 3 or newer.

20. Start Director, then go to **Tools > Media Sequencer Configuration**.
21. In the **Database** tab, Select **Pilot Data server**.

1. Restart Director. The following icon should appear in the bottom right: 🍍
   - Director has already had a status icon in the bottom right corner that told the user about the status of the database connection of the Media Sequencer. It is still there and works regardless of the configured back end system. It uses a new icon, but works the same way. When green, it means the Sequencer is connected to a Pilot database. However, the icon is also green when the connected database is different from the one that Director connects to. For example, Director may connect to Graphic Hub, while the Sequencer connects to Oracle. In this case, the configuration needs to be changed. If the icon is not green, there is a problem with the Media Sequencer's database connection. Check the Sequencer logs for further troubleshooting details.
   - If the Media Sequencer Configuration's **Database** tab in Director looks the same as prior to upgrading to Pilot 7 or newer, it is because it is connected to an older Media Sequencer that does not support connecting to a Pilot Data Server. Media Sequencer 4 or newer is required for Pilot 7 or newer.

**Notes**

- With the Graphic Hub setup, the Media Sequencer, clients, and Pilot Data Server need to be able to Graphic Hub REST across the network.
- Media Sequencer needs access to the Pilot Data Server.
- The Graphic Hub database connection needs to be configured in three locations:
  - For client applications by using the Pilot Configuration tool, as outlined above.
  - For Pilot Data Server by using the installer, as outlined above.
  - For the Media Sequencer by using Director configuration, formerly known as External Interfaces.
When started, Director and Template Wizard now uses Graphic Hub as the back end system.

### 2.5.4 Main and Replication Servers

**Pilot Data High Availability Cluster Solution (Main/Replication)**

As with previous Graphic Hub versions, each modifying statement in a cluster environment is replicated towards the Replication server to guarantee real-time redundancy. This means that all items, including the Pilot data on the main instance, are replicated to a second Graphic Hub instance in real-time. In case of a fail-over situation, all connected clients on the main instance are automatically redirected to the replication server. As soon as the main server resumes operation, all items created or modified in the meantime are automatically transferred from the replication server to the main server.

To check if main and replication are in sync, connect to both Graphic Hubs as an administrator user using the Graphic Hub Manager, then proceed to check for Pilot Server Differences.
2.5.5 Import Viz Pilot Data Schema

This section details the import of an Oracle Viz Pilot Schema to the Graphic Hub. For information on the use of the imported Oracle Viz Pilot Schemas, refer to the Viz Pilot documentation.
To Import a Viz Pilot Schema from Oracle

1. Click **Pilot > Import** to open the **Import Pilot data** window:

```
<table>
<thead>
<tr>
<th>Option</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host</td>
<td>Host_Name</td>
</tr>
<tr>
<td>Protocol</td>
<td>TCP</td>
</tr>
<tr>
<td>Port</td>
<td>1521</td>
</tr>
<tr>
<td>Service</td>
<td>VIZ3TDB</td>
</tr>
<tr>
<td>User</td>
<td>UserName</td>
</tr>
<tr>
<td>Password</td>
<td>**********</td>
</tr>
<tr>
<td>Server to import to</td>
<td></td>
</tr>
<tr>
<td></td>
<td>GHManServe@GH-MAIN(Admin)</td>
</tr>
<tr>
<td>Import settings</td>
<td></td>
</tr>
<tr>
<td>Delete Pilot data</td>
<td></td>
</tr>
<tr>
<td>Delete and import Pilot data</td>
<td></td>
</tr>
<tr>
<td>Only import library data elements</td>
<td></td>
</tr>
</tbody>
</table>
```

**Tip:** The **Import History** shows a log of previously imported Viz Pilot schema.
2. Enter the parameters to access a Viz Pilot schema on an Oracle database:

<table>
<thead>
<tr>
<th>Table: Viz Pilot Schema Access Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Host</strong></td>
</tr>
<tr>
<td><strong>Protocol</strong></td>
</tr>
<tr>
<td><strong>Port</strong></td>
</tr>
<tr>
<td><strong>Service</strong></td>
</tr>
<tr>
<td><strong>User/Password</strong></td>
</tr>
<tr>
<td><strong>Connection string</strong></td>
</tr>
</tbody>
</table>

Example: `Data Source=(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=10.211.2.11)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=VIZRTDB)));User Id=pilotdb;Password=pilotdb;` |

3. In the **Server to import to** drop-down menu, select the Graphic Hub to import to. A dimmed drop-down menu means the menu is unavailable because the Manager is logged on to only one Graphic Hub.

4. Click **Verify Connection...** to verify the connection details and check if an import can be done. If the connection details are verified, this connects the Manager to the Oracle database.

**Note:** An import does not work if the schema version does not match the Graphic Hub version, or the Graphic Hub version is below 3.0.0.

5. Select the **Import Settings:**
   - **Delete Pilot data:** Erase all data and sets up a clean Viz Pilot schema.
   - **Delete and import Pilot data:** Clean all and import new data.
   - **Only import library data elements:** When checked, only Data Elements marked as Library Element are imported.
6. Click Next to view the elements marked for import to or deletion from the Graphic Hub database:

The Pilot data import progress window displays the number of entries that will be cleaned or imported from the database tables, as well as a progress log. Depending on the selected Import settings, this stage have an Import or Clean button:
- If Delete Pilot data was selected, the button is labeled Clean...
- If Delete and import Pilot data was selected, the button is labeled Import....

7. Click Import or Clean depending on the selected task. The time to completion of this task depends on the number of tables and elements to be cleaned or imported. The progress bar provides a quick overview of the process, as well as the start and estimated end times.

8. When the import is finished, an alert window pops up with information about any errors encountered during the import:

   ![Alert Window]

   1 warning occurred during import:
   - Invalid UTF 8 char found in table plakat_data! Check log file for column information

   OK
9. Click OK to return to the import Pilot data window. If any errors were reported, click the **Open log directory...** button to access the import log files.
10. **Click Next** to open the Delete old Pilot elements window:

- The **Summary** pane provides an overview of the total number of elements older than 1 year, 1 month and 1 week, respectively. It also lists the number of library elements in each age category.
- The **Cleanup of old Pilot data elements** pane can be used to run a cleanup task on the Graphic Hub to delete elements older than a specified number of weeks, months, or years. Library elements are not deleted unless the delete library elements checkbox is checked. Check the integrity cleanup checkbox to perform an integrity cleanup operation during the deletion.

> **Tip:** The number of elements that can be deleted is displayed in red text. The number is updated depending on the **older than** setting.

- Use the **Schedule Pilot data** cleanup and **Cleanup Pilot changelog** panes to create scheduled cleanup tasks.

11. Click Finish to return to the Manager. A popup window reminds the user to enable the Pilot cleanup tasks.
2.5.6 Resolve Viz Pilot Data Differences Between Graphic Hubs

The **Pilot differences** window in the Graphic Hub Manager is used to view and resolve differences in Viz Pilot data between two or more Graphic Hub servers. This can be the main and replication servers in a cluster environment, or other Graphic Hub servers that contain Pilot data, such as a backup server.

**To Check for Pilot Data Differences**

1. In Graphic Hub Manager, log on to the servers that you want to compare.
2. Click **Pilot > Differences...** to open the **Pilot data differences** window.
3. Select the servers to compare in the **Overview** section, then click **Check for differences**. This compares the Viz Pilot content on the selected servers, and you can now perform a manual backup or resolve potential cluster differences.

**IMPORTANT:** Graphic Hub Versions below 3.0.3: Using the Thumbnail generator with Pilot Datasets larger than 5000 elements generates many requests for retrieving all data elements. This causes performance instability in form of timeouts and blocking Pilot calls. Be sure to limit the Datasets to a maximum of 5000 elements or upgrade Graphic Hub Version to at least 3.0.3 to grant performance stability and non-blocking calls.
Understanding the Viz Pilot Data Differences Window

- **Tables left/right (1):** The two panes *Tables left* and *Tables right* show a listing of all database tables that are compared between the two servers.
- **Overview (2):** The *Overview* pane provides a quick overview of the differences between two servers:
  - **Drop-down menu:** If the Manager is logged on to more than two servers, all servers are selectable from the drop-down menus to the left and right of the *Check for differences* button.
  - **Check for differences:** Click to compare the selected servers. This initiates a checksum-based comparison of the table data between the servers. In the left and right panes, identical tables are marked with a green check mark icon. Tables that differ are marked with an orange warning icon. The *Overview* is populated with a summary of the differences. Any changes made after the last click are indicated by a counter, and a timer indicates the time passed since the latest change.
  - **Lock/Unlock database:** Click to lock or unlock the databases. When the database is locked, read operations are permitted, while write operations are not. Locking the databases starts a timer that shows how long the database has been locked, and the button changes to *Unlock database*.

```
Caution: Lock & deploy overwrites content on the destination server and cannot be undone. Make sure to double check the direction of the deployment with the selected servers.
```

- **Lock & deploy << | >>:** Use lock and deploy to lock the databases for changes and deploy any elements required to bring the two servers into identical states. The arrows indicate if the deployment is from the right server to the left server (<<), or from left to right (>>). When clicked, a confirmation dialog appears, where you must confirm the deployment direction. A progress bar with an estimated time for the deployment is displayed during the process.
- **Table Details (3):** Double click a table in the *Left* or *Right table* panes to open a detailed view of the selected table in the *Details* pane. Multiple tables can be opened, and are added as separate tabs within the pane. Right clicking a table in either pane opens a context menu.
from which data can be loaded. Select Show differences to load only the entries that differ in the Details pane, or Show all to load all entries in the selected table. Select Lock & deploy all to lock the database on both servers, and deploy all tables from the selected server.

Scheduled Tasks

All Viz Pilot cleanup tasks can be configured and activated via Graphic Hub Terminal. Open the Graphic Hub Terminal, then select Options > Scheduled tasks. Scroll down the task list to find the Viz Pilot related tasks.

Tip: In addition to the tasks described here, it is highly recommended to periodically perform a normal shutdown when using Graphic Hub as Viz Pilot data back end. The recommended interval is once monthly.

To enable the tasks, click Options -> Advanced settings in the Terminal and go to the CLEANUP SETTINGS pane. Check the checkboxes to enable each task:

Cleanup of Viz Pilot Data Elements

Click on the task to open the configuration properties for the task:
The following properties can be specified:

- **Start time**: Defines the first execution of the task.
- **Interval**: Defines the interval on which the task is executed.
- **Older than**: Cleans up all elements older than the specified time span.
- **Cleanup of library elements**: Includes library elements during deletion when checked.
- **Integrity cleanup**: Deletes all rows that violates Viz Pilot data integrity to provide data consistency when checked.
- **Cleanup of Pilot data elements**: Can also be configured using the Graphic Hub Manager. However, it needs to be activated using the Graphic Hub Terminal. The Wizard appears after a successful schema import. Refer to Key Features and Workflow of Graphic Hub 3 as Viz Pilot Back-end System for further details.

**Cleanup of Pilot Changelog**

Click on the task to open the configuration properties for the task:

The following properties can be specified:

- **Start time**: Defines the first execution of the task.
- **Interval**: Defines the interval on which the task is executed.
- **Older than**: Cleans up all elements older than the specified time span.

**Graphic Hub Manager Integrity Cleanup**

The Graphic Hub Manager provides a tool to perform an integrity check of Viz Pilot data and clean data integrity violations:

1. Click **Server > Check** to open the Check Server window.
2. In the Check section, check the **Check Pilot tables** checkbox:

![Check Pilot tables checkbox](image)

This includes a check for data consistency in the Viz Pilot tables during server check. If any violations are found, these are listed in the **Pilot Data** tab:

![Pilot Data tab](image)

3. If any violations are found, click the **Fix all** button in the **Fix** panel to delete those violations:

![Fix panel](image)

The integrity cleanup can also be included during the execution of the data element deletion task (see Viz Pilot Tasks on how to include it) if it is included, all integrity violations are cleared during task execution.

**Multiple Graphic Hubs and Viz Pilot Data**

The **Pilot differences** dialog in the Graphic Hub Manager can be used to perform a manual backup of one server to another. However, merging the database content is not possible. The data is always overwritten on the destination server, to ensure that the content is identical to the source.

1. Log on to both the active and backup Graphic Hub servers.
2. Open the **Pilot differences** dialog and select these servers in the overview section.
3. Check for differences and deploy in the correct direction for backing up the data. Only the Viz Pilot data that has been changed after the latest backup is deployed.

Since GH Manager 5.2.0 and Deploy Agent 2.2.0, it is possible to automate Viz Pilot data backups via time-steered deploy tasks. Create a Viz Pilot deploy task via one of the following workflows in GH Manager:

- Either navigate to **Pilot > Create Pilot deploy task...** to configure a deploy task which **only** deploys Viz Pilot data. This option can also be used in addition to an existing real time file deploy task, so that there are regular updates of the Viz Pilot data plus real time updates of the file data on the destination server.
- Or create a file-based deploy task as usual and check the **Sync Pilot data** option in the task's Schedule configuration window. Use this option if it is preferred to have a copy of the data where the Viz Pilot and file data are widely consistent at a certain point in time (for example, for backup purposes).

⚠️ **Note:** In this case, there must not be any parallel real time file deploy task running between the two servers, as then conflicts occur which cause the tasks to fail.

⚠️ **Note:** The following restrictions apply:

- As with **Pilot differences**, the used databases only allow read-operations while Viz Pilot data is actively being deployed. No Viz Pilot data can be created or changed in the meantime.
- Also, while actively deploying Viz Pilot data, the task cannot be paused, cancelled or restarted.
- Be sure to check if the correct source and destination Graphic Hubs are selected for deploy. All Viz Pilot data on the destination Graphic Hub is overwritten.
- The database schema versions of source and destination Graphic Hubs need to match.
- To periodically backup Viz Pilot data, configure a recurring task which deploys changes at desired intervals. It is currently not possible to deploy Viz Pilot data via real-time tasks.

**Viz Pilot Data Backup Solution**

Using **Graphic Hub Manager** in Graphic Hub 3, Viz Pilot data can be backed up manually to a Graphic Hub server in 5/4 Free or Multiuser mode. Using **Graphic Hub Manager** and **Graphic Hub Deploy Agent** in Graphic Hub 3.2, Viz Pilot data can also be backed up automatically via Viz Pilot deploy tasks as outlined in the previous section. On the backup server, the **Graphic Hub Terminal** can then be used as a tool for creating full or incremental backups of the underlying data directory on Graphic Hub, using a scheduled shutdown task with backup after shutdown and server restart.
2.6 Graphic Hub Archives

This section contains details about the archive functionality of the Graphic Hub Manager. In the Archives Panel, archives can be imported and exported with drag and drop. It also offers other functionality:

- An archive search function.
- View the contents of an archive.
- Import single files from an archive.
- View archive details.

In the Tool bar click on View > Archives to open the Archive panel.
The Archives panel consists of:

- **Archives View (1)**: Shows archives in folders (User selected (see Archives View)).
- **Search View (2)**: Search in all or selected archives.
- **Archive Contents View (3)**: Shows the content of the selected archive.
- **Archive Details View (4)**: Shows the details of a selected archive.

This section contains the following topics:

- Archives View
- Search View
- Contents View
- Details View
- Archive Folders
- Import Archives
- Export Archives
- Import Viz 2.x Data and Archives

⚠️ **IMPORTANT**: Graphic Hub Manager versions *earlier than 5.1.0* may produce corrupted archives. This happens if the Archive was created by Viz Artist and content was added *afterwards* using Graphic Hub Manager. Importing such an Archive displays an error: *File seems to be corrupted: invalid checksum (-32642)* archive error. Be sure to update your Graphic Hub Manager to at least version 5.1.0 as there is **no way to restore this kind of corrupted archive**.

### 2.6.1 Archives View

The **Archives** view shows added folders, both watched and not watched (see Archive Folders), and all archives inside those folders. Three different views are available for each archive.
• **Archive folder location (1):** Shows the archive folders where the archives are located. The folder can be watched or not watched.

• **The Archive (2):** Click on the archive to show the archive details, in the Details View.

• **Archive View Options:** Expand the tree node to access the following:
  - **Content View:** Shows all files contained within an archive (without any additional folder information).
  - **Entry Point View:** Shows the archive content structured in a way that reflects how it was exported.
  - **Folder View:** Shows the archive content with its folder structure from the Graphic Hub.

**Tip:** The archive icon color provides key information about the archive.
- A red icon indicates a corrupted archive.
- An orange icon indicates that the archive is *Read only* on the Windows file system.
- (A lock overlay icon indicates that the archive is *Password protected*).

---

**To Add a New Empty Archive**

1. Right-click anywhere in the Archives panel.
2. In the context menu select **New Archive**

![Create new empty archive](image)

3. Select a folder where the new archive is to be created.
4. Select an archive template for automatic naming of the archive, or manually enter a name for the new archive.
5. Click **OK**. The new, empty, archive shows in the archives panel in the selected folder. If a new folder location was selected, it shows as a not watched folder.
To Add an Archive

1. Highlight a folder where the archive is to be added.
2. Right-click any where in the archive panel.
3. In the context menu select Add Archive.
4. Click the archive to import.
5. Click Open. The archive shows in the archives panel in the selected folder. If the archive was selected from a new folder location, the new folder shows as a not watched folder.

To Set a Folder as Watched or Not Watched

1. Right-click the folder.
2. In the context menu, select Add or Remove <folder location>, respectively.
3. The folder shows 🔄 when it is set as a watched folder, and 📹 when it is not watched.

To Add a Watched Folder

1. Right-click anywhere in the Archives panel.
2. In the context menu select Add watched folder.
3. Select an archive folder to be watched.
4. Click Select Folder. The folder is added to the Archives panel as a watched folder (see Archive Folders).

To Remove a Watched Folder

1. Select the watched folder to be removed.
2. Right-click the folder.
3. Select Remove <folder location> from watched folders.
4. Right-click the folder again.
5. Select Remove <folder location> and all its archives from view. See Archive Folders.

To Apply a Password Protection on an Archive

1. Navigate to View > Archives to display Archives Panel.
2. Right-click the Archive.
3. **Apply password.**

Password protection is indicated by the archive lock overlay icon: 🗝️

- **Tip:** If password protection is applied to an archive, the archive must be unlocked by entering the correct password to import or modify it. To remove password-protection, just apply an empty password.

To Remove Content from an Archive

- **Tip:** Deletion of single items, folders or projects from an archive is possible.

To Delete Selected Folder–link

1. Navigate to Archives Panel.
2. Select file in folder in archive.
3. Right-click.
4. Select **Delete.**
1. Only the selected folder-link of the file is deleted (if the deleted file is under a folder). If this is the only link name of the file, or if the file does not have a folder the file is deleted with **ALL** link names from the archive.

**To Delete Everywhere**

1. Navigate to **Archives** panel.
2. Select file in folder in archive.
3. Right-click.
4. Select **Delete everywhere else**.

### 2.6.2 Search View

The Search Tab provides options to search in the archives. The following file types can be searched:
- Scenes
- Geometries
When the search tab is selected, by default all folders and archives are selected as search areas.
Deselect folders and archives as required to narrow a search.

To Search for a File in an Archive Folder

1. Click on the Search tab.
2. In the Freetext box, type text to search for.
3. Search results are shown in the Search result panel.
4. Double-click a file in the Search results list to see the file properties.

**Tip:** Or right-click the selected file and select Properties.

### 2.6.3 Contents View

The Archive Contents Panel shows the content of the selected archive in three views. Select which view in the Archives View.
Files listed in the archive Content View can be imported to a Graphic Hub by drag and drop (see Import External Images).

### 2.6.4 Details View

The Details view displays all available data for the archive selected in the Archives View.
2.6.5 Archive Folders

The folders listed in the Archives view can be **Watched** or **Not Watched** folders:

- **Watched Folders**: All changes to watched folders are monitored and reflected in the Archive view.
  
  **Note**: Once added, folders can be set to not watched if required.

- **Not Watched Folders**: Folders added to the archives, but not monitored.

2.6.6 Import Archives

Viz archive files (*.via), containing folders and/or files, can be imported to the Graphic Hub through the **Archives Panel**.
To Import All or Selected Folders and Files from an Archive

Archived files and or folders can be imported from the Archive panel or the Search result panel.

**Tip:** Any file or folder that can be seen in the Archive panel or Search result panel can be imported with drag and drop.

1. Select **Archive** or **Search** view.
2. Select a folder or a file:
   - In the **Archive** view: Select an Archive and select the required folder(s) or file(s) from the view panel. Multiple selections are possible.
   - In the **Search** result view: Select a folder or file, or multi-select.
3. Drag a selected Archive folder or file to a Graphic Hub folder in the **Servers and Folders**.

**Note:** The Archive or file can be dragged to the **Explorer** panel as well. Make sure the correct folder is selected first in the **Servers and Folders**.
4. **Complete the **Import from Archive** window as required.**

![Import from archive - Analysis & Options](image)

- Archive: Nick's Archive - GM@Host:2018-02-26-093925AM via VizDbServer@Z420-041:/data/GLOBALS/IMAGE
- Destination path: VizServer@Z420-041:/data/GLOBALS/IMAGE
- Available disk space on server: 97.21 GB
- Selected objects: 5, 21.25 MB, 4.49 MB
- Referenced objects: 1, 1.24 MB, 0.00 KB
- All objects: 7, 22.49 MB, 4.49 MB

**Analysis**

- s_onlydata_ok (SCENE - 6.15 KB)
- img_1_ok (IMAGE)
- s_1_all_ok (SCENE - 6.43 KB)
- s_onlyupci_ok (SCENE - 6.09 KB)
- bg-clouds (IMAGE - 12.29 MB)
- uffia_crose_hdr (IMAGE - 4.47 MB)
- inter (IMAGE - 4.47 MB)

**Infos, warnings & errors**

Info: Analysis finished without any warnings or errors!

**Step 5 - Analyzing objects on the target server…** 7 of 7

**Behavior options**

- Import mode: Rebuild original structure
- Overwrite mode: Overwrite

- Overwrite owner
- Overwrite create date
- Force link name creation
- Overwrite name
- Overwrite access rights
- Import add-ons
- Import keywords

5. **Click Continue.**
6. Click **Import**.

![Import from archive](image)

**Tip:** If a password protected archive is imported, the password must first be entered.

![Password input](image)

Context Menu Import

Use **Import** from the context menu to import an archive directly to the selected server.

To Import an Archive

1. In the **Servers and Folders** panel, **right-click** the target server.
2. Select **Import from archive**.
3. Click **Browse** to select a source folder.

4. Select the archive.

5. To check for objects that exist with the same name (but a different UUID), check **Determine existing objects by same name instead of UUID**.

6. To overwrite objects that exist with the same UUID, check **Overwrite existing objects**.

7. Click **Import**.

### 2.6.7 Export Archives

Folders and/or files can be exported out of the Graphic Hub as Viz archive files (*.via) through the **Archives Panel**.

#### To Export a Folder or a Single File

<table>
<thead>
<tr>
<th>Note: Folders and files can be multi selected in the Explorer panel.</th>
</tr>
</thead>
</table>

1. Select the folder or file to be exported as an archive:
   - In the **Servers and folders** panel select a folder, or
   - In the **Explorer** panel select a file or folder
2. Drag the selected folder or file to an archive in the **Archives** panel.
3. Fill-in the **Export to Archive** panel, as required.

![Export to archive - Analysis](image)

- **Summary**
  - **Archive:** Admin's-Archive-from-VizDbServer@GHSERVER-2018-02-02-...
  - **Available free disk space:** 40.19 GB
  - **Source/Entrypoint:** VizDbServer@GHSERVER\data\Image_1
  - **Selected objects:** 1
  - **Referenced objects:** 0
  - **All objects:** 1

- **Analysis**
  - **Image_1 (IMAGE - 33.25 MB)**

- **Infos, warnings & errors**
  - **Info:** Analysis finished without any warnings or errors!

- **Step 6 - Analyzing objects in the archive:** 1 of 1

- **Export all linknames to the archive**

4. Click **Continue**.

**Note:** Export all linknames to the archive: All link names are exported (default). When unchecked, only link names from the folder/project from where the file was dragged, are exported to the archive. Link names in sub-folders are also added.
5. Click **Export**.

![Export to archive 'Admin'>Archive-from-VizDbServer@GHSERVER-2016-02...](image)

**Context Menu Export**

**To Export a Folder or a Single File**

1. Right-click the folder, project, or file to be exported.
2. Select **Export to archive**.
3. Click **Browse** to select a destination folder.

![Export to archive from server 'VizDbServer@GHSERVER'](image)

4. Enter a name for the archive.
5. Click **Apply password** to generate a password-protected archive.
6. Click **Export**.

**Note:** If password protection is enabled, the archive must be unlocked by entering the correct password to import or modify it. The user is automatically asked to enter the password during import or modification. Password protection can also be added on an existing archive by context-menu **View > Archives > Apply password**. To remove password-protection, leave an empty password.

### 2.6.8 Import Viz 2.x Data and Archives

To use files from other data directories, they must be imported into the Graphic Hub. In Graphic Hub Manager either data directories or archives created with Viz Artist 2.x. can be imported.

**Tip:** When single files are imported from a data directory or an archive, referenced files are also imported.

**Expert Settings**

In the **Import Window**, there are a number of optional Expert Settings that can be used for import operations.
IMPORTANT! Expert Settings must only be used by experienced and qualified personnel.

Expert Settings Properties

- **Expert settings**: Tick the tick box to enable Expert Settings.
- **No. of instances**: Number of import threads allows to run asynchronously.
- **Show instances**: Shows all currently configured import threads when check.
- **Overwrite existing files**: Select this option before starting the import operation if you want imported files to overwrite Viz 2.x files on the Graphic Hub.
- **Restart after**: Enter a value representing the number of objects after which the import executable restarts.
- **Timeout**: Restarts the import if the import executable takes longer than the value specified here.

Import Viz 2.x Data Directories

To Import a Viz 2.x Data Directory

1. Click **Server > Import > Viz 2.x data**.
2. Select a Viz 2.x data folder to import from, and click **Open**.
3. In the **Import Window** select the files to be imported, in the left panel.
4. Click **Import**.

   ![Specify import folder ( + additional options)](image)

   The data will be imported into the folder shown below. You must not change the name of this folder as long as you want to run external control in 2.x mode.

   - **viz_2x**
   - Convert all objects to lowercase
   - Import external references (if accessible)

   Click **OK**.

5. Click **Modify** and select a directory.
6. Select the **Convert all objects to lower case check box**. This gives full Viz 3.x compatibility with Viz Artist and Viz Trio.
7. Click **OK**.

   🔄 **Note:** If the directory is big, the import process can take some time. The import window show the import status.

---

### Import Viz 2.x Archives

Viz Artist 2.x archive files (*.eva) can be imported into a Viz 3.x system with the Graphic Hub Manager.

#### To Import a Viz 2.x Archive or Selected Items

1. Click:
   - **For complete archives:** Server > Import > Viz 2.x archive(s).
   - **For selected items from one or more archives:** Server > Import > Manually selected Viz 2.x archive(s).
2. Open the selected archive or files:
   - **For complete archives:** Select a folder housing archives to import, and click **Open**.
• **For selected items from one or more archives:** Select an .eva archive file, and click Open.

3. Select the required files from the left panel.

4. Click **Import**.

5. Click **Modify** and select a directory.

   **IMPORTANT!** A warning shows to make sure that it is correct to modify the file.
Resume a Canceled/Crashed Import Operation

If an error occurs and the import procedure crashes, or the import is canceled, it is possible to resume from where the import ended. When an import operation does not complete, an import backup file is automatically created. This backup file is used to resume the import procedure.

![Attention](image)

**Note:** As the log file for an import is created on the hard disk of the physical machine, the import can only be resumed on the machine it has been canceled on.

To Resume a Canceled/Crashed Import Operation

1. Click **Server > Import > Resume from canceled or crashed import.**
2. Select a backup file to import.
3. Click **Open.**
4. Click **Import.**
5. Click **OK.**

**Note:** If the directory is large, the import process can take some time. The import window shows the import status.

**Tip:** If resuming from a crashed import, check the selection of files to prevent the crash from happening again. Also, it is possible to automatically start the import when resuming, by enabling the **Import** option in the **Preferences** window.
2.7 Troubleshooting

This section contains information on the following topics:

- Known Limitations, Problems and Workarounds
- Drivers for HASP Runtime Installation Fails
- Troubleshooting Networks, Virtual Adapters and Session Disconnects
- Restoring Corrupted Files
- Graphic Hub Manager and Viz Artist Troubleshooting
- Replication Troubleshooting
- Deploy Troubleshooting
- Graphic Hub Terminal Server Startup Issues
- Pilot Clients Have No Database Connection
- Troubleshooting Graphic Hub REST
- Legacy Dongle Troubleshooting
- Browser Troubleshooting
- List of Ports Used for Graphic Hub Network Connectivity
- Frequently Asked Questions

2.7.1 Known Limitations, Problems and Workarounds

General

Antivirus and Firewalls

- A Windows firewall exception is added during the installation.
- Running a firewall and/or an antivirus program on the same systems where any Graphic Hub component is installed could lead to serious issues and performance problems when the firewall or antivirus product is not configured properly.
- Problems observable:
  - Graphic Hub Server cannot be found by any application - like Graphic Hub Manager or Viz Artist.
  - Graphic Hub Server could experience data or performance loss due to an antivirus application scanning the data directories and locking files.
  - Graphic Hub Terminal Web-UI cannot be accessed.
  - Graphic Hub Deploy Agent cannot be found by Graphic Hub Manager.
  - Graphic Hub Deploy Agent could experience data or performance loss due to antivirus application scanning the data directories.
  - Graphic Hub Manager will not find any Graphic Hubs.
  - Graphic Hub Manager will not find any Graphic Hub Deploy Agents.

Windows: UAC and Non-administrative Accounts

- Only default level and lower of UAC is supported.
- Graphic Hub Deploy Agent will not work as expected if UAC is enabled on Deploy Agent versions lower than 2.0.0!

Graphic Hub

**General:** Graphic Hub will not start when the data directory used is from a newer Graphic Hub version.

**General:** When copying data directories always ensure that the source Graphic Hub version is the same or lower as the destination Graphic Hub version.

**Problem:** Long login times from clients when multiple network interfaces are used (VIZGH-6777)

  - **Background:** Graphic Hub by default registers on all available IP addresses in the Naming Service. The NS delivers the list in no specific order, so that clients might try an address first which is not reachable to them. This leads to timeouts.
  - **Workaround:** Configure Graphic Hub to register on one specific NIC only using Graphic Hub Terminal.

**Problem:** Graphic Hub cannot be accessed if networking configuration changes while the Graphic Hub is running (VIZGH-5575, VIZGH-3157)

  - **Background:** Graphic Hub registers with the naming service at startup and cannot dynamically detect changes in the network interface configuration or connectivity.
  - **Workaround:** Restart Graphic Hub (single server or cluster).

**Problem:** Data synchronization is not working because of an intersystem corruption.

  - **Workaround:**
    - Shutdown the cluster.
    - Remove the folder VizDbRecover from the current data directory on both Computers.
    - Copy the health data directory to the second host.
    - Restart the cluster (Main first).

**Problem:** Graphic Hub Manager server view states 'Restart server/Cluster necessary'.

  - **Solution:**
    - Use Viz Graphic Hub Manager to shut down the server/cluster.
    - Wait until the server/cluster shut down is finished!
    - If you're running a replication environment start the main server first.
    - Wait until the main server is started.
    - Start the replication server.

**Problem:** Manual or automated file copy destroyed data content on Graphic Hub.

  - **Solution:**
    - Never copy single files from data directories! Copy the whole data directory instead.
    - Shutdown the server/cluster.
    - Backup the destroyed data directory.
    - Delete the destroyed data directory.
    - Copy a working backup of your data directory to the previous deleted data directory.
    - Start the server/cluster again.
Hardlock/Sentinel Dongle: You should never disconnect a dongle from a machine where Graphic Hub is still running. Never plug in more than one Viz Artist/Viz Engine Hardlock/Sentinel dongle to your Viz Graphic Hub computer at the same time!

Graphic Hub Deploy Agent

Problem: Deploy tasks using the option "Rebuild structure under target folder" can cause issues.
- The following issues can be observed:
  - Keywords will not be deployed unless the file has changed (checksum different) or is created in all task modes.
  - Pausing real-time deploy tasks before their start time ("Start at") can delay a following continue up to five minutes.
  - Pausing of deploy tasks.
  - Deletion of all data on the destination server!
- Solution: Avoid using "Rebuild structure under target folder", don't use "Remove deleted objects on target server(s) as well" when it is still used. Also check "Do 'emergency' pausing of real-time tasks" and insert the corresponding values.

Real-time deploy: Does not deploy changes from Graphic Hub Manager "Replace Reference" to prevent error situations:
- Solution: Use Graphic Hub Manager's DDC to re-synch the content.

Real-time deploy/content not completely synched: In rare cases the content couldn't be synched by Graphic Hub Deploy Agent:
- Solution: Execute server differences via Graphic Hub Manager and deploy the content manually, restart the deploy task or restart the Graphic Hub Deploy Agent service again to reinitialize the synchronization.

Real-time task stops when source/destination servers are offline or connection is lost:
- Solution: Task will be restarted when all servers are available again. Please check event log "Vizrt" if task does not start and/or restart Graphic Hub Deploy Agent in this case

Task hangs or does not copy a file:
- Solution: Check source and destination server with Graphic Hub Managers "Check server" Utility and fix corrupted files. Restart the task afterwards.

High availability disconnecting does not work (high availability partner lost):
- Solution: Stop Graphic Hub Deploy Agent and delete the file DeployAgentConfig.cfg in the Graphic Hub Deploy agent installation directory. All Graphic Hub Deploy Agent settings will be lost in that process. Start Graphic Hub Deploy Agent again and re-configure your current Graphic Hub Deploy Agent via Graphic Hub Manager.

Real-time deploy on sub folder or project: Rebuilds the complete project and folder structure on the destination server.

Scheduled deploy tasks do not start if Main server is shut down in a cluster setup (VIZGH-7136):
- Problem: When using GH as a cluster any scheduled deploy task (Pilot & GH data) only copies files if the original Main server is running. If the Main server is shut down the deploy task is
running but not copying files.
Note: Real time tasks are not affected by this issue, they continue running also in case of cluster failover.
  • **Solution:** After restoration of the cluster these tasks resume normal operation.

**Graphic Hub Manager**

**Viz 2.x Archive Import**
  • If dongle driver Sentinel 7.6.5 (installed by Viz World 14) is installed, Graphic Hub Manager may fail to import viz 2.x archives. Install Sentinel dongle driver version 7.5.1 to fix this problem!

**Search-based Deploy Tasks**
  • While all settings in the search filter are overtaken when creating a new Search-based Deploy Task the date ranges for the Create date and Modification Date do not follow this behavior, since for Search-based Deploy Tasks, those ranges are relative and should be expressed as intervals. Therefore, if you want to restrict the result of Search-based Deploy Tasks by those dates, you have to manually set corresponding intervals in the tab 'Search criteria' under 'Created within the last' and 'Modified within the last'.
  • When creating a search based deploy task where add-ons are searched, there are no results if free text is checked. If the status of the Deploy Agent is 'lost' press **search** to establish the connection.
  • Cancel and Pause are only working on established Deploy Agents.

**Installation**

**Problem:** Graphic Hub REST could not be updated, installation fails with "There is a problem with thin Windows installer package. A script required for this install to complete could not be run...". (VIZGH-6800)
  • **Background:** The configuration data for Graphic Hub REST are put into the `C:\ProgramData\Vizrt\Viz GH Rest\` directory. We have seen that in very rare cases the access rights to this folder become corrupted, making it impossible to complete installation.
  • **Workaround:** Delete the complete `C:\ProgramData\Vizrt\Viz GH Rest\` folder manually. Then start the installation again.

**Problem:** While uninstalling, the message "Warning 1910.Could not remove Shortcut XXXXX.lnk. Verify that the shortcut file exists and that you can access it." shows. Which results in temporary deleted shortcuts from the desktop.
  • **Solution 1:** After a Windows restart delete the desktop shortcut manually.
  • **Solution 2:** Due unspecified behavior in Windows the file `<SystemDisk>:\<Users>\<PublicUser>\Desktop\desktop.ini` has been set to read-only. Therefore, unset the read-only attribute before uninstalling results in expected uninstallation behavior.

**Problem:** Installation fails with permission errors reported during installation. Installation will not work as expected if user does not have administrative rights.
1. **Solution:** The user that performs the installation requires administrative rights and requires to approve any UAC dialog during installation.

2. **Problem:** Installation fails with "Sentinel HASP Run-time installation" warning.

3. **Workaround:**
   - Install Graphic Hub without dongle drivers:
     1. Start the Graphic Hub installation again.
     2. Choose Custom installation.
     3. Uncheck **Dongle drivers**.
     4. Proceed with install.
   - OR remove the dongle drivers and install again:
     1. download from ftp.vizrt.
     2. Extract the `haspdinst.exe` from the `.zip` file to `C:`.
     3. Open a command shell (cmd) and type `C:\haspdinst.exe -fremove`.
     4. Reboot the workstations.
     5. Start the Graphic Hub installation again.
     6. Install Graphic Hub as desired.

2.7.2 **Drivers for HASP Runtime Installation Fails**

Installation fails with a warning that says Drivers for HASP runtime cannot be installed.

To Start Sentinel HASP License Manager

1. On your Windows desktop, right-click **My Computer** and select **Manage**. The Computer Management window appears.

   ![Computer Management Window](https://example.com/computer-management.png)

2. In the left panel, expand the node **Service and Applications**.
3. Click **Services**.
4. In the right panel, right-click **Sentinel HASP License Manager** and select **Start**.
5. Install Graphic Hub again.
2.7.3 Troubleshooting Networks, Virtual Adapters and Session Disconnects

Some network settings can prevent the Graphic Hub applications from finding other running Graphic Hub Terminals on the network. To locate a machine which is running the Graphic Hub Terminal, try pinging that machine. If the host is not reachable across the network, the Graphic Hub Terminal is not reachable either.

It is necessary to run Graphic Hub Terminal in a local network where the settings shown below are identical on every workstation running the terminal application.

⚠️ IMPORTANT! While the Graphic Hub and/or the Naming Service are running, the server's network adapter status(es) and IP address(es) may NOT be changed.

To Check Network Settings

1. On the server machine, go to Start > Run > cmd.
2. In the console, enter `ipconfig /all` and press ENTER.
3. Browse to the current connected network adapter.
4. Check Subnet Mask and Default Gateway.
5. Repeat steps 1-3 on the client machine, and see that the Subnet Mask and Default Gateway are identical between client and server.

To Solve Network and Firewall Problems

1. Make sure that the client can broadcast to other clients and to the Graphic Hub Server. This means all firewalls between server and clients need to allow broadcast.
2. Make sure the following port settings for the Graphic Hub Terminal are open to firewall traffic in between all clients and servers:
   - TCP Port
   - UDP Port
   - Graphic Hub Server Port
3. Make sure that local firewall applications allow traffic for all Viz products.

Server Unreachable in Dual Network Setup

If installed on a server with two network cards, the Graphic Hub is normally operating on both networks. However, in certain hardware configurations, Graphic Hub versions 2.4.0, 2.4.1 and 2.4.2 may become unavailable or unresponsive on one of the networks. If this is the case, please submit a Support Request, making sure to include all the required information.

Sessions Keep Disconnecting from the Graphic Hub

Symptoms: Viz Engine is reporting disconnections and reconnect attempts on the console when loading data from the Graphic Hub. This may cause some delay when the session was disconnected (as it needs to reconnect first), as the Graphic Hub pings the client periodically and disconnects the session if it cannot reach it for 90 seconds. In addition, it causes load on the Graphic Hub, a sessions are disconnected periodically and log in again.
This can be caused by the client side firewall, different subnets with restrictions in routing or invalid or missing DNS records for the clients.

Client side firewalls may cause issues when the Viz Engine/Artist version is below 3.8.2 or the Graphic Hub version is below 3.0.0, since the communication protocol used was two-way and required the firewall on the client side to be open for the Artist/Engine processes. However, it is not required to disable the firewall completely, just certain ports need to be open for Artist/Engine.

- See List of Ports Used for Graphic Hub Network Connectivity
- See the Ports and Connections section of the Viz Engine Administrator Guide

How to Determine Connection Issues

- You can verify that clients stay connected with GH Manager in the active session view: see Server Information.
- Have a look at the login times of the sessions and if they disappear after some time (more than 90 seconds).
- Have a look at the Graphic Hub journal messages with GH Manager: Journal Panel.
- Filter by Alerts and look for messages with Level 751, 802 and 961 which indicate client connection loss.

How to Fix the Issue

- Check firewall settings on the client and ensure the required ports are open for Viz Artist and Viz Engine processes.
- Verify that clients are properly registered at the DNS and reachable from the GH server.

2.7.4 Restoring Corrupted Files

Any save operation from a client (e.g. Viz Artist) via Viz Engine triggers Graphic Hub to back up the old file and create a new one. The new file is streamed to the server until the client informs the server that the operation is complete. After that, Graphic Hub Server deletes the backup file.

A file is corrupted if Graphic Hub does not get the message from the client indicating that the save operation is done. For example, this can occur if the client application crashes during the save operation.

To Restore Corrupted Files

1. In Graphic Hub Manager, log into the server where the corrupted file is located.
3. Browse through all the results and click the P button in the Details panel. If a file has been corrupted, you are prompted to restore it.
4. Click Restore.
5. Repeat steps 3 and 4 until all corrupted files have been restored.
6. To make sure that the file has been completely restored, you can do a search to check that the restored file's checksum is not 0.

See also
2.7.5 Graphic Hub Manager and Viz Artist Troubleshooting

This page contains the following topics:

- Viz Artist Does Not Respond
  - To Restore a Locked or Corrupt File after Viz Artist Stopped Responding
- Graphic Hub Manager and/or Viz Artist Cannot Find Servers
  - Solution
- Graphic Hub Manager or Viz Artist Does Not React in Server Tree

Viz Artist Does Not Respond

If Viz Artist stops responding, files that were open keep their locks. Graphic Hub usually releases the session within a certain interval, but you should check if Viz Artist is responding to the session release attempt.

To Restore a Locked or Corrupt File after Viz Artist Stopped Responding

1. In Graphic Hub Manager, log into the server where the corrupted file is located.
2. Check the Active Session to see how long it takes for the server to clean up the session.
3. Check the Application Name and IP address in the Server Information's Active Sessions window.
4. Once all processes are complete, all related files are unlocked and checked in, and you can continue with Restoring Corrupted Files.

Graphic Hub Manager and/or Viz Artist Cannot Find Servers

When searching for servers, the system cannot detect any.

Solution

1. Disable all network blocking applications, like firewalls, anti-virus software, VPNs, virtual network adapters, etc.
2. Ask your system administrator to open necessary ports on the company’s firewall between the Graphic Hub Server, Graphic Hub Manager and/or Viz Artist.

Graphic Hub Manager or Viz Artist Does Not React in Server Tree

Sometimes you cannot get into the server tree. This is mostly due to a lost server connection. If you suspect the server connection is lost, a good first step is to click around the server tree. If it does not update, exit the application and log back in.

See Also

- Troubleshooting Networks, Virtual Adapters and Session Disconnects
- Replication Troubleshooting
2.7.6 Replication Troubleshooting

Most problems with replications can be solved by having a stable network environment. This means that applications which are causing drag on network performance, like global network updates or global virus scans, should not be performed in a replication environment.

To prevent data loss or conflicts between the main and replication servers, the server checks the network card for timeouts. If the timeout is too long, the server shuts down.

This page contains information on the following topics:

- Main Server Is Not Available
  - To Solve Cluster Timeouts
- Cluster Not Up and Running
  - To Restore a Healthy Cluster Environment
- Cluster Configuration on Graphic Hub Terminal
  - To Refresh the Connection Settings
- Journal Log Flooded with Replication Error Messages
  - To Synchronize Data Directories
- Both Main and Replication Servers Have Open Transactions
- Both Running As Main Shutdown Error
- Port Already Used Startup Error

Main Server Is Not Available

The main server often shuts down because network connections become unavailable. If this is a common occurrence, perform the procedure below.

To Solve Cluster Timeouts

1. Open Graphic Hub Terminal and open the Advanced Settings.
2. Configure the Additional Advanced Settings for Cluster Configurations, enabling the timeout settings and setting the cluster timeout to a higher value.

⚠️ Caution: Consult a Vizrt CA professional before enabling this functionality.

Cluster Not Up and Running

A server can become unavailable due to hardware problems, network problems, and so on.

To Restore a Healthy Cluster Environment

1. Open Graphic Hub Terminal on one of the cluster servers.
2. Check the status field. If the status does not say Cluster is up and running, start the server(s) that is shut down.
3. Wait until the server resumes its former role. If it was the main server, this may take some time while all open transactions are deployed and the server switches back to its original state.
4. The status field should now state **Cluster is up and running**, and **Open transactions** should be 0.
5. Open the **Graphic Hub Manager** and **Detect and Solve Server Differences**.

**Cluster Configuration on Graphic Hub Terminal**

In Graphic Hub Terminal, the message You are already connected to a cluster appears, even though the other server in the cluster is not running anymore. Graphic Hub Terminal has most likely not received an automatic update from the other Terminal.

**To Refresh the Connection Settings**

1. In Graphic Hub Terminal, click **Refresh**.
2. Start the cluster. If it still does not work, exit Graphic Hub Terminal and restart it. To start or stop the Graphic Hub Terminal, use the **Start Terminal Service** and **Stop Terminal Service** shortcuts located in the Start menu’s Vizrt folder, or by using the **Windows Service Control Manager**.

**Journal Log Flooded with Replication Error Messages**

This may occur if your data directories are not properly synchronized.

**To Synchronize Data Directories**

1. Shut down the replication server (see **Graphic Hub Shut Down**).
2. Back up, then delete the replication server’s data directory.
3. Shut down the main server.
4. Copy the main server’s data directory to the replication server’s (now empty) directory.
5. Start up the replication server.
6. Check the Journal for error messages.

**Both Main and Replication Servers Have Open Transactions**

1. Open the Graphic Hub Terminal and start the main and replication servers. The Terminal detects if both have open transactions when the second server starts, and present a dialog where the transactions can be backed up or deleted. Select backup or delete. The Terminal then attempts to restart.
2. If the above does not work, rename the **VizDbRecover** directory inside the data directory on the server that has the least number of open transactions.

⚠️ **Caution:** The server must not be running while renaming the directory!

3. Start both servers.
4. Wait until both servers report no open transactions, has switched back to real time replication status, and returned to their original modes.
5. Bring servers in sync again using the Graphic Hub Manager server differences tool.
Both Running As Main Shutdown Error

When a running main server shuts down with this message when starting the replication server, the problem may be caused by the replication server being unable to reach the main server, even though the main server is able to reach the replication server.

1. Check that both servers can reach each other on the network.
2. Check the network environment.
3. Try to log in from replication/main to the other machine using Graphic Hub Manager.

Port Already Used Startup Error

1. Open Task Manager (Start > Run > Task Manager) and check if VizGHNamingService.exe or VizGH.exe is running.
2. Restart the Terminal service using the Stop and Start Terminal Service shortcuts from Start > Vizrt > Graphic Hub.
3. If still not working check for conhost.exe or cmd.exe processes and terminate them. These are the console processes that can linger in some cases and keep ports bound.

2.7.7 Deploy Troubleshooting

This page contains information on the following topics:

- DDC Data Does Not Transfer Correctly
- Deploy Agent Does Not Transfer All Data
- Deploy Agent Does Not Run
  - To Maintain the Deploy Agent Service
- Deploy Task Runs for Too Long
  - To Release a Hanging Deploy Task
- Deploy Task Floods Journal with Corrupt File Detected Message
- Some files Cannot Be Processed Deploy Task Error
- Deploy Agent Service Cannot Be Started During Installation
- Deploy Agent Service Cannot Be Started After Installation
- Deploy Agent Is Not Reachable from Graphic Hub Manager
- Real-time Deploy Task Does Not Start

DDC Data Does Not Transfer Correctly

DDC data may not be transferred correctly in the following cases, which are also visible in the DDC Action Log:

- The connection between servers is lost
- A file is locked or checked in
- In other cases, it is necessary to file a bug report. Make sure that you include the exact error code and messages.
Deploy Agent Does Not Transfer All Data

A Deploy Agent task may not transfer all data correctly in the following cases:

- A file is locked or checked in.
- In other cases, review the unsuccessful task details and check all affected files.

Deploy Agent Does Not Run

To Maintain the Deploy Agent Service

1. Click **Start > Vizrt > Graphic Hub > Deploy Agent > Stop Viz GH Deploy Service** to stop the Deploy Agent Service, then **Start Viz GH Deploy Service** to start the service back up.
2. On your Windows desktop of the machine where the Deploy Agent is installed, right-click **My Computer** and select **Manage**. The **Computer Management** window appears:

   ![Computer Management window](image)

   In the left panel, expand the node **Service and Applications**.

3. In the right panel, right-click **GH Deploy Agent** and select **Properties**.
4. Click the **General** tab and then click the **Start** button.
5. If the Deploy Agent service still does not run, continue with the following steps.
6. Click the **Log On** tab.
7. Click the **This account** radio button.
8. Click **Browse**.
9. In the field **Enter the object name to select**, enter **Administrator** and click **OK**.
10. Enter and confirm the valid password for Administrator.
11. Click **OK**.
12. Start the Graphic Hub Deploy Agent again.

If it still does not run, make sure the Deploy Agents have been stopped.

16. Browse to the Deploy Agent directory and delete the folder **Open Tasks** and the **deployagent.cfg** file.
17. Start the Graphic Hub Deploy Agent again.
Deploy Task Runs for Too Long

To Release a Hanging Deploy Task
1. In Graphic Hub Manager, log into the source server and open the Active Sessions window.
2. Check the Graphic Hub Deploy session for locked files.
3. If there are locked files, cancel the affected deploy task. The task should restart on its own.

Deploy Task Floods Journal with Corrupt File Detected Message
If the Deploy Agent encounters corrupted files during operation, it attempts to restore these files on the source server. This causes the Deploy Agent to log Corrupt file detected to the Journal.

Some files Cannot Be Processed Deploy Task Error
If the Deploy Task fails to start or pauses with an error stating that some files cannot be processed, investigate the journals and finished deploy task messages for files with identical names, but with different UUIDs on the destination server.

Deploy Agent Service Cannot Be Started During Installation
Check if Service Control Manager is open and close it.

Deploy Agent Service Cannot Be Started After Installation
Use the Service Control Manager to restart the Deploy Agent service. If the service cannot be restarted this way, contact Vizrt CA.

Deploy Agent Is Not Reachable from Graphic Hub Manager
- Check all network blocking applications, such as firewalls, anti-virus software, VPNs, virtual network adapters, etc.
- Request from the system administrator that necessary ports on the company’s firewall are opened. Refer to the List of Ports Used for Graphic Hub Network Connectivity.

Real-time Deploy Task Does Not Start
- Check the target server for duplicate folders and projects with identical names with different UUIDs.
- Check if there are non-UTF-8 characters in folder or project names.
2.7.8 Graphic Hub Terminal Server Startup Issues

Graphic Hub Terminal Does Not Start the Server
This may occur if Graphic Hub is installed as a service but not started as a service.

To Start Graphic Hub as a Service
1. Exit Graphic Hub Terminal.
2. Wait until Graphic Hub Terminal starts itself automatically.

Graphic Hub Terminal Service Does Not Start

To Start the Graphic Hub Service
1. On your Windows desktop of the machine where the Deploy Agent is installed, right-click My Computer and select Manage. The Computer Management window appears.
2. In the left panel, expand the node Service and Applications.
3. Click Services.
4. In the right panel, right-click Viz GH Terminal Service Properties and select Start.
5. Wait for the Graphic Hub Terminal to start up.

2.7.9 Pilot Clients Have No Database Connection

1. Check if Graphic Hub REST is running and configured.
2. Check if the Graphic Hub is Running.
3. Check all network blocking applications, such as firewalls, anti-virus software, VPNs, virtual network adapters, etc.
4. Request from the system administrator that necessary ports on the company’s firewall are opened. Refer to the List of Ports Used for Graphic Hub Network Connectivity.
2.7.10 Troubleshooting Graphic Hub REST

This page contains the following topics:

- Service Cannot Be Started During Installation
- Service Cannot Be Started After Installation
- REST Is Not Reachable or REST Cannot Connect to Graphic Hub
- REST Is Returning Unexpected Data
- REST Is Unresponsive to Requests or Requests Are Timing Out

![Tip: If having trouble with the configuration page, please try to upgrade the web browser. For optimal performance, the Chrome browser is recommended.]

Service Cannot Be Started During Installation

Check if Service Control Manager is open. If it is, close it.

Service Cannot Be Started After Installation

- If the REST agent is installed on a machine that is already hosting an application on port 80, the agent fails to startup and terminates. To fix this issue, manually change the port in the Web Server Configuration Settings. The GH REST web server configuration file can be found in the REST agent installation directory at \config\rest.conf. After changing the value of `server.port = [new_port]`, open the configuration page `http://127.0.0.1:[new_port]/config.html` to configure Graphic Hub REST.
- If the standard browser login appears, please close it. Click logout and login with your Graphic Hub administrator account. Check the user name and password (case sensitive) through a login to your configured Graphic Hub via Graphic Hub REST.
- Use the Service Control Manager to restart the REST service. If the service cannot be restarted this way, contact Vizrt CA.

REST Is Not Reachable or REST Cannot Connect to Graphic Hub

- Check all network blocking applications, such as firewalls, anti-virus software, VPNs, virtual network adapters, etc.
- Request from the system administrator that necessary ports on the company’s firewall are opened. Refer to the List of Ports Used for Graphic Hub Network Connectivity.

REST Is Returning Unexpected Data

1. Open the REST configuration page.
2. Check which Graphic Hub server the REST service is bound to. If REST is bound to the wrong Graphic Hub server, change the binding.
REST Is Unresponsive to Requests or Requests Are Timing Out
Use the Service Control Manager to restart the REST service.

2.7.11 Legacy Dongle Troubleshooting

Apparently Valid Dongle/License Does Not Work
- Close all time-sync programs, like NTP.
- Shut down your anti-virus applications.
- Make sure your dongle is properly connected and the HASP driver is installed and running.
  See Drivers for HASP Runtime Installation Fails.

General Viz Artist and Graphic Hub Dongle Issues
- A Viz Artist dongle does not work with Graphic Hub.
- A Graphic Hub dongle does not work with Viz Artist.
- Make sure you have only one Viz dongle connected to a machine running Viz applications.
- 5/4 Free and Localhost modes can operate without a dongle.

2.7.12 Browser Troubleshooting

This page contains information on the following topics:
- Safari with Authentication Enabled on Windows
- Internet Explorer Issues with Default Security Settings
- Internet Explorer IP Issues with Default Security Settings

Safari with Authentication Enabled on Windows
Safari on Windows cannot be used for cluster configurations with authentication enabled on Windows. This is because Safari since version 5.1.7 does not support the Access-Control-Expose-Header, which is required for the Web Interface to access the Authentication header. Authentication is solely handled by the GUI itself, without the browser being involved.

As development of Safari on Windows has been discontinued by Apple, a newer version will not be available anytime soon.

Internet Explorer Issues with Default Security Settings
The Web Interface has issues with cross-origin HTTP requests (CORS) to multiple hosts when using the default security settings.

Known issues:
GH Terminal does not show information of the partner server of a cluster configuration, because the Web-UI is not able to retrieve the status of the partner server and therefore reporting it as 'not reachable' or 'Unable to connect to Graphic Hub Terminal on host XXX:19399'.

GH REST reports the GH status as ‘not reachable’ or 'Unable to connect to Graphic Hub Terminal on host XXX:19399'.

GH ImEx Agent is unable to show proper status of configured GH RESTs.

For most cases, enabling Access data sources across domains should resolve the issue:

1. In Internet Explorer, click Tools and then click Internet Options.
2. In the Internet Options dialog box, on the Security tab, click Custom Level.
3. In the Security Settings dialog box, do the following:
   a. Select Enable for Miscellaneous > Access data sources across domains.
   b. Click OK.
4. In the Confirmation dialog box, click Yes.

This needs to be done for both the Internet and Local intranet zone. Internet Explorer always uses the settings of the Internet zone if a site is opened using an IP address no matter if the site is actually a local one or not!

Internet Explorer IP Issues with Default Security Settings

If the Web-UI is opened using the IP address and the requests are based on hostnames, then this violates Zone Policies.

The reason is the Cross-Domain and Zone Policy (see https://msdn.microsoft.com/en-us/library/ms537505(v=vs.85).aspx#xdomain), which blocks cross-origin HTTP requests (CORS) requests to a different host using a hostname, while the Web-UI is opened with an IP address as these requests violate the Zone Policy settings.

Known issues:

- In GH Terminal when the Web-UI is opened with IP, but the loaded cluster configuration is based on hostnames, then the status is ‘not reachable’ or 'Unable to connect to Graphic Hub Terminal on host XXX:19399'.

A workaround for this issue is to add the Web-UI URL to the Trusted Sites:

1. In the Internet Options dialog box, on the Security tab, select Trusted sites.
2. Click Sites.
3. Disable Require server verification (https:) for all sites in this zone and click Add.
4. Click Close.

Make sure Miscellaneous > Access data sources across domains is also set to Enabled for the Trusted Sites zone.

2.7.13 List of Ports Used for Graphic Hub Network Connectivity

Since Graphic Hub 3, the server requires a limited number of open network ports. The following table lists the ports used for Graphic Hub server connectivity:
### Since GH Deploy Agent 2, Graphic Hub Manager 5, GH REST 2, and Viz Artist 3.8.2, these clients do not require any port exemption rules on the client side firewall configuration. However, for earlier versions, all ports must be open on the client side.

#### 2.7.14 Frequently Asked Questions

- **Question:** Can a Graphic Hub Deploy Agent deploy outside local network boundaries, for example, different subnets and gateways?
  - **Answer:** Yes. Log Graphic Hub Manager on with the IP address instead of the host name. Then schedule a deploy task.

- **Question:** Can a replication cluster work outside local network boundaries, if the main and replication servers are not in the same local network?
  - **Answer:** No. Use the Deploy Agent instead.

- **Question:** Can I share a single data directory over multiple servers?
  - **Answer:** No.

- **Question:** Can deleting or creating files within a data directory solve problems?
• **Answer:** No.

• **Question:** Can I do a backup of the data directory while the server is still running?
  • **Answer:** No. The server must be shut down before copying the data directory.

• **Question:** Can a localhost database be accessed from another machine?
  • **Answer:** From Viz Artist, no. A single-user database is only available on the machine it runs on.

• **Question:** Do all Graphic Hub Naming Services on the network contain information about all servers? Why is there a need for more than one Naming Service on the network?
  • **Answer:** A Graphic Hub Naming Service only contains information about the servers that have been applied to it. Before a Graphic Hub Server is started, a Graphic Hub Naming Service must be applied to it. Either a local Naming Service that is started together with the server can be applied, or another available Naming Service in the network is applied. A server cannot be started without connecting to a running Naming Service.

• **Question:** Can I terminate the VizDb.exe process?
  • **Answer:** No, never. Only use Graphic Hub Terminal or Graphic Hub Manager to shut down a server.

• **Question:** Can I shut down Windows while VizDb.exe is still running?
  • **Answer:** No. Use Graphic Hub Terminal or Graphic Hub Manager to shut down a server before exiting Windows.

• **Question:** Why is the content of the selected folder not listed in the Graphic Hub Manager’s File panel?
  • **Answer:** First, make sure that the selected folder contains files. Next, make sure that All or the correct file type is selected from the Show drop-down list in the Toolbar.

• **Question:** For an antivirus definition, we need the list of all file extensions used by Viz Graphic Hub.
  • **Answer:** List of file extensions for Graphic Hub data directories:
    .idx
    .fid
    .dat
    .vdb
    .upd
    .txt
    .tmp
    .conf
3 Graphic Hub Deploy Agent

The method to copy and synchronize a database is the Direct Deploy Copy (DDC) functionality. The Graphic Hub deploy solution makes it possible to copy folders/projects/files with all necessary data (referenced folders/projects/files) and all Pilot data from one server to another. For example, if a scene is to be deployed, all files that are referenced by this scene (images, materials, and so on) are also deployed.

The Deploy Agent enables the configuration of scheduled deploy tasks, and is run from the Graphic Hub Manager.

This section contains information on the following topics:

- Deploy Agent Modes
- Deploy Agent Properties
- Rebuild Original Structure
- Copy to Target Folder Only
- Schedule a Deploy Task
- Maintain Deploy Agents and Tasks

3.1 Deploy Agent Modes

The Deploy Agent supports two modes:

- **Standard Mode**: Creates only folders on the destination server which contain files that have to be copied by the task. This mode ensures that the folders on the source and destination servers have the same UUID if possible. I.e. folders outside of the original structure which contain references and/or folder links of files inside the structure have new UUIDs assigned if their original UUIDs are present on the destination server.

- **Direct Deploy Copy Mode**: Also creates only folders on the destination server which contain files that have to be copied by the task. This mode ignores the UUID of folders and makes sure that all folders have the correct name in the structure.

This page contains the following topics:

- Standard Mode Supported Options
- Direct Deploy Copy Mode Supported Options
- Additional Information on Data Modes
- Standard and DDC Supported Options

3.1.1 Standard Mode Supported Options

The standard mode supports these options:
### Options

<table>
<thead>
<tr>
<th>Schedule Options</th>
<th>Supported Item</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Real-time</td>
</tr>
<tr>
<td></td>
<td>Time steered</td>
</tr>
<tr>
<td></td>
<td>User triggered</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Data Mode Options</th>
<th>Supported Item</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Folder based (Only a single folder can be selected per task)</td>
</tr>
<tr>
<td></td>
<td>File based: in ‘Copy to target folder only’ mode (Multiple files can be selected per task, folders are not allowed)</td>
</tr>
<tr>
<td></td>
<td>Search criteria based: in ‘Copy to target folder only’ mode (Copies all files that result from executing the search criteria, folders are ignored)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Real-time Options</th>
<th>Supported Item</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rebuild original structure</td>
<td></td>
</tr>
<tr>
<td>Rebuild structure under target folder</td>
<td></td>
</tr>
<tr>
<td>Support for: Removal of deleted objects on target server(s), Synchronization users, groups, keywords, add-on templates, etc.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Time Steered Options</th>
<th>Supported Item</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy to target folder only</td>
<td></td>
</tr>
<tr>
<td>Rebuild original structure</td>
<td></td>
</tr>
<tr>
<td>Rebuild structure under target folder</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>User Triggered Options</th>
<th>Supported Item</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy to target folder only</td>
<td></td>
</tr>
<tr>
<td>Rebuild original structure</td>
<td></td>
</tr>
<tr>
<td>Rebuild structure under target folder</td>
<td></td>
</tr>
</tbody>
</table>

### 3.1.2 Direct Deploy Copy Mode Supported Options

The Direct Deploy Copy Mode (DDC) mode supported these options:

#### Note: Real-time is not supported in this mode.

<table>
<thead>
<tr>
<th>Options</th>
<th>Supported Item</th>
</tr>
</thead>
<tbody>
<tr>
<td>Schedule Options</td>
<td>Time steered</td>
</tr>
<tr>
<td></td>
<td>User triggered</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Data Mode Options</th>
<th>Supported Item</th>
</tr>
</thead>
<tbody>
<tr>
<td>Folder based (Only a single folder can be selected per task)</td>
<td></td>
</tr>
<tr>
<td>File based (Multiple files can be selected per task, folders are not allowed)</td>
<td></td>
</tr>
<tr>
<td>Search criteria based (Copies all files that result from executing the search criteria, folders are ignored)</td>
<td></td>
</tr>
</tbody>
</table>
### Additional Information on Data Modes

- **File based:** The task is not able to execute if the objects to deploy contain folders.
- **Search criteria based:** The task ignores all folders that are contained in the result of the search.

### Standard and DDC Supported Options

<table>
<thead>
<tr>
<th>Data Mode</th>
<th>Options</th>
<th>Standard Mode</th>
<th>DDC Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Real-time</td>
<td>Time-steered</td>
</tr>
<tr>
<td>Folder based</td>
<td>Copy to target folder only</td>
<td>✗</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>Rebuild original structure</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>Rebuild structure under target folder</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>File based</td>
<td>Copy to target folder only</td>
<td>✗</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>Rebuild original structure</td>
<td>✗</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Rebuild structure under target folder</td>
<td>✗</td>
<td></td>
</tr>
<tr>
<td>Search criteria based</td>
<td>Copy to target folder only</td>
<td>✗</td>
<td>✓</td>
</tr>
</tbody>
</table>
### 3.2 Deploy Agent Properties

The Deploy Agent properties panel shows the properties and configuration settings for the Deploy agent.

This page contains the following topics and procedures:

- Properties of a Deploy Agent
- Configuration Panel
- Version Info Panel
- High Availability Panel

#### 3.2.1 Properties of a Deploy Agent

To access the properties of a Deploy Agent:

1. Navigate to **Tools > Administer tasks > Running deploy tasks** to show Running deploy tasks tab.
2. Right click a Deploy Agent.
3. Click Properties of deploy agent.

In the Statistics panel, Graphic Hubs currently in use shows Graphic Hubs currently used as Deploy Agents. These Graphic Hubs are the source servers of one or more deploy tasks. The Graphic Hub Deploy Agent automatically removes all unused Graphic Hub source servers.

In some cases, a Graphic Hub can be lost or cannot be contacted by a Graphic Hub Deploy Agent. If this happens the add and remove can be done manually.

### Information
Configuring a Deploy Agent is only possible if logged in on this machine locally. This is by design for security reasons.

### Statistics Panel
In the Statistics panel, Graphic Hubs currently in use shows Graphic Hubs currently used as Deploy Agents. These Graphic Hubs are the source servers of one or more deploy tasks. The Graphic Hub Deploy Agent automatically removes all unused Graphic Hub source servers.

In some cases, a Graphic Hub can be lost or cannot be contacted by a Graphic Hub Deploy Agent. If this happens the add and remove can be done manually.

### To Add a Graphic Hub
(Which is not registered in the Deploy Agent)

1. Open the Properties of Deploy Agent window.
2. Open the Select Graphic Hub to add window.
   - Click Add, or
   - Right click in the Graphic Hubs currently in use box, and click Add.
3. Select a Graphic Hub to be added, from the drop down box.
4. Click OK or Apply.

### Note
The added Graphic Hub status is to be added until OK or Apply has been clicked (when not highlighted, the to be added Graphic Hub shows purple).
To Remove a Graphic Hub

1. Open the Properties of Deploy Agent window.
2. Click the Graphic Hub to be removed.
3. Remove the Graphic Hub:
   • Click **Remove**, or
   • Right click the selected Graphic Hub and click **Remove selected** from the context menu.
4. Click **OK** or **Apply**.

**Note:** The selected Graphic Hub status is *to be removed* until **OK** or **Apply** has been clicked (when not highlighted, the *to be removed* Graphic Hub shows red).
Note: If a Graphic Hub to be removed contains any running tasks, the remove will not be successful. Either click Cancel or undo the change via the context menu. If a removed Graphic Hub is not reachable by Graphic Hub Deploy Agent, a message displays where it is possible to select a forced remove or cancel the action. It is not possible to add or remove multiple Graphic Hubs at once.
### 3.2.2 Configuration Panel

#### Logging of additional/advanced runtime information

- **Log additional information to EventLog:** Configures the Deploy Agent to log warnings and errors to the event log of the source server of the task that caused the issues.
- **Log additional information to journal on dedicated Log-Server:** Configures the Deploy Agent to log warnings and errors of all tasks to the event log of a specified server.

#### Deploy agent work directory

- **Folder:** Shows where the Deploy Agent keeps its configuration file and temporary data.
• **Timeouts (related to communication with Graphic Hubs):** Changing the values of the timeout settings may have a significant impact on how Deploy Agent works. The default values have been tested in a LAN setting as well as for long range deploy tasks and should only be changed if the Deploy Agent has problems with servers that are connected via a slow / congested network or have a high server load. Increasing the timeout values may solve the problems in this case, decreasing does not improve the general performance of the agent and is not recommended.

  - **Establishing communication timeout (in seconds):** Specifies the maximum amount of time for a Deploy Agent is allowed to connect to a server. If the server does not respond in this period due to network characteristics or server load, it is considered as offline.
  - **Communication round trip timeout (in seconds):** Specifies the maximum amount of time for the Deploy Agent to wait for a reply from the server. If the server does not respond in this period due to network characteristics or server load, the affected task may be paused by the agent.
  - **Cluster failover timeout (in seconds):** This option is relevant for agents that operate in a setting with a failover server. If a main server becomes unavailable, this timeout specifies the period that a task is waiting for a notification from the failover server to switch over. If this time exceeds, the agent attempts to manually connect to the failover server.
  - **Transfer Buffer Size:** Adjusts the buffer size used by the Deploy Agent for communicating with the Graphic Hub.

• **Expert settings**
  - **No. of attempts to reconnect to Graphic Hubs:** Set the number of times the agent is to attempt to connect to Graphic Hubs.
  - **Time (in seconds) between attempts to reconnect:** Set the time between each attempt to reconnect to Graphic Hubs.
  - **Do emergency pausing of real-time tasks:** Click in the box to do emergency pausing of real-time tasks. Set the % of all objects or the number of objects.
  - **Use original DDC behavior for non real-time tasks:** This option is set globally for the Deploy Agent and affects all tasks. The major difference to the normal mode is that the “deploy under target folder” restriction of having no folder on source and destination that has the same UUID but an incompatible path does not apply. If the Deploy Agent discovers a folder with the same UUID but different path, a new folder with a new UUID is created in the expected path. This feature has a significant impact on the performance of the Deploy Agent, and should be chosen wisely as it affects all non-real-time tasks that are executed by the agent.
  - **Do not overwrite if destination file is newer:** If set, the file on the destination server is not overwritten, if it has a modification date/time newer than the source file. The default setting (=option is not checked) is always overwrite the file with the source-file.

• **Communications ports**
  - **TCP port:** Sets the TCP port number.
  - **UDP port:** Sets the UDP port number.
3.2.3 Version Info Panel

The Version info panel shows the version information for:

- The Deploy Agent.
- The Tasks scheduler.
- The Graphic Hub interface.

![Version info](image)

3.2.4 High Availability Panel

When a new High Availability Partner is configured, the configuration of these values automatically transfer to the High Availability Partner:

- **Timeouts**
  - Establishing communication timeout (in seconds)
  - Communication round trip timeout (in seconds)
  - Cluster failover timeout (in seconds)

- **Expert settings**
  - Do emergency pausing of real time tasks
  - Use the original DDC behavior for non real time tasks.

**IMPORTANT!** When disabling the High Availability partner, the configuration values return to their default values.

**Note:** Since Deploy Agent version 1.4.1, it is possible to configure high availability partners using host names or IP addresses.
To Configure a High Availability Partner

1. Click in the Configure high availability partner check box.
2. Select the Deploy agent from the Partner drop down box.
3. Click the Use IP address instead of host name box, if required.

⚠️ Note: If the High Availability partner configuration is set to use IP addresses, the clients need to have static IP addresses.

4. Click OK or Apply.

3.3 Rebuild Original Structure

This page details how to rebuild a database structure.

- To Create a New File Based Deploy Task
- Behavior

3.3.1 To Create a New File Based Deploy Task

The Options panel shows a deploy task configuration where folder B of Server 1 is deployed to folder U of Server 2.
The Options panel offers various settings to configure the deploy task:

- **Behavior options**
  - **Rebuild original structure**: The original folder structure and any folder links for the selected folder or project is recreated at the root level of the target server, including any parent folders. The selected folder or project is rebuilt including all sub-folders, sub-projects and objects contained therein.
  - **Rebuild structure under target folder**: The original folder structure is recreated using the target folder as root level.
  - **Copy to target folder only**: Recursively copies files only from the selected source folder to the selected target folder. See also Copy to Target Folder Only.
- **Overwrite existing objects**: If there is a file in folder B or any of its sub-folders and the same file exists on the destination server (a file with the same UUID), then the file is overwritten on the destination if the content is different.

- **Overwrite existing references**: If there is a file F in folder B or any of its sub-folders with a reference to file R and file R exists on the destination server (a file with the same UUID), then file R is overwritten on the destination if the content is different.

- **Overwrite owner**: If there is a file in folder B or any of its sub-folders and the same file exists on the destination server (a file with the same UUID), then the owner of the destination file is changed if it differs from the source file.

- **Overwrite creation date**: If not chosen, files and folders in the deployed structure have their creation dates set to the deployment time if they were not present. If chosen, they preserve the creation dates of their source objects.

- **Overwrite modification date**: If not chosen, files in the deployed structure have their modification dates set to the deployment time if they were not present. If chosen, they preserve the modification dates of their source files.

- **Multi-server Processing options**
  - **Parallel**: If multiple destinations are selected, the destinations are synchronized in parallel.
  - **Deploy all files to first server, then to the second, and so on**: If multiple destinations are selected, the destinations are fully synchronized one at a time.
  - **Deploy one file to all servers, then another file, and so on**: If multiple destinations are selected, missing files are copied to all destinations one at a time.

The Schedule panel shows the settings that are available to schedule the new deploy task.

Apart from the general settings, **Rebuild original structure/ Rebuild Structure Under Target Folder** tasks also support the deletion of files on the target server. Files are only deleted if they are removed from the source folder B or any of its sub-folders and the file also exists on the destination server in folder U or any of its sub-folders. If the file on the destination also has folder links outside folder U, then only the folder links inside the target structure are removed.
- **Deploy agent**: Select the Deploy Agent to be used. The version number and deploy mode of the selected Deploy Agent is shown below the drop down box.
- **Task**: Enter a name and description for the new deploy task.
  - **Schedule this task**: Click to enable or disable the Schedule field.
- **Schedule**: Create a schedule for the new deploy task:
  - **Mode**: Select either Once, Recurring or Recurring forever
  - **Start at/End after**: Options depend on the set Mode. Set the start and finish of a new deploy task
  - **Each**: Select how often the task should start from the drop down box.
  - **Real-time**: Click to enable or disable the Real-time options field.
- **Real-time options**
- **Remove deleted objects on target server(s) as well**: If ticked then not only newly created files or modified files are deployed to the target server (Graphic Hub), but also files that get deleted on the source server (Graphic hub) are also removed/deleted on the target server.

- **Synchronize**: Synchronize options can be chosen separately. Check each box as required. The Data panel shows that folder B is used as source for the new deploy task.

![Data panel showing objects to deploy](image)

### 3.3.2 Behavior

The image below shows the before and after condition of the deploy task.

**Before:**

![Before condition](image)

**After:**

![After condition](image)
To create a consistent deployment, not only folder B and its sub-folders but the whole relevant folder structure of the source server is created under the target folder on the destination server. This means that there must not exist any folder or project on either server, apart from already synchronized folders with the correct path. The deploy task goes out of sync if such a configuration is discovered. This restriction does not apply to files, but one needs to pay attention that content of files outside the target structure may be changed by this task.

The images below show an example deployment of the same deploy task setup as described before, but the option **Use original DDC behavior for non-real-time tasks** has been enabled and the schedule has been changed from real-time to a recurring task (see **Expert settings** in the Configuration Panel).

Before:

![Before Image]

After:

![After Image]
This has the effect that only folders that are needed for deployment are created, in this case the task creates all folders on the path to folder B and additionally folder C as it contains either a reference or a folder link from a file that is deployed. Folders AB and ABC are skipped and not deployed to the destination server. Furthermore, folder X on the destination server already contained folders LAA, A and B, which means that the Deploy Agent had to create new folders with new UUIDs under folder U.

**Changed in Viz GH Deploy Agent 2.1.0:** This behavior now also applies to deploy tasks using standard mode. In contrast to DDC mode, UUIDs of folders are retained if no clash occurs.

### 3.4 Copy To Target Folder Only

The image below shows the settings to deploy a folder from the source server to folder T on the destination server in **Copy to target folder only** mode.
In this case, the structure of the source server is ignored and all files from the source folder and its sub-folders are copied directly into folder $T$.
The image below shows that only files were deployed to folder $T$ and no sub-folders were created.
3.5 **Schedule A Deploy Task**

Deploy tasks can be scheduled to run on a regular basis. This is useful to replicate data for safekeeping on a regular basis.

To run scheduled Deploy Tasks the Viz Deploy Agent must be installed.

---

**IMPORTANT!** To configure a scheduled deploy task when the servers or the Deploy Agent are on different sub-nets, each server must be logged on to with its IP address, not its host name. Sign out of all servers and log back on using the servers IP address (see Graphic Hub Login and Log Out).

---

### 3.5.1 To Add a Deploy Agent for Use

**IMPORTANT!** Deploy Agents not reachable via UDP broadcast and / or for use in Login profiles need to be added manually.

1. Open **Tools > Edit preferences**.
2. Navigate to **Agents > Deploy**.
3. Press **Add**.

4. Insert *hostname* or *IP address*.

5. Provide *UDP port* (default: 19392).
6. Press **OK**.

   ![Deploy agent dialog box]

   **Deploy agent**

   **IP address:** GHSERVER  
   **UDP port:** 19392  
   **Receive timeout:** 100 (milliseconds)  
   **Transfer buffer size:** 1 (50.00 KB)  
   **Name:** GHSERVER

The Deploy Agent has been added to current configuration and can be found although not reachable via UDP broadcast.

7. Confirm all open windows.

   ![Check successful dialog box]

   **Check successful!**

   The deploy agent could be contacted.

   ![Deploy agent dialog box]

   **Deploy agent**

   **IP address:** GHSERVER  
   **UDP port:** 19392  
   **Receive timeout:** 100 (milliseconds)  
   **Transfer buffer size:** 1 (50.00 KB)  
   **Name:** GHSERVER

The Deploy Agent has been added to current configuration and can be found although not reachable via UDP broadcast.

### 3.5.2 To Schedule a Deploy Task

1. In Graphic Hub Manager, log-in to two or more servers.
2. Right-click a folder/project/file in the **Servers and Folders** panel or **Files** panel, and then from the menu that appears, select **Create Deploy Task**...
3. Select one or more target servers.

4. Select one of the **Behavior options**:
   - **Rebuild original structure**: Copies an exact replicate of all selected folders/projects/files and its references from source to destination server.
   - **Rebuild structure under target folder**: Copies an exact replicate of all selected folders/projects/files and its references from the source server to the destination folder on the destination server.
   - **Copy to target folder only**: Copies all selected folders/projects/files and its references from the source server to the destination folder on the destination server.
5. Enable/disable the following **Behavior options**:
   - Overwrite existing objects (does not apply to referenced files)
   - Overwrite existing references
   - Keep original owner

6. Select one of the following **Processing options**:
   - Deploy all files to the first target server, then the next server in the queue, and so on.
   - Deploy one file to all target servers, then the next file in the queue, and so on.

**Tip:** For **Copy to target folder only** and **Rebuilt structure under target folder**, you can also drag folders or projects into the field beside the **Behavior options** drop down menu.
7. In the left panel, click **Schedule**.

   ![Schedule](image)

   6. In the left panel, click **Schedule**.

   - **Deploy agent** (Choose the one which should execute the task!)
     - **Deploy agent**: GHSERVER
     - **Version**: 2.3.0.83857  **Deploy behavior**: Standard

   - **Task** (Give it a name and a meaningful description!)
     - **Name**: Deploy Task 2
     - **Description**: 

   - **Schedule** (Specify when this task should be performed)
     - **Mode**: Recurring forever
     - **Start at**: 3/7/2019 3:48 PM
     - **End after**: forever

   - **Realtime options**
     - **Sync Pilot data**

   - **Realtime options**
     - **Remove deleted objects on target server(s) as well**
     - **Synchronize**
       - **Users and groups**
       - **Keywords**
       - **Viz VR Studio setups**
       - **Add-ons (templates)**

   - **Synchronize options are not available, because only ‘data’ under root must be in objects!**

8. From the **Deploy agent** drop down box, select a Deploy Agent.

   - **Tip**: If you have several Deploy Agents installed on various machines, and you intend to schedule many tasks, use a different Deploy Agent for each task for the purpose of load balancing.

9. Name and describe the task in the fields provided.
10. Check the **Schedule this task** check box.
11. From the **Mode** drop down menu, select one of the following options:
   - Once.
   - Recurring.
   - Recurring forever.
12. In the **Start at** drop down menu, click to select a date from the calendar, and if necessary, adjust the time.

   **Note**: You cannot schedule tasks to begin in the past.

13. If your mode is **Recurring**, in the **End after** drop down menu, click to select a date from the calendar, and if necessary, adjust the time.
14. Select **one** of the following radio button options:
   - **Each**: Select an interval.
   - **Realtime**: The deploy task occurs every time there is a change in the database. With this selection, you can optionally **Remove deleted objects on the target server as well**.

   **Note**: Real-time tasks cannot be modified later.

15. In the left panel, click **Data** and drag any additional folders or files into the right panel, as necessary.

16. Click **OK** to create the deploy task.

---

3.6 **Maintain Deploy Agents And Tasks**

This page details the maintenance of Deploy Agents and configured Deploy Tasks in the following procedures:

- **To View Deploy Tasks**
To Modify a Deploy Task
To Search Scheduled Deploy Tasks
To Search Finished Deploy Tasks
To Maintain Deploy Agents

3.6.1 To View Deploy Tasks

- Click Tools > Administer Tasks > Running deploy tasks.
- Click Tools > Administer Tasks > Scheduled deploy tasks.
- Click Tools > Administer Tasks > Finished deploy tasks.

All selected deploy tasks are shown in the Journal.

3.6.2 To Modify a Deploy Task

⚠️ Note: Modifications do not affect tasks that are currently running. If you modify such a task, the changes only take place at the next interval. Realtime tasks can NOT be modified.

1. Make sure you are logged into the source server for which you wish to modify the deploy task.
2. Show the deploy tasks in the Journal, in accordance with one of the procedures above.
3. Right-click the task and select **Properties**. The Schedule Deploy Task window is shown.

4. Continue to schedule a Deploy Task from step 3 onward.
3.6.3 To Search Scheduled Deploy Tasks

1. Click **Tools > Administer Tasks > Scheduled deploy tasks**. The Journal is enabled for searching scheduled deploy tasks.

2. From the Filter, using the **Server** drop down box, select a server.

3. In the **Details like** field, enter free text like name of the task, name of the agent, or any description that may figure in the task.

4. In the Journal, click the **Search** button. The search results are shown in the panel below. The **Triggers in** column shows when the scheduled deploy task is set to run next. When one is selected, the deploy task’s details are shown in the panel to the right.

5. To modify the deploy task, do one of the following:
   - Right-click the deploy task in the results panel and select **Properties**.
   - In the details panel, click the **Properties** button.

6. Continue to schedule a Deploy Task from step 3 onward.
3.6.4 To Search Finished Deploy Tasks

1. Click **Tools > Administer Tasks > Finished deploy tasks**. The Journal is enabled for searching deploy tasks.

2. From the Filter, using the **Server** drop-down box, select a server.
3. Select a task **Status**. Your options are:
   - Only unsuccessful
   - Only successful
   - Both
4. From the **Date** drop-down box, select one of the following options:
   - **Anytime**
   - **From**: Selecting this option prompts you to also enter a beginning date and time.
   - **Until**: Selecting this option prompts you to also enter an ending date and time.
   - **Between**: Selecting this option prompts you to also enter a beginning and ending date and time.
5. In the **Details like** field, enter free text like name of the task, name of the agent, or any description that may figure in the task.
6. In the **Details not like** field, enter free text like name of the task, name of the agent, or any description that you want to exclude from the task search.
7. In the Journal, click the **Search** button. The search results are listed in the main panel. When a result is selected, the finished deploy task’s details are shown in the **Details of finished deploy task** panel to the right. There are general details as well as any errors and warnings.

If the Deploy Agent encounters corrupted files, it attempts to restore files on the source server. In such cases, an error message is logged in the journal if the restoration fails. If the log level is set to **All**, successful restore operations are also logged.

3.6.5 To Maintain Deploy Agents

1. Launch the Graphic Hub Manager on the machine where the Deploy Agent is to run.
2. Log into the source server(s) and view the deploy tasks.

3. In the left panel, right-click the relevant Deploy Agent and select **Properties**. The Deploy Agent properties window is shown (**Statistics** is selected by default). The data shown here is for information purposes only.
4. Click **Configuration**.

![Configuration](image)

- **Logging of additional/advanced runtime information**
  - Log additional information to EventLog
  - Log additional information to journal on dedicated Log Server

![Dedicated Log Server dropdown box](image)

- **Deploy agent work directory**

![Folder path](image)

- **Timeouts and Transfer buffer settings**
  - Establishing communication timeout (in seconds): 15
  - Communication round trip timeout (in seconds): 30
  - Cluster failover timeout (in seconds): 15
  - Transfer buffer size: (1,000.00 KB) 20

![Defaults button](image)

- **Expert settings**

![Number of attempts](image)

- **Communication ports**

![TCP port: 19393](image)

5. Configure the following parameters as necessary:

- **Log additional information to EventLog**: Select this option to include debugging information, as well as records of the start of tasks, in the Windows event log.
- **Log additional information to journal on dedicated log server**: Select this option to include debugging information, as well as records of the start of tasks, in the Graphic Hub server log, on one of the servers available in the **Dedicated Log Server** drop down box.
- **Deploy agent work directory**: The path and folder which acts as the temporary buffer for the Deploy Agent. The Deploy Agent process must have full access rights on the selected directory. This directory location can not be changed.
- **Timeouts**: Set the timeouts times for each file as required.
- **Expert settings**: Consult your Vizrt CA representative before changing any of these settings:
- **Do 'emergency' pausing of realtime tasks:** In the event that there is a risk of too many files being deleting on the destination server, select this option and assign a threshold as a percentage or number of files beyond which the Deploy Agent pauses the task. If such a task is paused, you can find it when searching for finished Deploy tasks. You are always able to resume the task.
- **TCP port:** Default is 19393. Change only after consultation with your network administrator, if there are firewall issues.
- **UDP port:** Default is 19392. Change only after consultation with your network administrator, if there are firewall issues.

**Note:** Changing TCP or UDP setting requires changes to the Graphic Hub Manager preferences: click **Tools > Edit preferences** and in the left panel select **Deploy**.

6. Click **Version Info**.

7. When reporting a problem, make sure to include this version information.

8. Click **High Availability**.

9. To configure a high availability partner, select the respective check box.

10. From the **Partner** drop down box, select the alternative to take over in case of failover.
11. Click **OK**.
12. Click **Close**.

**Note:** In general, it is recommended that you use the default TCP port.
4 Graphic Hub ImEx Agent

The Graphic Hub ImEx Agent (Import / Export agent) is a service that imports image media assets from file-system folders or HTTP sources to the Graphic Hub.

The Media Sequencer uses the ImEx Agent to stage image media assets for play-out, from HTTP sources. This reduces the load on Viz Engine as images are already available on the Graphic Hub with pre-computed mip-map levels, and must not be loaded through HTTP on actual play-out. The service depends on the Graphic Hub REST, which is used to import the images into the Graphic Hub. In addition file-system folders can be watched for image media assets to be imported.

The ImEx Agent uses projects or folders on the Graphic Hub to upload content, called destination directories. They are configured and managed by UUID. The destination directory path must be below the /data root folder, for example e.g. /data/imex/MyDestinationDirectory or /data/imexDestinationDirectory.

The ImEx Agent can be used in two ways:

1. The Media Sequencer triggers activity in the ImEx Agent by creation of Distribution Plans based on playlists.
2. Importing images from a configured Watchfolder into the Graphic Hub. This also creates so-called watchfolder distribution plans.

A Watchfolder is an ordinary folder on the file-system which is watched by the ImEx Agent and actively monitored. Image media assets are imported into the Graphic Hub on creation or overwritten when changed.

A Distribution Plan represents a set of image media assets that should be available on a number of destination directories during a specified period of time (1) or until they are cleaned up manually (2).

Availability Reports contain the content of an import operation, including additional information about the state and location of the media asset.

Housekeeping for uploads triggered by the MSE is done by setting expiration dates on the imported image assets on the Graphic Hub (watchfolder imports currently lack this feature). During the Cleanup of Expired Items Task, which must be enabled and configured in the Graphic Hub Terminal, all expired files are deleted.

[Diagram of the ImEx Agent process]
4.1 Supported Import Media Types

The following category and mime-types are supported by the ImEx Agent:

- image/jpeg
- image/gif
- image/png
- image/bmp
- image/tiff
- image/tga
- image/vnd.radiance
- image/x-exr

4.2 Notable Limitations

- GH REST version 2.0.1 and Graphic Hub version 3.0.1 or later are required. For HDR and EXR images, GH Rest version 2.4.0 or higher is required.
- The number of publishing points specifically used for media staging via Media Sequencer is limited to one per Viz Engine (Graphic Hub the Engine is connected to).
- Currently, a maximum of 5000 assets is recommended for a single watchfolder based import.
- Folders on a network share can be used as watchfolders if it is mounted as drive with the SYSTEM user, because the ImEx Agent service is running under the SYSTEM user.
- Currently, cleaning up images uploaded from a watchfolder must be done manually.
- Resolving file name conflicts between the watchfolder(s) and the destination directory on the Graphic Hub must be done manually.
- The watchfolder may NOT be renamed.

4.3 User Interface

The Graphic Hub ImEx Agent user interface consists of:
The **Menu Bar** (1):
- Import
- Options
- Report
- Help and About

The **System Status Panel** (2):
- System Status Panel

The **Status** bar beneath the menu bar displays concrete information about the current status and page displayed.

The **Status page** displays information of the overall status of the ImEx Agent service. The Status icon can be either of the following:
- **Running**: Everything is OK.
- **Warning**: There are warnings which may require user interaction.
- **Error**: There are errors which require user interaction.

The **main menu** has the following sections:, and a status panel that provides a quick overview of the system status:

- **Import**
  - **Destination directories**: Manage configured destination directories that can be used by the ImEx Agent and the Media Sequencer for imports.
  - **Watchfolders**: Manage watchfolders that can be used to import images from the file-system.

- **Options**
  - **Configuration**: Manage the ImEx options (webserver, connection, import and log settings).
• **GH REST hosts**: Manage configured GH REST services (and Graphic Hubs) the ImEx Agent can use for imports.

• **Pre-Authenticated Hosts**: Manage configured credential information for external import sources (e.g. Viz One) the ImEx Agent uses for authentication.

• **Change ImEx password**: Change the ImEx Agent specific password that is required when "Use authentication" is enabled in the **Configuration** under Webserver Configuration.

**Report**

• **Logs**: Displays searchable ImEx log content.

• **Distribution plans**: Displays the active and expired Distribution plans with current status information.

• **Availability report**: Displays search and filterable information of assets to import.

• **Export**: Possibility to generate reports which contain all relevant log files and state information.

• **Help**: Opens the Graphic hub manual.

• **About**

  • **Versions**: Displays information of the currently installed ImEx version and connected GH RESTS and Graphic Hubs.

---

### 4.4 Initial Setup

When installation of the ImEx Agent is complete, the default web browser opens [http://127.0.0.1:19390/index.html](http://127.0.0.1:19390/index.html) for initial configuration.

### 4.4.1 Quick Start

1. **Install the ImEx Agent**.
2. **View web interface on [http://127.0.0.1:19390/index.html](http://127.0.0.1:19390/index.html).**
3. The initial configuration wizard displays if no destination directories exist.

4. Select a Graphic Hub REST host to use for importing assets. You can also enter the host manually, in the format \texttt{http://resthost:port/}. The GH REST must be bound and connected to a running Graphic Hub.

\textbf{Note:} GH REST version 2.0.1 or newer and Graphic Hub version 3.0.1 or newer are required.
5. Providing a valid GH REST host enables the **Login** panel. Provide a valid GH username and password from the Graphic Hub you are connecting to.
6. Select a destination directory (folder or project), by clicking the browse icon (... on the right side. You can also create new projects or folders using the directory browser.
7. Save the selected destination directory by pressing **OK**, then **Add**.

After successful configuration, the ImEx status page opens.
4.4.2 Configure ImEx for Media Staging

The following describes how to configure ImEx for media staging using (third-party) search providers. For a guide on how to setup related Viz products for media staging, see Basic Media Sequencer Configuration.

After setting up ImEx (see Quick Start), a search provider in Pilot Data Server and other media staging related Viz products, also add the fitting pre-authenticated host to ImEx's pre-authenticated hosts list, see Manage Pre-Authenticated hosts.

4.4.3 Basic Media Sequencer Configuration

The following list describes how to setup Media Sequencer for media staging via ImEx Agent.

1. Setup Viz Pilot and Media Sequencer, see Basic Viz Pilot and Media Sequencer setup using, for example, a Viz One as search provider.
2. Open the Media Sequencer configuration file named default.xml in an editor of your choice. By default, this file is located in C:\ProgramData\vizrt\Media Sequencer.
3. Disable the http_resource_poller by adding:

   ```xml
   mode="disabled"
   ```

4. In the scheduler section of the configuration file, add the following node:

   ```xml
   <handler type="vme" name="imex_image_staging">
     <entry name="service_document">http://my-imex-host:my-imex-port/</entry>
     <entry name="log_level">50</entry>
     <publish_media_type>image</publish_media_type>
   </handler>
   ```

   Here, my-imex-host and my-imex-port need to be set to the relevant ImEx host name in lowercase format (e.g. imex-host) and the relevant port that ImEx uses (e.g. 19390), respectively.

5. When using a single Graphic Hub/Viz Artist: Add a single publishing point to Media Sequencer by adding/configuring the following node in the config section of the configuration file:

   ```xml
   <entry name="global_publishing_points">
     <entry name="image">
       <entry name="uri">http://my-imex-host:my-imex-port/publishingpoint/my-pp-uuid</entry>
       <entry name="atom_id">MY-PP-UUID</entry>
     </entry>
   </entry>
   ```

   Here, my-imex-host, my-imex-port, my-pp-uuid and MY-PP-UUID need to be set to the host name in lowercase format used in bullet 3, the port used in bullet 3, the UUID of the relevant publishing point in lowercase formatted as xxxxxxxx-xxxx-xxxx-xxxxxxxxxxxx (e.g. c94a50d8-867b-11e7-bb31-be2e44b06b34) and the used publishing point UUID in uppercase format (e.g. C94A50D8-867B-11E7-BB31-BE2E44B06B34).
When using multiple Graphic Hubs/Viz Artists: To distribute images used for media staging to several Graphic Hubs, first remove the `global_publishing_points` node from the `config` section of the configuration file. Then, add a distinct publishing point for each Viz Engine by adding the following nodes to the `handler` sections of type `viz` in the configuration file:

```xml
<entry name="image_publishing_point_uri">http://my-imex-host:my-imex-port/publishingpoint/my-pp-uuid</entry>
<entry name="image_publishing_point_atom_id">MY-PP-UUID</entry>
```

The Viz handlers can be configured in Director, see the Profile Configuration page in the Director Configuration section of the Viz Pilot User Guide. Again, set `my-imex-host`, `my-imex-port`, `my-pp-uuid` and `MY-PP-UUID` (see bullet 4).

⚠️ **Note:** For each Viz handler, add a publishing point on the Graphic Hub connected to the Viz Artist/Engine which corresponds to the currently relevant Viz handler. Adding an image publishing point to a solely configured Viz handler achieves the same effect as adding a global publishing point. Again, the `global_publishing_points` node has to be removed from the `config` section to enable publishing points bound to Viz handlers.

**Examples**

1. **When using a single Graphic Hub/Viz Artist:** Add the following node to the `scheduler` section to enable the ImEx Agent on host `imex-host` and port 19390 for media staging:

```xml
<handler type="vme" name="imex_image_staging">
  <entry name="service_document">http://imex-host:19390/</entry>
  <entry name="log_level">50</entry>
  <publish_media_type>image</publish_media_type>
</handler>
```

Then, add the following node to the `config` section to enable a publishing point with UUID `c94a50d8-867b-11e7-bb31-be2e44b06b34`:

```xml
<entry name="global_publishing_points">
  <entry name="image">
    <entry name="uri">http://imex-host:19390/publishingpoint/c94a50d8-867b-11e7-bb31-be2e44b06b34</entry>
    <entry name="atom_id">C94A50D8-867B-11E7-BB31-BE2E44B06B34</entry>
  </entry>
</entry>
```

Also, disable the `http_resource_poller`.

2. **When using multiple Graphic Hubs/Viz Artists:**

ℹ️ **Info:** This example demonstrates how to add two publishing points respectively residing on distinct Graphic Hubs. For other numbers of publishing points/Graphic Hubs proceed analogously.
Add the following node to the **scheduler** section to enable the ImEx Agent on host *imex-host* and port 19390 for media staging:

```
<handler type="vme" name="imex_image_staging">
  <entry name="service_document">http://imex-host:19390/</entry>
  <entry name="log_level">50</entry>
  <publish_media_type>image</publish_media_type>
</handler>
```

Next, navigate to each **handler** node of type **viz** and respectively add the corresponding image publishing points. In this example, two entities of Viz Artist (respectively connected to Graphic Hubs on *gh-host1* and *gh-host2*) have been configured in Director. The Media Sequencer configuration reads:

```
<handler name="viz_background_ai" connected="yes" mode="enabled" type="viz">
  <entry name="encoding">UTF-8</entry>
  <entry name="state"/>
  <entry name="renderer">
    <entry name="gh-host1">
      <entry name="active"/>
    </entry>
  </entry>
  <entry name="publishing_point_uri"/>
  <entry name="publishing_point_atom_id"/>
  <entry name="info"/>
  <command_timeout>20.</command_timeout>
</handler>
```

and

```
<handler name="viz_background_e" connected="yes" mode="enabled" type="viz">
  <entry name="encoding">UTF-8</entry>
  <entry name="state"/>
  <entry name="renderer">
    <entry name="gh-host2">
      <entry name="active"/>
    </entry>
  </entry>
  <entry name="publishing_point_uri"/>
  <entry name="publishing_point_atom_id"/>
  <entry name="info"/>
  <command_timeout>20.</command_timeout>
</handler>
```

Then, enable the publishing points with UUIDs *b02cbb8e-87d6-11e7-bb31-be2e44b06b34* and *d0053030-87d6-11e7-bb31-be2e44b06b34*, which respectively reside on *gh-host1* and *gh-host2*, by adding them to their corresponding Viz handler. The configuration file should then read:
<handler name="viz_background_ai" connected="yes" mode="enabled" type="viz">
  <entry name="encoding">UTF-8</entry>
  <entry name="state"/>
  <entry name="renderer">
    <entry name="gh-host1">
      <entry name="active"/>
    </entry>
  </entry>
  <entry name="publishing_point_uri"/>
  <entry name="publishing_point_atom_id"/>
  <entry name="image_publishing_point_uri">http://imex-host:19390/publishingpoint/b02cbb8e-87d6-11e7-bb31-be2e44b06b34</entry>
  <entry name="image_publishing_point_atom_id">B02CBB8E-87D6-11E7-BB31-BE2E44B06B34</entry>
  <entry name="info"/>
  <command_timeout>20.</command_timeout>
</handler>

and

<handler name="viz_background_e" connected="yes" mode="enabled" type="viz">
  <entry name="encoding">UTF-8</entry>
  <entry name="state"/>
  <entry name="renderer">
    <entry name="gh-host2">
      <entry name="active"/>
    </entry>
  </entry>
  <entry name="publishing_point_uri"/>
  <entry name="publishing_point_atom_id"/>
  <entry name="image_publishing_point_uri">http://imex-host:19390/publishingpoint/d0053030-87d6-11e7-bb31-be2e44b06b34</entry>
  <entry name="image_publishing_point_atom_id">D0053030-87D6-11E7-BB31-BE2E44B06B34</entry>
  <entry name="info"/>
  <command_timeout>20.</command_timeout>
</handler>

Last, check if the global_publishing_points in the config section exists. If it does, it needs to be removed to enable the newly configured publishing points. Also, disable the http_resource_poller.

## 4.5 Configuration

Use the Configuration page to make changes to the web server, connection, import, or log settings. This section provides information on the different configuration settings available, and describes how to perform the initial Graphic Hub ImEx Agent Configuration.
4.5.1 Webserver Configuration

- **Port**: Set the HTTP port number the ImEx web server should listen to. The default port number is 19390.
- **Thread pool size**: Set the maximum number of concurrent threads for the ImEx Agent web server to handle requests. The default value is 80.
- **Enable access log**: Check the box to log information about connections and requests to the ImEx web server.
- **Use authentication**: Check the box to enable HTTP basic authentication on ImEx Agent web server with ImEx Agent specific credentials. This makes a Login button appear in the top right corner. The default username is Admin, and the default password is VizDb. You can change this in Options > Change ImEx password.

4.5.2 Connection Settings

- **General request timeout (ms)**: Set the default timeout in milliseconds for HTTP requests performed. The default timeout value is 10000.
- **GH REST request timeout (ms)**: Set the timeout for Graphic Hub REST requests in milliseconds. The default timeout value is 10000.
4.5.3 Import Settings

- **Maximum RAM usage (Mb):** Define the maximum amount of RAM allocated for caching temporary images in megabytes. The default value is 1500.
- **Maximum parallel uploads:** Set the maximum number of simultaneous uploads. The default value is 32.
- **Maximum parallel downloads:** Set the maximum number of simultaneous downloads. The default value is 32.
- **Monitoring interval assets (ms):** Set the interval in which the ImEx Agent checks the availability of all non-expired assets. In case an asset is accidentally deleted, the ImEx Agent automatically fetches the asset again. The default value is 10000.
- **Monitoring interval REST agents (ms):** Set the interval in which the ImEx Agent checks the availability of all configured GH REST agents. The default value is 10000.
- **Monitoring interval staged assets (ms):** Set the interval in which the ImEx Agent checks unavailable assets that have been staged. When the asset becomes available, the ImEx Agent automatically fetches the asset. The default value is 10000.

4.5.4 Log Settings

- **Maximum size (all logs)(MB):** The default value is 60.
- **Log lifetime in days:** The default value is 28.
- **Log level:** Select which log messages should be reported.
4.6 Manage Imports

This page contains information on import behavior and how to manage Destination directories, Watchfolders, GH REST hosts and Pre-Authenticated hosts.

- Import Behavior
- Manage Destination Directories
- Manage Watchfolders
- Manage GH REST Hosts
- Manage Pre-Authenticated Hosts

The ImEx Agent can only upload content to the configured Graphic Hub’s destination directories.

4.6.1 Import Behavior

During import, handling of destination directories and images differs depending on the import variant.

- When importing via media staging (MSE triggered):
  - A child folder with the title and id of the Distribution Plan is created in the destination directories. If the folder already exists, the existing folder is used.
  - The expiration date defined in the Distribution Plan is set as the expiration date for the project/folder on the Graphic Hub.
  - When an expired items cleanup task is enabled and configured in the Graphic Hub Terminal, the project/folder and its contents are deleted automatically when expired as soon as the expired items cleanup task is executed.
  - Files are always imported with a unique name (file name with asset ID). Files are never overwritten during import.

- When importing via watchfolder:
  - The images are saved directly in the destination directories.
  - Corresponding distribution plans do NOT expire. Images uploaded from a watchfolder have to be cleaned up manually.
  - Images which are deleted from a destination directory are automatically re-uploaded. To clean them up, first delete the corresponding file from the watchfolder and then delete it from the destination directory.
  - Importing different but identically named files from different watchfolders into the same destination directory leads to conflicts. These need to be resolved manually.
  - Overwriting images in the watchfolder leads to overwriting on the Graphic Hub if the checksums are different.
  - Renaming images in the watchfolder leads to upload of the renamed images. The image with the old name is not automatically deleted on the Graphic Hub.
  - Renaming or overwriting images in the destination directories re-uploads the versions in the watchfolder. The renamed file is not automatically deleted on the Graphic Hub.
  - Overwriting or deleting images from the watchfolder updates the corresponding distribution plan with the new information.
• By default, **Add file extension** is enabled. Images are named by appending their original names with an underscore and their respective file extension (e.g. `image.bmp` > `image_bmp`). It is not advised to disable this option, see **Add watchfolder** for details.

### 4.6.2 Manage Destination Directories

Use the **Import > Destination directories** page to configure the destination directories used by the GH ImEx Agent.

- **Status**: The current status of the configured destination directory. If a warning or an error is shown, hovering over the icon displays additional information.
- **Destination directory**: The absolute path of the currently configured destination directory (project or folder on the Graphic Hub).
- **Graphic Hub**: The configured Graphic Hub of the destination directory to which the GH REST is connected to.
- **GH REST**: The GH REST service(s) used for importing assets to the destination directory.

**Note**: Click the copy icon to open a dialog containing the import directory link to copy it for the Media Sequencer configuration.
To Add a Destination Directory

1. Open **Import > Destination directories**.
2. Click **Add destination** at the bottom left (1). This shows the Add Destination dialog (2).

3. Select a **Graphic Hub REST** host to use for importing assets. You can also enter the host manually, in the format `http://resthost:port/`. The GH REST must be bound and connected to a running Graphic Hub.

   **Note:** GH REST version 2.0.1 and Graphic Hub version 3.0.1 or higher are required.

4. Provide a valid GH username and password from the Graphic Hub you are connecting to.
5. Select a destination directory (folder or project), by clicking the browse icon (…) on the right side. You can also create new projects or folders using the directory browser.

6. Click **Add** to add the destination directory.

**The new Destination directory appears in the Default directories list:**

To Remove a Destination Directory

You can remove destination directories that are **not in use**.

1. Open **Import > Destination directories**.
2. Remove the desired destination directory by clicking the trash can icon at the far right of the watchfolder’s destination directory.
4.6.3 Manage Watchfolders

Use the Import > Watchfolders page to configure watchfolders which the ImEx Agent can use to import images from.

- **Status:** The current watchfolder status. If a warning or an error is shown, hovering over the icon displays additional information.
- **Destination directories:** The absolute path of the destination directory. This is a project or folder in a Graphic Hub.
- **Watchfolder path:** The absolute path of the watchfolder. This is a folder in the local file system or on a network share drive.
- **Interval:** The scan interval in minutes. Determines in which intervals the watchfolder is scanned.
- **Extension:** Shows if files have their file extension appended to their name.

**To Add a Watchfolder**

1. Open Import > Watchfolders.
2. Click **Add watchfolder** at the bottom left (1) to show the Add watchfolder dialog (2).

3. Select a watchfolder by clicking the browse icon (…) on the right side and choosing a folder. The folder list consists of folders on all local drives and correctly mounted network share drives.

   ▶ **Note:** For a network share drive to appear in the folder list, it needs to be mounted as the SYSTEM user, because the ImEx Agent service is running under the SYSTEM user. Alternatively, manually enter the absolute path of the folder.

4. Choose the length of the additional scan interval in minutes by either entering a value manually or increasing/decreasing it using the up/down arrow buttons.

5. Choose if files have their file extension (i.e. file type) appended to their name by checking/unchecking the **Add file extension** checkbox. (e.g. the files image1.jpg, image1.png and image2.bmp are imported as image1_jpg, image1_png and image2_bmp if the box is checked).

   ▶ **Note:** It is not advised to deactivate file extension adding as files with identical names overwrite each other on upload. Which of these persists depends on its position in the upload queue (i.e. the last one that gets uploaded is then the file on the Graphic Hub).

6. Select a destination directory from the drop-down menu by checking the directory. By checking multiple destination directories, images are imported to multiple destinations. More details regarding the destination directories is listed in the drop-down menu: **Destination** reads the absolute path of the destination directory on the
7. Click **Add** to add the watchfolder. The new watchfolder appears in the Watchfolders list:

![Graphic Hub Administrator Guide - 3.6](image)

**To Change Watchfolder Scan Interval**

You can change scan intervals of your watchfolders. The ImEx Agent periodically scans the content in the watchfolder in addition to the monitored update notifications from the file system.

1. Open **Import > Watchfolders**.
2. Click on the watchfolder you want to re-configure the scan interval for.
3. Change the length of the scan interval in minutes by either entering a new value manually or increasing/decreasing it using the up/down arrow buttons.
4. Click **Apply** to apply the change. The new scan interval is applied to the watchfolder and is shown in the **Interval** column.
To Remove a Watchfolder

1. Open **Import > Watchfolders**.
2. Remove the desired watchfolder by clicking the trash can icon at the far right of the watchfolder’s entry.

### 4.6.4 Manage GH REST Hosts

Use the **Options > GH REST hosts** page to configure the Graphic Hub REST hosts used by the GH ImEx Agent.

![Graphic Hub ImEx - 127.0.0.1](image)

- **Status**: The current GH REST host status. If a warning or an error is shown, hovering over the icon displays additional information.
- **GH REST**: The GH REST host URL.
- **Graphic Hub**: The Graphic Hub to which the GH REST is connected.
- **Username**: Graphic Hub username that is used.
- **Authentication**: Authentication method (Basic means HTTP basic authentication).
- **Imports**: The number of imports that are currently performed on this GH REST (refresh interval is five seconds).

To Add a GH REST Host

1. Open **Options > GH REST hosts**.
2. Click **Add GH REST host** at the bottom left (1) to show the Add GH REST host dialog.

3. Select a **Graphic Hub REST** host to use for importing assets. A GH REST host can only be added once. Already configured hosts are disabled in the selection drop-down (A). You can also enter the host manually, in the format `http://resthost:port/`. The GH REST must be bound and connected to a running Graphic Hub.

⚠️ **Note**: GH REST version 2.0.1 and Graphic Hub version 3.0.1 or higher are required.
4. Provide a valid GH username and password from the Graphic Hub you are connecting to.
5. Click **Add** to add the destination directory. The new GH REST appears in the list.
To Remove a GH REST Host
You can remove GH REST hosts that are not referenced/used by any of the configured import directories. You can view a list of GH REST hosts in use under Import > Destination directories.

1. Open Options > GH REST hosts.
2. Remove the desired host by clicking the trash can icon at the far right of the host's entry.

4.6.5 Manage Pre-Authorized Hosts
Go to Options > Pre-Authorized Hosts to view a list of configured pre-authenticated hosts that are used by the ImEx Agent to authenticate at external HTTP image sources.
To Add a Pre-Authenticated Host

1. Open Options > Pre-Authenticated Hosts.
2. Click **Add Pre-Auth host** at the bottom left. This enables the Add Pre-Authenticated Host pane:

3. Enter the URL for the host you are pre-authenticating, as well as the **Username** and **Password**.
4. Click **Add**. This adds the Pre-Authenticated host to the list view.

To Remove Pre–Authenticated Hosts
You can remove pre-authenticated hosts that are **not in use**.

1. Open **Options > Pre-Authenticated Hosts**.
2. Remove the desired host by clicking the trash can icon at the far right of the host's entry.

4.7 **Monitor The Asset Import**
You can view current import progress, asset availability and status from the Report menu.

**Note:** The import configuration (distribution plans, asset import schedules, availability report) is not persistent and lost when the ImEx Agent service is stopped/re-started.

4.7.1 **Monitor Distribution Plans**
A distribution plan describes the content, the storage location(s) (multiple destination directories) and the timeline of an import operation. A distribution plan represents a set of assets that should be available on a number of destination directories during a certain period of time.

Select **Distribution plans** from the **Report** menu, to display an overview of current distribution plans.
The overview contains the following information:

<table>
<thead>
<tr>
<th>Column</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status</td>
<td>Displays the current status of the distribution plan.</td>
</tr>
<tr>
<td></td>
<td>- Green check mark: Everything is okay.</td>
</tr>
<tr>
<td></td>
<td>- Two arrows in a circle: The ImEx Agent is currently working.</td>
</tr>
<tr>
<td></td>
<td>- Hourglass icon: The distribution plan is waiting to start work.</td>
</tr>
<tr>
<td></td>
<td>- Orange warning icon: A set upload has warnings or errors.</td>
</tr>
<tr>
<td></td>
<td>- Red error sign: Destination directory error.</td>
</tr>
<tr>
<td></td>
<td>- Inactive symbol: For expired items.</td>
</tr>
<tr>
<td>Type</td>
<td>Displays the type of the distribution plan.</td>
</tr>
<tr>
<td></td>
<td>- Calendar icon: Media staging (MSE triggered).</td>
</tr>
<tr>
<td></td>
<td>- Folder icon: Watchfolder.</td>
</tr>
<tr>
<td>Distribution plan</td>
<td>The name of the current distribution plan (if set) or watchfolder location.</td>
</tr>
<tr>
<td>Column</td>
<td>Details</td>
</tr>
<tr>
<td>----------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Earliest use</td>
<td>Denotes the start time of this distribution plan. All assets should be available at this point in time. Also used to prioritize imports. Does not apply to watchfolders.</td>
</tr>
<tr>
<td>Expires</td>
<td>Denotes the end time of this distribution plan. Does not apply to watchfolders.</td>
</tr>
<tr>
<td>Destination</td>
<td>The destination directories this distribution plan imports the assets to.</td>
</tr>
<tr>
<td>Availability</td>
<td>Current progress / availability of all assets on all destination directories.</td>
</tr>
</tbody>
</table>

### 4.7.2 Monitor Availability Report

An availability report contains the content of an import, including additional information about the state and location.

Select **Availability report** from the **Report** menu to display an overview of all assets that are scheduled for import.

The overview provides the following functionality:

<table>
<thead>
<tr>
<th>Area</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Filter by asset status. Only assets with the selected states are displayed.</td>
</tr>
<tr>
<td>Area</td>
<td>Details</td>
</tr>
<tr>
<td>------</td>
<td>---------</td>
</tr>
<tr>
<td>2</td>
<td>Filter by custom text, date, destination directory, title of distribution plan.</td>
</tr>
<tr>
<td>3</td>
<td>Grid view of assets.</td>
</tr>
</tbody>
</table>

Monitor Availability Report for a Specific Distribution Plan

1. Go to **Report > Distribution plans**.
2. Click the **Availability** column to View availability reports for a specific distribution plan.

3. All assets for **this specific distribution plan** are shown:
4. To investigate asset errors from this view, look at the **Details** column, which contains information about why an asset was not uploaded in case of an error. Use the filter buttons to display only assets in the desired state, as for example, errors or warnings.

4.8 **Log And Report**

- A general GH ImEx Agent related log can be viewed under **Report > Logs**.
- You configure the log level under **Options > Configuration**.
Furthermore, you can download an archive of all log and configuration files from Report > Export. This is particularly useful when troubleshooting and for support requests.

### 4.8.1 To View ImEx Agent Logs

1. Navigate to Report > Logs to display the logs section.
2. Search with custom text using the text field in the top right hand corner.

![ImEx Agent Logs](image)

### 4.8.2 To Manage Reports

2. The Export section displays all previously created report exports.
3. Select one or multiple exports
4. Click **Download** to download a .zip file containing information about ImEx Agent settings and current configuration.

![Image of Export List](image)

**Note:** The report archives are stored in a temporary directory of the operating system, not persistent, and are lost when you stop or restart the ImEx Agent service.

4.8.3 To Create a Report

Click **Create** (1) to immediately generate an report export. The newly generated report is added to the list (2).

![Image of Export List with Create and Download buttons](image)
4.9 Load Balancing

It is possible to bind multiple REST services to the same Graphic Hub. This can increase performance and decrease the workload of each GH REST by utilizing multiple GH RESTs. Furthermore, multiple GH RESTs ensure a higher degree of redundancy and fault tolerance. The ImEx Agent automatically uses each configured GH REST that is available based on the connected Graphic Hub. It is possible to add GH REST services at any time and remove them if it is not utilized.

**Note:** It is recommended to configure the bound REST services to have identical content size limits. The ImEx Agent does not automatically distribute assets to RESTs with appropriate content size limits.

If multiple GH RESTs are used for a destination directory can be seen in:

- **Import > Media staging** in column GH REST, which contains multiple values.
- **Options > GH REST hosts** when the Graphic Hub column contains the same value.

The ImEx Agent detects if e.g. a GH REST is bound to a different Graphic Hub and operates with the currently available GH REST connections. If connection to a Graphic Hub is completely lost that has currently used destination directories on it then a proper error is reported.

4.9.1 ImEx Agent Related Configuration

There are certain configuration options in the GH ImEx Agent that influence the import behavior.

1. Navigate to the ImEx Agent configuration interface, for example, `http://127.0.0.1:19390/index.html`
2. Go to **Options > Configuration**.
3. Look at the **Import** settings section.

The **Maximum RAM usage** in Megabyte defines the amount of RAM the ImEx Agent is allowed to use for caching downloaded files. If there is not enough RAM available, it uses the hard drive to cache files.

**Warning:** The default settings ensure a properly working ImEx Agent. Changing these values may decrease ImEx Agent performance.
4.9.2 GH REST Related Configuration

There are certain configuration options in the GH REST that influence the GH ImEx Agent import behavior.

**Warning:** Please be aware that a mis-configured Graphic Hub REST service may cause the system to not work properly.

1. Navigate to the GH REST configuration interface, for example, [http://127.0.0.1:19398/config/index.html](http://127.0.0.1:19398/config/index.html).
2. Go to **Configuration > Viz GH Rest.**

![Graphic Hub REST Configuration Interface](image)

**Warning:** Keep the default values, and only reduce them if resource demand is too high. Increasing these values is not recommended, as this can cause system instability.

4.10 Troubleshooting GH ImEx Agent

This page provides help for troubleshooting the following scenarios:

- Unable to Connect to GH ImEx Agent Service
- Status Box Displays an Error
- Status Box Displays a Warning
- Media Staging Status Shows an Error
- Media Staging Status Shows a Warning
4.10.1 Unable to Connect to GH ImEx Agent Service

This indicates that the GH ImEx Agent HTTP server is not accessible or that the service is not running.

1. Press **WINDOWS + R**.
2. A **Run** window opens in the bottom left corner.
3. Enter **services.msc** and click **OK**. An overview of services opens.
4. Check whether the **Viz GH ImEx Agent** service is in **Running** status.
5. If the service is not running, right click the Viz GH ImEx Agent service and select **Start** or **Restart**.

6. In the ImEx Agent web interface, click **Retry to connect** or refresh the page in the browser.

### 4.10.2 Status Box Displays an Error

1. Click on the error icon to get forwarded the page where you can investigate the error.
2. In this example, we are taken to the **GH REST hosts** overview page. Hover the mouse over the error to display more information, for example, *Request failed: Status='502'*.

3. The status code **502 Bad Gateway** is returned because the Graphic Hub or REST host used in a Distribution plan is either not running or reachable.

### 4.10.3 Status Box Displays a Warning

1. Click on the warning icon to get forwarded the page where you can investigate the warning.

2. In this example we are taken to the GH REST hosts overview page. Hover the mouse over the error to display more information, for example, *GH-Rest not reachable*.
4.10.4 Media Staging Status Shows an Error

Note: ImEx displays a warning although GH REST is not reachable. This is proper behavior, because the given host (here, http://TUTORIAL02:19398) is not referenced by any import jobs, as you can tell from the enabled trash can icon.
1. Hover over the error icon to get further information:

![Error Icon with 'Folder deleted' message]

2. In this example, the destination directory `/data/ImportDirectory01` has been deleted. To resolve the error, select an existing folder by clicking the browse (…) icon.

![Click to Select Existing Folder]
3. Selecting an existing folder/project resolves the error:
4.10.5 Media Staging Status Shows a Warning

1. Hover over the warning icon to get further information:

2. In this example, the current folder has been renamed.

3. To remove the warning, click the warning icon and **Acknowledge** to remove the warning.
5 Graphic Hub Manager

The Graphic Hub Manager is the administrative tool for the Graphic Hub. It enables the administration of files and folders over multiple Graphic Hubs, for such tasks as searching, and working with Deploy Agents.

This section contains information on the following topics:

- Main Menu
- Preferences
- Explorer
- Servers and Folders
- Graphic Hub Login and Log Out
- Add-ons Panel
- Journal Panel
- Alerts
- Archives Panel
- Action Log
- Graphic Hub License
- Graphic Hub Manager Customization
- Enable a Graphic Hub for a Virtual Studio

5.1 Main Menu

The main menu contains the following items:

- Server Menu
- View Menu
5.1.1 Server Menu

- **Login...**: Opens the Login window, used to log on to one or more Graphic Hubs.
- **Logout**: Opens the Log out window used to log out from a Graphic Hub.
- **Terminals...**: Opens the Terminals Window. The Terminals monitor window can be used to monitor available terminals on the network.

⚠️ **Note**: Terminal monitoring is only supported for Graphic Hub Terminal versions prior to version 3. For Terminal 3, connect to the Terminal's web interface.

- **Shutdown...**: Opens the Shutdown window, used to remotely shut down servers (see Graphic Hub Shut Down).
- **Check...**: Opens the Check Server window where a search for Data Errors in the internal structure can be performed. Requires the user to be logged on as an Administrator.
- **Import**
  - **Viz 2.x data**: Opens the Import window. From this window it is possible to import a Viz 2.x data folder to the selected database.
  - **Viz 2.x archive(s)**: Opens the Import window. From this window it is possible to import one or more Viz 2.x archives from a folder to the selected database.
  - **Manually selected Viz 2.x archive(s)**: Opens the Import window. From this window it is possible to import one or more Viz 2.x archives to the selected database.
  - **Resume from canceled or crashed import**: Opens the Import window. From this window it is possible to resume from a failed import by using an automatically created import backup file.
• **Edit preferences**: Opens the import **Preferences** window. From this window it is possible to define various preferences for the import operation, for example the root directory for import log files.

• **Differences**: Opens the Server Diff window. From this window it is possible to detect differences between two servers, or the servers in a cluster environment (see **Detect and Solve Server Differences**).

• **Administer journal entries**: Shows/hides the Administer Journal Entries panel in the Main window (see **Journal Panel**).

• **Configure Alerts**: Opens the Alerts panel, where e-mail notifications and recipients can be configured for an event where errors occur in the system (see **Alerts**).

• **Exit**: Automatically logs out from all connected Graphic Hubs, and closes the Graphic Hub Manager.

### 5.1.2 View Menu

- **Toolbars**: Select which tool bars to view:
  - Main
  - Servers and Folders
  - Folders and Files
  - Quick Search
  - Layout

- **Panels**: Select which Panels to view:
  - Servers and Folders
  - Search Panel (see **Import External Images**)
  - Add-ons Panel

- **Archives**: Open the **Archives Panel**

- **Messages (Chat)**: Show/hide the chat panel in the main window.

- **Logging panel**: Opens the Logging Panel, which shows logged messages, which includes:
  - Error messages
- Warning messages
- Info
- Update messages
  Tick the Write to log-file to write the selected messages to the Graphic Hub log file, if required.

- **Duplicates**: Open the duplicates window. From this window it is possible to locate duplicate server files (see Locate Duplicate Files).
- **Object types**: Opens the Object Types window.
- **Active sessions**: Opens the Active Sessions window. From this window it is possible to monitor all active sessions.
- **Layouts**: Select, save and maintain layouts:
  - **Load layout**: Select a layout to load.
  - **Save current layout**:
  - **Save current layout as...**: Save the current layout as a new layout.
  - **Lock/Unlock current layout 'xxx'**: Lock or Unlock the current layout.
  - **Maintain layouts**: Opens the Maintenance of layouts window.
- **Refresh explorer**: Refreshes the Explorer.

### 5.1.3 Tools Menu

- **Monitor servers**: Opens the Monitor Servers window. This window shows an overview of all the servers Graphic Hub Manager is logged in to.
- **Administer users and groups**: Opens the Administer Users and Groups window. From this window it is possible to manage users and groups on the various servers (see User and Group Management).
- **Administer keywords**: Opens the Keywords window. From this window it is possible to manage the Keywords in the database.
- **Administer add-ons**: Opens the Add-ons Panel.
- **Administer tasks**
  - **Running deploy tasks**: Shows/hides the Running Deploy Tasks panel in the Main window.
- **Scheduled deploy tasks**: Shows/hides the Scheduled Deploy Tasks panel in the Main window.
- **Finished deploy tasks**: Shows/hides the Finished Deploy Tasks panel in the Main window.
- **Search by UUID**: Opens the Search by UUID on server window, used to search for files in the connected databases using universally unique identifiers.
- **Configure deploy agent**: Opens the Properties of Deploy Agent dialog box. From this dialog box it is possible to define various Graphic Hub Deploy agent settings (see Deploy Agent Modes). This menu-option is only available in setups with an installed Graphic Hub Deploy agent.
- **Export settings (incl. layouts) to file**: Opens a window from where it is possible to export all the workstation-based customizations to the Graphic Hub Manager, such as changes to any of the panels, column layout and visibility, as well as the user interface in general.
- **Import settings (incl. layouts) from file**: Opens a window, from where it is possible to import all the workstation-based customizations to a Graphic Hub Manager, such as changes to any of the panels, column layout and visibility, as well as the user interface in general.
- **Edit preferences**: Opens the Preferences window. From this window it is possible to define various system preferences.

### 5.1.4 Extra Menu

- **Viz VR Studio Setup**: Allows you to import the enabling XML file so that Graphic Hub can support a virtual set environment (see Enable a Graphic Hub for a Virtual Studio).
5.1.5 Pilot Menu

- **Differences...**: Opens the Pilot data differences panel.
- **Create Pilot deploy task...**: Opens the create Pilot data deploy task panel.
- **Import...**: Opens the import Pilot data panel (see Main and Replication Servers).

5.1.6 Info Menu

- **License info**: Opens the License Info window. From this window it is possible to monitor the license information for the available servers.
- **About**: Shows the software version and build number of the Graphic Hub Manager.
- **Help**: Opens the Graphic Hub online help file.

5.2 Preferences

The Preferences window, located under **Tools > Edit Preferences**, shows all the system preferences and is divided into the following panes:
5.2.1 General

The General preferences consist of:

- Login
- Login Profiles
- Timeouts and Buffer Settings
- Deploy Direct Copy
- Startup
- CSV Export
- Look

Login

In the Login panel, set the Start-up and Login preferences.
- **TCP Port used for Logins**: Sets a TCP port to be used for Log-ins. Click **Set default** to set the TCP Port back to its default value (19396).

- **Auto Login**
  - **Use Auto Login**: Enables Auto Login when box is checked.
  - **Protect Auto Login with Password**: Sets a master password for auto Login.
  - **Confirm Auto Login**: Checks to require login confirmation for the Graphic Hubs which are part of the Auto Log-in list.

  **Note**: This option is not available if **Protect Auto Login with Password** is enabled. When **Protect Auto Login with Password** is checked, automatic login is disabled.

- **En-/disable servers for Auto login and change Auto login order**: Selects which servers to use Auto Login.
  - **Up/Dn./Top/Bot.**: Changes the Auto login order of available servers.
  - **Pre-check availability of servers before login**: Contacts servers designated for Auto login before actual login when selected. If they cannot be contacted, they are automatically
unchecked for Login and diagnostic information shows in the according line of the server in the login window.

- **Enable 'Login to multiple servers' using Auto login at any time:** Provides the option **Login > to multiple servers** in the main menu, under **Server** when selected.
- **Enable 'Logout for all Servers':** Provides the option **Logout > from all servers** in the main menu, under **Server** when selected.

**Note:** Complete automatic login to Graphic Hubs is only available if Auto login is not protected with a (master) password, if a Login profile does not exist and if **Confirm Auto log-in** is not checked. And even if all those conditions apply, automatic login is not started if **Precheck availability of servers before login** is ticked and not all of the servers seem to be available for some reason.

---

## Login Profiles

Click this tab to configure different Login Profiles for use with Auto Login. Use Login Profiles to configure which servers and associated Deploy Agents should be logged onto by Auto Login.

- **Login profiles:** Selects, creates or deletes login profiles.
- **Choose servers for use in login profile <login profile>:** Selects which servers to include with the login profile.
Choose deploy agents for use in login profile <login profile>: Selects which Deploy Agents to include with the login profile. If no Deploy Agents are selected for the Login Profile, Deploy Agent configuration and deploy tasks are unavailable for the duration of session. If no Deploy Agent is configured in the Agents section, this list is empty.

Revert: Reverts settings before Apply or OK is clicked, if required.

Timeouts and Buffer Settings

From this panel it is possible to define various timeout values related to communication with Graphic Hubs. Changing the values of the timeout settings may have a significant impact on how the Deploy Agent works. The default values should only be changed if the Deploy Agent has problems with servers connected through a slow or congested network, or that have an unusually high server load. Increasing the timeout values may solve the problems in such cases. Decreasing the values does not improve the general performance of the agent, and is not recommended.

Establishing communication timeout (in seconds): Sets the maximum amount of time for a Deploy Agent to connect to a server. If the server does not respond in this set time, due to network characteristics or server load, it is considered as offline.

Communication round trip timeout (in seconds): Sets the maximum amount of time for the Deploy Agent to wait for a reply from the server. If the server does not respond in this set time, due to network characteristics or server load, the affected task may be paused by the Deploy Agent.

Cluster failover timeout (in seconds): Specifies the period that a task is waiting for a notification from the failover server to switch over if a main server becomes unavailable. If this time exceeds, the agent attempts to manually connect to the failover server. This option is relevant for Deploy Agents that operate in a setting with a failover server.

Deploy Direct Copy

In the Deploy Direct Copy panel set the Direct Deploy Copy defaults.
• **Default Behavior options**: Set the defaults for Deploy Direct Copy:
  - Rebuilds original structure,
  - Rebuilds structure under target folder,
  - Copies to target folder only.

• **Overwrite existing objects**: Overwrites files with the same name existing in the target folder.

• **Overwrite existing references**: Overwrites the file references if the same file name exists in the target folder.

• **Overwrite owner**: Keeps the original owner of deployed files when selected. If the file existed already on the server, the owner of the pre-existing file is overwritten.

• **Overwrite creation date**: Keeps the original creation date when selected. If the file existed already on the server, the creation date of the pre-existing file is overwritten. If not selected, the creation date is set to the time of deployment.

• **Overwrite modification date**: Keeps the original modification date when selected. If the file existed already on the server, the modification date of the pre-existing file is overwritten. If not selected, the modification date is set to the time of deployment.

• **Default Multi-server processing options**:
  - Deploys all files to the first server, then to the second, and so on.
  - Deploys one file to all servers, then another file, and so on.

**Startup**

In the Startup panel, specify if the listed windows should automatically open on a new start of the Graphic Hub Manager. Also, specify if this should depend on if those windows were open when the Graphic Hub Manager was last exited.
• **Automatically open windows that were visible on last exit:** Opens all windows listed below, if they were open on the last exit when selected. If not ticked select which windows to open from the list below:

• **Automatically open 'Monitor servers' / 'Active sessions' / 'Terminals':** Opens a window on start-up when selected.
  • **But only if it was open the last time:** Opens the window at start up only if it was open on last exit.

**CSV Export**

In the CSV Export panel, specify the default settings used when exporting search results (explorer and archive search).

• **Value separator:** Determines value separator used in the generated CSV file (one of ",", ";", TAB or user defined)

• **Export with/without column-names:** Assigns a header row to the CSV file when set.

• **Export of currently visible or all columns:** Does not export hidden and removed columns by default (can be enabled in configuration).

**Look**

In Look panel set the style of the User interface.
• **Visual Style**: Sets the user interface style from the drop-down list.
• **Docking Tab Colors**: Assigns tab colors in the GUI.

### 5.2.2 Import

In the Import panel, set the data directory for log files and temporary files used for the import of Viz 2.x data and archives (see [Import Viz 2.x Data and Archives](#)).

It is also possible to disable the auto-import when an import resumes after a canceled or crashed import procedure.

• **Directories**: Shows the root directories for log and temporary files. Select **Browse** to change the directories if required.
• **Behavior**: Starts import automatically if the system is resumed when selected.
• **Troubleshooting**: Shows the location of an alternate import executable (*viz_import.exe*) if there are problems with the Graphic Hub Manager. This field normally should be empty.

⚠️ **Note**: This alternate import executable could either be an older one than the one that came with the installation or a newer/updated one sent out by Vizrt.
5.2.3 Viz

General

In the Viz panel, define the TCP port and Viz executable to use within the "Re-save with Viz..." dialogue in the files, folder or search results view. This enables Graphic Hub Manager to send transfer control protocol commands to the viz executable to re-save files and folders.

5.2.4 Monitor Servers

In the Monitor Servers panel, define various disk and memory warnings, related to free disk space/memory. It is also possible to define warnings when the license expiration date approaches.

Warnings
5.2.5 Agents

The Agents panel is used to set the preferences for automatic updates on running Deploy Agents.

**Deploy**

- **Search for deploy agents on these UDP ports**: Enter the UDP port where to search for available Deploy Agents. Deploy agents are configured to listen on port 19392, by default. If they are configured to listen on another port, this port should be added here.

  **Note**: With a UDP search, the Graphic Hub Manager only finds Deploy Agents which listen on the ports which are added here, and only those which are running on machines within the same subnet as the machine running the Graphic Hub Manager itself.

- **Use this timeout for receiving answers from deploy agents**: Sets the timeout (milliseconds) for a Deploy Agent search. Default is 100 ms.

  **Tip**: If there are problems with the network condition, try to increase the default value.

- **Deploy agents not reachable via UDP broadcast and/or for use in Login Profiles**: Manages Deploy Agents (Add, Remove, Modify or change the order of listed Agents) that are running on a machine, which is outside the subnet of the machine on which the Graphic Hub...
Manager is running. If Deploy Agents are to be used in Login Profiles, they must be added here even if they are on the same subnet.

When Add or Modify is clicked it opens the Deploy Agent window:

- **IP address**: Enter an IP address or host name.
- **UDP port**: Enter the UDP port number.
- **Received timeout**: If the Deploy Agent does not answer in the given timeout or does so only sometimes, you may increase this timeout value here to make sure that the Graphic Hub Manager can always contact the Deploy Agent.
- **Name**: Name of the host/machine (auto filled).
- **Intervals (in seconds)**: Timeouts for answers from Deploy Agents:
- **Interval to get updated info for running tasks**: Sets the interval, in seconds, in which updated information about tasks executed by the Deploy Agents should be requested.
- **Interval to try to reconnect to lost agents**: Sets the interval, in seconds, in which the Graphic Hub Manager should try to recontact Deploy Agents for which communication with them was broken.

### 5.2.6 Archives

In the Archives panel set the preferences for the import and export of Archives as well as some general preferences.
General Preferences

- **Watched folders**: Lists all Watched folders.
  
  **Note**: The Archives view automatically lists all (Viz 3.x) archives (extension 'via') which it finds in any of the given watched folders. Sub-folders of watched folders are not automatically watched, make sure to specify each single folder, as required.

- **Add...**: Adds a new Watched folder.
  
  **Tip**: If a folder shows as **yellow**, there are no Viz Archives in that folder. If a folder shows as **red**, it currently is not accessible or does not exist.

- **Remove selected**: Removes a Watched Folder (this removes the folder as a Watched folder, but the folder stays in the Graphic Hub Manager Customization).
Import Preferences

- **Import mode**: Sets the import mode:
  - Rebuilds original structure.
  - Rebuilds structure under target folder.
  - Copies to target folder only.
- **Overwrite mode**: Sets the overwrite mode:
  - **Overwrite**: Overwrites all files on import. Files are not overwritten if the destination file has exactly the same content.
  - **Duplicate**: Imports with a new file name if a file with the same name exists.
  - **Skip**: Does not import if a file already exists.
- **Force link name creation**: Creates links to all links from the original and imported file if the file to be imported has the same data, but has different file links.
• Select which data from the source file is applied at import:
  • Overwrite owner.
  • Overwrite name.
  • Overwrite create date.
  • Overwrite access rights.
  • Import add-ons.
  • Import keywords.

Note: As these settings are under the import section, they change the parameters of the file being imported.
For example, if a file has a Owner = Owner1 and Creation Date = yesterday and you import it to another server today, then: If the settings Overwrite Owner and Overwrite Creation Date are set, the Owner is changed to Owner2 and Creation Date is changed to today at successful import. The overwrite is not file-based, it is based on the file parameters selected at import.

Export Preferences
In the Archives Export panel, create new and view Archive export Templates.
- **Templates for creating name of new archives**: Selects a template from the list.
  - **Remove**: Removes a selected template.
  - **Add**: Adds a new template. First create the new template in **New Template**.
- **New template**: Creates a new template. Select tokens to add from the **Add token** drop-down (use separators as required between the tokens).
- **Preview**: Shows a preview of the new template.
- **Default template for creating name of new archive**: Selects a default Template from the list of Templates.
- **Export all linknames**: Enables an export of all linknames when checked. Unchecking this exports only the linknames from the folder/project, the file is dragged from.
- **Allow extended header**: Enables / disables extended header functionality for archive creation.

⚠️ **IMPORTANT**: Enable this for a system with all clients at least version 3.0.0. The extended header flag generates **incompatible archives for pre 3.0.0 versions**.

See Also
5.3 Explorer

Below the main menu is the Explorer of the Graphic Hub Manager.

Tip: The panels in the Explorer are resizable, and they can be dragged around. Also, it is possible to navigate through the trees in the Explorer with the mouse pointer, arrow keys, or by typing the first character of the required folder/file.

The Explorer is automatically updated immediately after changes made to files and/or folders, but a manual refresh of the Explorer is sometimes necessary, for example after re-enabling columns. To refresh the Explorer, select View > Refresh Explorer or press F5.

This page contains information on the following topics:

- Explorer Columns
- Column Headings
- To Hide, View, Remove or Add Columns
- Explorer Icons
- Tool Bar
  - Main
  - Servers and Folders
  - Folders and Files
  - Quick Search
  - Layout
5.3.1 Explorer Columns

When server files are shown in the Explorer view, columns are used to show information about the files.

There are two mandatory columns, **Name** and **UUID** (these can be hidden if required), and then additional columns which can be added or removed as required. Each column can be moved to a new position as required.

Column customization works for:

- Explorer
- Search results
- Journal
- Server differences
- Scheduled tasks
- Action Logs
- Running tasks
- Finished tasks

5.3.2 Column Headings

- **Name**: Shows the name of the file.
- **Size**: Shows the size of the file.
- **Type**: Shows the file type, for example material.
- **Date Modified**: Shows the date and time when the file was modified the last time.
- **Modified by**: Shows the name of the user that modified the file the last time.
- **Date Created**: Shows the date and time when the file was created.
- **Owner**: Shows the name of the user that owns the file.
- **Checked out by**: Shows the name of the user that has checked it out, if the file is checked out.
- **Locked by**: Shows the name of the user that is working on it, if the file is session locked.
- **Access rights (U/G/W)**: Shows the access rights for user, group, and world (see User and Group Management).
- **Folder links**: Shows the number of folder-links (number of folders the file is placed in).
To Hide, View, Remove or Add Columns

1. Right-click on the column bar.

   ![Column settings menu]

2. Add, remove, hide or show columns, as required.

   ![Warning icon]
   **Note:** In Remove Column, **UUID** and **Name** are grayed out. They cannot be removed, but they can be hidden.

   To customize the column order, drag the column to the required location.

### 5.3.3 Explorer Icons

The following icons are used in the Explorer:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Folder icon]</td>
<td>Regular Folder</td>
<td>![Image icon]</td>
<td>Image</td>
</tr>
<tr>
<td>![Folder icon]</td>
<td>Project Folder</td>
<td>![Material icon]</td>
<td>Material</td>
</tr>
<tr>
<td>![Font icon]</td>
<td>Base font</td>
<td>![Scene icon]</td>
<td>Scene</td>
</tr>
<tr>
<td>![Font icon]</td>
<td>Font</td>
<td>![Video icon]</td>
<td>Video</td>
</tr>
<tr>
<td>![Geometry icon]</td>
<td>Geometry</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
5.3.4 Tool Bar

At the top of the Explorer is the Tool Bar.

Main

- Show Servers and folders: Show/hide the Servers and Folders, or click View > Servers and Folders.
- Show search: Show/hide the Preferences.
- Show add-ons: Show/hide the Add-ons Panel.

Servers and Folders

- One level up: Jump one level up in the Servers and Folders tree structure.
- Address: Shows the current folder path.

From the drop-down list, it is possible to see the history of all folders that have been used within this session. To re-open to one of these folders, select it from the list. The format in which the history is shown is `<ServerNumber>:\data\<path>`. The history of a server that has been disconnected is no longer available.

Folders and Files

- Type: Filter file types. Click the arrow to the right to toggle between the options.
- Show/Hide project and folders: If enabled, the subprojects/sub-folders of the selected folder show in the Explorer list.
- Display icons/Details: Toggles between showing files in the Explorer with details or as icons.

Quick Search

- Search in: Graphic Hub Quick search function. Select a server to search in, enter a search string and press ENTER or click on to start a Free text search on the selected server.
### Layout

- **Layout**: Loads a saved layout. Options:
  - **System Clean (Locked)**: (Basic standard layout)
  - **System Default**: (as last saved (default layout))
- **Save**: Saves the current layout.
- **Save as...**: Saves as a new layout.

⚠️ **Note**: A Layout is local for the current machine in use.

#### 5.3.5 Display Files as Icons

By default, the files in the Explorer are presented with detailed information. To view the files as icons, toggle the (As Icons) button in the Tool Bar.

⚠️ **Note**: The icons can also be enabled from the shortcut menu of the Explorer.

When files are viewed as icons, in the lower right corner of the icon characters show the file type:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Audio</td>
</tr>
<tr>
<td>B</td>
<td>Base font</td>
</tr>
<tr>
<td>?</td>
<td>Default</td>
</tr>
<tr>
<td>F</td>
<td>Font</td>
</tr>
<tr>
<td>G</td>
<td>Geometry</td>
</tr>
<tr>
<td>I</td>
<td>Image</td>
</tr>
<tr>
<td>M</td>
<td>Material</td>
</tr>
<tr>
<td>M2</td>
<td>Material advanced</td>
</tr>
<tr>
<td>S</td>
<td>Scene</td>
</tr>
<tr>
<td>V</td>
<td>Video</td>
</tr>
</tbody>
</table>

Additional information may also be shown on the icon:
### 5.4 Servers And Folders

The **Servers and Folders** panel displays folders, and the servers they are on, in a tree structure.

Right-click a server folder in the tree to open a context menu. From this menu, the folder tree can be expanded or collapsed, and, for example, new folders created or access rights set.

The server tree order can be changed by drag and drop. The server order changes, but server numbers stay the same.
This page contains information on the following topics:

- **Folders**
  - Tree Structure
    - To View the Content of a Folder
- **Working with Folders**
  - To Expand Folders
  - To Collapse Folders
  - To Create a New Folder
  - To Rename a Folder
  - To Move a Folder
  - To Change the Owner of a Folder
  - To Set Rights for a Folder
  - To Delete a Folder
- **Folder Properties**
• To View the Properties of a Folder
• To View the Properties of Multi-selected Folders
• General Properties
• Add-Ons Properties

Working with Files
• Overwrite Files
• To Create Linked Files
• To Create Duplicate Files
• To Create Duplicate Files Including Referenced Objects
• To Move Files
• To Overwrite Files
• To Re-save with Viz Executable

File Properties
• To View the Properties Assigned to a File
• General Properties
• Keyword Properties
• References and Link Properties
• Duplicates
• Total Size Properties
• Advanced Properties
• File History
• File Availability
• File Add-ons

Folder and File Expiration Dates
• To Set an Expiration Date

Illegal Characters

5.4.1 Folders

The server tree can contain two types of folders:

- **Project folders**, displayed with a blue folder icon.
- **Regular folders**, displayed with a yellow folder icon. Project folders cannot be created inside a regular folder, but can contain regular folders. Both types of folders can be dragged around after being added to the server tree. Also, project names must be unique and in compliance with the list of illegal characters.

In Viz Artist, the difference between a regular folder (2) and a project folder (1) is that by defining a working project, the tree can be collapsed so that only the currently selected project and its sub-folders and sub-projects folders are shown.
5.4.2 Tree Structure

Within the database, files are organized in a virtual structure of project and regular folders. This structure is shown as a tree in the Servers and Folders panel.

![Server Structure Diagram]

In this panel, all connected servers are shown as root entries. These entries show the name of the Graphic Hub Server, the Graphic Hub Naming Service the server is registered on, and the current user name.

The level below the root entry contains the data project, which other clients refer to. New projects or regular folders/files can be added under the data project.

**Tip:** It is possible to create folders on the same hierarchy level as data, but these folders are not accessible from client applications such as Viz Artist. In these folders, it is practical to move data that should not be worked on anymore, yet is not ready to be deleted.

The data directory holds folders that the server files are stored in.

To View the Content of a Folder

- Click the folder in the tree, or
- Double-click a subfolder in the Explorer, or
- Right-click the folder, and select Open.

The server files in the selected folder are then shown in the Explorer.

5.4.3 Working with Folders

To Expand Folders

After logging in, the branch representing this database is collapsed. To expand the branches, use one of the following options:

- Click to the left of the branch.
- Double-click the branch to be expanded.
- Right-click the required branch and select Expand.
· **Right-click** the required branch and select **Expand Completely** to expand the branch and all its subbranches.

### To Collapse Folders

· Use one of the following options:
  · **Click** to the left of the branch.
  · **Double-click** the branch to be collapsed.
  · **Right-click** the required branch and select **Collapse**.
  · **Right-click** the required branch and select **Collapse Completely** to collapse the branch and all its subbranches.

### To Create a New Folder

Use to create new Regular or Project Folders.

⚠️ **Note:** A new project folder cannot be created in a regular folder.

1. **Right-click** on a folder, or select the folder and right-click in the **Explorer**.
2. Select **New > Project** or **Folder**.

### To Rename a Folder

· **Right-click** the folder and select **Rename**.

⚠️ **Note:** The **data** project below the server root entry cannot be renamed. Folder names must be unique, and in compliance with the list of **illegal characters** below.

### To Move a Folder

1. Drag the folder from either the servers and folder or the **Explorer** onto the target destination. The **Action Log** for moving folders is shown.
2. Click **Duplicate**. You can also use standard Windows functions **CTRL + X**, **CTRL + V** and **Right-click > Cut/Paste**.

⚠️ **Note:** This procedure only applies to moving a folder within a single server. For information about moving folders between **multiple servers**, see **Schedule a Deploy Task**.

### To Change the Owner of a Folder

1. Right-click the folder.
2. Select **Set Owner**.

![Set owner of 'Project1'...](image)

- Owner to set: Admin
- Apply only to objects which aren't in other folders
- Apply to all subfolders and objects

Select the new owner from the drop down list.

4. Select the **Apply to all subfolders and objects** check box, if required.

5. Click **Set**.

   - The Action Log opens.

6. Click **Set owner**.

7. Click **Close**.

   - The owner of a folder can also be assigned from the folder **Properties** window.

### To Set Rights for a Folder

1. Right-click the folder.

2. Select **Set access**.

![Set access rights of 'Project1'...](image)

- User: The owner of the folder.
- Group: All the members of the group the owner belongs to.
- World: All database users.

3. Define the new rights.

4. Click **Set**.

   - The Action Log for changing the rights is shown.

5. Click **Set access**.

   - The rights for a folder can also be assigned from the folder **Properties** window.

### To Delete a Folder

1. Select the folder.

2. Delete the folder:
   - Press **Delete**, or right-click the folder and select **Delete**...
     - The Action Log opens.

3. Click **Delete**.
4. Click **Close**.

⚠️ **Note:** Only empty projects or folders can be deleted. Also, by deleting a folder from the Graphic Hub, the respective folder-links in the properties of the files are deleted too.

### 5.4.4 Folder Properties

The **Folder Properties** window lists available properties of each folder.

**To View the Properties of a Folder**

1. Right-click a folder.
2. Select **Properties**.

**To View the Properties of Multi-selected Folders**

1. Multi-select the required folders (1).
   - Right-click folders with **CTRL** pressed, or
   - Select a range of folders with right-click with **SHIFT** pressed
2. Right-click on one of the selected folders.
3. Select **Properties**.

   The **Properties** window shows the Generally combined contents of all selected folder (2) and is for information only.

**Add-ons** are not available.
General Properties

- **Name**: Shows the name of the folder. Folder names must comply with the list of Illegal Characters.
- **Type**: Shows if the folder is a regular folder or a project folder.
- **UUID**: Shows the automatically generated UUID of the folder.
- **Path**: Shows the path of the folder within the data directory of the database.
- **Name**: Shows the name of the folder. To rename the folder, type a new name in the box.
- **Owner**: Shows owner of the folder. To reassign the folder to a new user, select a user from the list.
- **Created**: Shows the date and time when the folder was created.
- **Expires**: Set an expiration date for the selected folder or file.
- **Contains**: Shows a summary of all folders and files contained in the selected folders.
- **Access Rights**: Shows the access rights for the folder. To change the rights, enable/disable one or more check boxes (see User and Group Management).
Add-Ons Properties

The following folder properties are available in the Add-ons panel:

- **Name**: Folder name.
- **Type**: Project or Regular Folder.
- **UUID**: Automatically generated UUID of the folder.
- **Text** tab: Assigned add-ons as text.
- **Edit** tab: Enables editing and assignment of add-ons.
- **XML** tab: Assigned add-ons as XML.
- **Search**: Search text within assigned add-ons.
5.4.5 Working with Files

Overwrite Files
When a file type is to be linked or duplicated in another folder, and the same file type with the same name already exists in the destination folder, the Overwrite Existing File dialog menu opens. Select an option from the window:

- **Yes**: Overwrites the existing file.
- **Yes to All**: Overwrites all existing files.
- **No**: Does not overwrite the existing file, and create a new file.
- **No to All**: Does not overwrite all existing files and create new files.
- **Cancel**: Cancels the action.

To Create Linked Files
A link to the file is created in the destination folder.
Linked files have the benefit of saving disk space and enhancing system performance. It is especially useful when a file is referenced in many places. For example, a station logo is best to be referenced as a link rather than duplicated in many locations.

1. Select the required file.

   **Note**: Multiple files can be selected.

2. Drag the file to the target folder and release.
3. In the Action Log click **Link**.

4. If the same file type, with the same name, already exists in the destination folder select to overwrite, or not overwrite, the existing file.
5. Click **Close**.
   or
1. Select the required file.

   ![Note: Multiple files can be selected.]

2. Create a linked shortcut:
   - Right-click and select **Link (create shortcut)**, or
   - Press **CTRL + Y**.
3. Select the target folder.
4. Link the file:
   - Right-click on the target folder and select **Link here**, or
   - Right-click in the folder area and select **Paste**
5. In the **Action Log** click **Link**.
6. If the same file type with the same name already exists in the destination folder select to overwrite, or not overwrite, the existing file.
7. Click **Close**.

**To Create Duplicate Files**

1. Select the required file.

   ![Note: Multiple files can be selected.]

2. Press **CTRL** and drag the file to the target folder and release.
3. In the **Action Log** click **Duplicate**.

![Duplicate, Link or Move](image)

4. If the same file type, with the same name, already exists in the destination folder select to overwrite, or not overwrite, the existing file.
5. Click **Close**.
   or
1. Select the required file(s).
2. Copy the selected file(s).
3. Select the target folder.
4. Duplicate the file:
   - Right-click on the target folder and select **Duplicate here**, or
   - Right-click in the folder area and select **Paste**.
5. In the Action Log click **Duplicate**.
6. If the same file type with the same name already exists in the destination folder select to overwrite, or not overwrite, the existing file.
7. Click **Close**.

To Create Duplicate Files Including Referenced Objects

1. Select the required files. Right-click and drag files to target servers folder.
2. Select **Copy here (DDC)**.
3. In the **Deploy Direct Copy** dialog after Analyzing and checking Behavior options, Click **Continue.**
4. Click **Deploy**.

5. The selected files are being deployed including all references.

**To Move Files**

If a the same file type, with the same name, exists in the destination folder, the moved file is set with a new name (for example: Yellow would be renamed Yellow(1)).

1. Select the required file(s).
2. Hold Shift and drag the selection to the target folder.
3. In the **Action Log** click **Move**.

4. Click **Close**.
   
   or

   1. Select the required file(s).
   2. Cut the selected file(s).
   3. Select the target folder.
   4. Move the file(s):
      - Right-click on the target folder and select **Move here**, or
      - Right-click in the folder area and select **Paste**.
   
   5. In the **Action Log** click **Move**.
   6. Click **Close**.
To Overwrite Files

A file can only be overwritten if it is in the same folder and of the same type.

1. Select the required file.
2. Drag the file to the file to be overwritten and release.

⚠️ **Note:** Source and target file must be of the same type.

3. In the Action Log click **Overwrite**.

4. Click **Close**.

To Re-save with Viz Executable

The menu action **Re-save with viz...** execution starts **viz.exe** (if not already running) and re-save the selected files through Viz Engine. Be sure to define a proper Viz executable path in Tools > Edit preferences > Viz > General.
Click Set..., Continue... and Re-save to initiate the `viz.exe` re-save.

![Image of Re-save with viz...]
### 5.4.6 File Properties

This section describes the available properties of each file.

#### To View the Properties Assigned to a File

- Double-click a file in the Explorer, or
- Right-click a file and select Properties.

#### General Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Image4</td>
</tr>
<tr>
<td>Type</td>
<td>IMAGE</td>
</tr>
<tr>
<td>UUID</td>
<td>52F7A84E-FCC0-4ACF-8A174C7E03350C1F</td>
</tr>
<tr>
<td>Original name</td>
<td>Image4</td>
</tr>
<tr>
<td>Owner</td>
<td>Guest</td>
</tr>
<tr>
<td>Checked out by</td>
<td></td>
</tr>
<tr>
<td>Locked by</td>
<td></td>
</tr>
<tr>
<td>Size</td>
<td>53.27 KB (64,796 bytes)</td>
</tr>
<tr>
<td>Created</td>
<td>Wednesday, September 07, 2016 4:06:03 PM</td>
</tr>
<tr>
<td>Modified</td>
<td>Wednesday, September 07, 2016 4:06:03 PM</td>
</tr>
<tr>
<td>Modified by</td>
<td>Guest</td>
</tr>
<tr>
<td>Expires</td>
<td>Never</td>
</tr>
<tr>
<td>Folder links</td>
<td>1</td>
</tr>
<tr>
<td>Link name</td>
<td>Image4</td>
</tr>
<tr>
<td>User rights</td>
<td>Read, Write</td>
</tr>
<tr>
<td>Group rights</td>
<td>Read, Write</td>
</tr>
<tr>
<td>World rights</td>
<td>Read, Write</td>
</tr>
</tbody>
</table>

- **Name:** Shows the name of the file. File names must comply with the list of Illegal Characters.
- **Type:** Shows the file type, for example material.
- **UUID:** Shows the UUID of the file.
- **Original name:** Shows the name of the file. To rename the file, type a new name in the box. If changing the name of a file that has more than one folder-link, only the name of this link is altered. In other folders, the name is not changed.

- **Owner:** Shows the name of the user that owns the file. To reassign the file to a new user, select a user from the list.

- **Checked out by:** If the file is checked out, shows the name of the user that has checked it out. To check out the file, click the Check Out button. To check in the file, click the Check In button.

- **Locked by:** If the file is session locked, shows the name of the user that is working on it. To session lock the file, click the Lock button. To unlock the file, click the Unlock button.

- **Size:** Shows the size of the file.

- **Created:** Shows the date and time when the file was created.

- **Modified:** Shows the date and time when the file was modified the last time.

- **Modified by:** Shows the name of the user that modified the file the last time.

- **Expires:** Set a date for the select file to expire.

- **Folder links:** Shows the number of folder-links (number of folders the file is placed in). The box below shows the paths to folders where the file is linked.

- **Link name:** Shows the name of the folder-link. By default, the folder-link name automatically equals the file name.

- **Access rights:** Shows the access rights for user, group, and world. User refers to the owner of the file, group refers to all the members of the group the owner belongs to, and world refers to all database users.

---

**Keyword Properties**

<table>
<thead>
<tr>
<th>Name</th>
<th>Image4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>IMAGE</td>
</tr>
<tr>
<td>UUID</td>
<td>52F7A84E-FCC0-4ACF-9A174C7E0335D0C0F</td>
</tr>
</tbody>
</table>

**Assignable keywords:**

- **Name:** Shows the name of the file.
- **Type**: Shows the file type, for example material.
- **UUID**: Shows the UUID of the file.

There is a search field for locating keywords and you can assign and remove keywords from the selected file.

### References and Link Properties

<table>
<thead>
<tr>
<th>References and links</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name: Image4</td>
</tr>
<tr>
<td>Type: IMAGE</td>
</tr>
<tr>
<td>UUID: 52F7A84E-F0C0-4ACF-9A174C7E03350C0F</td>
</tr>
</tbody>
</table>

- **Name**: Shows the name of the file.
- **Type**: Shows the file type, for example material.
- **UUID**: Shows the UUID of the file.
- **References**: Shows the files which are contained in the current file. For example, if you check the references for a scene, you see images, geometries, etc., that are used in this scene. Drilling down, the references of the images show the images used in that file. And so on.
- **File links**: Shows the files where the current file is referenced. For example, with an image used in different scenes, all those scenes appear as file links.
- **Folder links**: Shows all folders where the same file is linked (all shortcuts).

### Duplicates

<table>
<thead>
<tr>
<th>Duplicates</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name: Image4</td>
</tr>
<tr>
<td>Type: IMAGE</td>
</tr>
<tr>
<td>UUID: 52F7A84E-F0C0-4ACF-9A174C7E03350C0F</td>
</tr>
</tbody>
</table>

- **Name**: The name of the selected item.
- **Type**: Shows the item type, for example, **BASE_FONT**.
- **UUID**: Shows the item’s UUID.
Total Size Properties

- **Name**: Shows the name of the file.
- **Type**: Shows the file type, for example material.
- **UUID**: Shows the UUID of the file.
- **Filters**
  - **View by Reference** or **View by Size**.
  - **Sort by Name, Size, Type and Name, Type and Size**.

The file's total size in KB, MB or GB is shown. Using the tree, you can see all the component parts and their respective sizes.
**Advanced Properties**

<table>
<thead>
<tr>
<th><strong>Name</strong></th>
<th>Image4</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>IMAGE</td>
</tr>
<tr>
<td><strong>UUID</strong></td>
<td>62F7A84E-FCC0-4ACF-8A174C7E0335D0F</td>
</tr>
<tr>
<td><strong>Checksum</strong></td>
<td>525E769A79F50F4</td>
</tr>
<tr>
<td><strong>Original file csum</strong></td>
<td>N/A</td>
</tr>
<tr>
<td><strong>Version</strong></td>
<td>viz=3.7.0.39276, DEL=2.0.1.39276, Windows 7=6.1.1.7501</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Units</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unit 1: 1 fragment with a size of 2.00 KB (2,043 bytes)</td>
<td></td>
</tr>
<tr>
<td>Unit 2: 1 fragment with a size of 2.00 KB (2,043 bytes)</td>
<td></td>
</tr>
<tr>
<td>Unit 3: 2 fragments with a total size of 58.99 KB (60,396 bytes)</td>
<td></td>
</tr>
<tr>
<td>Unit 4: 0 fragments with a total size of 0.00 KB (0 bytes)</td>
<td></td>
</tr>
<tr>
<td>Unit 5: 1 fragment with a size of 0.30 KB (304 bytes)</td>
<td></td>
</tr>
</tbody>
</table>

- **Name**: Shows the name of the file.
- **Type**: Shows the file type, for example material.
- **UUID**: Shows the UUID of the file.
- **Checksum**: A server-generated value to detect duplicates and differences between similar files. Useful for importing and replicating and deploying files; when two files are very similar, you can use the checksum to determine whether to overwrite or allow a parallel instance.
- **Original file csum**: The file’s original checksum from before it was imported to the Graphic Hub. This is used to determine if a specific file has already been imported, and to improve duplicates discovery.
- **Version**: Version is the last client application version that changed the file/wrote to the file. This should be the same as the last entry in the history.
- **Units**: The component units of a file. A file consists of multiple units that form part of the internal data. Used in troubleshooting.
- **Attributes**: Each unit has specific attributes describing it. Used in troubleshooting.
File History

- **Name**: Shows the name of the file.
- **Type**: Shows the file type, for example material.
- **UUID**: Shows the UUID of the file.
  
The file's transaction history is shown with columns for date, user, changes and serial number.

File Availability

If you are logged into multiple servers, you are able to check whether a file exists and is identical among instances.

- **Name**: Shows the name of the file.
- **Type**: Shows the file type, for example material.
- **UUID**: Shows the UUID of the file.
- **Modified at**: Displays last date and time modified.
- **Modified by**: Displays last user to modify the file.
- **Checksum**: Indicates whether the file is identical on every server.
- **Availability on other servers where logged in**: The availability of the same file on other servers where you are logged in. Even if the file name is different, if the UUID and checksum are the same, the file figures in this panel, shown as OK.

**File Add-ons**

<table>
<thead>
<tr>
<th>Add-Ons</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name: Image4</td>
</tr>
<tr>
<td>Type: IMAGE</td>
</tr>
<tr>
<td>UUID: 52F7A84E-FCC0-4ACF-8A174C7E0335DC0F</td>
</tr>
</tbody>
</table>

- **Name**: Shows the name of the file.
- **Type**: Shows the file type, for example material.
- **UUID**: Shows the UUID of the file.
- **Text tab**: Assigns add-ons as text.
- **Edit tab**: Enables editing and assignment of add-ons.
- **XML tab**: Assigns add-ons as XML.
- **Search**: Searches text within assigned add-ons.

### 5.4.7 Folder and File Expiration Dates

Each folder (and its contents) and files can be set an expiration date.

When a Clean-up of Expired items Scheduled Tasks is performed, folders and files with an expiration date on or before the date configured in the task are deleted. The following exceptions apply:

**Note**: Folders are deleted recursively.
- If a folder, which has expiration date before a due Clean-up operation, contains a folder or files that have an expiration date set after a due Clean-up operation, it is ignored in the delete operation. The expired folder is not deleted, although it is expired.
- The deletion of a folder only happens when all folder contents, and any linked content, have reached their expiration date.
- Any files and folders, in an expired folder, that do not have a set expiration date get deleted.
- An expired folder or files, with file links, can only be deleted if all linked files are inside the expired folder.

**Example:** If a scene, which includes an image that is inside of an expired folder, is not included in the expired directory, the image cannot be deleted because it has file links to the scene which has not expired.

After a clean-up task has completed, a log file is created: `%ProgramData%\Vizrt\Viz GH Terminal\CleanupExpired.log`. The log file contains:

- Timestamp for when the task was performed.
- Expired items that were found.
- Number of deleted items (folders/projects/file links).
- Duration of cleanup operation.
- Number of physically deleted files grouped by file type.
- List of errors that occurred during the cleanup operation.
- List of UUIDs that got physically deleted by file type. If an expiration date is removed before running the Cleanup of Expired Items task, the folder and its contents, or files, are not deleted.

**To Set an Expiration Date**

1. Right-click the folder or file.
2. Select **Properties**...
3. Check the **Expires** box.

4. Click on the drop-down arrow and set an expiration date and time.

   ![Note: Click the drop-down or highlight a date number and change it, to set the date. Click on the hour or minutes to change the time.]

5. **Click OK.**

5.4.8 **Illegal Characters**

The following list of characters are not allowed in folder or file names:

- Colon (:)  
- Semicolon (;)  
- Period (.)  
- Comma (,)  
- Question mark (?)  
- Asterisk (*)
1. Quotation marks: (" ")
2. Angle brackets: (< >)
3. Braces: ({{ }})
4. Tab key escape character: (\t)
5. Newline key escape character: (\n)
6. Blank space: ( )

See Also
- Graphic Hub Manager Customization
- User and Group Management

5.5 Graphic Hub Login And Log Out

To log in or logout from a Graphic Hub Server the Graphic Hub Manager must be running. Before the Graphic Hub Manager is started make sure that the a Graphic Hub is started first (see Graphic Hub Startup).

This page contains information on the following topics:

- Single Server Login Start Up
- Multiple Server Login Start-up
- Replication Server Login
- Auto Login
- Logout

5.5.1 Single Server Login Start Up

When the Graphic Hub Manager starts up a User Login window opens. Use this to log on to a single server.

⚠️ Note: For start up with a single server login, Auto Login must be disabled. If Auto Login is enabled, the start up login window is for Multiple Server Login Start-up.

Once the Graphic Hub Manager has started, more servers can be logged on to.

To Start the Graphic Hub Manager with a Single Server Login

1. Open the Graphic Hub Manager:
   - Click Start > All Programs > Vizrt > Graphic Hub > Graphic Hub Manager > Graphic Hub Manager, or
2. From the **Host** drop down box, select the host name of the machine where the Naming Service is running.

   - **Note:** Available Graphic Hub servers are shown in white. Unavailable Graphic Hub servers (available servers on a different sub-net), which are configured for auto-login, are shown in yellow.

3. If the Naming Service host is configured for more than one Graphic Hub server, select the server to connect to from the **Hub** drop down box.

4. If Auto Login is required, check the **Enable for Auto login** check box.

5. From the **Name** drop down box, select a user from the list of users registered in the database, on the selected server.

6. In the **Password** field, enter the correct password.

   - **Note:** The default password for administrators is **VizDb**.

7. Click **LOGIN**.

   

**To Login to More Servers**

After the Graphic Hub Manager Start Up, login to more servers, if required.

   - Click **Server > Login**...

**5.5.2 Multiple Server Login Start-up**

When the Graphic Hub Manager starts up a User Login window opens. Use this to login to a single server or multiple servers.
When there are several Graphic Hub servers configured in the Graphic Hub Manager, it is possible to login to:

- A single Graphic Hub Server, or
- Several Graphic Hub Servers at the same time.

If there are Login Profiles defined, select a profile to have a defined subset of servers and Deploy Agents to login to.

To Start Graphic Hub Manager with a Multiple Server Login

1. Open the Graphic Hub Manager:
   - Click Start > All Programs > Vizrt > Graphic Hub > Graphic Hub Manager > Graphic Hub Manager, or
   - Double-click the Graphic Hub Manager desktop icon.

2. Select the servers to log on to, or check the Use Login profile box and select a login profile.
3. Click Login.

To Login to More Servers

- Click Server > Login > to one server... or to multiple servers...
5.5.3 Replication Server Login

When logged to the Replication server, the administrator has rights to login to the Main server in the Cluster and to change the content of the host.

This is helpful to manually deal with synchronization issues in a Main/Replication server (Cluster). But this can also create risks for synchronization between the servers in a Cluster.

⚠️ Caution: To avoid unwanted synchronization errors, leave the As system administrator check box unchecked. Login as system administrator only when absolutely necessary.

To Start Graphic Hub Manager in a Cluster on a Replication Server

1. Open the Graphic Hub Manager:
   - Click Start > All Programs > Vizrt > Graphic Hub > Graphic Hub Manager > Graphic Hub Manager, or
   - Double-click the Graphic Hub Manager desktop icon

2. In the Host drop down box, select the host name of the machine where the server or Naming Service is up and running.
3. In the Hub drop down box, select the name of the running server.
4. In the Name drop down box, select your user from the list of users registered in the database on the selected server.
5. Enter the password in the Password field.

⚠️ Note: The default password for administrators is VizDb.

6. To log in as system administrator, check the As system administrator check box.

⚠️ IMPORTANT! Use this feature sparingly and with caution.

7. If Auto Login is required, check the Enable for Auto login check box.
8. Click **Login**.

### 5.5.4 Auto Login

Auto login allows an automatic login to one or more Graphic Hubs, with the option of bypassing the credentials, as well as requiring a password for each and every server in the network. A global password can be set for all registered servers as well.

**To Enable Auto Login**

1. Click **Server > Login**.
2. Click **Preferences...** in the main Login window.
3. Click the **Use Auto login** box in the Login panel of the **Preferences** window that opens.

4. To set a global password, select the **Protect Auto login with password** box, and click the **Set password** button. In the dialog box that opens, enter a password, and then click the **OK** button.

5. Alternatively, with no global password set, select the **Confirm Auto login** box, and then select the servers to include in the auto-login process. When logging in, you are prompted to confirm each server to be logged into. To remove a server from the auto login process,
right-click the server, and then from the list that appears, select **Remove selected**.

6. Click the **OK** button.

**To Disable Auto Login**

1. Click **Server > Login > to one server...**
2. Open the Login preferences window: Click **Tools > Edit Preferences...**

![Login Preferences Window](image)

**Note:** The Login preferences window can also be opened in the main Login window. Click **Preferences...**
3. Clear the **Use Auto login** box (1), in the Login panel of the **Preferences** window that opens.
4. Click **OK**.

### 5.5.5 Logout

This section describes how to logout of one or all servers from Graphic Hub Manager.

**Note:** Click **Server > Exit**, to logout of all servers and exit Graphic Hub Manager at the same time.

#### To Logout of One Server

1. Open the logout window:
   - Click **Server > Logout > from one server**... or
   - Press **F8**, or
   - Press **CTRL + O**.

2. Select the server from the drop down box.
3. Click **OK**.

#### To Logout of All Servers

If **Enable Logout from all servers** is configured under **Tools > Edit preferences > Login**:
1. Click **Server > Logout > from all servers...**

   ![Logout Confirmation Dialog]

   Are you sure you want to logout from all servers?

   ![Yes or No Buttons]

2. Click **Yes**.

5.6 Add-Ons Panel

The add-ons panel shows the following properties for all published Add-ons.

![Add-Ons Panel]

In the Text Tab, you can search for text within published add-ons. This search facility includes matching case and whole words. Text found is highlighted.
From the Edit Tab, you can assign, unassign and edit published add-ons for currently selected and multiple files.
In the XML tab, you can search for text within published add-ons. This search facility includes matching case and whole words. Text found is highlighted.

5.7 Journal Panel

From the Journal panel it is possible to search for journal entries and view their details. Journal entries are log files created according to various alert levels.

The Journal is a good place to start for troubleshooting problems encountered in Graphic Hub. The Journal records all server activities. When faced with troubleshooting scenarios, the journal is a good place to search for clues. The activities logged in the journal are the creation, modification
and deletion of objects in Viz Artist, as well as other information messages, warnings, errors and deploy task information.

This page contains the following topics:

- Journal Tool Bar
- Search the Journal
  - To View the Journal
  - To Search the Journal with Filter Settings
  - To View a Live Feed of Server Activities
- Automatic Journal Backup
  - To Schedule Automatic Journal Backup
- Export and Import of Journal Entries
  - To Export Selected Journal Entries
  - To Import Journal Entries

5.7.1 Journal Tool Bar

The Journal tool bar (1) has these options:

- **Search**: Search for journal entries based on the preferences defined in the Journal Filter frame
- **Optimize search for faster export**: If enabled, backup files with a large number of journal entries are optimized for export, by not containing all available information about these entries
- **Import journal entries**: Opens a dialog box, from where it is possible to select an XML journal backup file to import
- **Export selected entries**: Allows you to export only the entries that you choose
- **Backup task**: Opens the Configure Journal Backup Task window
- **Switch to feed mode**: Allows you to receive journal updates in real time
- **Show/hide entry properties**: Shows/hides the Journal Properties frame
- **Show filter**: Shows/hides the Journal Filter frame
5.7.2 Search the Journal

To View the Journal

- Click Server > Administer journal entries.

To Search the Journal with Filter Settings

1. Open the Journal panel.
2. In the Journal filter, from the Server drop down box, select a server.
3. Select an application. Your options are:
   - Any: Searches System and GH Deploy.
   - System: Graphic Hub Server. Any work done on Graphic Hub is logged in the system.
   - GH Deploy: All Graphic Hub Deploy Agent tasks, successful or failed, plus warnings and other pertinent information, are logged in the journal.
4. Optionally, enter a UUID of a folder or file.

⚠️ Note: Adding a UUID to the search criteria may provide hints toward finding and resolving corrupted files.

5. From the Date drop down box, select one of the following options:
   - Anytime
   - From: Selecting this option prompts you to also enter a beginning date and time
   - Until: Selecting this option prompts you to also enter an ending date and time
   - Between: Selecting this option prompts you to also enter a beginning and ending date and time
6. In the Details Like field, enter free text like name of the task, name of the agent, or any description that may figure in the task.
7. In the Details Unlike field, enter free text like name of the task, name of the agent, or any description that you want to exclude from the task search.
8. Check the Alerts check box if you wish to filter by selected alerts. There are various Action Logs, information messages, warnings and errors to choose from.
9. Optionally, click Optimize Search (2) for Faster Export button.
10. In the Journal, click the **Search** (1) button.

![Journal search](image)

The search results are shown in the panel below. When one is selected, the details are shown in the panel to the right.

**To View a Live Feed of Server Activities**

2. In the Journal tool bar, click the Feed button (1).

![Journal feed](image)

The journal is updated in real time.
- **Green:** New journal entries.
- **Yellow:** Warnings.
- **Red:** Errors.

Only the **Level** and **Subject** columns are colored in red or yellow when there are warnings and errors to report.

### 5.7.3 Automatic Journal Backup

To automatically backup all Journal entries, **Enable journal backup** must be enabled in Journal/Logging Settings.

**IMPORTANT!** Once an automatic backup task has completed, all journal entries are deleted.

**To Schedule Automatic Journal Backup**

1. Open the Journal panel: Click **Server > Administer journal entries**.
2. Click the backup task (1) button.

3. Set the **Start time**.

   ![Journal backup task configuration](image)

   **Tip:** Click the drop-down or highlight a date number and change it, to set the date. Click on the hour or minutes to change the time.

4. Set a frequency **Interval**.

5. In the Graphic Hub Terminal, check that **Enable journal backup** is enabled under **Options > Journal/Logging settings**. This option is enabled by default.

6. Click **OK**.

5.7.4 Export and Import of Journal Entries

With the export of journal entries select one, or as many as required, entries to be exported. Exported journal entries can be imported by other users for help with troubleshooting.

To Export Selected Journal Entries

2. In the journal, select the entries to be exported.

![](image)

**Tip:** Press CTRL + A to select all entries.

3. Export the selected entries by clicking the export button ![export](image), or by right-clicking the selection and select **Export Selected**.

**Note:** From the context menu, **Export and Delete Selected** can also be selected. This frees up disk space and increase performance.

4. Select a location, optionally enter a file name.
5. Click **Save**.

**To Import Journal Entries**

1. Open the Journal panel: Click **Server > Administer journal entries**.
2. Click the **Import Journal Entries** button.

3. Select the required file.
4. Click **Open**. The file is loaded into the journal.

5.8 Alerts

Email can be sent about specific types of Journal entries. This section details how to define email notifications that should be sent when errors occur in the system. To send email, email must first be enabled in the Graphic Hub Terminal. Then use the Graphic Hub Manager to configure which and when messages are to be sent. Configured alert settings can also be exported and imported.

5.8.1 Server Alerts

The Graphic Hub Server issues alert messages in the following scenarios:

- GH needs administrative attention.
- License errors or expiration.
- Low memory.
- Low disk space.

Refer to **Monitor Servers** for details on how to monitor such situations.

5.8.2 To Configure Send E-mail

1. Open the Alerts panel: Click **Server > Configure alerts...** or **SHIFT + CTRL + F7**.
2. Select one or more subjects to receive e-mails from.
3. Click **Configure**.
4. Edit the **Subject** and **Description** fields as required.
5. From the drop down box in the lower-right corner, enter or select the address or addresses to which the e-mail alerts are to be sent.
6. At the bottom left, if you wish to override the default, enter an interval in minutes or select a predefined interval from the drop down box. Data is collected and messages are sent at this frequency.
8. **Click OK.** Messages to be sent appear in the Alerts window.

5.8.3 **Importing and Exporting Alert Settings**

E-mail alert settings can be imported or exported in the Alerts window. To import previously configured settings, click the **Import** button or the keyboard shortcut **F6**. To export such settings, select the settings to be exported from the list in the Alert window, and click the **Export** button or **F7**.

See Also

- Email Configuration Options in Graphic Hub Terminal.

5.9 **Archives Panel**

This section contains details about the archive panel of the Graphic Hub Manager. In the Archives Panel, archives can be imported and exported with drag and drop. It also offers other functionality:

- An archive search function.
- View the contents of an archive.
- Import single files from an archive.
- View archive details.

In the Tool bar click on **View > Archives** to open the Archive panel.
The Archives panel consists of:

- **Archives View (1):** Shows archives in folders (User selected (see Graphic Hub Manager Customization)).
- **Search View (2):** Search in all or selected archives.
- **Archive Contents View (3):** Shows the content of the selected archive.
- **Archive Details View (4):** Shows the details of a selected archive.

Go to Graphic Hub Archives for detailed information about:
- Archives View
- Search View
- Contents View
- Details View
- Archive Folders
- Import Archives
- Export Archives
- Import Viz 2.x Data and Archives

## 5.10 Action Log

The Action Log is automatically activated when certain operations are done in the Graphic Hub Manager, for example, the duplication and /deletion of files and folders, or when user rights are modified.
The action to be done is shown in the window title, and an icon which symbolizes the action shows below the file list. For example, a trash can icon is used if files or folders should be deleted.

This page contains information on the following topic and procedures:

- Action Log Parameters
- To Add Additional Files
- To Action the Operation

### 5.10.1 Action Log Parameters

- **Close this window automatically if no problem occurred**: If enabled, the Action Log is closed when the required operation finishes successfully.
- **Reuse this window for same actions**: By dragging files or projects/folder onto the Action Log, the action is also performed on these elements.
- **Do not insert entries that are already in the list**: Prevents the addition of duplicate entries.

**Note**: This option is only available if Reuse this Window for Same Actions is enabled.

- **Warn me about not inserted**: Enable to notify when duplicate entries have been detected.

**Note**: This option is only available if both Reuse this Window for same Actions and Do not Insert Entries that are Already in the List are enabled.

### 5.10.2 To Add Additional Files

Add additional files that the same action should be completed on. Drag files from the Explorer or the search results onto the list of elements in the Action Log.
5.10.3 To Action the Operation

1. Add the required to the Action Log.
2. Click the button corresponding to the operation that should be done. When the operation has completed, the Action Log provides feedback. If the operation has been successful, a check mark, is shown to the left of the file name. If the operation has failed, an X shows. Status information in text form is also shown in the Info column.

<table>
<thead>
<tr>
<th>File</th>
<th>Path</th>
<th>Info</th>
</tr>
</thead>
<tbody>
<tr>
<td>✔ Image(1)</td>
<td>data\Project1</td>
<td>File deleted successfully</td>
</tr>
</tbody>
</table>

5.11 Graphic Hub License

This section details how to apply a new Sentinel Hardlock Dongle license. A new license can also be applied in the Graphic Hub Terminal.

For some Graphic Hub modes a license is required. A license is normally acquired when the product is purchased. To get additional or updated licenses contact your local Vizrt representative.

⚠️ **Note:** To apply a license using the WIBU licensing system, please consult the Vizrt Licensing Guide in the Vizrt documentation center.

5.11.1 To Apply a License

Use this procedure to apply a first time license, apply a new license after a license expiry, or apply a new license before a license expires.
1. Log into a server in Graphic Hub Manager.
2. From the main menu, click **Info > License info**...

   ![License info for server 'VizDbServer@GHSERVER'](image)

   **License info for server 'VizDbServer@GHSERVER'**

   - **Server**: VizDbServer@GHSERVER (Admin)
   - **License details**:
     - Serial Number: 3c130b4b1ecf4c3
     - Key Number: 4
     - Product expiry date: 3/2/2017
     - Feature expiry date: 3/2/2017
     - Features:
       - User Management: Expriy date: 3/2/2017
   - **License string**: [enter the new license string for the connected Sentinel Hardlock Dongle]
     - Click **Set**

3. In **License string** enter the new license string for the connected Sentinel Hardlock Dongle.
4. Click **Set**.

---

### 5.12 Graphic Hub Manager Customization

The GUI has two default layouts but it can be customized with different layouts in the workspace. In addition to the Layouts function, the look and feel of the Graphic Hub interface can also be customized. The Graphic Hub GUI has several options to modify its look and feel. In the **Look** panel of the system **Preferences** change the overall look from the drop down list. Also the color of the text for a selected server can be modified as required.

This page contains the following topics:

- **Default Layouts**
  - System-Clean (locked)
  - System-Default
  - Locked/Not Locked Layouts
- **Layout Maintenance**
  - To View the Layout Maintenance Window
  - Layouts Maintenance Properties
- **Layout Procedures**
  - To Save a Layout
  - To Save a New Layout
  - To Load a Layout
  - To Drag and Drop Layout Panels
  - To Load a New Look
  - To Change the Color of a Server Text
- **Import and Export Custom Settings**
  - To Export Local Graphic Hub Manager Settings

---

*Graphic Hub Administrator Guide - 3.6*

Copyright © 2021 Vizrt
To Import Local Graphic Hub Manager Settings

5.12.1 Default Layouts

System–Clean (locked)

The System Clean layout is always identical to the presented layout when the Graphic Hub Manager is opened after a fresh install.

System–Default

System-Default is the default layout if a User does not create or save layouts. This layout is, by default, not locked, which means, that if a User opens the archives pane and then close the Graphic Hub Manager then on next startup the archives pane is shown.

Locked/Not Locked Layouts

Each layout can be set to locked or unlocked:

- **Not locked:** When the Graphic Hub Manager is closed the last used layout is stored and when the Graphic Hub Manager is started this last stored layout is used.
- **Locked:** If a User modifies a locked layout, the layout must be saved or the modifications are not saved.
5.12.2 Layout Maintenance

To View the Layout Maintenance Window

Layouts Maintenance Properties

- Load selected layout: Opens the selected layout.
• **Save selected layout as...**: Create a new layout from the selected layout.
• **Lock/Unlock selected layout**: See Locked/Not Locked Layouts (not available for System-Clean).
• **Remove selected layout**: Delete the layout (not available for System-Clean and System-Default).
• **Initialize selected layout**: Set the selected layout to the same layout as System-Clean (not available for System-Clean).

### 5.12.3 Layout Procedures

#### To Save a Layout
- Click **View > Layouts > Save current layout < layout name >**, or
- Click the **Save** button in the Layout bar

#### To Save a New Layout
1. Open the **Save as** window:
   - Click **View > Layouts > Save current layout < layout name > as...**, or
   - Click the **Save as** button in the Layout bar

![Save current layout ‘System-Clean’ as]

2. Type a new layout name.

![Tip: Also save a new layout to an existing layout, if required. Existing layouts are listed in the drop down menu.]

3. Tick the **Save it as locked** box, if required.
4. Click **Save**.

#### To Load a Layout
- Click **View > Layouts > Load layout > <layout name>**, or
- In the Tool Bar, click the **Layout** button and select a previously saved layout.

#### To Drag and Drop Layout Panels
1. Click and hold the title bar of the element to be moved.
2. Drag and drop the panel in a new position. Options are:
• Drag the panel to a symbol which shows possible target positions. When a valid place is reached, that area is highlighted:
Drag the panel to the title bar of another panel. When a valid place is reached, that area is highlighted:

⚠️ **Note:** When a series of elements are docked together, they show as tabs.
Drag to white space. When released the panel becomes a floating panel:

To Load a New Look
1. Click **Tools > Edit Preferences > Look**.

2. Select a visual style from the drop-down.
3. If colored tabs are required, tick the **Docking Tab Colors** box.
4. Click **Apply** or **OK**.

To Change the Color of a Server Text
Change the color of the text for the selected server, in the Server Tree.

**Tip:** A right-click on a server in the **Servers and Folders** also opens the Color window - go to step 3.
1. **Click** Tools > Edit Preferences > Login.

   ![Image showing the preferences window]

   **En/Disable server for Auto login and change Auto login order:**

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>User</th>
<th>SysA</th>
</tr>
</thead>
<tbody>
<tr>
<td>VizDataServer@GHSERVER</td>
<td>Standard</td>
<td>Admin</td>
<td>No</td>
</tr>
<tr>
<td>GHMainServer@GH-MAIN</td>
<td>Main</td>
<td>Admin</td>
<td>No</td>
</tr>
<tr>
<td>GHApplications@SLIDER</td>
<td>Standard</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

   ![Image showing the color picker]

   **Remove selected Del**
   **Remove all Shift+Ctrl+A**
   **Move to top Ctrl+1**
   **Move up Ctrl+2**
   **Move down Ctrl+3**
   **Move to bottom Ctrl+4**

   ![Image showing the text color in explorer]

   **Text color in explorer... Shift+Ctrl+C**

   ![Image showing the up and down buttons]

   **Up**
   **Top**
   **Down**
   **Bot**

   **Note:** Use buttons to the left to change Auto login order. L menu in the list of servers for more options!

2. **Right-click a server and select** Text color in Explorer...
3. **Select a color** (Standard or Custom) from the color picker.
4. **Click OK.**

5. **In the Preferences window, click** Apply or OK.

   ![Warning note]

   **Note:** All folders and files in the Server show the selected text color in the Graphic Hub GUI.

---

### 5.12.4 Import and Export Custom Settings

All workstation-based customizations to the Graphic Hub Manager, such as changes to any of the panels, column layout and visibility, as well as the user interface in general can be exported (and subsequently re-imported on another machine).
To Export Local Graphic Hub Manager Settings

1. Click **Tools > Export settings (incl. layouts) to file**.
2. Select a file name and location, and click **Save**.

⚠️ **Note:** The settings are saved with a file extension of `.vghms`.

To Import Local Graphic Hub Manager Settings

1. Click **Tools > Import settings (incl. layouts) from file**.
2. Select a settings file with the `.vghms` extension, and click **Open**.

5.13 Enable A Graphic Hub For A Virtual Studio

The XML necessary to support a virtual set environment is generally obtained from Vizrt Support. The following procedure indicates how to import or export such an XML file.

5.13.1 To Import or Export a Virtual Studio Settings File

1. From the main menu, select **Extra > Viz VR Studio Setup**. The Viz VR Studio Setup window opens.
2. On the tool bar, click the **Import** or **Export** button.
3. Select the XML file and click **Open** or **Save**.
6 Graphic Hub REST

The Graphic Hub REST is a web-service for Graphic Hub. It is an interface to retrieve and send data to and from Graphic Hub via HTTP requests. The Graphic Hub REST configuration page is loaded automatically after installation:

![Graphic Hub REST configuration](image)

**Tip:** The configuration page can be opened manually by navigating a browser to `http://127.0.0.1:19398/config.html`.

Select the Graphic Hub the REST service should connect to from the drop-down list, and click **Apply**. This opens an authentication window:
In the **GH username** and **GH password** fields, enter a user name and password for the Graphic Hub, then click **OK**.

![Authentication required](image)

Tip: User names and passwords are case sensitive.

A popup window appears, informing about the successful configuration of the Graphic Hub REST service:

![Success](image)

Click **OK**. This opens the REST status page:
The GH REST Configuration Settings and Web Server Configuration Settings is accessible from this page. However, the default settings can in most cases be left unchanged.

The following topics are covered in this section:

- Graphic Hub REST API Documentation
- Web Server Configuration Settings
- Graphic Hub Failover Servers
- Change Graphic Hub Server
- Maintain Graphic Hub REST Bindings
- Report
- Failover/Load Balancing
- SSL in REST

6.1 Graphic Hub REST API Documentation

The Graphic Hub REST API documentation provides a programmer with the necessary information to use the Graphic Hub REST API. The API documentation can be accessed by selecting Viz GH REST API from the Help menu, or entering http://127.0.0.1:19398/doc/documentation.html in the web browser address bar.

6.1.1 GH REST Configuration Settings

To make changes to the default REST configuration settings, select Viz GH REST from the Configuration menu. Any changes made are highlighted by the parameter name changing color. Click Apply to apply any changes, or Back to go back to the main configuration page.

⚠️ Note: Any changes to the GH REST configuration do not take effect until the Graphic Hub REST service has been restarted.
**VIZ GH REST CONFIGURATION**

- **Request timeout (ms):** If the defined timeout is exceeded, the HTTP daemon disconnects the request. The default value is 120000.
- **Max. sessions per user:** Sets the maximum number of sessions per user connecting to the Graphic Hub. The default value is 10.
- **Default max search results:** Sets the default number of maximum search results. The default value is 20.
- **Max journals:** Sets the maximum number of buffered journals. By setting the value to 0, buffered journals are disabled. The default value is 500.
- **Max journals days:** Defines the maximum days to retrieve journals, subtracted from the current date. The minimum value is 1. The default value is 2.
- **Content size limit in MB:** Defines the upper limit of the amount of memory in MB the REST service can allocate for processing content. The default value is 200.

**Log Levels** Check the box to include the required logs:

- **Debug:** Prints and logs debug messages. Off by default.
- **Trace:** Prints and logs trace messages (needs trace enabled). Off by default.
- **Information:** Prints and logs informational messages. On by default.
- **Warning:** Prints and logs warnings messages. On by default.
- **Error:** Prints and logs error messages. On by default.
- **Critical:** Prints and logs critical messages. On by default.
- **ACE:** Prints and logs Viz GH Interface ACE messages. Off by default.

**VIZ GH REST IMAGE UPLOAD CONFIGURATION**
• **Max. used system Memory in %:** The maximum memory (as a percentage) VizGHRest allocates for processing parallel image and archive uploads.

• **Default compression:** Select the default compression for imported images: **AUTO**, **NONE**, **DXT1**, or **DXT5**. The default setting is **AUTO**.

• **Max. number of parallel uploads:** Maximal number of images that can be uploaded in parallel. If the value exceeds 12, a performance loss can occur.

**REVERSE PROXY SETTINGS**

• **Enable URL rewriting:** Rewrites URLs in responses with the configured protocol, host:port and base-path when enabled, where the requested URL contains the configured base-path. **Disabled** by default.

• **URL protocol:** Selects which protocol to use in responses where a requested URL contains the configured base-path. Valid values are **http** and **https**. The default value is **http**.

• **URL base-path:** Defines the URL base-path (prefix) to use in responses when the requested URL contains the configured base-path (as, for example, when requested from a proxy). When URL rewriting is enabled, this field cannot be empty. The path must be an absolute path, excluding protocol, host and port. The base-path cannot be ‘/’. The base-path format is /base-path/path.

> **Example:** /my-media-base-path/content

• **URL host:port:** Defines the URL host and port to use in responses when the requested URL contains the configured base-path (e.g. when requested from a proxy). If empty, host and port will be taken from the **HTTP Host** header.

### 6.2 Web Server Configuration Settings

This window is used to customize certain settings for the Graphic Hub REST service web server. Any changes made are highlighted by the parameter name changing color. Click **Apply** to apply any changes, or **Back** to go back to the main configuration page.
- **Port**: The port of the web server. The default value is **19398**.
  
  **Note**: Changing the port to 1 or 65535 causes the web user interface to cease functioning in Chrome, UC Browser, Opera and Firefox, as these browsers block requests on these ports.

- **Configuration directory**: The directory where the web server configuration files are located.
- **Upload directory**: Sets the directory where uploaded files are temporarily stored.
- **Document root**: The web server document root directory, where the html files reside.
- **Error log**: Set the location of the error log files for the web server.
- **Default index**: Set the default index file name for directory requests. The default value is `index.*`.
- **Local endpoint**: The local endpoint defines which IP address(es) the web server listens to. The default value is `0.0.0.0`, which means that it listens on all installed adapters.
- **Log directory**: The directory for Viz GH REST and web server log files.
- **Thread pool size**: Set the maximum simultaneous connections (threads) the web server can process.
- **Use keep-alive**: Enable or disable keep-alive header handling on the web server. This is enabled by default.
6.3 Graphic Hub Failover Servers

A Graphic Hub failover server can be added in addition to the currently connected Graphic Hub. Graphic Hub failover servers must have fully synchronized content with the currently configured Graphic Hub. Synchronizing the content between multiple Graphic Hubs can be achieved by using the Graphic Hub Deploy Agent.

To add a new failover server, click the Add failover server button, and enter the Naming Service, Server and Port details:

- **Naming Service**: Failover Graphic Hub Naming Service.
- **Server**: Failover Graphic Hub server
- **Port**: Failover Graphic Hub port.

**Note**: When activating SSL, the user is automatically redirected to the new site. When disabling SSL, automatic redirects are not possible due to requirements in the HTTPS protocol.

**Note**: Any changes to the web server configuration do not take effect until the Graphic Hub REST service has been restarted.
To remove a failover server from the list, select the trashcan icon. Click **Apply** to apply any changes, or **Back** to go back to the main configuration page.

### 6.3.1 Methods to Test Failover Servers

1. Perform a request to Graphic Hub REST, for example by navigating a browser to `http://127.0.0.1:19398/users/`.
2. Shut down the configured Graphic Hub.
3. Perform the same request to Graphic Hub REST again.

If the first failover server is configured correctly, the response (error code and content) should match.

### 6.4 Change Graphic Hub Server

You can change the binding between the Graphic Hub REST and Graphic Hub server.

1. Navigate to **Configuration > Change Graphic Hub server**.

![Change Graphic Hub server](image)

2. Select a Graphic Hub server from drop-down menu or enter the address manually in form of `VizDbServer@GHServer:19396` to bind to Graphic Hub server.

![Select Graphic Hub server](image)
3. Confirm with **Apply**.

![Graphic Hub server selection screen](image)

4. The server has been successfully changed and the binding to the previous server is removed.

![Success message](image)

6.5 Maintain Graphic Hub REST Bindings

Select Maintenance from the main menu to show information about the currently configured Graphic Hub connection, its bindings, and failover Graphic Hubs. Graphic Hub REST is automatically registered and the configuration is stored when connecting to a Graphic Hub for the first time.
The Graphic Hub REST to Graphic Hub bindings enable third party applications to discover the currently connected Graphic Hub REST servers on a Graphic Hub.

- **Protocol**: The protocol used to connect to the specified Graphic Hub REST.
- **Hostname**: The host name or IP address for the specified Graphic Hub REST.
- **Port**: The port of the specified Graphic Hub REST web server.
- **Service doc path**: The path where the service doc is configured on the specified Graphic Hub REST.
- **Service doc accept type**: Defines the http request headers accept type used to retrieve the service document on the configured service document path.

Click **Apply** to apply any changes, or **Back** to go back to the main configuration page. If Graphic Hub REST runs as a replication cluster (failover or load balanced), you must also change the configuration of the proxy.

Click the trashcan icon to remove a Graphic Hub REST binding from the list. Accidentally deleted Graphic Hub REST bindings can be re-applied by configuring the deleted Graphic Hub REST again.

### 6.6 Report

Use the **Report** menu to access the **Export** functionality of Graphic Hub REST. This feature creation and download of a system export file, as well as the possibility to view log files.
6.6.1 To Manage Reports

1. Click **Report**. The **Export** panel displays all previously created report exports, as well as the `error.log` and latest log files.
2. Click **Create** to generate a new export.

3. Select one or multiple exports, then click **Download** to download a .zip file containing information about REST settings and current configuration (or click **Delete** to remove all selected exports).

4. To view the desired file
   a. Click the Eye icon next to `error.log` or
Failover/Load Balancing

It is possible to configure Graphic Hub REST to support failover and load balancing. Graphic Hub REST is a standard HTTP server, so there is no need for integrated failover or load balancing logic. This requires setting up a failover and load balancing cluster. A network professional must configure a proxy and the DNS failover.
The proxy covers only the redundancy of Graphic Hub REST. It does not cover redundancy for Pilot or the Media Sequencer.

### 6.7.1 Important Notes

- Never call the configuration site through the proxy URL. Always use the direct server configuration URL instead.
- In a failover/load balancing proxy setup, *always* configure all Graphic Hub REST nodes to connect to the same Graphic Hub.
  - For very large installations *only*: Use multiple automatically synchronized Graphic Hubs to increase the performance of big Graphic Hub REST clusters. You achieve this by utilizing the Graphic Hub Deploy Agent.
- Do not run a proxy on the same server as any Graphic Hub REST node.
- Add all IP addresses to the proxy configuration on servers with multiple network adapters.
- Some API calls do not work with a cluster configuration or multiple Graphic Hubs in a cluster:
  - The REST resource monitoring and statistics do not work in a cluster.
  - The Graphic Hub statistics, journals, and sessions, do not work in a cluster with clustered Graphic Hub RESTs connected to multiple Graphic Hubs.
- The API documentation states proxy cluster compatibility information for every endpoint.

### 6.8 SSL In REST

SSL/TLS can be activated in GH REST by enabling **Use SSL HTTPS connection** in *Web Server Configuration Settings*. This encrypts connections to the REST interface using the HTTPS protocol. If the HTTPS page includes content retrieved through a regular HTTP connection, the connection is only partially encrypted. Most popular browsers block mixed content by default.

**Information:** The certificate, private key and password can be changed by modifying the current GH REST installation.

In the Web Server Configuration panel the SSL/TLS versions, to be supported by the server, can be chosen from the option list once the *Use SSL https connection* option is enabled.
6.8.1 SSL/TLS Configuration

To configure GH REST to support HTTPS (HTTP over SSL/TLS) connections the following information is needed:

- Certificate, Private Key and Password.
- Vizrt Viz GH REST SSL/TLS Configuration.
- Verification of New SSL/TLS Configuration.

Certificate, Private Key and Password

The certificate and private key files must be .pem filetype. The generation of those files is in the responsibility of the customer.

OpenSSL for Windows (Optional)

**IMPORTANT!** Self-signed certificates are highly discouraged for production because they are meant for testing purposes only.
Optionally, for testing purposes, OpenSSL for Windows can be utilized to create a self-signed Certificate Signing Request (CSR) which generates the certificate and private key files.

- OpenSSL for Windows can be downloaded and installed from [https://slproweb.com/products/Win32OpenSSL.html](https://slproweb.com/products/Win32OpenSSL.html):

  ![OpenSSL Installation](image.png)

- Using the command line the installation of OpenSSL can be verified using:

  openssl version

  ![Powershell Command](image.png)

- A self-signed CSR, combined with a password (which should not be forgotten), can be generated using:

  openssl req -x509 -newkey rsa:4096 -keyout server_key.pem -out server_cert.pem -days 365
The `newkey` option can also be `rsa:2048`.

- The file pair, of certificate and private key, can be found in the directory where the above command was executed:

```
The newkey option can also be rsa:2048.

- The file pair, of certificate and private key, can be found in the directory where the above command was executed:
```

How Graphic Hub REST looks in a browser with a self-signed certificate (left) compared to vizrt.com (right):
Your connection is not private

Attackers might be trying to steal your information from [URL] (for example, passwords, messages, or credit cards). Learn more

NET:ERR_CERT_AUTHORITY_INVALID

To get Chrome’s highest level of security, turn on enhanced protection

This server could not prove that it is [URL]; its security certificate is not trusted by your computer’s operating system. This may be caused by a misconfiguration or an attacker intercepting your connection.

Proceed to [URL] (unsafe)
An invalid self-signed certificate indication (left) compared to a valid one (right).
Vizrt Viz GH REST SSL/TLS Configuration

1. The certificate, private key and password can be changed in GH REST by modifying the installation:

   - In modern Windows versions, Settings > Apps > Vizrt Viz GH REST > Modify can be used.

   ![Modern Windows](image)

   - In older Windows versions, Control Panel > Programs and Features > Vizrt Viz GH REST > Change can be used.

   ![Older Windows](image)
2. In the *Change, repair or remove installation* phase click **Change**:

![Change, repair, or remove installation](image)

**Change**

Lets you change the way features are installed.

**Repair**

Repairs errors in the most recent installation by fixing missing and corrupt files, shortcuts, and registry entries.

**Remove**

Removes Vizrt Viz GH REST 2.5.2.30001 from your computer.

3. Click **Next** a few times to navigate the installation wizard to the *SSL Configuration* phase and place the file paths and password in the fields:

![Important: Files with limited accessibility (unprivileged or from network shares) may cause access issues in GH REST where the installer is unable to complete or start the server.](image)
4. Click **Next** a few times and then click **Change**: 

Click Change to begin the installation. Click Back to review or change any of your installation settings. Click Cancel to exit the wizard.
5. When the installer completes click **Next**, then **Finish**:

![Screenshot of the installer process](image)

Please wait while the Setup Wizard changes Vizrt Viz GH REST 2.5.2.30001.

**Status:** Starting services

---

**Verification of New SSL/TLS Configuration**

- The status of the new configuration can be tested using OpenSSL (for example, to test TLSv1.2):

  ```bash
  openssl s_client -connect localhost:19398 -tls1_2
  ```

![OpenSSL output](image)
As a verification, the specified protocol in the command is displayed in the output under **SSL-Session > Protocol**:

```
TLSv1.2, Cipher is AES256-GCM-SHA384
```

While the Graphic Hub REST interface can run with SSL/TLS encryption, **Graphic Hub Terminal** cannot. Because of this, the connection between them is considered mixed content and hence blocked. This may cause an **Unable to connect** error message:

---

### 6.8.2 GH Terminal

While the Graphic Hub REST interface can run with SSL/TLS encryption, **Graphic Hub Terminal** cannot. Because of this, the connection between them is considered mixed content and hence blocked. This may cause an **Unable to connect** error message:
This issue can be resolved by adding a security exemption. The steps to do this depend on the browser in use:

- **Google Chrome**
  - Click the shield icon in the right of the address bar, or
  - Start Chrome from the command line using the additional flag `--allow-running-insecure-content`.

- **Internet Explorer**
  - Scroll to the bottom of the screen and click Show all content.

- **Mozilla Firefox**
  - Click the shield icon to the left of the address bar.
  - Click the arrow next to the Connection is Not Secure warning, and select Disable protection for now.

For details on how to show mixed content in other browsers, please refer to the documentation for the browser in question.
7 Graphic Hub Terminal

Graphic Hub Terminal is the web based user interface used to configure, start, stop, or restart the Graphic Hub server and the Graphic Hub Naming Service. This chapter describes the Terminal’s user interface, and how to use the Graphic Hub Terminal to configure and run the Graphic Hub.

The Graphic Hub Terminal User Interface consists of:

- The **Menu Bar** (1):
  - Graphic Hub Modes
  - Backup and Restore
  - Reports
  - Options
  - Help and About

- The **System Status Panel** (2):
  - System Status Panel

- The **Event Log** (3):
  - Event Log Panel

The Menu Bar provides access to the configuration of the Graphic Hub server and Naming Service, backup and restore, reports, and settings. The icon on the left hand side of the menu lets the viewer know in a glance if both of, one of, or none of the Graphic Hub server and Naming Service are running:

- Both the Graphic Hub server and Naming Service are running.
- Only the Graphic Hub server is running.
- Only the Naming Service is running.
7.1 Graphic Hub Mode Configuration

The **Mode** menu is used to show information about the current configuration, create a new configuration, or revert to a previous configuration. As the Graphic Hub server cannot be configured or reconfigured while running, the Mode menu is inactive while the Graphic Hub server is running. Shut down the server to access the configuration settings.

This page details the configuration of all the **Graphic Hub Modes**, and is divided in the following sections:

- Localhost, 5/4 Free, and Multiuser Configuration
- Cluster Configuration
- Graphic Hub Configuration Parameters
- Naming Service Only Modes
- Directory Agent Only Configuration

7.1.1 Localhost, 5/4 Free, and Multiuser Configuration

1. From the **Mode** menu, select the desired configuration mode and click **Create new configuration**.
2. Click the **Configuration** button.
3. Enter the **Server name** as it should be registered with the Naming Service. Click the reload button to reset to the default name, **VizDbServer**.
4. Enter the **Data directory** path where the Graphic Hub should store the data elements:

   ![Data directory](image)

5. Enter the parameters for a **Naming Service**:
   - In **5/4 Free** and **Multiuser** modes, the Naming Service host name must be entered unless **Connect to local Viz GH Naming service** is checked. For Graphic Hubs in **Localhost** mode, this parameter cannot be changed.
   - Enter the **Naming Service Port** number. The default port is 19396.
6. Uncheck the **Connect to local GH Naming Service** if only a server start is required.
7. Select a **Network Adapter** if the system has more than one adapter installed, or choose to run the Graphic Hub on all adapters (default).
8. Enter the **Server Port** number on which the Graphic Hub listens to. The default port is 19397.
9. Click **Apply**.

7.1.2 Cluster Configuration

1. From the **Mode** menu, select Cluster and click **Create new configuration**.
2. Select the Main and Replication server from the drop-down list.

3. If Graphic Hub Terminal HTTP authentication is enabled, log on to the servers:

   ![Login to terminal](image)

   ![IMPORTANT! If HTTP authentication is enabled, it must be enabled on both servers, and the user name and password must be identical on both servers.]

4. Click **Create**. This enters a two-step process, where the **Step 1** is setting the parameters for the Main server. **Step 2** is setting the parameters for the Replication server.
   a. Set the parameters for the **Main Server**. The parameters are described in the Localhost, 5/4 Free, and Multiuser Configuration section. Click **Next**.
   b. Set the parameters for the **Replication server**.

5. Click **Finish** to return to the System Status panel, which should show the status for both servers. The currently logged on to server is signified by it's panel casting a shadow:
7.1.3 Graphic Hub Configuration Parameters

This section details the configuration parameters for running the Graphic Hub server in Localhost, 5/4 Free, Multiuser, and Cluster (Main and Replication) modes. The Graphic Hub configuration parameters can only be changed when the Graphic Hub server is not running. In the Graphic Hub Terminal, click the **Configuration** button in the System Status panel to open the configuration window:

**Graphic Hub**

- **Server Name**: Set the Graphic Hub server name.
- **Data Directory**: Set the path to the Graphic Hub data directory.

**Connection Settings**

- **Connect to local Viz GH Naming Service**: Check the checkbox to start a Naming Service on the local machine. When disabled, the Graphic Hub starts in server only mode when started. However, this is only available for servers running in 5/4 free or multiuser mode. In such a case, the hostname or IP address of a Naming Service server must be provided.
- **Naming Service Hostname**: The host name or IP address of the server running the Naming Service to connect to. Can only be edited when not connecting to a local Naming Service.
- **Naming Service Port**: Set the port the Naming Service uses to directly communicate with the other applications in the network. The default port is 19396.
- **Network Adapter**: Select which network adapter the Graphic Hub should use. For maximum performance, always choose the fastest network card available. Virtual connections tend to be the slowest. When the network adapter is restricted, any connecting Viz Artist client must connect to the IP address, not the host name.
• **Server Port:** Set the port the Graphic Hub server listens to. The default port is 19397.

✅ **Tip:** Make sure that the selected port is not in use by any other applications.

### Advanced Settings

In most cases, there is no need to change the advanced settings. Click the **Advanced Settings** title bar to open the Advanced settings panel.

- **Performance Settings**
  - **Search instances:** The number of search threads that will be generated, limited by the number of CPUs. The number of threads available for the Graphic Hub to execute a search (the range is 1 to the number of CPU cores in the system). The default value corresponds to the number of CPU cores in the system. Applies only to Graphic Hub servers running in **Multiuser, Main** or **Replication** mode.
  - **Process priority:** Set the Graphic Hub process priority level (Low, Below Normal, Normal, Above Normal, High, Realtime)

⚠️ **Caution:** Increasing the process priority level may cause system instability.

- **Log Settings**
  - **Log server state:** Check to enable logging of additional call information on the Graphic Hub.
  - **Journal level:** Set the system journal entry level.
    Available journal levels:
    - **No Logging:** Disables all logs.
    - **All:** Logs all the entries listed below.
    - **Errors:** Log Fatal Errors, Replication Errors, and so on.
    - **Warnings:** Log Errors and Warnings.
    - **File news:** Log Errors, Warnings, and new file entries.
    - **File updates:** Log Errors, Warnings, and updated file entries.
    - **File deletes:** Log Errors, Warnings, and deleted file entries.

- **Graphic Hub Timeout Settings:**
  - **Server to Client timeout (sec/10):** The recommended setting is 2.

- **License Settings**
  - **License system:** Set the license system to use as the Graphic Hub license source. Available choices:
    - **Sentinel + WIBU:** Prioritizes licenses from a Sentinel dongle. If no dongle is found, the WIBU system is used instead.
    - **Sentinel:** Sets the Sentinel dongle as the license source.
    - **WIBU:** Sets the WIBU licensing system. To use this system, the CodeMeter Runtime needs to be installed, running and configured on all affected systems.

⚠️ **Note:** Even if the Sentinel license is expired or invalid, it remains tied to the dongle.
• **WIBU license location**: Set the WIBU license container location.

  ![Warning](Note.png) **Note**: Details regarding the types of containers are listed in the **Local** and **Network** descriptions below.

  - **Local/Network**: Prioritizes WIBU system licenses from a local license container. If no valid license is found locally, the system switches to a network container.
  - **Network/Local**: Prioritizes WIBU system licenses from a license server on the network. If no valid license is found on the network, the system switches to licenses to a local container.
  - **Local**: Sets a local license container as the license location. This container may be:
    - a file-based container on the local system,
    - or a WIBU dongle-based container connected/bound to the local system.
  - **Network**: Sets a network license container as the license location. This container may be:
    - a file-based container on a configured license server on the network,
    - or a WIBU dongle-based container connected/bound to the license server on the network.

**Additional Advanced Settings for Cluster Configurations**

These settings apply to Main Server and Replication Server modes only.

![Advanced Settings](AdvancedSettings.png)

- **Graphic Hub Timeout Settings**
  - **Server to Client timeout (sec/10)**: The recommended setting is 2, which is 0.2 seconds.
  - **Cluster timeout (sec/10)**: The recommended setting is 300, which is 30 seconds.
  - **Cluster idle switchback time (sec)**: Defines how long the Graphic Hub waits for no activity from clients to return from a failover or switchback. The range is 1 to 30 seconds. The default value is 15 seconds.

- **Naming Service Timeout Settings**
  - **Timeout Responsiveness (s)**: Sets the timeout responsiveness. Must be 1 or greater.
  - **Check frequency (s)**: Sets how often to check for unresponsive Naming Service servers.
  - **Unbinding Time (s)**: Sets the delay after which unresponsive servers are unbound.
- **No. of Loops Used**: Determines the number of loops for unresponsive server recognition. Must be 1 or greater.
- **Performance Settings**: Sets the number of *Search instances* and the *Process priority* level, as described for Localhost, 5/4 Free and Multiuser above.

### 7.1.4 Naming Service Only Modes

The Naming Service is a discovery service that provides client applications with the location of one or more Graphic Hubs on the network. The most common configuration involves each Graphic Hub server running its own Naming Service, a configuration option which is valid for all Graphic Hub Modes. It is also possible to configure one Naming Service for Multiple Servers. However, this configuration is only valid for 5/4 Free and Multiuser modes.

---

To Start in Naming Service Only Mode

1. Open the Graphic Hub Terminal.
2. Go to **Mode > GH Naming Service only > Create new configuration**.

![Mode > GH Naming Service only > Create new configuration](image)

3. In the **Graphic Hub Naming Service** configuration screen, Enter the port number for the Naming Service to communicate through. The default port number is **19396**. The host name is the name of the local machine, and cannot be changed:

![Graphic Hub Naming Service Configuration](image)

4. Click **Apply**, then **Start Naming Service** when the Terminal has returned to the main page to start in Naming Service Only mode.

![Naming Service Running](image)

**Naming Service for Multiple Servers**

Two or more Graphic Hubs running in different modes can be connected to one Naming Service. The following example configuration utilizes three machines: one as Naming Service server, and the other two as Graphic Hub servers.
To Configure One Naming Service for All Servers

1. On the Naming Service server, start the Graphic Hub Terminal in Naming Service only mode.
2. Open the Graphic Hub Terminal on the servers that are intended to connect to the Naming Service.
3. Create a new 5/4 Free or Multiuser configuration.

4. Click **Configuration**.
5. Uncheck the **Connect to local Graphic Hub Naming Service** checkbox.

6. In the **Naming Service Hostname** field, enter the IP address of the server running the Naming Service.

   ![Connection Settings](image)

<table>
<thead>
<tr>
<th><strong>Graphic Hub</strong></th>
<th><strong>Server name</strong></th>
<th><strong>Data directory</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>VizDbServer</td>
<td>C:\VizGHData</td>
</tr>
</tbody>
</table>

   **IMPORTANT!** Unique names are required for each Graphic Hub server on the network. This means it is not possible to start two Graphic Hubs configured with identical Naming Service and Graphic Hub server names.

7. Click **Apply**.
8. Click **Start** to start in Server Only mode.

### 7.1.5 Directory Agent Only Configuration

When the Graphic Hub is in Directory Agent only mode, the Service Location Protocol (SLP) service is configured to run as a Directory Agent. The Directory Agent collects information from other Graphic Hub Terminals on the network, configured as SLP Service Agents, and presents this information when asked. A correctly configured SLP service presents Graphic Hubs available on the network or other networks to client applications on the same subnet without performing multicast or broadcasting.

A Graphic Hub Terminal configured in Directory Agent only mode cannot simultaneously be used as a Graphic Hub. However, Directory Agent functionality can be enabled in parallel when a Graphic Hub is running, under the **Service Discovery Settings** of the Terminal.

---

### 7.2 Backup And Restore

The **Backup** menu shows the backup, restore and data recovery options. As the Graphic Hub server cannot be backed up or restored while running, the server must be shut down to enable changes to the configuration settings.
The internal backup and restore operations of the Graphic Hub are incremental processes. If one backup or restore operation succeeds, all subsequent operations copy the difference from the successful backup/restore to the current operation. Restore points are created to accomplish this process.

- The first restore point holds information about the original data directory.
- The second point holds information about changes from the startup to the first backup.
- The third point holds information from the first to second backup, and so on. If no changes have been made since the previous backup, the Graphic Hub does not create a new restore point.

**Example:** The first backup finished successfully at 01.01.2009 00:00:10 and the second at 01.01.2009 12:00:00. Between the backups, one scene was modified: *MyScene*. The latest restore point would then only contain data regarding this scene. If restoring to the previous point, only *MyScene* resets to its status at 01.01.2009 00:00:10.

There are two kinds of backup, internal and external, both of which are configured in the Graphic Hub Terminal. Make sure to shut down the Graphic Hub before configuring a backup.

### 7.2.1 Internal Backup

Internal Backups are incremental backups as described above. It is possible to limit the number of restore points after a backup. Reducing the amount of restore points vastly reduces the amount of disk space required on the server.

### 7.2.2 External Backup

External backups are executed via a command line call of the Graphic Hub Terminal. It is a full backup, and requires the creation of a batch file for execution. Output from the batch file to the console is visible in the Terminal logging window.

This example batch file copies the data directory to `C:\COPY`:

```
@ECHO off
echo Starting copy of data dir: "%1"
IF [%1] == [] (    
    echo ERROR: NO DATADIR
SET
```
### Backup Configuration

This section details the parameters and configuration of the backup and restore system.

**Tip:** Backup can only be configured when the Graphic Hub server is not running.

Go to **Backup > Backup > Configuration** to open the Backup configuration window:

```
5 | EXIT 1
6 |
7 | robocopy "%~1." "C:\COPY" /MIR /COPY:DAT /DCOPY:T
8 | echo "robocopy exit code: %ERRORLEVEL%"
9 | IF %ERRORLEVEL% LEQ 7 (
10 |   echo FINISHED SUCCESSFULLY
11 |   EXIT 0
12 | ) else (  
13 |   echo ERROR DETECTED
14 |   EXIT 1
15 |
```

### Backup Configuration

- **Disabled:** Disables backup.
- **Internal Backup:** Activates internal backup.
  - **Backup Directory:** Determines backup directory path. Only local drives are allowed as backup directory path.
• **Cleanup restore points**: Enables limits to the number of stored restore points when checked. All restore points beyond the maximum are deleted. This can save considerable hard disk space.

• **Maximum restore points**: Sets the maximum number of restore points.

• **External Backup**: Activates external backup.

• **Batch file path**: Sets the path to and name of the batch file to execute.

⚠️ **Note**: As Graphic Hub Terminal runs as a service under the SYSTEM account, it cannot access network drives mapped by another user. Make sure that the destination path for the external backup is a local drive.

### Automatic Backup Settings

This is used in combination with a shut down task to do periodic automated backups:

• **Automatic backup after successful shutdown**: Performs automatic backup on server shutdown when checked.

• **Start after backup**: Starts the server automatically upon completion of the automatic backup when checked.

⚠️ **Note**: **Start after backup** is only applicable when shutting down the server through the Graphic Hub Manager or when the server is shut down by Scheduled Tasks.

### To Configure Backup

1. Shutdown the Graphic Hub server if it is running, in accordance with the Graphic Hub Shut Down procedure.
2. Open the Graphic Hub Terminal.
3. Go to **Backup > Show Configuration**.
4. Select the required backup type, Internal or External.
5. For Internal Backup:
   a. Select **Internal Backup**.
   b. Enter the **Backup Directory** path.
   c. If required, check the **Cleanup restore points** checkbox and set the maximum number of restore points.
6. For External Backup:
   a. Select **External Backup**.
   b. Enter the **Batch file path**.
7. Select as required:
   - **Automatic backup after successful shutdown**
   - **Start after backup**.
8. Click **Apply** to perform the backup operation.

### 7.2.3 Perform Database Backup

This section details the backup of a Graphic Hub database. The procedure depends on whether an internal or an external backup has been configured.

**To Do an Internal Backup**

1. Shutdown the Graphic Hub server if it is running, in accordance with the Graphic Hub **Shut Down** procedure.
2. Open the Graphic Hub Terminal.
3. Select **Backup > Create backup now.**
4. The backup is created in the directory specified in the backup configuration, as indicated by the Create backup now link.

![Backup Progress](image)

To Do an External Backup

1. Shutdown the Graphic Hub server if it is running, in accordance with the Graphic Hub Shut Down procedure.
2. Make sure that the a batch file has been created and is available.
3. Open the Graphic Hub Terminal.
4. Select Backup > Create backup now (External Backup).

![Backup Progress](image)

7.2.4 Restore Files

To open the Restore Points panel, open the Graphic Hub Terminal and select Restore from the Backup menu. The panel contains information about the restore points available according to the current backup configuration, such as the date and time the restore point was created, how many files it contains, and the location.
The Restore Points panel is accessible when the Graphic Hub is running. However, it is not possible to perform a restore task while the Graphic Hub is running.

**Restoring Files: Best Practices**

When files are restored, observe these best practices:

- **Data directories**: It is not recommended to restore files to an already existing data directory. Create a new directory and restore the files there. Then start a new configuration of the Graphic Hub Server using the location of the restored files as data directory.

**To Restore Backup Files**

1. Shutdown the Graphic Hub server if it is running, in accordance with the Graphic Hub Shut Down procedure.
2. In the Graphic Hub Terminal, go to **Backup > Restore**.
3. Select which restore point to restore.
4. In the **Restore directory** field, enter the location which the files should be restored to, or press the browse button to browse to the desired location. New directories can be created either by typing in a non-existing path in the Restore directory field, or by right clicking the directory tree while browsing and selecting **New folder**.
5. Click **Restore**. The Restore progress window appears, providing information about the restore process.

7.2.5 **Safe Mode**

The Graphic Hub Terminal should be started in Safe Mode if the database has crashed and needs to be restarted. Rebuilding the database in Safe Mode can take several hours, depending on the amount of data that needs to be reconstructed. The recovered directory cannot be accessed by clients such as Viz Artist. It can only be accessed by a system administrator using the Graphic Hub Manager.

⚠️ **Caution:** Do not use Safe Mode for valid data directories.

To Prepare for Database Repair

1. Back up the current data directory.
2. Close all Graphic Hub Deploy Agent connections to the server.
3. Close all Graphic Hub Rest Agent connections to the server.
4. Make sure that the instance is not part of a Graphic Hub Cluster environment.
5. Make sure that the latest version of Graphic Hub is installed.
To Start Graphic Hub Terminal in Safe Mode

1. Prepare the repair procedure as described above.
2. In the Graphic Hub Terminal, go to **Backup > Data recovery (Safe Mode):**

3. Carefully read the information, then click **Start** to proceed.

4. Check the configuration settings, then click **Start**.
   This begins the rebuild process. Rebuilding a large database may take several hours to complete.
When the data has been rebuilt, the Graphic Hub Manager contains a folder called **RECOVERED_AT_YYYY-MM-DD_HH_MM_SS**. The date and time in the folder name serves as a timestamp for the last modification.

**Successful Restore Operation**

The database has been successfully restored when:

- The red console panel shows that the server is up and running.
- All processed files are listed in Reports.
- Files can be viewed in the Graphic Hub Manager.
Depending on the severity of the database corruption, it might be required to run a full server check on the recovered data. Found issues can then be repaired from there (see Data Errors).

**IMPORTANT!** A Graphic Hub server in a production environment must never run in Safe Mode. Safe Mode is only for restoring a corrupted database. This instance can now serve as a source for rebuilding an empty destination database through the DDC functionality (see Graphic Hub Deploy Agent).

### 7.3 Reports

Use the **Report** menu to access system information, the Graphic Hub log, or Graphic Hub console. In addition, the **Export** menu item allows the creation of a system export file, and shows all previous created report export files.

- **System information:** View the **Process List** and **System information** panels.
- **Graphic Hub Log:** View the current Graphic Hub Server log.
- **Graphic Hub console:** View the Graphic Hub Console.
- **Export:** Create, download or delete system export files.
7.3.1 System Information

The Process List panel provides an overview of the processes running on the machine and their resource use. If required, the CPU usage can also be measured, by checking the Measure CPU Usage check box in the upper right corner. The Process list lists the following information:

- The process identifier (PID) and name of the process executable.
- The number of handles and threads used by the process.
- The current and peak Working Set (WS) size in bytes.
- The number of input/output (IO) operations performed in read (RO), write (WO) and other (OO) operations.
- The number of input/output (IO) bytes read (RT), written (WT) and other (OT) transfers.
- The number of page faults.
- The current and peak pagefile usage.
- Estimated CPU usage (if enabled).

The system information panel lists details regarding the current system’s hardware and software configuration. This includes:

- The system architecture (32- or 64-bit).
- Other installed Graphic Hub applications, such as the Graphic Hub Manager and Graphic Hub Deploy Agent.
- The amount and usage of system RAM.
- The installed network adapters and their IP addresses and connectivity status.
- Information about the installed hard disk drives.
- Information about the system CPU(s).
- Further information about the workstation configuration, the configured network, operating system and installed software.
7.3.2 Export File Parameters

Reports are essential troubleshooting tools when there is any kind of system error. The generation of a report should be one of the first actions performed when a system problem occurs, as it can provide valuable information and help to find a solution. Reports can also be generated automatically in case of an unexpected server shutdown.

**IMPORTANT!** In the reports folder, there is a file called SystemInfo.txt. Before this file is sent anywhere, make sure to read it and remove any information that could compromise Company security policies and interests.

**Tip:** On a cluster setup, exporting the report from the Main server automatically generates and downloads two reports, one for each of Main and Replication servers. Both reports are required for troubleshooting.

The Export file panel shows all report files created for export:

- Click the download icon (1) to download the selected export file.
- Click the trashcan icon (2) to delete the selected export file.

To Manually Generate a Report

1. Click **Report > Export**.
2. Click **Create**.

3. Select to **Open** or **Save** the created file.

To Automatically Create Reports of Unexpected Shutdown

1. Click **Options > Journal/Logging settings**.

3. Click **Apply**. The report is exported to the directory selected as **Report Export directory**.

7.3.3 Report Content

A report consists of the following files and information:

- Graphic Hub version information (**VersionInfo.txt**).
- Windows event logs (**vizrt.evt**, **system.evt**, **application.evt**).
- Graphic Hub log files (**LogFiles** directory in export).
- Graphic Hub HQL tables with journals (***.dat**, ***.idx**, ***.idx.fid**).
- Terminal log files (Terminal directory in export).
  - OpenSLP configuration.
  - Terminal configuration (Terminal/Configuration Files directory).
  - Naming Service and Graphic Hub configuration (***.cfg**).
  - Configuration backup files (***.reg**).
  - Terminal log files (***.log**, Terminal/Log Files directory).
- Journal backup files (**VizGHJournalBackup.xml**).
- System information (**SystemInfo.txt**), containing:
  - Graphic Hub Applications registry settings.
  - Network adapters.
  - Drives.
  - CPU, Workstation, Operating System.
  - Installed Programs and Updates.
- Running processes information (**ProcessInfo.txt**).
- Crash dump files if available (Crash Dumps directory in export).
- Timestamps when report export was generated (**timeinfo.txt**).
- Current data directory (**datadirectory.txt**).
Graphic Hub Application related firewall information (*Firewall.txt*).

### 7.4 Options

Use the **Options** menu to access a range of configurations and settings, as well as schedule tasks in the Graphic Hub Terminal:

- **Service Discovery Settings**
  - Directory Agent Only Configuration
  - Service Location Protocol (SLP)
    - To Configure Multiple Isolated Subnets
    - Proposal for Performance Improvement
- **Journal/Logging Settings**
- **E-mail Configuration**
  - E-mail Settings
  - To Enable E-mail
- **Scheduled Tasks**
  - Scheduled Tasks Parameters
  - Task Types
  - To Schedule a Journal Backup Task
  - To Schedule a Cleanup of Expired Items Task
- **Advanced Settings**
- **Change Terminal Password**

#### 7.4.1 Service Discovery Settings

The Graphic Hub Terminal publishes a service through the Service Location Protocol (SLP) on the network. This enables clients to find Graphic Hubs running on the local network or other connected networks without knowing their host names or IPs.

The Graphic Hub Terminal can be used to configure the SLP service, letting it act as a Service Agent. Configuring the SLP service as a Directory Agent speeds up searching, because the server acts as a service cache on its own subnet, responding to requests from clients without broadcasting (multicast).
- **Registration check interval (s):** Interval in which to check for Graphic Hub Terminal service registration status. The Graphic Hub Terminal periodically checks that the Service Location Protocol service (slpd) is running and attempts to restart the service if it has stopped. The Terminal re-registers a previously registered service if:
  - The slpd service is restarted.
  - The registration is about to time out, based on lifetime provided at registration and registration time.
  - The slpd service process start time is after the registration time, meaning the slpd has been restarted between re-registration checks.

- **Lifetime (s):** The initial Graphic Hub service lifetime until the service registration expires.
  - If set to immediate (65535, Maximum), the service remains registered for the lifetime of the Graphic Hub Terminal service process and is immediately unregistered when the Terminal process ends.

- **Directory Agent:** Enable or disable the Service Location Protocol service to function as a Directory Agent. It is recommended to read the OpenSLP Users Guide before enabling this setting. Consider the following:
  - Only a few Directory Agents should exist per subnet.
  - Do not add any local IP addresses or the hostname to the list of Directory Agent addresses.
  - When enabled, the Directory Agent sets the slpd configuration file tag (`net.slp.isDA`). It automatically creates a slpd configuration file if one does not previously exist, however, it does not change an existing configuration file or restart the slpd service if nothing is changed.

- **Directory Agent Addresses:** Define a list of IP addresses with the location of one or more Directory Agents. Click the list button to display a list of all Directory Agents discovered on the network.
  - This is useful if the Directory Agent cannot be discovered via multicast or broadcast.
  - When empty, no predefined Directory Agent is used and automated discovery is performed. Forces local User Agents and Service Agent to use the specific Directory Agents and disables dynamic Directory Agent discovery.
- Creates a slpd configuration file if it does not exist yet.
- Sets the slpd configuration file tag `net.slp.DAAddresses`.
- Does not change the configuration file or restart the slpd service if nothing has been changed.

**Interfaces:** List of IP addresses to listen for Service Discovery requests. This is useful on a system with multiple interfaces.
- When empty, all interfaces are used to advertise the Graphic Hub Terminal service.
- If set, the slpd service listens for unicast and multicast or broadcast SLP requests on the interfaces that are listed, rather than on the default interface or all interfaces.
- Sets the slpd configuration file tag `net.slp.interfaces`.
- Creates a slpd configuration file if it does not exist yet.
- Does not change the configuration file or restart the slpd service if nothing has been changed.

⚠️ **Note:** The Graphic Hub Terminal service is advertised on all interfaces by default.

- **Client request timeout(s):** Set the maximum combined timeout allowed for SLP client requests in seconds. Adjusts multiple timeout values: Unicast, multicast and Directory Agent discovery timeout.
- **Re-initialize:** Re-start the Service Location Protocol service.
Directory Agent Only Configuration

1. From the **Mode** menu, select **Directory Agent only**.

2. The System automatically configures the SLP service to run as Directory Agent.
3. Press **Start**.

Service Location Protocol (SLP)

SLP is used by devices to announce services on a local network using "service URLs". In addition there may be attributes set, basically key-value pairs.

**Example**

URL: `service:terminal.vizrt:http://GHSERVER:19399/terminal.svc`

Attributes: `x-version=3.0.3.71516, x-ip-addresses=10.211.2.150, x-operation=SERVER, x-ns-name=GHSERVER, x-server-name=GHSERVER`

SLP has three different roles for devices. They can also have two or more roles at the same time.

- **User Agents (UA):** search for services
- **Service Agents (SA):** announce one or more services
- **Optional:** **Directory Agents (DA):** cache services information, therefore they are used in larger networks to reduce traffic
Possible operation of SLP:

1. UA obtained the location of DA: UA unicasts a request to DA to resolve a particular request. DA unicasts a reply to UA. If DA cannot service the request (e.g. no information) it returns a response with zero values, possibly with an error code set.

2. UA does not have knowledge of DA or no DA's available: UA multicasts a request to the service-specific multicast address, service responds. All the SA's which are listening to this multicast address respond, provided they can satisfy UAs request. SAs which have no information for the UA must not respond.

To Configure Multiple Isolated Subnets

Routing of multicast packets across subnet boundaries is by default disabled or more accurate blocked. Therefore when SAs and UAs are on different subnets steps need to be initiated:

- Set up organizational or geographical DAs (per subnet).
- Configure SAs and UAs to use them.
Proposal for Performance Improvement

**Use of DAs has several Advantages:**

- UAs receive faster responses.
- Less network bandwidth used.
- Minimum multicast messages are issued.

**Improve performance in Large Networks:**

Use more DAs to enhance Service Location Protocol performance.

- Creates roughly duplicate repositories of service information without requiring any formal database synchronization between them.
- UAs can choose any available DA to issue requests to, the load is shared among DAs.
- Provide robustness in cases where one fails or becomes overloaded.

### 7.4.2 Journal/Logging Settings

This section details the parameters and configuration of the Graphic Hub Journal.
• **Journal Backup Settings**
  - **Enable Journal Backup**: Check the box to enable scheduled journal backup tasks. By default, the journal backup interval is set to once a week, starting one week from 01.01.2007 at 00:00:00.
  - **Directory**: Set the directory where the journal backup file (VizGHJournalBackup.xml) is created.
  - **Truncate**: Check the box to create one backup file only, which is truncated and overwritten on each backup. If not checked, every journal backup task creates a new backup file, with the date and time of the backup in the file name.

• **Report Settings**
  - **Report Export Directory**: Set the directory where the exported reports should be stored.
  - **Report on unexpected Graphic Hub shutdown**: Check the box to enable automatically generated reports in the event of an unexpected shutdown of the Graphic Hub server.

• **Graphic Hub Terminal Log Settings**:
  - **Log event history length**: Sets the maximum event history log length.
  - **Log file history count**: Sets the maximum number of logged operations per log file.
  - **Log file log event count**: Maximum of log events per log file to keep

### 7.4.3 E-mail Configuration

The Graphic Hub can be configured to send notifications about specific types of journal entries via email. The type of journal information that can be sent as an email includes:

- **Action Log**
- **Information**
- **Warnings**
- **Errors**
- **Deploy task information**

The Graphic Hub Terminal is used to enable and configure the email settings for the Graphic Hub. Go to **Options > Email settings** to configure the outgoing email server settings. Then use the Graphic Hub Manager to configure which alerts should trigger an email notification.
E-mail Settings

- **Enable mail sending**: Send an email to defined recipients when unexpected server shutdowns occur, or if the license is not valid or about to expire. The system also sends email according to the defined log level.
- **Mail server host**: Enter the hostname or IP address of the SMTP server. This field is required.
- **Mail server port**: Enter the SMTP server port.
- **Use SSL**: Check the box to enable Secure Sockets Layer (SSL) encryption when connecting to the specified SMTP server.
- **Username/Password**: Set the username and password used to authenticate the sender on the outgoing email server, if required.
- **From**: Enter the email sender address. Required field.
- **To**: Enter the email address(es) that the messages should be sent to, one per line. Press enter to store an entry. Required field.
- **Send mail after successful server start**: Check the box to send notifications when the server is successfully started. This is in addition to the default and log level emails.
- **Send mail after server emergency shutdown**: Check the box to send an email when the Graphic Hub server is shut down through the Terminal. This is in addition to the default and log level emails.
- **Send Test Mail**: Click the button to send an email to the defined recipients for testing purposes.

**Note**: Supports only the SMTP Service Extension for Secure SMTP over Transport Layer Security as defined in RFC 320 with STARTTLS.
To Enable E-mail

1. In the Graphic Hub Terminal, click Options > Email settings.

2. Check the Enable mail checkbox.
3. In Mail Server host, enter the SMTP server hostname or IP address.
4. Enter the Mail Server port.
5. Check the Use SSL checkbox if SSL encrypted connection is required.
6. In From, enter the sender email address.
7. In To, enter one or more recipient addresses.
8. Click OK.
9. If required, check the boxes to include:
   - Send mail after successful server start
   - Send mail after server emergency shutdown
10. Click Apply.
11. Optional: To check the email settings, click Send Test Email.
12. Go to Alerts in the Graphic Hub Manager and configure email alerts.

7.4.4 Scheduled Tasks

This section details how to create scheduled tasks for Shutdown, Journal backup, and Cleanup of expired items.
Scheduled Tasks Parameters

The **ACTIVE** panel contains rows of defined scheduled tasks, and provides an easy overview of the configured settings for each task specified in each column:

- **Active**: A green check mark indicates that the task is active.
- **Task**: The task type.
- **Mode**: The task mode can be **Once, Recurring** or **Recurring forever**.
- **Start at**: Contains the time and date for the first instance of the task.
- **End after**: Defines the number of repetitions or the end date and time. Only applicable when task mode is set to **Recurring**.
- **Each/Interval**: Defines the time between each instance of a recurring task, in hours, days or weeks. Only applicable when task mode is set to **Recurring** or **Recurring forever**.
- **Detail**: Provides additional information about the task, such as the next scheduled occurrence.

Click on a task to open it in the **EDITOR** panel and to configure its settings. The available settings depend on the task selected. The **Mode, Start at, End after** and **Each** parameter all correspond to the columns in the **ACTIVE** panel. In addition, the following settings can be edited:

- **Checkbox**: Check the box to activate the scheduled task. Applies only to the **Shutdown** task type.
- **Info**: Provides information about the selected task, such as the next scheduled run or if the task has expired.
- **Cleanup of Pilot data elements** task type only:
  - **Cleanup of data elements older than**: Sets the time range of kept Pilot elements and library elements of Cleanup of library elements are also checked. All entries older than this setting are deleted upon execution of the task.
1. **Cleanup of library elements**: Checking this box enables cleanup of the Pilot library elements in addition to the cleanup of data elements.
2. **Cleanup of invalid elements (integrity cleanup)**: Checking this box enables cleanup of invalid Pilot data elements with broken integrity.

**Task Types**

- **Shutdown**: View scheduled server shutdowns.
- **Journal Backup**: View scheduled Journal backups (see *Journal Panel*).
- **Cleanup of expired items**: Tick the box to enable a cleanup of expired items after a journal backup (see General Properties in *Servers and Folders*). This task can only be enabled or disabled in the *Advanced Settings*.
- **Cleanup of Pilot data elements**: This task deletes all data elements that are older than the configured timespan when the task is executed. Optionally, deletion of library elements and invalid elements can be enabled in the task settings. This task can only be enabled or disabled in the *Advanced Settings*.
- **Cleanup of pilot changelog**: This task deletes all Pilot changelog entries that are older than the configured timespan when the task is executed. This task can only be enabled or disabled in the *Advanced Settings*.

⚠️ **Note**: The cleanup tasks do not run on a Replication server, except when it is running in the Main mode and the tasks are enabled in the Graphic Hub Terminal.

**To Schedule a Journal Backup Task**

1. Make sure that the **Enable journal backup** checkbox in *Journal/Logging Settings* is checked.
2. Go to *Options > Scheduled tasks > Journal backup*.
3. Set a **Start Time** and select an **Interval** for the backup. The **Info** displays information about the next scheduled journal backup.
4. Click **Apply** to commit the changes.

**To Schedule a Cleanup of Expired Items Task**

1. Go to *Options > Advanced settings*.
2. Make sure that the **Enable cleanup** checkbox is checked for the selected cleanup task.
3. Go to *Options > Scheduled tasks > Cleanup of expired items*.
4. Set a **Start Time** and select an **Interval** for the cleanup task. The **Info** displays information about the next scheduled cleanup task.
7.4.5 Advanced Settings

- **Start and Shutdown Settings**
  - **Start server on Terminal service start**: Automatically start the last successful server configuration when the Terminal service starts.
  - **Automatic restart Graphic Hub server on unexpected termination**: Automatically start the last successful configuration if the Graphic Hub terminates unexpectedly. If the Graphic Hub has been restarted three times and an unexpected shutdown occurs within 30 minutes after the last startup, the automatic restart is skipped. An entry is added to the event log of the Graphic Hub Terminal, as well as to the Graphic Hub server log file.

- **GH Terminal HTTP Connection Settings**: The web server is restarted after applying any changes to the HTTP connection settings, which may take some time.
  - **HTTP port**: Set the Graphic Hub Terminal port. The default port is 19399. The port can only be changed while the Graphic Hub server is not running, or during installation of the Graphic Hub.
  - **HTTP authentication**: Enable or disable authentication for the Graphic Hub Terminal. The username is *Admin* and the default password is *VizDb* (case sensitive). The password can be changed after applying changes, by selecting **Options -> Change Terminal password**.

- **Cleanup Settings**
  - **Cleanup of expired items**: Check the box to enable scheduled cleanup of expired items.
  - **Cleanup of Pilot data elements**: Enable cleanup of old Pilot data elements by the Graphic Hub Terminal. In addition, a cleanup task for Pilot data elements must be configured. When the cleanup of Pilot data elements task is performed by the Terminal, it deletes all data elements that are older than the configured timespan when the task is executed (for example, all data elements older than one week are...
deleted when the task is run). Optionally, deletion of library elements can be enabled in the task settings. After the cleanup task, a log is written to the file CleanupPilotDataelements.log. If email notifications are enabled in the Terminal options, this operation triggers a notification.

- **Cleanup of Pilot changelog**: Enable cleanup of old Pilot changelog by the Graphic Hub Terminal. In addition, a cleanup task for the Pilot changelog must be configured. When the cleanup of Pilot changelog task is performed by the Terminal, it deletes all Pilot changelog entries that are older than the configured timespan when the task is executed (for example, all changes older than one day are deleted when the task is run). After the cleanup task, a log is written to the file CleanupPilotChangelog.log. If email notifications are enabled in the Terminal options, this operation triggers a notification.

- **GH Terminal Connection Settings**
  - **Global timeout (s)**: Global timeout for Graphic Hub Terminal’s connection to Graphic Hub. Default: 30 seconds.
  - **Connect timeout (s)**: Global timeout for Graphic Hub Terminal to initialize the connection to Graphic Hub. Default: 15 seconds.

### 7.4.6 Change Terminal Password

[Image of Change Terminal Password interface]

**Change Terminal password** is used to change the password of the Terminal’s Admin user. **HTTP authentication** must be enabled in the **Advanced Settings** to change the Terminal password. On a cluster, both Terminals must have the same user names and passwords. If the passwords are not identical, automatic start of the partner server does not work.

### 7.5 Help And About

[Image of Help And About interface]

- **Help**: Opens the Graphic Hub documentation in a new window.
- **About**
• **Versions:** Opens the Versions window, which lists the version numbers for the core components of the Graphic Hub. It also displays the number of emails that have been sent or failed to send since the Graphic Hub was started.

• **Graphic Hub License:** Opens the Graphic Hub License information window, which displays information about the license and expiry date, and can be used to update the license string.

• **Third party licenses:** Opens the Graphic Hub third party license information window, which displays the Graphic Hub copyright information as well as the copyright and licensing information for any third party material.

### 7.5.1 Graphic Hub License

For all Graphic Hub modes except Localhost and 5/4 Free, a license is required. A license is normally acquired when the product is purchased. To get additional or updated licenses, contact the local Vizrt representative. The Graphic Hub Terminal License window is used to register a license for the Graphic Hub server, whether it is the first or a renewed license. A new license can also be applied using the Graphic Hub Manager.

**Tip:** To avoid service interruptions, make sure to update the license before it expires.

#### To Apply a New or Renewed License

1. Make sure that the correct license USB dongle is inserted in the machine.
2. In the Graphic Hub Terminal, go to **About > Graphic Hub License**.

**Note:** If this is the first time a license is registered, or if the previously registered license has expired, the license details display **Expired!** instead of an expiration date.
3. Check that:
   a. The **Dongle ID** in the License Information file matches the **Serial Number** in the License details window.
   b. The license string has 32 pairs of characters, separated by a single space.
   c. No empty spaces have been added at the end of the license string.
4. Copy the license string from the License Information text file.
5. Paste the license string in the **License string** field of the License window.
   a. Make sure that the license key has not been entered twice.
   b. Check that the whole string is pasted.
6. Click **Set**.

7. Setting Authenticate with a Graphic Hub Administrator account, check the details again and confirm that you want to apply the new license.
8. If the license is successfully set, a dialog is displayed:

If there is an error in setting the license, an appropriate message is displayed.
9. The updated license information is displayed in the **Graphic Hub License Details** window.

![Graphic Hub License Details Window](image)

10. If the updated license information does not display immediately, try to refresh the license information by clicking the **Refresh** button.

![Refresh Button](image)

## 7.6 System Status Panel

The System Status screen shows the current mode configuration and its menu options.

![System Status Panel](image)

- **Mode panel** (1): Shows the current status of the configured mode:
  - **Panel Border Color**: The color of the panel border may indicate a warning state when orange. The shadow around the panel indicates the machine the web interface is currently opened on, allowing for quick identification on cluster setups.
  - **Naming Service/Server Name/Mode/Version**: Information on the current configuration. If the hostname exceeds 20 characters, it is truncated. However, the tooltip displays the name in its entirety.
  - **Naming Service/Server Status**: Displays current server status.
  - **Data Path**: Displays the path to the Graphic Hub data directory.
- **Shutdown Task**: Displays the status of configured shutdown tasks.
- **Automatic Backup**: Displays the status of automatic backup tasks.
- **Journal Level**: Displays the current journal level.

- **Start Server / Emergency Shutdown (2)**: The button label and function changes depending on if the Graphic Hub server is running or not. When the server is not running, click the button to start it. When the server is running, a Graphic Hub Emergency Shutdown can be executed by clicking the button.

> **Warning**: An Emergency shutdown shuts down the server almost immediately. For a controlled shutdown of the server, use the Graphic Hub Manager to shut it down.

- **Show Configuration (2)**: Open the Graphic Hub Mode Configuration panel.
- **Show GH Log (2)**: Open the Graphic Hub Server Log panel, which displays the contents of the server log file.

### See Also

- Graphic Hub Manager
- Graphic Hub Shut Down

## 7.7 Event Log Panel

The Event Log panel contains messages, warnings, and error messages from the Graphic Hub server. To view the event log panel, click the double arrow icon in the lower left corner of the Terminal window. When the event log panel is minimized, it displays the last entry in the log only.

The event log panel view can be customized by clicking the **Messages**, **Warnings** and **Errors** buttons. A pressed button means log messages of that type are included in the event log listing.