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This manual is organized as follows:

Introduction
Operation
Viz Mosart User Interface
Templates
Audio Panel
Playing Audio
Timing Display



Viz Mosart User Guide -  5.6

Copyright © 2024  Vizrt                                                          Page  10

•
•

•

•

•

1 Introduction

Viz Mosart enables preprogramming of all studio operations required during a show. 
Preprogramming reduces the risk of manual errors and enables production quality to be focused 
upstream, before the event goes on air.

Viz Mosart supports two types of production:

Live Production Mode
Story Recorder Mode

1.1 Live Production Mode
Viz Mosart controls the devices in the gallery that previously were operated manually. Where 
previously production staff in a live show had to work a vision mixer, an audio mixer, cue 
video recordings, these tasks can now be programmed in advance.
For example, Viz Mosart can be instructed to send commands to the vision mixer for 
switching from a camera to a video clip, whilst fading down the presenter mic.
Studio equipment and content cuing instructions are created by the show producer on Viz 
Mosart templates.
There are several Viz mosart template types, each corresponding to a specific studio 
operation.
For example, commands to the audio mixer like, "Pull the studio microphone faders down" 
belong to the Camera template (this operation must be performed during the time this 
camera is in use), whilst simultaneously "Pull the video server faders up", belongs to the 
video clip Package template (as the clip must be faded-in on the desired channel). These two 
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actions remove sound from the studio (news presenter's mic) and enable sound from the 
video server only (audio on the video clip).
An NRCS (for example, iNEWS, ENPS or OpenMedia) is the principle method of scheduling the 
set of Viz Mosart templates that contain commands for controlling the on-air production. 
From the NRCS, a journalist writing a story can quickly create an entire ready-to-air news 
story by inserting (drag and drop) Viz Mosart templates as grommets into their story.
The Viz Mosart GUI displays the NRCS story as one of a series of story rows, in a rundown.
Viz Mosart can receive continuous updates from the NRCS (however, Viz Mosart 
can never update the NRCS), enabling last-minute changes to a scheduled story.
Once the NRCS stories are loaded in the rundown, each time the Viz Mosart operator 
hits Take Next, commands in story elements that were created in the NRCS, direct what is 
placed on air.

1.2 Story Recorder Mode
Viz Mosart enables frame-accurate recording of a Viz Mosart-driven show.

Once the rundown is finalized, this operating mode provides all the benefits of a template-
based Live Production, and also offers the producer the ability to pause the ongoing 
recording, go back to a known point in the show, and retake.
With any desired improvements retaken, once the show is completed, a final show clip is 
automatically stitched together for future playout.

For more details, refer to the topic Story Recorder Mode.

1.3 Related Documents
Viz Mosart Administrator Guide: How to install and configure software and hardware in a Viz 
Mosart system.

For more information about all of the Vizrt products, visit:

www.vizrt.com
Vizrt Documentation Center
Vizrt Training Center
Vizrt Forum

1.4 Feedback And Suggestions
We encourage suggestions and feedback about our products and documentation. To give feedback 
and/or suggestions, please contact your local Vizrt customer support team at www.vizrt.com.

http://www.vizrt.com/
http://documentation.vizrt.com/
http://www.vizrt.com/training/
http://forum.vizrt.com/
http://www.vizrt.com/
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2 Operation
Viz Mosart controls the devices in the gallery that previously were operated manually. Where 
previously production staff in a live show had to work a vision mixer, an audio mixer, cue 
video recordings, these tasks can now be programmed in advance.
For example, Viz Mosart can be instructed to send commands to the vision mixer for 
switching from a camera to a video clip, whilst fading down the presenter mic.
Studio equipment and content cuing instructions are created by the show producer on Viz 
Mosart templates.
There are several Viz Mosart template types, each corresponding to a specific studio 
operation.
For example, commands to the audio mixer like, "Pull the studio microphone faders down" 
belong to the Camera template (this operation must be performed during the time this 
camera is in use), whilst simultaneously "Pull the video server faders up", belongs to the 
video clip Package template (as the clip must be faded-in on the desired channel). These two 
actions remove sound from the studio (news presenter's mic) and enable sound from the 
video server only (audio on the video clip).
An NRCS (for example, iNEWS, ENPS or OpenMedia) is the principle method of scheduling the 
set of Viz Mosart templates that contain commands for controlling the on-air production. 
From the NRCS, a journalist writing a story can quickly create an entire ready-to-air news 
story by inserting (drag and drop) Viz Mosart templates as grommets into their story.
The Viz Mosart GUI displays the NRCS story as one of a series of story rows, in a rundown.
Viz Mosart can receive continuous updates from the NRCS (however, Viz Mosart 
can never update the NRCS), enabling last-minute changes to a scheduled story.
Once the NRCS stories are loaded in the rundown, each time the Viz Mosart operator 
hits Take Next, commands in story elements that were created in the NRCS, direct what is 
placed on air.

This rest of this section describes:

Managing NRCS Rundowns
Operating from the Rundown View
Managing Media Pool Assets
Countdown to a Selected Story
Using Direct Take Templates
Pretake Next Overlay
Looping Part of the Rundown
Locking a Rundown or Story
Rehearsal and On Air Mode
Creating Sequences
Modifying Stories in the GUI Rundown
Changing Template Sets
Changing Graphic Profiles
Controlling Device State
Running Viz Mosart in Browse Mode
Story Recorder Mode
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Recalling a Workspace/Keyboard Layout by Control Command from a Template
Sourceview with Template Router Source Assignment
Quick Access to Ad Hoc Assets

For a detailed description of the menus, panels, selections and commands that you can use with 
these operations, refer to the corresponding section in section Viz Mosart User Interface.
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2.1 Managing NRCS Rundowns
iNEWS

Working with iNews Rundowns
Story Status Updates with Avid iNews Web Services

MOS
Working with MOS-based Rundowns

2.1.1 iNEWS

Working with iNews Rundowns

To add an iNEWS rundown to Viz Mosart

In the Viz Mosart UI, select Tools > Edit rundowns.

Story Status Updates with Avid iNews Web Services
You can automatically update the iNEWS rundown with Viz Mosart story status updates. This is a 
useful utility that, for example, can provide clip availability to the NRCS user.

Note: The menu item Edit rundowns only displays when iNEWS is connected to Viz Mosart.

 You can also view these added rundowns from the Tools menu:
Tools > Arrange Rundowns menu.


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1.
2.

For a setup description and usage examples, please refer to the section Avid iNews Web 
Service for Status Feedback in the Appendix of the Viz Mosart Administrator Guide.

2.1.2 MOS

Working with MOS-based Rundowns

To select a rundown from the NRCS
From the Rundowns > NCS active option on the menu bar, select your required rundown.

To add a MOS-based rundown
In the Viz Mosart UI, select Tools > Edit rundowns.

To modify a MOS-based rundown
Tools > Edit rundowns
From the drop-down menu, select NCS active.
This displays all rundowns sent from the NRCS to Viz Mosart.

http://docs.vizrt.com/viz-mosart.html
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From the displayed rundown rows, select required rundown.
It will be highlighted in orange.

Perform required rundown action, remembering to end with the Apply button.

To load a MOS-based rundown
To display and run a specific rundown, select the rundown entry from a row 
under Rundowns > NCS active.
(Selecting a rundown from this menu is equivalent to the Timeline keyboard shortcut, Reload 
Rundown).

To select a ready to air rundown
A special, predefined rundown is the ready to air rundown.

Tools > Edit rundowns
From the drop-down menu, select Ready to air.
All rundowns with Ready to Air status are displayed, sorted by editorial start time.
From the displayed rundown rows, select required ready to air rundown.

Note: Any new rundowns connected to Viz Mosart, with status Ready to Air, are added or 
appended to this listing.


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2.2 Operating From The Rundown View
A rundown is viewed as Story Info to the left and a larger Timeline to the right.

The Story Info and Timeline panes provide a visual representation and control over the studio 
events originating from NRCS rundown story rows.
Each story row comprises color coded items and sub-items presented chronologically on a 
timeline. The colors correspond to the Viz Mosart templates that have been pre-programed to 
execute each operation, when taken.

Timeline Operations
Info Area

Current Story Indication
Set as Next Story

Timeline Views
Floating Window
Timeline Viewer Web App
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2.2.1 Timeline Operations
From a keyboard or touch screen you manually control and optionally override the items that 
sequentially execute once the rundown is initialized.

Each operation is mapped by default to a customizable keyboard shortcut.

Initializing a Rundown
Taking Items in the Rundown
Skipping a Story Item
Unskipping a Story Item

Initializing a Rundown

Initialize the rundown with the RELOAD RUNDOWN command.

This resets the status for all stories and story elements and cues the first element in the first story 
in program, and the second element in preview. 
Any changes made to the rundown in the GUI are replaced by the latest NRCS data.

This operation can be mapped to any keyboard button.
Default keyboard shortcut: SHIFT+F12.

Taking Items in the Rundown

Start the rundown or move to the next story element with The TAKE_NEXT command.
If the current element is the last element in a story, the TAKE_NEXT command takes the first 
element in the next story.
When the rundown is running, the current play position within the On Air template is 
indicated by a red play marker.

This operation can be mapped to any keyboard button.
Default keyboard shortcut: F12.

Skipping a Story Item
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Skip the next story item with the SKIP NEXT command, making it disappear from the 
Timeline.
The item following the skipped item is then cued in Preview.

This skip operation can be mapped to any keyboard button.
Default keyboard shortcut: F9.

Skipping Multiple Story Items
Each time you press F9, the next story item is skipped. 
You can skip multiple items, but pay attention to the order of any subsequent Unskipping of 
multiple story items.

Unskipping a Story Item

Undo an item skip with the UN-SKIP NEXT command, making it reappear on the Timeline.
Once you have progressed beyond the skipped item in the running order, it is no longer 
possible to bring it back with UN_SKIP NEXT.

This skip operation can be mapped to any keyboard button.
Default keyboard shortcut: Shift+F9.

Unskipping of multiple story items
Each time you press Shift+F9, the most recently skipped story item is returned to its place 
on the Timeline.

2.2.2 Info Area
The Info area summarizes details on story level. It is displayed as a left hand column in the 
rundown view.

•

Note: Please be aware that multiple skipped items are placed on a 'stack'. This is illustrated 
by the following example:

If you press F9 twice, and skip I1 and I2 (two adjacent story items in that order), and 
then press Shift+F9, then I2 is unskipped.
If you again press Shift+F9, then E1 is unskipped.

The two items reappear on the Timeline in the SAME order, but are unskipped in reverse 
order to how they were originally skipped.


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Current Story Indication

The current story is highlighted with a red background in the Info area and displays three 
timers:

Left timer: When the story went on air.
Middle timer: How long the story has been on air.
Right timer: The editorial duration provided for the story.

Set as Next Story

You can jump to any story in the rundown by placing the mouse over the story's Info area 
(left hand column of the Rundown view) then Right-click > Set as next story.
A story set as next, is highlighted in the Info area with a yellow background. 
If the rundown/timeline has not been started, selected story is set as the first story.

2.2.3 Timeline Views
The Timeline provides essential real-time monitoring of the current rundown. With mouse and 
keyboard actions, the operator can execute the next item, or make last-minute changes to the 
programing schedule. 

Floating Window
You can display the Timeline as either

a fully operational floating window
or
a web based monitor (read-only).

•

Note: All the remaining items in the current story are first taken (if not skipped), before the 
the first item of a Set as next story is taken.

For example, if your on air story contains four items, and while running item 2 on 
air, you perform a Set as next story somewhere else in the rundown, item 3 and item 
4 in the on air story will still be cued and played (if they are not skipped.)
When Viz Mosart takes item 4 on air, it then cues in Preview the first item of the Set 
as next story, ready to take as next. 



For details, refer to section Rundown View.
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Timeline Viewer Web App
You can display also display read-only Timeline details in a separate, scalable Mosart Web App.
This requires an additional once-only installation, as described in the web Apps section of 
Rundown View.
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•
•
•
•
•

2.3 Managing Media Pool Assets
Located at the lower-right of the Viz Mosart UI, the Media Pool provides a convenient one-stop 
shop for asset operations at showtime.

This section presents each of the Media Pool tabs and provides examples of useful tasks you can 
perform.

2.3.1 Media Pool Tabs
The Media Pool is accessed by a series of tabs.

Assets Tab
Last-minute Edits to Graphic Elements
Search Tab
Favorites Tab
Quick Access Tab

Assets Tab
Here all items in a selected rundown story are displayed.

Right-clicking an item opens a context menu for further operations.

Last-minute Edits to Graphic Elements
You can make last minute corrections to the content of graphic element (for example, a lower 
third) by selecting it from the Quick Access panel and editing it.

This option is only available for NRCS-defined graphics that originate from Viz Pilot Edge (graphics 
that were created in the newsroom system using the Viz Pilot Edge plugin).

Note: Your edits are saved in Viz Pilot Edge, and not in the NRCS.
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1.
a.
b.

2.

3.

To edit a rundown graphic element
You can select a valid graphic element, edit it and push it directly back to the rundown.

Select the required element either
From the Quick Access tab in the Media Pool.
From the Quick Access panel (a floating window).

Right-click > Edit.

After a couple of seconds (this may take slightly longer, the first time the Editor is opened) 
an editing panel opens.

If the rundown is reloaded (not locked in Viz Mosart), the naming of the graphic will revert 
to whatever it is called in the NRCS, but will still point to and take your updated (edited) 
graphic element.
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4.

5.

a.
b.

You can change text details of the graphic (in this example Designation).

When finished, click the Save icon ( ) and either

Rename the text (Overwrite)
Clone the element with the new data (Create new element).

Search Tab
Enter a search string to locate an asset, before dragging it to another Media Pool tab.
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•

Favorites Tab
During an ad-hoc show, an upcoming story might require several templates. If there are a lot of 
graphic in the rundown that the operator wants to use, they can pre-save them on the Favorites tab 
for easy access prior to the story running.

To populate the Favorites tab
Drag and drop items onto the Favorites tab (Star icon).

A 'wifi' symbol appears on the Favorites tab ( ), indicating that the tab is populated 
with globally-shared items.

Quick Access Tab
You can get all the features of Quick Access by selecting the Quick Access tab in the Media Pool. 
The content under this tab display according to filters that you define here.

Note: In the illustration above, the appearance of the shared icon  , indicates that 
the favorites displayed on this Viz Mosart client (UI), are public and shared with all 
other Viz Mosart clients that are connected to the same Viz Mosart server.
See the description for the setting Use public buttons, in section General Settings > 
User interface > Keyboard.


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1.

2.
a.

i.

ii.

b.
i.

To create or modify a filter button
Select the Quick Access tab.

Either
Add a button 

Right-click in the row next to a filter button (Cam Vid All in the screenshot 
above)
Select Add to insert a new filter button.
or

Modify an existing button
Place the mouse over the selected button and right-click.
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ii.

1.
2.
3.

a.

Select action or modifier from the menu.

Changes take effect immediately.

Finding and Taking Manual Lower Thirds
The Quick Access tab can be very useful For lower thirds. It uses the same filter as Quick Access
panel but displays the content as a vertical list. 
You can also create QUICK_EVENT control commands to navigate the list and take the selected 
item.

To create a quick event
Open the Quick Access panel.
Mouse-over any of the Filter buttons and right-click, to display a context menu.
Enable the following options:

Items > Show Templatetypes: LOWERTHIRD
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b.

4.
a.
b.

Show only ad-lib items.

The QUICK_EVENT has to have a TAKE_SELECTED shortcut to be able to take the item. 
It is also possible to right-click and select Directtake.
You can also have a shortcut to preview the item.
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•

2.4 Countdown To A Selected Story
You can add a countdown clock to assist with estimating story run times.

2.4.1 Adding a Countdown Timer

Right-click in the info area of a story and select Count down to.
A countdown clock with minutes and seconds to the selected story’s estimated On Air time 
appears in the middle of the info area.

2.4.2 Customizing the Appearance of Stories in a Rundown
Story line options control behavior and display characteristics of each story in the rundown.

Refer to topic Story Line in the User Interface section.

Again selecting Right-click > Count down to, toggles the timer off.
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2.5 Using Direct Take Templates

Direct take templates are recalled from the numeric keypad. Enter the number of the direct take 
template, and use the minus (-) key on the number pad to take. The number entered is displayed 
in yellow in the lower right hand corner of the GUI.
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2.6 Pretake Next Overlay
This is a control command. In Keyboard Shortcuts editor, create a new Control Command →
OVERLAYGRAPHICS

To pretake an overlay item in the next story element, use an assigned shortcut (default: CTRL+O). 
This can load a complex graphics item on a studio screen during a package. This avoids any load-
related delay in rendering graphics on air which might occur if the Cue and Play commands are 

sent simultaneously. The first overlay, with time code equal to 0 , is taken. 

All Overlay Graphics control commands share the Render parameter. This parameter can be set to 
send the given command to a specific engine, or to engines which currently have active graphics 
on air. 

In the Parameter field, it is possible to enter a graphics Handler name (i.e. WALL or DSK etc). The 
entered value in Parameter overrides the Render value. Default: CTRL + O.

See Keyboard Shortcuts for more information on shortcut setup.
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•
•
•
•

a.

b.

2.7 Looping Part Of The Rundown
Working with Rundown Loops
Defining the Scope of the Loop
Auto-take Mode
Moving a Loop
Stopping the Loop

You can loop a part of the rundown, by setting a loop start and a loop end point in the rundown. 
The loop start and end are marked with 2 vertical white dots (see image below).

2.7.1 Working with Rundown Loops

2.7.2 Defining the Scope of the Loop

To set a loop start point
You can either:

Set the loop in by right-clicking on any item in the story from where you want to start 
loop and select Loop > Start.

Use a STORY_ACTION LOOP_START control command to set the Loop Start item as the 
first item in the selected story.
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a.

b.

To set the loop end point
You can either

Set the loop out by right-clicking on any story item that you want to end the looping 
and selecting Loop > End.

Use a STORY_ACTION LOOP_END control command to set the Loop End item as the 
last looped item in the selected story.

2.7.3 Auto-take Mode
When entering the first item in a loop, Viz Mosart goes into auto-take next mode.
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•

To exit auto-take mode
Use the control command AUTOTAKE.
The screenshot below shows that either TOGGLE or DE-ACTIVATE will exit auto-take mode.

The command sequence STORY_ACTION > LOOP_CLEAR will also end the autotake.
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1.

2.

•

2.7.4 Moving a Loop

To remove an end loop point
Left-click the loop point and select Loop > End to remove it.
Autotake continues while you are moving the point.
Left-click the new position and choose Loop > End (or use a shortcut as described above).
The same procedure can be done for Loop > Start.
If the Loop > End point has been reached without a valid Loop Start point above it in the 
rundown, the next item is set to the first story in the rundown.

2.7.5 Stopping the Loop

To clear the loop
Left-click and select Loop > Clear. 
This stops the auto-take. Removing both Loop Start and Loop End continues the auto-take. 
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•
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2.8 Locking A Rundown Or Story
Any updates to the rundown in the connected NRCS, immediately update Viz Mosart's locally 
cached copy. This behavior is by design, bit might cause issues during a show, if an upcoming 
production has been locally modified with the Quick Editor.

It is possible to prevent NRCS-driven rundown updates by locking the rundown.

Rundown Locks
Story Locks

2.8.1 Rundown Locks

To Control Locking of a Rundown
From the Rundowns menu, select Lock Rundown.

This prevents continuous synchronization of the Viz Mosart rundown, and the NRCS.

It is recommended to lock the rundown during a show.
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•

To open the connection again, select Rundowns > Unlock Rundown. 

2.8.2 Story Locks

To Control Locking of Individual Stories
You can also lock single stories in a rundown.

Right-click on the selected story and select
Lock Story from NCS Update.

A Padlock icon indicates the story is locked:

Unlocking the rundown immediately synchronizes the current Viz Mosart rundown to 
the NRCS.


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• Repeat this procedure to unlock a locked story.
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2.9 Rehearsal And On Air Mode

To disable Viz Mosart from sending the running element status to the NCS, enable Rehearsal mode 
by choosing the Rehearsal option from the Rundown menu. A rehearsal indicator is shown next to 
the Viz Mosart logo. Switch back to On Air mode by clicking the Rehearsal option again.
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•

•

1.

2.

3.

•

2.10 Creating Sequences
You can save a story a sequence.
A sequence is a saved story that includes primary and secondary items and their associated 
timing information. 
A sequence can then be recalled from a template or by Adding a Sequence Macro in the 
NRCS.

2.10.1 Working with Sequences

Saving a Story as a Sequence

To save a story as a sequence
Right click the info area of the required story, and select Edit > Save story as sequence.

In the dialogue menu that appears, type a name for the sequence.

Click Save.
The sequence is saved to the chosen studio setup on template set-level.

Advanced operations for working with templates are described in the section Template 
Editor of the Viz Mosart Administrator Guide.

Recalling a sequence from a template is an advanced operation, described in the Viz 
Mosart Administrator Guide, in the section Show Design and Template Editor, under 
Working with Templates > Template Properties.



Note: A sequence can only be used in the template set in which it was created.

http://docs.vizrt.com/broadcast.html
http://docs.vizrt.com/broadcast.html
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1.

2.

Adding a Sequence to the NRCS Story using a Macro

Adding a Sequence Macro in the NRCS
A Viz Mosart sequence can be added to an NRCS story, using the Macro command.

By adding this single command in the NRCS, all the events (like primary templates, secondary 
templates and timed overlay graphics) are included in the story exactly as they were when 
originally saved in the story.

Assign a newsroom alias to the Mosart type MACRO in NCS tags in Newsroomsettings:

You can now add the macro in the same way as other templates, in the format 
"MACRO=[Sequence name]”.
If you insert the command from the example above in iNews, it looks like this:

This story then displays in Viz Mosart as:

Note: If the Viz Mosart ActiveX is used, the saved sequences will appear in the variants list 
when selecting the type Macro in the first column.
Any templates in the saved sequence that have newsroom tags will also appear, making it 
possible to change sources etc.





Viz Mosart User Guide -  5.6

Copyright © 2024  Vizrt                                                          Page  42

•
•
•
•
•
•

•

•

•
•

2.11 Modifying Stories In The GUI Rundown
You can make last minute changes to upcoming stories directly in the rundown displayed in Viz 
Mosart.

Adding a Story
Adding Items to a Story
Modifying Items in a Story
Removing a Story
Lock Story from NCS Update
Rundown Reloads

Right-clicking in the story's information area displays a context menu:

2.11.1 Managing Stories

Adding a Story

To add a new story
Right-click in the info area and select Edit > Insert story. 
A New Story placeholder is added underneath the selected story.
To populate this new story, see To add items to an upcoming story below.

Adding Items to a Story

To add items to an upcoming story
From Assets and Favorites tab, drag items into the story.
Alternatively insert content using the Quick Editor.
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1.

2.
3.

Modifying Items in a Story
You can make last-minute changes to graphic elements in a story.

This is typically where the operator notices spelling mistakes in graphic text and need to correct a 
live show before the story goes on air.

To edit a graphics item
This procedure only works with graphical elements created with Viz Pilot Edge.

To the right of the rundown, click the square symbol (that indicates availability of ad-hoc 
elements ).

Select required graphic, Right-click > Edit.
A Viz Pilot Edge editor panel opens, to complete the task.

This procedure is fully described in the section Managing Media Pool Assets (topic Last-minute 
Edits to Graphic Elements).

To copy items to the current story
You can append existing story items to the current story row.
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•

•

•

•

Right-click on the story containing the items you want to append and select Append items to 
current story.
All items (templates) from the right-clicked story are appended to the current story.

Removing a Story

To remove a story
Right-click in the info area and select Edit > Remove story.

2.11.2 Story Locks and Updates

Lock Story from NCS Update

To lock a story from NCRS updates
You can prevent any ongoing changes in the NRCS from affecting your manual story modifications 
(as described above).

Right-click in the info area and select Edit > Lock story from NCS update.

Rundown Reloads
Please note that a reload of the rundown will still delete any manual story modifications, even 
though the option Lock story from NCS update has been selected.

To prevent deletion of manual story modifications at rundown reload
From the Viz Mosart menu bar select Rundowns > Lock rundown.
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•

2.12 Changing Template Sets

The currently loaded template set can be changed directly from Viz Mosart.

From the menu bar, select Studio Setups and then choose the desired template set.
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2.13 Changing Graphic Profiles

The currently loaded graphic profile in Trio Interface/Overlay Graphics Interface can be changed 
directly from the Viz Mosart GUI. To do so, use the Graphics Profiles menu and select the desired 
graphic profile from the pull-down menu.   
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•

2.14 Controlling Device State
You can set equipment to standby mode from the Viz Mosart UI, AV Automation or the Mosart 
Overlay Graphics Interface controllers and engines.

Placing a Device in Standby from Viz Mosart UI
Placing a Device in Standby from AV Automation
Placing a Device in Standby from Overlay Graphics Interface

2.14.1 Placing a Device in Standby from Viz Mosart UI
All devices are available from the Viz Mosart UI.

Device Status
The status of devices, controllers and engines are indicated with a circular color code as follows:

Green: The device is connected and active
Yellow: The device is connected but in standby mode.
Red: There is a problem with connecting to the device.

In Mosart GUI, the color in the Standby menu bar changes if any of the AV Automation devices, OGI 
controllers, OGI Engines are not green. 
For example:
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•

When a device, controller or engine is in standby, yellow status is indicated in the menu bar.

When a device, controller or engine is not connected, red status is indicated in the menu 
bar.
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For further details, refer to the section Standby.
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•

To Place a Device in Standby (Viz Mosart UI)
From the Standby drop-down menu, select the desired device. 

Once in state standby, all Viz Mosart commands sent to the selected equipment are 
disabled, until the device is re-enabled from this menu.

2.14.2 Placing a Device in Standby from AV Automation
You can set any device configured in AV Automation to standby. Once a device is in standby, 
Mosart will not send any messages to it.

To Place a Device in Standby (AV Automation)
From the Standby drop-down menu, select the desired device.

Device status color coding is the same as described in Device Status above.

2.14.3 Placing a Device in Standby from Overlay Graphics Interface
You can set any graphic controller or graphics engine configured in the Overlay Graphics interface 
to standby mode from the application's menu.

If a sub-item like a robotic camera is connected and one of these sub-items are in standby, 
the menu appears green but with a square orange icon.


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•

To Place a Device in Standby (OGI)
From the Standby drop-down menu, select the desired device.

When a device is marked in red, it is not connected.
When a device is marked in yellow, it is in standby mode.


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2.15 Running Viz Mosart In Browse Mode
When a Viz Mosart menu is in browse mode, the user is only able to browse the rundown and click 
on stories to view their contents in the Script and Assets windows.

Any Viz Mosart GUI can be put into browse mode. To activate or deactivate Browse mode in 
a GUI, select View > Browse mode.

All actions and shortcuts affecting the rundown or connected equipment are disabled. A Viz 
Mosart administrator can even remove the ability for a user to toggle the Browse mode menu, 
which enables a locking of a user's available menu choices.
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2.16 Story Recorder Mode
Story Recorder enables the producer to record a Viz Mosart driven show, story-by-story. During 
recording, any story can be paused and retaken as required, the end result is a single, perfectly 
stitched clip, ready to air. 

Introduction to Story Recorder
Definitions

2.16.1 Introduction to Story Recorder
For a production that will be prerecorded, Viz Mosart offers a single button pause-fix-retake 
solution, for a template-driven show.

Story Recorder mode expands Viz Mosart's traditional role as a tool for managing live productions, 
to now powerfully support prerecorded productions.

The producer benefits from both the failsafe, timely execution of gallery equipment operations 
and an ability to pause and backtrack, when an improvement to the ongoing recording of a show 
is identified.

Highlights of Story Recorder
Frame accurate
Fully reliable operation of studio equipment, synchronized down to frame-level. This delivers 
perfect cuts every time for the supported template features.
Records both clean and dirty feeds
As well as the current show, with all graphics (dirty), Story Recorder retains a clean feed that 
can be for example, be rebranded or reused in another language. 
Pause & retake
As the show runs, whenever an improvement is identified, the recording can be paused and 
recording begin again from a selected point.
Backtracking
When the timeline is paused and a retake point selected, Story Recorder attempts a 'track 
back' in time, restoring the state of various attributes like graphics and audio.
Intelligent asset management
Smart under-the-hood features. For example when using iNews, a long clip is broken into 
segments, minimizing backtracking if the pause occurs mid-clip. This improves user 
response times.

Note: Some mandatory studio equipment calibration must first be performed. If Story 
Recorder mode is unavailable, contact your System Administrator.



Note: Operating Viz Mosart in story Recorder mode requires an additional license. Please 
contact Vizrt support.





Viz Mosart User Guide -  5.6

Copyright © 2024  Vizrt                                                          Page  54

Inbuilt file housekeeping
Recorded video files are always large. Viz Mosart offers an active purging regime to optimize 
disk space.
Dynamic review of cut points
An automatic 'snippet generator' provides a short review clip of the cut point after a pause-
retake, while recording continues.
Automatic equipment and graphic reset
At recording pause, before recording resumes, video and audio devices plus graphics are 
reset to a known state.  
Timing information
Clear display of over/under countdown timers and accumulated record time of the show.
Future-proof design
Story Recorder has been purposefully designed with a flexible interface to third party 
systems like editors, transcoders and asset management.

The Story Recorder Panel
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Feature Explanation

1 Editable reference name for the show's EDL files 
and final clip.

2 Recording time. Total duration of recorded show, 
so far.
Grows from the first taken item, and does not 
include any initial Break items.

3 Show countdown timer. Remaining time of show, 
based on planned show duration provided from 
the NRCS.

4 The story slug, as provided in the NRCS. This 
column can be resized and repositioned.

5 Notifications area.

6 The local (wall) time when the item was taken to 
PGM in format HH:MM:SS.
This column can be resized and repositioned.

7 Preroll duration adjustment (seconds). Press Apply 
to set a non-default (10 seconds) value.

8 Broadcast the show EDL to subscribers (to the 
Vantage transcoder that stitches the show into a 
single clip).

9 Number of successful broadcasts.

10 Duration of the story item in format HH:MM:SS:FF 
(frame count only shown after the item is paused/ 
recorded).
This column can be resized and repositioned.

11 Story separator

12 Grey coloring: The selected item row

13 Selection of the Retake point.

14 Toggle switch for the appearance of calibration 
details (see Calibration Info below).
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Feature Explanation

15 Blue border: The first item that will be retaken (the 
Retake point).

16 Play a 10 second snippet to review the cut point.

17 Separator, indicating a cut (a retake) and marker 
for a retake point.

18 Name of the story item that is identified by a 
primary Viz Mosart template and template variant.
This column can be resized and repositioned.

19 Record | Pause button and status indicator.

20 Story Recorder On | Off switch.

Calibration
Info

(Details from the initial calibration setup of 
Story Recorder)

Item-type icon displays selected story item name 
and story name.

Record Mark In In-point, displayed as clock (wall) time. Format 
nnn/hh:mm:ss:ff, where nnn is the absolute frame 
number.

Record Mark Out Out-point, displayed as clock (wall) time. Format 
nnn/hh:mm:ss:ff, where nnn is the absolute frame 
number.

Zero based Mark In In-point, displayed as zero-based time.

Zero based Mark Out Out-point, displayed as zero-based time.

The following sections introduce Story Recorder with examples of common production scenarios:

Working with Story Recorder
Troubleshooting and Housekeeping
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2.16.2 Definitions
To help you around the following sections, here are some terms used specifically within context of 
Story Recorder.

AsRunLog: Viz Mosart’s internal log of show recording events, with timestamp. 
Events are internal technical transactions, for example RUNDOWN_STARTED, 
RUNDOWN_ENDED, STORY_STARTED, STORY_ENDED.
Clean feed: An SDI video signal that does not have any added (burned in) graphics or text.
Consolidation: Stitching. The process that begins in the background with ongoing 
generating of an EDL file that holds all the timecodes of the Mosart primary events that were 
sent to PGM.
The EDL assets (all recordings, including clips, cuts and graphics) are sent to a transcoder 
where they are rendered into a single clip.
Dirty feed: The stream on PGM, program circuit or on-screen graphics (even when there is no 
commentary or atmospheric sounds).
EDL: Edit Decision List. Video editing involves listing the timecodes of specific frames at the 
point where video edits are to be made. These edit points form an edit decision list, used in 
the post-production process of the film or video editing.
In the simplest case, these points are written on paper, but usually are stored as metadata in 
a file that can be used by an NLE or transcoder.
Frame: The smallest measurement in a timecode, precisely specifying a single and complete 
video picture, comprising two interlaced fields.
Frame accuracy: Ability to edit media and control associated studio equipment with 
timecodes defined to frame level, that will always trigger at the start of the specified frame. 
This enables seamless cuts and transitions, whilst ensuring predictable, synchronized 
equipment behavior.
GUI: Graphical User Interface.
LTC: Linear (or Longitudinal) Time Code, a timing signal (for synchronization) embedded in 
audio recordings.
NLE: Non linear editor. An editing station, for example Adobe Premiere Pro.
NRCS: Newsroom control system. Planning utility for show design. Can also refer to Vizrt's 
Showmaker.
Pause: The operation of stalling recording of the current story row. This operation also 
initiates backtracking to the start of the interrupted story item (primary template), and 
insertion of a pre-roll event in front of this primary template.  
Pre-roll: A ten second (by default, but may be different on your setup) period that a camera 
(anchor) is given to prepare in a video production, before the production is live. At pause, 
this period is also used behind the scenes for the technical setup (studio equipment, clip 
players, graphics players, recorders and transition continuity etc.) to be made ready for the 
new take. 
Pre-roll item: A pseudo-template which, at pause, is inserted in front of the interrupted 
primary item of the executing story. 
PRG: Program
PRV: Preview
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Recorded segments: The usable parts that get stitched together to build the final clip from 
the recorded show.
Rendering/Stitching: A transcoding task where clips are joined to form a single file, based 
on cut points and metadata contained in the session's EDL.
Story: A Viz Mosart equivalent of an NRCS-created MOS story. It covers a single topic (for 
example, an interview) comprising several items (for example, multiple camera scenes).
Story item: A single element of a story (for example, a single camera scene) associated with 
a discrete Mosart template.
Timecode: Exact position of a frame in a recording, used to locate a recorded point. Can be 
relative (to the start of the clip) or absolute (time of day of the recording) or based on 
another reference, such as studio clock (wall) time. Used to synchronize when referencing all 
audiovisual media, for example, video, audio, captions, visual effects, and more.
Timeline: A chronological display of on-air events (for example, story items) showing their 
start time and duration. In the Story Recorder window, these are represented by rows. 
Transcoding: Digital-to-digital file format conversion from one standard of encoding to 
another. For example, a movie file encoded for the PAL system can be converted 
to NTSC, or mxf to mp4 video. Also audio files and character encoding (for 
example, UTF-8 to ISO/IEC 8859).
VITC: Vertical Interval Time Code, (pronounced vit-see) is a timing signal embedded in a 
video recording.
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2.16.3 Working with Story Recorder
This section presents

Managing a Story Recorder Session
Recording
Rolling Back in Time at Retake
Timing Details

Managing a Story Recorder Session
Story Recorder offers three principle modes for supporting error-free production and recording of 
a Viz Mosart-driven show.

Record a Show as a Single Clip
This mode assumes that the show was made error-free and Story Recorder has captured the 
required scheduled performance.
Pause-Fix-Retake Mode
An improvement has been identified, and the show is rolled-back to a chosen point, to take 
again.
Publish an Early Version of the Show
Sending the recorded stories to a publishing point, either before the show is complete, or 
with additional stories appended later.

Preparations

To Display The Story Recorder Menu

With Viz Mosart running, from the menu bar select View > Floating windows > Story 
Recorder tool.
Position the Story Recorder window on your workspace.
(You can also place this window on a second screen).
(Optional) Save this workspace setup for future use:
View > Save as new workspace and enter a unique name.

To Start A Story Recorder Session

You activate Story Recorder with a switch at the top of the Story Recorder panel in Viz Mosart.

In the Story Recorder tool menu switch to On, as shown above.
After a few seconds start-up, the display indicates Ready, and the REC button is red, 
indicating the system is operational, ready to record.
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From this point on, any story items taken on air (using the standard Take Next, default F12) 
will be recorded and displayed in Story Recorder panel, item by item (see below).

Recording

Recording a Show as a Single Clip
This mode assumes that the show was made error-free and Story Recorder has captured the 
required scheduled production.

To Record A Show As A Single Clip

Ensure the rundown containing the show's story rows is loaded in Viz Mosart.
If the rundown begins with a Break template, for initializing equipment, make sure this 
entire story is executed before enabling Story Recorded mode.
From the Story Recorder panel, switch on Story Recorder mode (described above).
After a few seconds, the REC button is red, indicating the system is ready to record your 
show.
If Step 2 above was performed, then execute Take Next to continue with the next story item 
in the show (this will be the first recorded story item). Otherwise begin the show by taking in 
the first story item of the show. 
For each story item taken, a row is presented in the Story Recorder panel, the most recent 
indicated with Recording...

When the show is over, an instruction in the last template of the show will automatically 
pause the recording (see section Automatic Pause at Show End of topic Story Recorder Mode
in the Viz Mosart Administrator Guide). 
If an automatic pause has not been set, click the PAUSE button in Story Recorder panel or the 
Pause keyboard shortcut.

Note: Keep in mind that once switched on and the show started, Story Recorder will begin 
consuming considerable storage, recording all the media used for your ongoing show that 
is fed to PGM.



Tip: If Story Recorder fails to start up, please refer to the Troubleshooting and 
Housekeeping section.



Tip: For a quick guide to what is displayed in Story Recorder, refer back to the 
illustration The Story Recorder Panel.



https://docs.vizrt.com/viz-mosart
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(Optional) provide an alternative name for the final clip by changing the pre-populated field 
in the SR panel:

Click the Broadcast button.
A confirmation message and counter indicate that the clip has been sent for stitching.

Disable Story Recorder with the On/Off switch at the top left of the panel.

Pause-Fix-Retake Mode
The standard use of Story Recorder is where you wish to pause an ongoing show recording, make 
a correction to the production, then resume from the pause.

To Record A Show With Pause-Fix-Retake

Initiate recording as described in the first 4 steps of To record a show as a single clip above.
Press PAUSE to interrupt recording as required.

In the Story Recorder panel, the current story item is marked as Paused.
In Rundown view above, the corresponding rundown story title is also blue.

Note: The name displayed can be collected from the NRCS, as a characteristic of the 
first (Break) story. If not, Viz Mosart automatically inserts a name, based on the 
rundown name.



Note: The counter indicates the number of EDLs currently being stitched on the EDL 
transcoder. Each time you click Broadcast, a new task is sent. See also Broadcast
below.
If you accidentally order the same stitching operation multiple times (by pressing 
Broadcast more than once for your required recording), you can cancel the 
transcoding job by reviewing the job queue on the transcoder. Your System 
Administrator can assist with this task. 
The counter is cumulative per recording session, and does not decrease once the 
stitching job has finished or been cancelled on the EDL transcoder side.


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In the Rundown view, on the story row, a pre-roll template is automatically inserted 
before the paused story item.

Make required changes and prepare to recommence recording, by clicking the PAUSED
button.
A countdown timer cues for retake and recording resumes from the break point.

Continue as above till the last story line, where an information text warns that the show 
recording will soon be complete.
Reviewing the Cut
(Optional) When resuming after a pause, approximately 10-15 seconds into the new 
recording, a snippet featuring the previous cut is available for review.

Click the Play icon to start view.
When the show is over, an instruction in the last template of the show will automatically 
pause the recording if configured so (see section Configure template for automatic pause of 
the show in the topic Story Recorder Mode of the Mosart Administrator Guide). Otherwise, 
click PAUSE button in Story Recorder panel or the Pause keyboard shortcut.
(Optional) provide an alternative name for the final clip by changing the pre-populated field 
in the Story Recorder panel:

http://docs.vizrt.com/viz-mosart.html
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Click the Broadcast button.
A confirmation message and counter indicate that the clip has been sent for stitching.

Disable Story Recorder with the On/Off switch at the top left of the Story Recorder panel.

Broadcasting an Alternative Version of the Show
Broadcast means generating a show-level EDL, from the list of story rows in the Story Recorder 
panel. 

This EDL is generated into the EDL transcoder (Vantage) watch folder. The EDL transcoder will then 
pick up the EDL file and start the job of stitching the clips that represent the story rows, into a 
single show clip. This single clip is used for playout.

You can broadcast at any time, during a paused recording, and then continue recording.
This might be when a trailer, or a second language variant of the show, or when in the 
afternoon you want only to change the last couple of stories from the morning's recording.

Similarly, you can append additional rundown rows to a completed, paused show.
Use the Tools > Arrange rundowns menu, as described in the topic Arrange Rundowns. 

In these scenarios, you must always create a retake point in the story prior to the change or 
addition.

Rolling Back in Time at Retake
The smallest rollback is a Viz Mosart primary story item. A story row usually comprises several 
story items, each item defined with a Viz Mosart primary template. 
So for example, if your running show is executing item three of the four primary items that make 
up the story, then the pause will cause a rollback to the start of item three.

Note: The name displayed can be collected from the NRCS, as a characteristic of the 
first (Break) story. If not, Viz Mosart automatically inserts a name, based on the 
rundown name.



Note: The counter indicates the total number of stitching tasks started on the EDL 
transcoder for the current recording session. Each time you click Broadcast, a new 
task is sent. See also Broadcast below.
If you accidentally order the same stitching operation multiple times (by pressing 
Broadcast more than once for your required recording), you can cancel the 
transcoding job by reviewing the job queue on the transcoder. Your System 
Administrator can assist with this task. 
The counter is not decreased if the stitching job has finished or this has been 
cancelled on the EDL transcoder side.


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A retake point is always at the start of a primary item, regardless of where the pause was made.

Pre-roll
When you pause a story, Viz Mosart automatically inserts a pre-roll event in the story row, before 
your paused story item.

The duration of this pre-roll is configurable, usually around 10-15 seconds. The pre-roll period 
provides the system time to automatically initialize itself back to a stable, known status for all 
equipment like robotic camera positions, onscreen graphic elements, media clip availability, fader 
levels. It also provides a cue for the talent to prepare for beginning again.

Critically, the pre-roll period can never be less than the time the video server hardware requires to 
prepare for recording. This is typically 10-15 seconds.

You can configure the pre-roll time from the Story Recorder panel:

Timing Details
The Mosart UI has been extended with support for Story Recorder related time fields.

The Story Recorder panel displays the following new timing details:

The Recording Time field starts at zero when a Story Recorder session is started, and

When the timeline is running, this counter is continuously growing, equal to the sum of the 
already recorded sections + the duration of the current recording.
When timeline is paused, this counter is static, equal to the sum of the recordings prior to 
the selected Retake Point.

Currently, it is not possible to replace a specific recorded story item. All the recorded story 
items after the retake point, including the story item set as retake point, must be re-done 
once the show is restarted after a pause.


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The Show Countdown displays the difference between the planned duration as defined in NRCS 
and the Recording Time.

When the timeline is running, this is counting down.
When the timeline is paused, this is static.

If the Recording Time exceeds the Show Planned Duration, this will become negative and will be 
counting up.

The Rundown over/under field is an existing field in the Viz Mosart UI, and when Story Recorder 
mode is enabled, it provides an indication of the executed recordings relative to the remaining 
rundown and the planned duration of the rundown:

Under: indicates the number of seconds the show must be extended to meet the planned 
duration.
Over: indicates the number of seconds the show exceeds the planned duration.

All these Story Recorder related time fields are also shown in the Mosart Timing Display and 
forwarded to the Plura Timing System (using the Time Request Protocol).
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2.16.4 Troubleshooting and Housekeeping

Troubleshooting
Invalid Retake Position
Error when Pausing the Story
Naming of Final Clip Show from NRCS not appearing in Story Recorder UI
Recording not Starting

Housekeeping
Limitations

Troubleshooting
If the recording session does not function as expected, Story Recorder reports errors and warnings 
at the top of the Story Recorder panel. 

Invalid Retake Position
If you get the error notification Retake position no longer valid. Please set retake point this means 
that you restarted the show after a pause, but the selected story item is not the retake point (the 
story item with the Set Retake button):

To fix, do one of the followings:

Select the current retake point (if this has changed by mistake) 
or
Make the selected story item the new retake point by clicking the row's Set Retake button.

If you choose (2), remember that all the recorded story items after the retake point, 
including the story item set as retake point, must be re-done once the show is restarted 
after pause (see Working with Story Recorder).


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Error when Pausing the Story
If you get the error notification Timeline can not be paused while pre-rolling, this means you are 
trying to pause while the system is in pre-roll mode. The pre-roll process can not be interrupted.

If this action was done intentionally, let the pre-roll time-out and auto-take the item to be retaken, 
and then pause again.

Naming of Final Clip Show from NRCS not appearing in Story Recorder UI
The naming is not displayed in the Story Recorder panel. Some alternatives are:

The name is read from the first story in the NRCS rundown. Check the status of the first 
story.
If for example it has been set to float, and is not displayed in Viz Mosart, you will need to 
add the name to whatever story in the NRCS is now the first story.

If the Show Final Clip name was changed in NRCS during a Story Recorder session, this will 
be taken into consideration only at the next Story Recorder session (disable Story Recorder 
mode and enable again for a new show).

Recording not Starting
If when you start recording, you get
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this means that the pre-roll time is not long enough for the recording hardware to prepare itself 
for recording your story.

At the top of the Story Recorder panel, try increasing the value of Preroll (seconds) to a value 
big enough for the recording to start plus 1-2 seconds extra (typically 10-15 seconds in 
total). 

Housekeeping
You must create a separate, dedicated template set for shows that use Story Recorder. These 
templates cannot be used when Viz Mosart runs in non-Story Recorder mode.
Viz Mosart can be configured to automatically purge the locally stored EDL data. At initial 
setup, the default is no housekeeping. The file purging scheme is actively managed by your 
local System Administrator. 
When you reload a rundown, you do not loose the current Story Recorder session (simply 
switch off SR to disable it).
All settings, like Pre-roll duration and where files are saved, are preserved between sessions.

Limitations
You can only retake from the beginning of a primary story item. In addition, the following 
story elements and secondary items will give unpredictable results around the cut point, and 
must be carefully reviewed:

Accessories
Manual commands
Running animated graphics
State variant behavior.

Due to timing differences in the execution of the templates for a Story Recorder show (Viz 
Mosart runs in Frame Accurate mode, not Standard mode) , not every feature from Standard 
mode is available or possible in Story Recorder.

Tip: Use the snippet player to verify the cut point (see Reviewing the Cut). 
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2.17 Recalling A Workspace/Keyboard Layout By Control 
Command From A Template

A work space and keyboard layout can be recalled with a control command. This control command 
can be added to a template.
This could be, for example, a BREAK that is invoked at the beginning of a show.

In AVAutomation, select Template Editor.
From the Template properties dialog, select the Control Commands tab.
Under the Command column drop-down menu, select GUI.
Under the Value column drop-down menu, select WORKSPACE.
In the Parameter column, enter the name of the Workspace (the naming must exist in the Viz 
Mosart UI).



Viz Mosart User Guide -  5.6

Copyright © 2024  Vizrt                                                          Page  70

1.

2.

3.

2.18 Sourceview With Template Router Source Assignment
The Template Router can be used for controlling ME steps on the vision mixer. The MEs can be 
routed to external sources like a wall or studio monitors.

For each source that might get routed to the ME create a LIVE template source. In this 
example LIVE 1, LIVE 2, LIVE 3 is used.
For each output a template router accessory has to be created for each ME. e.g. ME1, ME2, 
ME3.

Create a template router shortcut for each ME template. e.g. ME1, ME2 and ME3.

Note: This is a specific example, for general use of the these features, see sections 
 Sourceview and Template Router.


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2.19 Quick Access To Ad Hoc Assets
Quick Access provides dynamic and flexible power to a show with an ad hoc stories or late 
changes.

2.19.1 The Quick Access Panel
In the Quick Access panel, you can create filters that only display certain elements from the 
rundown. This enables rapid selection of an specific item, without having to scroll through the 
rundown.

This section provides some examples of using Quick Access for an ad hoc show.

The Quick Access Panel

There are two methods for working with Quick Access.

From a floating menu, the Quick Access Panel.
From the Quick Access tab in the Media Pool.

Quick Access Panel Operations

To access the Quick Access
From the Viz Mosart menu bar navigate to
View > Floating windows > Quick Access Panel.

Locating Missing Clips or Graphics
You can trap rundown items with missing clips or graphics.

To locate missing media elements
Open the Quick Access panel.

For preparation, look and feel and all non-showtime operations, see the User Interface 
topic, Quick Access Panel.


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Mouse-over any of the Filter buttons and right-click, to display a context menu.

In the Items section, enable the following options:
Show Templatetypes: PACKAGE, VO, GRAPHICS, DVE
Show items with status: Invalid

Finding Invalid Templates

To locate an invalid template
Open the Quick Access panel.
Mouse-over any of the Filter buttons and right-click, to display a context menu.
In the Items section, enable the following option:
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Show items with templatestatus: Invalid

Use the new Inv filter button to list invalid templates.

Favorites Pool
The Favorites Pool reflects the content of the Media Pool Favorites tab.

To reveal the Favorites Pool
On the right of the QAP, click the arrow by the vertical text Favorites Pool.

Planning Ahead: Moving specific items to the Favorites Pool
During a ad-hoc show, an upcoming story might require several templates. If there are a lot of 
graphic in the rundown that the operator wants to use, they can save them to the Favorites Pool 
for easy access prior to the story.



Viz Mosart User Guide -  5.6

Copyright © 2024  Vizrt                                                          Page  75

1.

2.

To add items to the Favorites Pool
Open the Favorites Pool can by clicking the bar on the right side of the panel.

Here you can select from the left side and add to the pool using the + button at the top of 
the favorites panel.
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3 Viz Mosart User Interface
The Viz Mosart GUI (Multi GUI) is the main control interface for operators and can be customized 
to suit your workflow.

You run the GUI either on the Mosart server or with one or more GUIs connected over 
the Mosart server network.
A common customization is having user action shortcuts on a separate touch-enabled 
screen, detaching the keys to a floating window.
View > Floating windows > Function buttons.

The areas of the Viz Mosart GUI are described in the following sections:

Main Menu
Rundown View

Quick Editor
Program Window
Preview Window
Transition Panel

Audio Function Area
Video Transition Area

Media Pool
Script Window
Keyboard Shortcuts
Status Bar

In addition, the following editors/panels can also be opened or configured as part of the layout:

General Settings
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Arrange Rundowns
Managing Your Workspace
Robotic Cameras
Quick Access Panel
Template Router
Recording
Source View
MSE Playlist Panel
Story Recorder Panel
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3.1 Main Menu
The main menu is located at the top of the Viz Mosart user interface, providing access to different 
functions and windows.

The various options in the main menu are briefly described below. Some more detailed 
explanations are provided later in this section.

Rundowns
View
Studio Setups
Graphics Profiles
Standby
Connections
Tools
Help
Notifications

3.1.1 Rundowns
Viz Mosart's primary source for rundowns is the NCS. Viz Mosart also saves the rundown (as an 
XML file) on the Viz Mosart server. Viz Mosart automatically saves changes to the rundown, but the 
user may also save manually. To distinguish later versions of a rundown from the original, Viz 
Mosart appends a timestamp to the file name of any subsequent version. The user may also open 
a rundown from one of these files. The file rundown is mainly meant for debugging purposes, and 
not intended for on air productions.

The Rundowns item contains the following options:
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Open from file. Lists rundowns found in the folder mentioned above. Normally stored at C:
\Manus.

Refresh. Refreshes the list of available rundowns.
Between Refresh and Special there are eight menu options for 'today' (this and similar 
words not referring to the day of writing or the day of reading, but to the day of Viz 
Mosart use), yesterday, the day before yesterday, up to the day a week ago. The option 
names are the names of the days in the language of the user's computer. For each of 
these eight days, there is a sub-menu containing the timestamped rundown files saved 
on that day. (If none, there is no sub-menu.)

Special. Lists the non-timestamped rundown files.
Save as. Saves the current rundown with a new name in the window that opens.

Save. Saves the current rundown.

Rehearsal. Enables rehearsal mode when selected. Click Rehearsal again to switch back 
to On Air mode. See Rehearsal and On Air Mode.

Arrange. Opens the Arrange rundowns  panel.
Lock rundown. Locks the rundown. 
See Locking a Rundown or Story.

Note: Do not include an underscore ('_') in the name.

 Note: By default, the location where rundowns are saved is C:\manus, but this may 
be overridden by the Manus Directory setting in the Settings Editor for 
either iNews or MOS.)



Info: Between Rehearsal and Arrange there may be additional options depending on 
the connected NRCS and on what has been configured in Tools > Edit rundown 
shortcuts . For more information, see Managing NRCS Rundowns.



https://docs.vizrt.com/viz-mosart-admin-guide/3.9/Settings_Editor_-_iNews.html
https://docs.vizrt.com/viz-mosart-admin-guide/3.9/Settings_Editor_-_MOS.html
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3.1.2 View

 

The View item contains the following options and sub-options:

Save as new workspace. Saves the current view/workspace with a new name in the window 
that opens.
Save workspace. Saves the current view/workspace. 
Workspaces. Selects from the available workspaces.

Manage workspaces. Opens the Manage workspaces window.
Keyboard shortcuts. Determines which Keyboard Layout to be used.
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Browse mode. Activates/deactivates Browse mode. For more information see Running 
Viz Mosart in browse mode. The appearance of this option is controlled in General 
Settings accessed from the Tools menu. 
Floating windows. Lists both the different parts of the main window that can be released as 
separate windows, as well as windows that can be opened that are not part of the main 
window:

Releasing Windows 
Function buttons. Releases the Keyboard buttons panel. See Keyboard Shortcuts. 
Story script. Releases the Script panel. See Story Script Window. 
Preview program. Releases the Program, Transition and Preview panels. See Program 
Window, Preview Window, Video Transition Area and Audio Function Area.   
Timeline. Releases the Rundown panel. See Rundown View.
Media pool. Releases the Media pool panel. See Media Pool.

Opening Windows  
Story script - Web. Displays a web-based, read-only view of the Story Script Window.

Note: The 'eye' icon indicates a floated window.
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1.

a.

Timeline - Web. Displays a web-based, read-only timeline view of the rundown. See 
Rundown View.
Robotic cameras. Opens the Individual Camera Controller window. See Robotic 
Cameras. See also Camera Robotics in AV Automation in the Viz Mosart Administrator 
Guide.
Quick Access Panel. Opens the Quick Access Panel. See Quick Access Panel. 
Template Router. Opens the Video wall manager. See Template Router.
Playlist Panel. Opens a Media Sequence Engine (MSE) panel host. See section 
Configuring the MSE Playlist Panel in the Viz Mosart Administration Guide.
Sourceview. Opens a Sourceview panel. See Sourceview.

3.1.3 Studio Setups

Provides a drop down list of the studio setups. Identical to 'Template Sets' in AV Automation in the 
Template Editor. See topic Show Design and Template Editor > Working with Template Sets in the 
Viz Mosart Administration Guide.

3.1.4 Graphics Profiles

Provides a drop-down list of the graphics profiles. See the topic Overlay Graphics Configuration 
Property Tabs (under section Overlay Graphics Interface) in the Viz Mosart Administration Guide
for more information.   

3.1.5 Standby

The drop-down list has two purposes:

It lists the configured devices in AV Automation and Overlay Graphics Interface, with the 
current connection status.

Green is connected and active.

http://docs.vizrt.com/viz-mosart.html
https://docs.vizrt.com/viz-mosart.html
https://docs.vizrt.com/viz-mosart.html
https://docs.vizrt.com/viz-mosart.html
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Red means not connected.
Orange means in standby.

Enables setting selected devices in and out of a standby state. Standby means the device is 
no longer under control of Viz Mosart; no commands will be sent to it from Mosart. 
During a production, this typically occurs when the device is no longer needed and can 
instead be used for other purposes (under manual control).

Usage Notes
Standby state selection for a device is not changed if you switch to another GUI or switch to 
the backup Viz Mosart server.
Standby state selection will also be kept if you need to restart the Viz Mosart server while 
keeping the GUI running. This ensures that any such recovery actions will not interfere with 
the devices that are in standby, so that one does not risk that a Mosart problem impacts 
other devices than the ones that are currently under control by Mosart.
In AV Automation, it is possible to configure devices to be in standby at startup. See the Viz 
Mosart Administration Guide section AV Automation Devices General > General, topic 
Standby at startup. In adherence of the above rule, these 'Standby at startup' selections are 
ignored if a Viz Mosart GUI is operational or if a backup Viz Mosart server is operational. 
Those settings thus only apply at a complete restart of all Viz Mosart applications.

3.1.6 Connections
Depending on the network setup, this item lists the main and backup server pairs configured in 
General Settings. The Status Bar updates when changing the connection. 

Note: The naming of these menu-driven operations in the Overlay Graphics Interface and 
the Viz Mosart UI, are not the same.



https://docs.vizrt.com/viz-mosart.html
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3.1.7 Tools

The Tools item contains the following options:

General settings. Opens the General settings dialog. See General Settings. 
Keyboard shortcuts editor.  Opens the Keyboard shortcuts editor. See Keyboard Shortcuts .
Import shortcuts from server. See Keyboard Shortcuts Editor (section Exporting and 
Importing Shortcuts from Server). 
Edit rundowns. Opens Edit Rundowns panel. See Managing NRCS Rundowns. This menu 
option only appears when having a connection to iNEWS. When using other newsrooms 
systems, the menu option is not visible.
Arrange rundowns. Opens the Arrange rundowns panel. See Arrange Rundowns.
Record. Opens a recording panel to create a new video recording. See Recording.

3.1.8 Help

The Help item contains the following options:
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License Configuration. Opens the License Configuration menu, intended for the Viz Mosart 
administrator. Please refer to the section Licensing in the Viz Mosart Administration Guide.
Viz Mosart User Guide. Opens (this) User Guide.
Viz Mosart Administrator Guide. Opens setup and configuration documentation intended for 
a Viz Mosart administrator.
About. Product version identifier and third party license details.

3.1.9 Notifications

The Notifications icon to the right also appears at the top of all menus. A red marker indicates an 
unread notification. 

Clicking the icon. Opens the Notification Box menu, listing important system messages that 
will usually require action.

 

https://docs.vizrt.com/viz-mosart.html
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3.2 Rundown View
The active rundown is displayed in Viz Mosart as a list of stories and a timeline made up of the 
templates and items that will execute chronologically as the story is played out. 

The details correspond to the content received from the NRCS and can be modified at any time by 
updates from the NRCS, or by manual edits from a Viz Mosart operator. 

Story and Timeline
Story Info
Timeline

Story Elements
Template Types: Primary Story Elements
Template Types: Secondary Story Elements

Additional Rundown Features
Story Editorial Time
Autotaking an Element
Effect Transitions
Timing Information
Mouse-over Rundown Info
Clip Status on Current and Mirror Server

Floating Windows
Timeline
Story Info

Mosart Web Apps
Rundown Viewer

3.2.1 Story and Timeline
Each story line consists of a Story info area to the left and a representation of the Viz Mosart 
templates and secondary elements (extracted from Viz Mosart commands in the NRCS), in the 
Timeline view to the right.
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2.

3.
4.
5.

Story Info
The left Titles and Timings area (also called Story Info area) displays the following details:

Top left hand corner: Estimated On Air time (11.53.23 in this example).
Timer in the middle of first line: When the story is on air, how long the story has been 
running.
Top right hand corner: The editorial duration of the entire story, as entered in the NRCS.
Second line: The story title as entered in the NRCS.
Red marking: The story currently on air.
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Yellow marking: The next story that will be taken to air.

Timeline
The Timeline provides a story-by-story chronological, controllable, real-time monitor of the current 
rundown.

For an explanation of the details presented in this view, and the operations available, see section 
Operating from the Rundown View.

3.2.2 Story Elements
Templates are represented in the right hand, Timeline area using color-coded elements. The length 
of each element reflects the calculated or exact duration of the template, depending on the 
template type.

An identifier in the top left corner denotes the variant name of the template type.
A story using a recognized template type but an invalid variant displays the variant title in 
red:
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When a story contains several elements with long duration, a vertical scroll bar appears to 
the right (one story will not display over more than four story rows in the Viz Mosart GUI).
Stories with no corresponding Viz Mosart commands appear as empty lines in the timeline.

Story elements are described in detail in the following sections:

Primary Story Elements
Secondary Story Elements
Further Rundown Features.

Template Types: Primary Story Elements
A story element corresponds with a Viz Mosart template type. From each basic template type, a 
show designer creates clones with show-specific commands. Each clone is called a variant. 

Camera
A Camera template is displayed as a green colored element in the GUI. The variant of the template 
type (often the camera number) appears in the top left hand corner. The duration of the template 
is automatically calculated based on the presenter's script as entered in the NRCS (see Story 
Editorial Time below).

Package
This template type is for playing (or recording) a video clip.
The package template type is displayed as a light blue element in the GUI. The variant identifier 
appears in the top left hand corner. The length of the package element is calculated from the 
actual clip length, if available on the video server.

Keyframes

In some systems, Keyframe markers are displayed with grey semicolon markers:

•

•

Error Situations

Note!
If the package clip is not available from the video server , the template 
representation appears with a blue/red checkered pattern.
Similarly, placeholder clips are displayed with a white/blue-checkered pattern.
Zebra-stripes mean that the video server has failed to cue clip for playing.


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Voiceover
A Voiceover template is displayed as a light blue and green element in the GUI. The variant of the 
template type is indicated in the top left hand corner of the colored element. The small notch in 
the green bar shows the calculated duration of the presenter text. The light blue represents the 
clip as with the server template type and the green represents presenter text as with the camera 
template type. If the clip is not available from the server, the clip section of the element has a 
checkered pattern.

The length of the voiceover element is calculated from the actual clip length when available on 
server.

 

Live/external Source
A Live template is displayed as a red element in the GUI. The variant of the template type is 
indicated in the top left hand corner of the colored element.

Graphics
A Full screen graphics template is displayed as a yellow element in the GUI. The variant of the 
template type is indicated in the top left hand corner of the colored element. Duration of the 
element is timed from the presenter text entered in the NRCS.
For graphics systems which support this feature, the element has a checkered pattern if the 
attached graphics content is not available for playout from the graphics system.

Digital Video Effect (DVE)
A DVE template is displayed as a yellow and red element in the GUI. The variant of the DVE 
template type is indicated in the top left hand corner of the colored element.

Note: If back-to-back full screen graphics are within in the same story (and use the same 
engine), the scene is not retaken for each graphic, but just kept playing. As the show 
advances, and one story is left, a new story entered, the graphics are taken again (the 
engines are ejected) so that any other graphics that are using the same engine are taken 
normally.


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Telephone
A Telephone interview type is displayed as a yellow and white element in the GUI. The variant of 
the template type is indicated in the top left hand corner of the colored element.

AdLib Pictures/Floats
An Adlib pictures template is represented by a symbol at the right end of the story line on the 
timeline. If the associated media object is not on the server, the symbol is checkered.

 

The element also appears in the Assets window as a colored slug with a green top half and light 
blue bottom half for clips, and orange bottom half for graphics. They can be taken on air or to 
preview either by right-clicking and using the context menu in the Timeline or the Assets pane.

 
Adlib picture templates adds the audio faders specified in the template to the current audio fader 
set. The faders are subtracted when returning from the Adlib pictures. Adlib pictures are typically 
used in live external or studio interviews.

Adlib pictures pause when it is taken off air. If the Adlib picture is inserted again, the clip 
continues from the paused point.
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Break
A Break/continuity template is displayed as a white element. The break story is the default start 
and end-point of the show from which total show timers are made. Break templates can also be 
used for commercial breaks, when master control takes over.

Other Primary templates

Jingle

Video Wall

Template Types: Secondary Story Elements

Overlay Graphics
An Overlay graphics (lower third) is shown as a yellow secondary element. Secondary elements 
appear on top of primary elements and are executed relative to the primary template. The 
secondary element is scaled to the duration of the lower third element, set in the NRCS.

 
Different types of overlay graphics with separate handlers in the Overlay Graphics application, 
such as lower thirds, wall elements or OSGs, can be displayed on different lower third levels.

 

 
See General Settings for details on setup.

Take In

Take-in of lower third elements may be performed either manually or automatically by Viz Mosart.

Automatic: If an in-time is set in the NRCS for the lower third, Viz Mosart automatically takes 
it in.
Manual: If no time-in is set in the NRCS for the lower third, Viz Mosart marks it as a manual 
lower third. These elements are displayed on the right hand side of the GUI window, and can 
be executed in the same way as adlib pictures.

Take Out

Take out of lower thirds can be performed in four ways. Each are displayed differently in the Viz 
Mosart GUI:

AUTOOUT: Is taken in and taken out automatically from the in-time and duration or out-time 
set in the NRCS
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BACKGROUNDEND: Is taken in automatically as defined in the NRCS and taken out 
together with the primary element to which it is attached.

 STORYEND: Is taken in automatically as defined in the NRCS and taken out when the 
story it is attached to is taken off air.

OPENEND: Is taken in automatically as defined in the NRCS and is not taken out until 
the operator takes it out.

Audio Play
An Audio Player secondary element is displayed as a small speaker symbol on top of a primary 
template. Its position represents the time code given in the NRCS. The audio starts to play when 
the timeline reaches this position. If no in-time is defined for the sound, it appears as a manual 
element in the symbol in the right hand area of the rundown (where manual lower thirds and 
adlibs are shown).

Accessory Elements
Accessory secondary elements are usually displayed as a small, black background plus (+) icon, on 

top of its primary template . 
However, the icon will change slightly to reflect the content type driven from the newsroom 
system. For example, if the Accessory item holds Viz Arc related content (in this example, three 
items), the icons are visualized as follows: 

Taking an Accessory element

There are two ways to use an Accessory element. This relates to how they are taken:

Automatic: (timecode driven) The element's display position represents the timecode 
provided in the NRCS. The Accessory item is taken when the timeline reaches the accessory 
icon.
Manual: If no in-time is defined for the Accessory item, it is displayed as a manual element, 
with its icon to the right of the rundown, similar to where manual lower thirds and adlibs are 
displayed.

Tip: Mouse-over an Accessory element (manual or automatic) to see further details. 
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Example of Accessory Elements in a Rundown

Color coding

Black background: Normal, the element is available.
Red background: The Accessory template does not exist/is unavailable or an error is 
reported related to the content.
Checkerboard background: Content is not available (for example, with clips or full screen 
graphics)
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Other Secondary Templates
Sequence

3.2.3 Additional Rundown Features

Story Editorial Time
The story planned duration (editorial time) entered in the NRCS is indicated by a grey marker on a 
story element or after the last story element.

Autotaking an Element
If a primary story element is programmed with autotake next, this is indicated at the end of that 
element with a black triangular symbol.
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Any element e1 following immediately any element e2 based on that template, will be taken 
automatically when e2 is 'finished'.

Effect Transitions
If an element is set to use an effect transition (either defined from the NRCS or the Template 
Editor), this is indicated with a black and white symbol.

Timing Information
At the top of the rundown view, there are indicators at every 30 second mark. Vertical lines across 
the timeline indicate every second, broader lines every ten seconds.

Mouse-over Rundown Info
Hovering the mouse pointer over an element in the rundown displays the NRCS script and timed 
commands connected with the story element.

 
In this example, mousing-over the Camera 1 element displays the transition which is used going 
into the template: A four frame mix and the template variant 1.
In addition, the entire script written into the NRCS story connected with this template is visible, 
along with details of a secondary Accessory template element.

Clip Status on Current and Mirror Server
When a current-mirror server pair is employed for redundancy, a clip will be either available or 
unavailable on each server in the pair. 
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Color coding and patterns of the corresponding Package template, report the status of the clip on 
each server, guiding the operator to switch to the the server where the clip is available.

Appearance of Package 
template

Clip status

Blue Current server: Available

Mirror server: Available
(See A30 below). This blue template representation appears in the 
Script, Rundown and Asset panes.

The coloring is also displayed in any mouse-over Tool tip.
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Appearance of Package 
template

Clip status

Blue / Gray  Current server: Available

Mirror server: Unavailable

(See A31 below). This blue/gray template representation appears 
in the Script, Rundown and Asset panes.

 
The coloring is also displayed in any mouse-over Tool tip.

In the Script and Tooltip panes (see above)

the label CURRENT has a blue background, this is the server 
with the clip available.
the label MIRROR has a red on blue checkered background. 
Do not switch to this server, the clip is unavailable!
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Appearance of Package 
template

Clip status

Red on Blue checkered Current server: Unavailable

Mirror server: Available

(See A15 below). This blue/red template representation appears 
in the Script, Rundown and Asset panes.

The coloring is also displayed in any mouse-over Tool tip.

In the Script and Tooltip panes (see above)

the label MIRROR has a blue background, this is the server 
with the clip available.
the label CURRENT has a red on blue checkered 
background. 
Switch to MIRROR, the clip is unavailable on this (CURRENT) 
server!
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Appearance of Package 
template

Clip status

Blue on Red checkered Current server: Unavailable

Mirror server: Unavailable

(See A10 below). This blue/red template representation appears 
in the Script, Rundown and Asset panes.

The coloring is also displayed in any mouse-over Tool tip.

This is a potential failure situation that must be addressed, as the 
clip is not available for playout!

3.2.4 Floating Windows

Timeline
You can open the Timeline as a separate window, either fully operational or as a read-only copy.

To float the Timeline window
All operations are available from the floated window.
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a.

b.

a.

From the menu bar select View > Floating windows > Timeline.

Position the floating window by dragging its menu bar and adjustable frame handles.

To view the Timeline window in a web browser
You can display a read-only copy of the Timeline, floating as a web-based window.

From the menu bar, select View > Floating windows > Timeline - Web.
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b.

a.

b.

Position the floating window by dragging its menu bar and adjustable frame handles.

Story Info
You can open the Story Info floated as a separate fully operational window or as a read-only copy.

To float the Story script window
All operations are available from the floated window.

From the menu bar, select View > Floating windows > Story script.

Position the floating window by dragging its menu bar and adjustable frame handles.

Tip: A superior, scalable read-only view, is offered by viewing these details as a separate 
web browser app. See Mosart Web Apps below.


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a.

b.

To view the Story script in a web browser
You can display a read-only copy of the Story script, floating as a web-based window.

From the menu bar, select View > Floating windows > Story script - Web.

Position the floating window by dragging its menu bar and adjustable frame handles.

3.2.5 Mosart Web Apps
As part of a modernization and optimization improvements to Viz Mosart, much of the existing Viz 
Mosart feature set is now being offered as simple Web Apps, that run on any browser in the Mosart 
network.

Rundown Viewer
The Mosart web App Rundown Viewer displays both Timeline and Story Info. 

To view rundown details in a web browser
As a useful extension to a floating window, you can also view the current rundown details as a 
scalable read-only display of the Story info and Timeline, in a separate Mosart Web App.

Tip: A superior, scalable read-only view, is offered by viewing story details in a separate 
web browser app Rundown viewer. See Mosart Web Apps below.


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This view offers advantages in readability and clarity when monitoring the ongoing show.
Compare the scalable App view below, where all item details are readable, with the floating 
Timeline - Web view above.

This view is available on any device that is connected to the Mosart server.

Note: The view runs as an app in your web browser, requiring an additional once-
only installation as explained in Mosart Web Apps - Rundown Viewer.



https://docs.vizrt.com/viz-mosart-webapps/1.6/Mosart_Rundown_Viewer.html
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3.2.6 Quick Editor
The Quick Editor provides a convenient method for modifying template characteristics in a 
rundown story. For example, when you decide to perform the next studio shot in Cam 2 instead of 
Cam 3.

Quick Editor Operations
Usage Notes
Working with the Quick Editor

Opening the Quick Editor
Closing your Quick Edit Session

Story Template Operations
To Remove a Story Item
To Replace a Story Item
To Insert a Story Item
To Insert a Story Item at the end of the Story
To Search for a Template Variant

Quick Editor Operations
After double-clicking a template you can:

Change the type: Delete, replace, and insert primary elements (for example, Camera)
Change the variant: Delete and replace accessories, delete lower thirds
Delete the entire template
Insert a new template directly after the current one.

Template types Camera, Package, Voice over, Float, Live, Graphics, DVE, Telephone, Break
and Jingle are supported as primary story items in the Quick Editor.

Usage Notes
Changes made from this menu are not persistent. Modifications made with the Quick 
Editor get deleted whenever the rundown is updated by the NRCS.

As Quick Edit story modifications, get deleted with every NRCS update, it is 
recommended to lock the rundown/story. See Locking a Rundown or Story.


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When using a predefined template set from the NRCS, these are listed below the Remove
button (after double-clicking a template).
Only templates from their own set are shown in the Quick Editor.

Working with the Quick Editor

Opening the Quick Editor
There are several ways to get started:

Double-click the information area of a story, on a template or to the right of the last element 
in a story.
The Quick Editor opens:

Double-click on the right side of the last item in any story.
A minimized view of the Quick Editor opens:

Using this view, you can insert a new item at the end of the story. 
See To Insert a Story Item at the end of the Story below.
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Closing your Quick Edit Session
Just close the menu or click in the timeline.

Story Template Operations

To Remove a Story Item
Click Remove, the story item is removed.

To Replace a Story Item
Select the new template
Click Replace.

The previous template is replaced with the newly selected item.

To Insert a Story Item
Select the new template for insertion
Click Insert.

The new template is inserted after the selected item.

To Insert a Story Item at the end of the Story
Double-click on the right side of the last item in any story
Select a template type
Choose a variant
Click Insert.

To Search for a Template Variant
The Quick Editor Search field helps you locate a specific template. The search tool is not case 
sensitive. Some tips:

A space between keywords acts as a logical AND, enabling multiple keywords.
For example:

CAM VIDEO: Lists variants with both CAM and VIDEO in their name.
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CAM AUX 3: Lists variants with with all three namings  CAM, AUX and 3.

A + sign between keywords acts as a logical OR, enabling multiple keywords.
For example:

CAM+VIDEO: Lists variants that have CAM or VIDEO in their name.
CAM+AUX+3: Lists variants with any of the namings CAM, AUX or 3.

Combination of space and + (+ sign has a lower priority).
For example:

CAM+AUX 3: Lists variants that have CAM or AUX and 3 in the name.
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• CAM AUDIO+AUX 3: Lists variants that have CAM and Audio or AUX and 3 in the name.
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3.3 Program Window
The Program window is placed in the top right-hand corner of the Viz Mosart GUI, with details
about the currently running story element.

NDI® Program
Hiding Video Preview Types in Program

End Phrase
On-air Overlay Graphics
Template Continue Points
Timing Information
Continue Count
Auto Take Next
Key Select

Without Destination Panel
With Destination Panel
With Defined Template Destination Panel

Settings Menu
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3.3.1 NDI® Program
Choose NDI Program Preview by clicking the Settings cogwheel icon and selecting Select ndi 
program 
Then choose the NDI stream that represents the program output.

If an NDI workflow is not in use, a hardware converter device (for example SDI => NDI) can be used 
to add the program output as a NDI signal on the network. 
The stream becomes available in the drop down list, as shown below.

Hiding Video Preview Types in Program
You can hide the stream for certain template types.

Click the Settings cogwheel icon and select Hide video preview types in program
Check the types you want to hide from the list.

3.3.2 End Phrase
End phrase is shown across the bottom of the program window if the last words are available from 
the newsroom script.
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3.3.3 On-air Overlay Graphics
The overlay graphics currently On Air are displayed in a list at the bottom of the control. 

If more than two overlay graphics are on air at the same time, the operator can scroll up and 
down the list with a mouse wheel arrow keys.
Overlays can be taken off air by right-clicking them in the list and selecting Take out.

3.3.4 Template Continue Points
When a Viz Mosart template with built-in continue points goes on air, the descriptive text from the 
template design is displayed.

Use the keyboard shortcut for Take Next (F12) to take the continue point.
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3.3.5 Timing Information

Timing information on the top of the control consists of four counters:

Counts the downtime to the next break.
Counts how much the rundown is over/under.
Counts down the remaining time for the current On Air template.

Once it reaches zero, the background color of the counter changes to red and the 
timer starts counting upwards with a + sign.
Optional: By setting the Clip visual countdown (Tools > General Settings > User 
Interface > Preview/Program window > Program) to a value above 5, the countdown of 
PACKAGE and VOICEOVER templates changes to purple to alert the user when the 
countdown reaches this value. 
Example: If this setting has a value of 10, the counter when running a clip changes 
color as follows:

Shows the duration of the current On Air template.

3.3.6 Continue Count
The number of remaining continue points in the full-screen graphics is displayed in 
the Program window.

3.3.7 Auto Take Next
The auto take next label signals that the Viz Mosart rundown is currently in automatic
mode. Meaning that when the template on air reaches its out-point, the consecutive 
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template is taken to air automatically. When the last template in the rundown goes to air, the 
very first template in the rundown will be queued in preview, and taken as the next item. 
Consequently, this feature allows for automatic playout within the rundown, and a looping 
mechanism of the rundown. Default keyboard shortcut is CTRL+SHIFT+A.

3.3.8 Key Select
A template allows key select if it contains newsroom tags that are related to crosspoints in:

video switcher inputs
audio mixer inputs
video switcher effects
router sources
router destinations.

There are different ways to edit these keys while On Air or in Preview. With the destination panel 
and sourceview workflow mentioned below it is currently only possible to edit video switcher 
inputs.

Without Destination Panel
If a crosspoint is selected and newsroom tags are defined in the template, the program 
window shows a drop-down menu of the crosspoints.

Note: Autotake is available for primary templates only. An offset (in frames) can be set 
when Autotake is enabled to adjust the continue action at the end of the event.  See 
Template Properties in the Viz Mosart Administration Guide for more details. 



Note: These are normally set in the NCS, but can be modified in Viz Mosart before or while 
On Air.


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The user can, for example, change the keyfill crosspoint while on air.

With Destination Panel
Navigate to the Destination panel: AVAutomation > Template Editor > Template Properties.

Here you can create sources for sending to target areas (video switcher inputs in a DVE).
If Destination panel option is enabled and the template has newsroom tags and a configured 
destination panel configured, but no video, a background thumbnail defined in the template is 
used instead.
Or, if no thumbnail is selected it is transparent with the main template color as background.

With Defined Template Destination Panel 
The target areas can be filled with a selected template or sourceview source of type stream . If a 
template is used the video switcher input crosspoint will be retrieved from the template.

Template sources can be found in Keyboard shortcuts, Quick Access Panel
Stream sources can be used from sourceview. 
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The illustration below shows the side-by side option (with NDI sources) that is used whenever the 
width of the Program/Preview control is wide enough.

Click on a source.
The Preview/Program panel displays a dotted line around potential destinations.
To assign the destination in the template to use the selected input source, click on a 
destination.

3.3.9 Settings Menu
The Settings menu can be reached by clicking the Setting cogwheel icon to the right of Program 
control

Settings are the same as those found in General settings > User Interface > Preview/Program 
Window > Program. Any changes are reflected in General settings.

Note: For this feature to be available, the Template Destination panel must first be 
configured in Template Editor > Properties > Destination.


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Show onair overlay graphics: When this is checked, overlay graphics are displayed in the 
Program window when they go on air.
Hide video preview types in program: A selectable list of template types that should not 
display the preview video. 
Clip visual countdown: A list of options for countdown to be used when counting down to 
clips. 
Will change the color of the countdown when the values becomes less than the specified 
value. 0 will disable this option. See Timing Information
Select ndi program: If any NDI sources are available on the network, you can choose a source 
here.
The source will be set as the program preview source in General settings.  (  not available 
in General settings). 
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3.4 Preview Window
This window displays information about the next story element.

NDI® Preview
Lower Thirds
Adjust Video Clip in/Out Points
Timing Information
Cued Playout Port/Graphics Engine
Recue Server
Key Select
Settings Menu

3.4.1 NDI® Preview 
You can set NDI Program Preview from the Tools wheel by selecting Select ndi preview and the 
required NDI stream that represents the program output.

If an NDI workflow is not in use, you can add a hardware converter device (for example, SDI => 
NDI) that will add the preview output as an NDI signal on the network. The stream then becomes 
available in the NDI preview drop-down list, as shown below.
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Hiding Video Preview Types in Preview
It is possible to hide the stream for certain template types. Check the templates types you want to 
hide in this list.

3.4.2 Lower Thirds
Any previewed lower third graphic appears in a list at the bottom of the preview window 
until it goes On Air.

3.4.3 Adjust Video Clip in/Out Points
When the video server driver supports it, the operator can select a new in point and out point for 
video clips in the preview window.

Drag the left and right markers to the desired points
Dragging the in point marker causes corresponding scrubbing to occur on the server, 
allowing the operator visual preview of the new in point.

3.4.4 Timing Information
The number in the top right hand corner of the Preview window indicates the duration of the 
item currently in preview. 
The number to the right of the title indicates the clip duration of the clip currently in 
preview.
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3.4.5 Cued Playout Port/Graphics Engine
The alias of the port which the next clip is played out from is displayed in the top left hand 
corner of the preview window. 
This area is also used to display which full-screen graphics engine are used next.

3.4.6 Recue Server
By right clicking inside the Preview window, the operator can select to recue a server clip.
This is used, for example, to recue and play from the beginning an adlib/float element from 
its starting point, rather than the point it had previously reached.

3.4.7 Key Select
Key Select in preview works as in program but puts send content to the preview channel. 
See Program Window > Key Select. Here shown with the side-by side option that will be used if the 
width of the program\preview control becomes wide enough.

3.4.8 Settings Menu
The Settings menu is reached by clicking the Setting icon at the far right of the Preview control.
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These settings are the same as those found in General settings > User Interface > Preview/Program 
Window > Preview. 
Any changes made here are reflected in General settings.

Show next item update: When this is checked, a warning is displayed as small pair 
of footprints in the Preview window, whenever the story in preview is updated from the 
NRCS.

Hide video preview types in preview: A selectable list of template types that should not 
display the preview video. 
Always hide mark in/out control: Hides the mark in/mark out selector that is displayed when 
a clip is in preview. (If unchecked, these selectors will be shown when a clip is in preview, 
otherwise not.)
Select ndi preview (  not available in General settings): If any NDI sources are available on 
the network it is possible to choose one of the sources from this menu. 
The source will be set as the preview video source in General settings.
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3.5 Video Transition Area

The transition area is positioned between the preview and program windows.

3.5.1 Hold Video Transition (HV)
Pressing Hold (HV) holds the video transition when the next template is called. Viz Mosart waits to 
do the video mixer crosspoint change until a new Take Next command is issued when the hold 
video transition is active.

In a situation where you have CAM 1 in program and a clip (PACKAGE) in preview and use the Take 
Next with Hold video transition, Viz Mosart handles all transitions between the two templates, 
except the vision mixer crosspoint change. Viz Mosart fades down the sound from the CAM 
element and fades up the sound from the clip. It starts to play the video on the assigned video 
port, and all secondary items with an in-time use the Take Next as the relative starting point.

The Viz Mosart GUI Program window notifies the user that the video transition is on hold,

and that the user needs to send a new Take Next to change the vision mixer crosspoint. This 
functionality can also be toggled to be auto-taken in a template or by a keyboard shortcut key.
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3.5.2 Next Transition (M,W,E)
The type of the next vision mixer transition is shown in the transition area by highlighting the 
corresponding transition icon. Available transition types are Mix (M), Wipe (W) and Effect (E). In the 
value field to the right of the transition type boxes, the duration of Mix (M) or Wipe (W) is shown. 
For Effect (E), the name of the effect is shown.

Mix (M) or Wipe (W)
The next vision mixer transition can be overridden by clicking on the corresponding transition icon 
in the transition area. For Mix (M) and Wipe (W) transitions, the duration of the transition (in 
frames) can be changed by clicking M or W, and then use the scroll-wheel, or right-click and drag 
up or down in the duration field.

Right click the Transition number to show some suggestions. The left column let the user increase 
or decrease the number. The right column have some transitions listed that the user can choose.

If a touch screen is used and the user touch and hold the transition area a similar menu will be 
shown, allowing the transition to be used on a touch based interface.

Effect (E)
Selecting Effect (E) and then clicking the empty square causes a drop-down menu to appear, 
containing the transition effects stored in AV Automation's A/V Setup.
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When Studio Setup is changed, the items in the drop-down are updated accordingly. For more 
information on configuring Studio Setup, see the Audio and Video Setup page in AV Automation
section of the Viz Mosart Administrator Guide.

The next transition type can also be selected by a TRANSITION TYPE control command. By default, 
this control command is assigned to the Tabulator key, which can then be used to cycle through 
the three transition types.

http://docs.vizrt.com/viz-mosart
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3.6 Audio Function Area

 
This area controls dedicated audio features. When a feature is active the button is blue. The audio 
controls are activated either by keyboard shortcuts or clicking directly on the buttons.

Audio Controls on the Viz mosart GUI
Hold Audio Transition
Keep Sound
Manual Fade Sound
Level 1 and Level 2

Audio Controls from Keyboard Shortcuts

3.6.1 Audio Controls on the Viz mosart GUI

Hold Audio Transition
Hold (HA) 
When this button is active, any audio transition is held, even when the next template is called. Viz 
Mosart waits with the audio mixer fader change until a new Take Next command is issued.

Example:

You have CAM 1 in Program and a clip (PACKAGE) in Preview and use the Take Next where Hold 
Audio is active. Viz Mosart will:

Make all scheduled transitions between the two templates except the audio mixer fader 
change.
Change the cross point on the vision mixer to the PACKAGE element. 
Start to play the video on the assigned video port
All secondary items with an in-time use the Take Next as the relative starting point.
In the Viz Mosart UI, the user is notified that the audio transition is on hold and that they 
need to send a new Take Next to perform the audio mixer fade.

Keep Sound
K
Clicking this button in the GUI retains current sound levels. This keeps the currently active audio 
faders and their levels, until deactivated (press K again).

Note: This functionality can also be toggled to be auto-taken in a template or by a 
keyboard shortcut key.


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All audio fader configurations in story commands are ignored as long as Keep Sound mode is 
active.  Mosart stops sending any commands to the audio mixer, until deactivated.

Manual Fade Sound
FM 
Selecting Manual Fade sound mode allows the operator to start an audio fade prior to the F12 to 
next element or after the F12 to the next element. 

To enable manual fading for the sound of the current story element, select the FM button.
The current on air set of audio faders are kept open throughout the next story until they are 
faded using the Fade Kept Audio (command FADE_OUT_KEEPS) keyboard shortcut (CTRL+F
by default), while the faders connected with templates in the next story are added to and 
subtracted from them.

To disable manual fading of sound, select the FM button again.
Sound will be faded on the next take. The duration of the fade in this case is set as a global 
value in AV Automation settings.

Sample workflow
A video clip contains music or other audio that the operator would like to fade nicely into the the 
next item in the rundown. This could be a promotional video clip with music towards the end of 
the clip, going into the studio with a Camera template as the next item.

The operator can click FM (or the keyboard shortcut) during the video clip, and the last few 
seconds (depending on the edited post roll for the clip) will fade out when mixing from the 
video clip to the camera.
If the clip has a particular long audio tail, the operator can fade out with keyboard shortcut 
CTRL+F (default) at the suitable time, to send command FADE_OUT_KEEPS.

Level 1 and Level 2
L2 L2 
Each Viz Mosart template can be configured with three audio level setups for the complete set of 
audio faders defined in the template.

Level 2 audio for Preview and On Air can be accessed from this Audio Function area in GUI with 
these buttons, L2 and L2, respectively.

Level 1 is set as default in a template,
Level 3 is the fader’s base On level (normally Out equals In). This one can be modified from 
the AV Automation application.

Pressing the L2 button or CTRL+L (default) toggles level 2 for all faders in the template cued in 
Preview. Level 2 is used when the previewed element is taken On Air with F12.

Note: By default, keyboard shortcut CTRL+K toggles Keep Sound mode.

Note: By default, keyboard shortcut CTRL+M toggles Manual Fade mode.
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Pressing the L2 button or SHIFT+CTRL+L (default) immediately uses level 2 for all faders in the 
template currently On Air.

3.6.2 Audio Controls from Keyboard Shortcuts
As an alternative to controlling audio from the Audio Function Area, you can set-up a keyboard 
shortcut that will send a command that performs the same task.

Defining keyboard shortcuts is performed prior to going on air, and is described in the Viz 
Mosart Administrator Guide, in section Control Command Keys, of the Keyboard Shortcuts
topic.

https://docs.vizrt.com/viz-mosart.html
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3.7 Media Pool
Use Media Pool for locating and managing media items for the rundown.  

This panel has four tabs: 

Assets Tab
Search Tab
Favorites Tab
Quick Access Tab

3.7.1 Assets Tab

The Assets tab displays assets for a selected story or group.

From the Asset tab, these elements can be used in several ways.

Note: Any assets from the selected story (or group of stories) that were manually added to 
the story in the Viz Mosart rundown (and are not present on the NRCS) are not displayed 
on the Assets tab.


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Elements can be dragged directly from the Assets tab and into the Rundown window to add 
and edit the currently loaded rundown.

Dragged elements are added at the point at which they are released - primary 
elements like lives or packages are inserted before or after another primary element, 
and secondary elements like lower thirds are added to the primary element on which 
they are dropped.
The elements are added to the rundown with the template type that it is entered in the 
NCS. Any modification to the rundown disappears on the next Reload or when the 
story is changed in the NCS, unless the story is locked.

Elements can be dragged to a shortcut button in the Shortcut Keys window, to be recalled 
later with a single keystroke. See Keyboard Shortcuts.
Elements can be dragged to the Favorites Tab  and stored for easy access.

The legends corresponding to the various template types and are customizable, see User Interface 
- Assets.

Hover-over Asset Details
Hovering the cursor over an item in the Assets tab displays more information about the 
item, including any secondary elements attached to it.

Context Menu
Right-clicking an element in the Assets tab displays a context menu as in the illustration below.

Note: You switch this feature on or off with the option Hide big tooltips in assets window, 
found under Tools > General settings >Assets.


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Clicking Take takes the element to air immediately.
For secondary elements with a duration Take OUT takes them Off Air again.
Clicking Preview adds the clicked primary element as the next story element in the rundown.
Clicking Edit opens the Viz Pilot Edge editor for last-minute changes.
Clicking Continue (if available) takes an element continue point.
Recue

Recue > Recue recues the video content of a template with video content that has 
been previously played. 
Recue > Recue and Preview also adds the template to the timeline in the next position.

In the Show Templatetypes context menu the operator can choose which Viz Mosart types 
are visible in the Assets tab (CAM, PACKAGE, VO, LIVE, GRAPHICS, DVE, JINGLE, TELEPHONE, 
FLOAT, LOWERTHIRD, SOUND, ACCESSORY). By default CAMERA and JINGLE is not shown.
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In the Sort by menu the user can select if the list should be sorted by template or timeline
order.

The View Preload option will preload any selected graphic.

3.7.2 Search Tab

The Search tab enables searches for clips on connected video servers. These can then be dragged 
onto shortcut buttons which have been predefined with a template designed to contain a video 
file. The search field is case sensitive.

Example:

Create a shortcut key for a Package type template which allows drop of content (for details 
see Keyboard Shortcuts). Then use the Search window to find a video file, and drag it onto 
the same button.
The video file is now executed within the template assigned to the button.
Additionally, elements can be dragged directly from the search window to shortcut keys and 
to the Media Pool and Rundown windows.

By default:

Dragging drops the file as a Adlibpix type with variant default.
SHIFT+drag drops it as a Package type with variant default.
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CTRL+drag drops it as a Voiceover type with variant default.

See General Settings > User Interface > Search pool  for more information on setting up this 
feature.

3.7.3 Favorites Tab

The Favorites tab   can be used to gather primary and secondary elements from several stories in 
the rundown, creating a temporary toolbox for the operator. Items in the Favorites tab have a 
context-sensitive (right-click) menu that offers similar functionality as the Assets tab.

Adding and Removing Elements

To Add Elements to the Favorites Tab
Select the story containing required elements (as shown in the Rundown window)
Drag the desired elements into the Favorites tab.

Note: In the illustration above, the appearance of the shared icon  , indicates that the 
favorites displayed on this Viz Mosart client (UI), are public and shared with all other Viz 
Mosart clients that are connected to the same Viz Mosart server.
See the description for Use public buttons, in section General Settings > User interface > 
Keyboard.


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To Remove an Element from the Favorites Tab
To remove a single element from the Favorites tab, mark the element, right-click and from 
the context menu, select Remove item.

To Remove all Elements from the Favorites Tab
To remove all collected elements from the Favorites tab, right-click on the tab header and 
select Clear Pool.

Working with Elements in the Favorites Tab
Elements saved on the Favorites tab can be:  

Dragged to a new place in the rundown
Dragged to shortcut keys, 
Directtake to air or to Preview, Take Out or Remove item through a right click context menu.

Context Menu
Right-click an element in the Favorites window, for a context menu.

Directtake takes the element straight to air immediately.
Preview adds the clicked primary element as the next story element in the rundown.
Remove item removes the item from the Favorites Tab. 
Take OUT takes the graphic out if it is on air (only works for graphics).

In addition:
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Hovering the cursor over an item in the Favorites tab displays more information about the 
item, including secondary elements attached to it.
Any item added to the favorites tab pool can also be found among the Quick Access 
Panel Pool favorites and vice versa.

3.7.4 Quick Access Tab
The Quick Access tab (QAT) gives the user yet another way to interact with the rundown, it 
potentially displays all the elements in the entire rundown but filters can be applied to only show 
the desired content.

The QAT is an enhancement of the Quick Access Panel and shares the filter functionality. Any 
filters applied to one of them are immediately applied to the other. It is possible to filter by type, 
status (On Air, preview, aired etc.), slug, story title, available, unavailable.

Elements can be dragged from this panel to anywhere in the rundown, and they are then 
attached to that story or item.
It is also possible to drag secondary elements directly onto any primary element.
Elements can be dragged to the neighboring Favorites Tab to be stored for easy access. 
They can also be dragged onto a Keyboard Shortcuts button in the shortcut keys window.

The context menu that appears when right-clicking on an element provides the same 
functionalities as described in the Assets Tab.

Operation
The QAT can be operated with keyboard and mouse. The configurable keyboard shortcuts control 
commands called QUICKEVENT should be used for optimal workflow. Both the mouse or keyboard 
can be used to select multiple items.
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By holding CTRL while using the mouse the item can be set as group-selected/unselected.
By using the the QUICKEVENT command NEXT_GROUP_ITEM, the user can step through the 
selected items.
Items can be taken to air or preview using the QUICKEVENT control command shortcuts.

The items can be grouped by story, or listed without showing the stories. In this example only 
the lower thirds are visible.

Story, item and sub-item on-air indication:

Lower thirds can be taken both On Air and Off Air. While they are On Air, the On Air indication 
is visible. All items in the list can be drag-and-dropped directly to the Favorites tab, Wall 
items, Timeline or Keyboard shortcuts.

It is possible to show and control all kinds of Viz Mosart elements in this view.

300
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3.8 Story Script Window
You can browse details of the stories in your rundown either directly in the Viz Mosart UI, or as a 
separate, repositionable floating window.

Story Script in the Viz Mosart UI
Story Script as a Floating Window

3.8.1 Story Script in the Viz Mosart UI
By default, the Story Script window presents the content of two stories. For example below:

The top half (sequence story) displays the On Air story, (or the first story that will go On Air), 
highlighted in red.
The bottom half (FS three continue points) shows the next story to go On Air, highlighted in 
orange.

If you select another story in the rundown, the Story Script window displays this selected story, not 
the next On Air story. The highlighting is then standard grey.
At the next F12 (which changes the On Air story), the Story Script window reverts to the default 
red/orange view. 

Story Content and Timing Information
The top line of each story in the Story Script window displays story characteristics. For example 
below:

The estimated On Air time of the story (14:27:30)
Story name (Headline)
Editorial duration of the story, as defined in the NCS (00:05).
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Below the story header, each template and secondary element is displayed chronologically, using 
the same color coding as in the Rundown window. The complete contents of the script are also 
displayed, along with any written Viz Mosart commands in the script window.

Primary story templates are displayed with their in time only.
Secondary elements also show durations.

At the top of the Story Script window are two timing indicators. For example above:

To the left is the total planned time for the story currently On Air. 
To the right a countdown timer, since this story went on air.
As soon as this timer reaches zero, the story timing information area turns red and the clock 
starts counting upwards, to indicate a planned duration overrun.
This is illustrated in the example above, where the timer has reached zero, and is counting 
UPWARDS (now at 03:24).

3.8.2 Story Script as a Floating Window
You can either

Reposition the Story Script window on any monitor, as an optional floating window
or
Display a web browser copy of the Story Script as a read-only window.

Refer to section Story Info in Rundown Story and Timeline Views.
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3.9 Keyboard Shortcuts
The Shortcut Keys area is by default across the bottom of the Viz Mosart GUI, displaying any 
configured shortcut keys.
Keyboard combinations can include CTRL, ALT and SHIFT to present additional keyboard 
shortcuts.

Skip to section On Air Shortcut Operations to learn about using shortcuts whilst a show is 
running.

3.9.1 Button Details
Each button presents its operation and status details.

 

Button Detail Description

Text The naming on the button displays the text entered in the Keyboard 
Shortcuts Editor. Alternatively, if the button is bound to some NRCS 
content, it can display the corresponding NRCS slug.

Label (below) The characters at the base of the button identifies which keyboard button is 
controlling the operation named on the button. 

Note: The example above shows how the Viz Mosart UI mimics a standard computer 
keyboard with the key label shown under the rectangles. Key labels on your 
keyboard may be different.


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Button Detail Description

Color The color (button color or stripe at the base of the button) corresponds to 
the template to be taken.
For example, in the large screenshot above:

LIVE 1, LIVE 2, LIVE 3 (keyboard numbers 1, 2, 3) are red, 
corresponding to Live templates.
L3 Viz trio A/Viz trio A (keyboard +), has a yellow stripe, 
corresponding to a Lower Third template.
Other operational shortcuts (for example TAKE NEXT, keyboard F12), 
not related to a template, have a solid gray background, with no 
additional color coding.

Luminosity A dimmed button is non-operational. This button status means that Viz 
Mosart is awaiting NRCS content (not yet received).

For example, in the large screenshot above, LIVE (button F5) is dimmed 
(compare with the active LIVE 1, 2 and 3).

Status Color-coding also indicates status:

Red border: Template is on-air.
Red border, label highlighted: Button is selected, template is on-air.
Blue border, label highlighted: The button is selected. 

In the illustration above:

CAM 2 is on-air
CAM 3 is selected (button F3 
highlighted).

In the illustration above:

CAM 2 is both on-air and 
selected.
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Button Detail Description

Corner Icons

Lower right Triangle icon: The button operation is bound to NRCS 
content.

Lower left Public icon: The button has been manually updated and 
is shared with all Mosart UIs on the same server.
To activate this option (affects all manually updated shortcut buttons), 
see setting Use Public Buttons, in section  Keyboard, under General Settings 
> User Interface .

Audio icon: The audio symbol in the upper left corner of a button 
indicates that this an Audio template. 

Accessory icon: The 'plus' symbol in the upper left corner of a 
button indicates that this an Accessory template.
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Button Detail Description

Context Menu

 

 

Right-clicking over a keyboard shortcut displays a context menu.

The availability and actions of this menu depend on preferences set in the 
Keyboard Shortcuts menu (Tools > Keyboard shortcuts editor)

Clear: Remove the session-based (show-based) button definition from 
this Viz Mosart session. 
This option is only available for buttons that have not been hard-defined 
from the Keyboard Shortcuts menu.
Buttons that are not hard-defined appear as grey/dark grey in the UI. A 
light grey box can be populated with a session-based button definition 
(for example by drag and dropping a template or lower third from the 
Assets panel, see the screenshot below).

 
These session-based button definitions disappear when the UI is 
restarted.
Reset: Temporarily remove the wording on a button, to discourage 
selecting the defined operation (for example a camera number).
This does not clear the operation definition, which will still be executed 
if the button is pressed. Restart the UI to display the button text again.

Note: Importing an existing keyboard shortcuts file into a newer 
version of Viz Mosart may give unexpected operational behavior.
It is highly recommended to verify keyboard-driven operations after 
an upgrade, and as necessary, redefine the shortcuts, before going 
on-air.


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Button Detail Description

Administration 
status

In the Viz Mosart UI menu Tools > Keyboard shortcuts editor,

Blue border: The button is being worked on using the Keyboard Shortcuts 
Editor.

In the illustration above:

SKIP NEXT (F9) has been selected in the Keyboard Shortcuts Editor.

This section contains:

Keyboard Shortcuts Editor
Template Keys
Control Command Keys
Timeline Keys
Layout Keys
Template Router Keys
On Air Shortcut Operations
Video Port Control Commands
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3.9.2 Keyboard Shortcuts Editor
All keyboard shortcuts for the Viz Mosart GUI are fully customizable.

Working with Keyboard Shortcuts
Shortcut List
Editor Window
Menu Bar
Modifying Keyboard Shortcuts

Working with Keyboard Layouts
Selecting Keyboard Layout
Modifying a Keyboard Layout
Exporting and Importing a Keyboard Layout

Working with Keyboard Shortcuts
You create or edit a keyboard setup by navigating to Tools > Keyboard shortcuts > Keyboard 
shortcuts.
Several sets of keyboard shortcuts (keyboard layouts) can be stored and recalled from the 
Keyboard shortcuts menu.

The Keyboard Shortcuts Editor is divided into four areas:

Shortcut List
Editor Window
Menu Bar
Keyboard Layout Preview.
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Shortcut List

Having chosen a keyboard layout, the left-side panel lists all the shortcut keys, grouped by

Control Command
Template
Timeline

functionality.

Editor Window



Viz Mosart User Guide -  5.6

Copyright © 2024  Vizrt                                                          Page  145

1.

The options available for each shortcut in the editor window are mainly dependent upon the type 
of shortcut being created or edited. 
The four main types of shortcuts are Template keys, Control Command keys, Timeline keys
and Layout keys.

If there is a shortcut of type AUTO or CONTINUE, it shows how many continue points there are left.

Menu Bar

 
The menu bar at the lower left of the Keyboard shortcuts window is where you create a new 
keyboard shortcut.

Modifying Keyboard Shortcuts

To Add A New Keyboard Shortcut

Select Add new shortcut from the menu bar .

Note: From Viz Mosart 4.x, Template Router is the new name for what was Wall Manager.
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Choose a shortcut type from the list in the Editor Window.
After working with the shortcut, click Save.

To Remove A Keyboard Shortcut

Select shortcut from the Shortcut List.
Click Remove.
Click Save.

To Edit A Keyboard Shortcut

The procedure for associating a shortcut to a specific keys is similar for all keyboard shortcut 
types.

Click the center rectangle (F12 in the illustration above).
A red, pulsating circle appears.
Press the desired key, including any modifier keys (for example, combinations of Alt, Shift or 
Ctrl).
The main key appears in the rectangle, any modifier keys are highlighted to the left (in the 
illustration above, Shift and Ctrl).
Type the name to appear on the shortcut button in the rectangle to the right (in the 
illustration above, the field with TRANSITION_TYPE)
Click the pulsating center rectangle.
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Working with Keyboard Layouts

Selecting Keyboard Layout

To Select A Keyboard Layout

In the Keyboard shortcuts menu bar, left-click over the Layout (naming) text. of the menu.

Select Open Layout and choose required configuration.

See the following sections for more details:

Template Keys
Control Command Keys
Timeline Keys
Layout Keys
Template Router Keys
On Air Shortcut Operations
Video Port Control Commands.

Note: As a starter, we recommend using the Default setup described in this section.



Viz Mosart User Guide -  5.6

Copyright © 2024  Vizrt                                                          Page  148

1.
a.

i.
ii.

b.
i.

ii.

1.
2.
3.

4.

1.
2.

Modifying a Keyboard Layout

To Rename Or Assign As Default, A Keyboard Layout

In the Keyboard shortcuts menu bar, left-click over the Layout (naming) text. of the menu.
To rename a current keyboard layout:

Select Rename layout
Provide an appropriate name and click OK.

To set the current keyboard layout as Default:
Select Open layout, and from the selection of keyboard layout names, choose 
your new default.
Mouse-over the layout name in the menu bar, left-click and select Set as default.

Exporting and Importing a Keyboard Layout
You can store and restore layouts on the server (Manus Admin).

To Export A Keyboard Layout

In the Keyboard shortcuts menu bar, left-click over the Layout (naming) text. of the menu.
Select Export.
(Information only) In the Manus Admin console, the operation is registered:

An acknowledgement dialog menu appears. Click OK.

To Import A Keyboard Layout

In the Keyboard shortcuts menu bar, left-click over the Layout (naming) text. of the menu.
Select Import.
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(Information only) In the Manus Admin console, the operation is registered:

An acknowledgement dialog menu appears. Click OK.

Server-based shortcuts overwrite local shortcuts.

To Always Import The Server Shortcuts When Starting The Viz Mosart Client

To set this as default behavior, navigate to Tools > General Settings > User interface > 
Keyboard > Import keyboard shortcuts on startup.

Note: This operation is also available in the Viz Mosart UI menu bar with Tools > 
Import shortcuts from server.


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3.9.3 Template Keys
Template keys are keyboard shortcuts associated with the templates that have previously been 
created in Viz Mosart's Template Editor.

The scope of shortcut operations available depends on the type of template sets that have been 
created for each gallery.

Working with Template Keys
Access template keys by navigating to Tools > Keyboard shortcuts editor > Keyboard 
shortcuts > "> icon" > Template Key:

Template Variant Selection
Key Selectors
Default Setup

Template Variant Selection
You can work with any defined variant of a template type.
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To Select A Template Variant

In the panel to the left, click the down arrow next to Template to lists available variants 
(templates previously created).

Key Selectors 
There are several types:

Touch mode:  This selection defines what happens when pressing a key in the Keyboard 
Shortcuts panel, using a touch screen or clicking on it with the mouse cursor.

Select: Highlights the key, and the operator can then press either the Program or 
Preview window to either take the template to air or to preview. When the operator 
clicks a shortcut on the panel, it is highlighted and a Set as Selected button appears in 
the Program and Preview panels. window. By pressing one of these buttons the 
operator sets the selected template to either Program or preview.
Preview: Takes a touched template to Preview.
OnAir: Takes a touched template straight to air.
None: Disables touch control for the key. It may still be fired by pressing the assigned 
key on the keyboard.

Key press option checkboxes:
Preview: When the key is pressed, the template is taken to Preview instead of to air. Do 
not confuse this with Template Keys.
Insert: Inserts the template as the next element without replacing the existing next 
primary element (if the next primary element was added using a shortcut earlier).
Neither selected: The template is taken to Program.

Template binding option checkboxes:
Bind to NCS content: The key takes its content, such as associated video clips, from 
that defined in the NRCS for the last played or selected story.

Note: Only templates from the active template set are available here. 
To select a variant exclusively available in different set, you must first select the other set 
before assigning the key.


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Bind to NCS template: The key takes its template variant (for example, camera number 
or external source) from the NRCS definition, for the last played or selected story.
Bind to NCS slug: The key takes its slug from that defined in the NRCS for the last 
played or selected story.
Allow drop: Checking this box enables dropping of other templates onto this key in 
the shortcut window. This effectively overwrites the key, until the keyboard layout is 
reloaded.
Drop content only: This selection is only available when the Allow drop is already 
selected. Selecting Drop content only ensures that only content, like video files, can be 
dropped onto the key without replacing its associated template.

Lower thirds (special case): If a template key is specified as a lower third some additional 
options appear:

DEFAULT: Takes the template to air if not already taken. If already taken, then it is 
taken Off Air.
AUTO: Takes the lower third to air. If already On Air, it takes the next continue point 
or takes it Off Air if there are no more continue points.
CONTINUE: Takes the next Continue point.
TAKEIN: Takes On Air (same as default).
TAKEOUT: Takes Off Air (even if there are more Continue points left).

AdLibpix & Lower thirds (special case):
Bind to NCS exclusive: When unselected, the next Lower third/AdLib pix template (in 
the list) binds again to the same NRCS content. 
For Lower thirds, this is convenient if the operator wants, for example, a take-in, 
continue and take-out shortcut of the same Lower third from the NRCS and can have 
multiple lower thirds in a story. 
For AdLib pix this is convenient if the operator wants the option to use different 
templates on the same clip (for example, putting the clip on a back-wall or on screen).

Default Setup
A default setup is provided on request containing the following Template keys. Use of Touch Mode 
is highly individual, so this is left with default setup. Suggested defaults:

F1 - Camera 1: Set with no parameters, so it is taken straight to air.
F2 - Camera 2: Set with no parameters, so it is taken straight to air.
F3 - Camera 3: Set with no parameters, so it is taken straight to air.
F4 - Camera 4: Set with no parameters, so it is taken straight to air.
SHIFT+F1: Set Cam 1 in ME1 Key 1.
SHIFT+F2: Set Cam 2 in ME1 Key 1.
SHIFT+F3: Set Cam 3 in ME1 Key 1.
SHIFT+F4: Set Cam 4 in ME1 Key 1.
F5 - Live Drop Key: Set up to go to Preview, and all Bind settings selected. This causes the 
shortcut to get all the properties of the last run or selected Live template. 
To select a template in this way, click its story in the rundown.
F6 - DVE Drop Key: Set up to go to Preview, and all Bind settings selected. This causes the 
shortcut to get all the properties of the last run or selected DVE template. 
To select a template in this way, click its story in the rundown.
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F7 - Telephone Drop Key: Set up to go to Preview, and all Bind settings selected. This causes 
the shortcut to get all the properties of the last run or selected Telephone Interview 
template. 
To select a template in this way, click its story in the rundown.
F8 - AdLib Drop Key: Set up to go to Preview, and all Bind settings selected. This causes the 
shortcut to get all the properties of the last run or selected AdLib template. 
To select a template in this way, click its story in the rundown.
1 - Live source 1: Set to Preview.
2 - Live source 2: Set to Preview.
3 - Live source 3: Set to Preview.
4 - Live source 4: Set to Preview.
SHIFT+1: Set Live 1 in ME1 Key 2.
SHIFT+2: Set Live 2 in ME1 Key 2.
SHIFT+3: Set Live 3 in ME1 Key 2.
SHIFT+4: Set Live 4 in ME1 Key 2.
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3.9.4 Control Command Keys
This section focuses on control commands and the common use case of assigning them to a 
keyboard shortcut. Topics covered include:

Working With Control Commands for a Keyboard
Keyboard-based Control Command Categories
Additional Control Command Actions
Control Commands in Templates

Control Commands are commands an operator can send direct from their keyboard, to one of the 
connected devices, independent of templates currently in use.

For example, a control command key can be defined to send a DVE FORWARD command to the 
vision mixer or similarly, a Continue graphics command can be sent to the connected graphics 
system.

You access these settings from the menu bar: Tools > Keyboard shortcuts editor and then 
selecting Control Command Key from the panel on the right.

Working With Control Commands for a Keyboard

Common Parameters

Touch Mode

 
All control command keys share the Touchmode parameter. 

OnAir indicates that clicking or pressing the keyboard shortcut in the shortcut window 
immediately executes the relevant control command.
None disables touch/click functionality for the button.
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Adding a New Command

To Add A New Parameter

Refer to the table Keyboard-based Control Command Categories
From the menu bar select Tools > Keyboard shortcuts editor.
Click Add new command to add multiple commands to a shortcut.

 
In the figure above, two commands have been added: SET_AUX_CROSSPOINT and LIGHT. 
These commands are executed sequentially from left to right (in the example, first 
SET_AUX_CROSSPOINT, then LIGHT).

Keyboard-based Control Command Categories
In the Viz Mosart UI, control commands are arranged in categories, based on the key.

The table below refers to commands available per category.
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AUDIO

AUTOTAKE

AUTOTRANS

DIRECTTAKE

DVE

ENABLE_GRAPHICS_MIRRORING

FULLSCREEN_GRAPHICS

GRAPHICSPROFILE

LIGHT

MARKER

OVERLAY_GRAPHICS

SET_AUX_CROSSPOINT

SET_CROSSPOINT

SET_CURRENT_ME

RUNDOWN_NCS_RESYNC

SEQUENCE

Control Command Keys

VIDEOWALLMODE

TAKE_SERVER_TO_PROGRAM

TRANSITION_TYPE

WEATHER

ACCESSORIES

SET_VIDEOSERVER_SALVO

MIRRORING

NCS

SWITCH_VIDEO_SERVER_MIRRORING

SWITCH_GRAPHICS_MIRRORING

SWITCH_REHEARSAL_MODE

SWITCH_GENLOCK_MODE

RECORD

Control Command Keys

VIDEO_PORT

DEVICE_PROPERTY

USER_MESSAGE

OVERLAY_TO_MANUAL
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STORY_ACTION

ENGINE_SWITCHER

STORY_RECORDER

Command Category 
and Summary

Parameters Default / 
Notes

AUDIO

Audio Control 
Commands have an 
associated Faderate 
parameter,
enabling the operator to 
set a fade rate.

Faderate: In frames where relevant.

Action:

FADE_OUT_KEEPS
Faders that are set as "keep level" in the template On 
Air are faded out.
Also work when new templates have been taken in 
between the 'keep' action and the FADE_OUT_KEEPS.

CTRL+F

FADE_MANUAL
The audio faders for the On Air server channel are set 
to Manual control, and are not changed by Viz Mosart 
until taken out of manual control again.

CTRL+M

FADE_UP_SECONDARY_AUDIO
Viz Mosart fades up relevant audio sources not 
connected to the video currently On Air, when cutting 
between sources. 
For example, when cutting from a camera to a live 
source, internal Viz Mosart logic dictates that all the 
microphones in the camera template are left up. 
Pressing SHIFT+F10 fades the camera template 
microphones down. F10 brings them back up again, 
for example to allow the presenter to talk to a reporter 
at the end of a live segment.

F10

FADE_DOWN_SECONDARY_AUDIO
Viz Mosart fades down relevant audio sources not 
connected to the video currently On Air. 

SHIFT+F10

FREEZE_AUDIO
With the Control Command Freeze Audio all sound 
faders are frozen, and do not respond to commands 
from templates. 
This command is a toggle function. Same function as 
'Keep Sound'.
(the K button in the Audio Function area).

CTRL+K
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Command Category 
and Summary

Parameters Default / 
Notes

SET_LEVEL_2_PREVIEW
The second level for faders in the template are set on 
the template which is in preview, and be performed on 
next transition. 

CTRL+L

SET_LEVEL_2_ONAIR
The second level for faders in the template which are 
On Air are set. 

SHIFT+CTRL
+L

AUTOTAKE

Sets the Viz 
Mosart system to auto 
take mode.

The key can be defined as a toggle key, or two 
separate keys can be used to activate or deactivate 
autotake mode.

Action:

TOGGLE

ACTIVATE

DE-ACTIVATE

Toggle with 
CTRL+SHIFT
+A

AUTOTRANS

Instruct the switcher to 
perform a transition on 
a given ME between the 
currently cued and On 
Air source.

MixEffect:

PP

ME1

ME2

ME3

ME4

M_RIP

M_OTH

Transitionrate: In frames
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Command Category 
and Summary

Parameters Default / 
Notes

DIRECTTAKE

Executes a direct take 
template.

Template: Recall Number of the direct take template 
(nnnn).

When the direct take has been created, you can assign 
a keyboard shortcut to perform in this menu.

You can 
create a 
direct take 
in the 
Template 
Editor.
Note that all 
direct takes 
have to be 
created as 
part of the 
special 
Directtakes 
template 
set.

Define the 
direct take 
number 
under 
Template 
properties > 
Recall Nr.

DVE

Sends a forward or 
reverse command to the 
DVE in the vision mixer.

Direction:

FORWARD

BACKWARD

Forward 
with PageUp

Backward 
with 
PageDown

ENABLE_GRAPHICS_MIRR
ORING

Send the same graphic 
commands to multiple 
graphics engines.

Target: Where to enable/disable graphics mirroring

FULLSCREEN

OVERLAY

ALL

Action: What to perform
ENABLE

DISABLE
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Command Category 
and Summary

Parameters Default / 
Notes

FULLSCREEN_GRAPHICS Engine: The engine number on which control 
commands execute.
The engine number must be same as the number 
defined in AV Automation.

Action:

CONTINUE
Send a Continue command for a full screen graphic on 
a graphics engine.

MACRO
For graphics systems that support macro recall, recalls 
a macro on the defined engine.

Parameter:
Specific functionality depending on the chosen 
command.

Send a 
Continue to 
the current 
engine with 
F11.

GRAPHICSPROFILE

Changes the current 
graphics profile loaded.

Name: The name of the desired graphics profile.

LIGHT

Activates a specific light 
setup.

Scene: The number of the desired scene.

MARKER

Inserts a metadata 
marker into the 
timeline.

Description: Description to be entered for the marker.

•

•

For VIZRT graphics, two special macros are 
available:

INITIALIZE (or INITIALISE): Initialize the 
playlist.
CLEANUP: Clear the playlist.


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Command Category 
and Summary

Parameters Default / 
Notes

OVERLAY_GRAPHICS

The Overlay Graphics 
Interface provides 
control and monitoring 
of overlay graphics for 
all Viz Mosart-approved 
graphic engines.

All OVERLAY_GRAPHICS commands share the Render 
parameter. This parameter can be set to send the 
given command to a specific engine, or to engines 
which currently have active graphics On Air.

Render: Specifies the engine number (from the Overlay 
Graphics screen) to clear the graphics from, if 
Parameter is empty. 
This value can also be non-numeric (in the left-hand 
example below: Current), to clear the graphics from 
all the engines.

For 
a detailed 
description, 
see 
section Over
lay Graphics 
Interface of 
the Viz 
Mosart 
Administrat
or Guide.

Any non-numeric value (including the empty 
value) has the same effect: Clear the graphics 
from all the engines.



Parameter field value has a higher precedence 
than the value of Render.



http://docs.vizrt.internal/viz-mosart.html
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•

•

•

•

•

Command Category 
and Summary

Parameters Default / 
Notes

Action: 

CLEAR
Take out all on-air overlay graphics.

CONTINUE
If the current overlay graphics contains stop points/
triggers, this command continues the timeline. 
The Parameter can be either one of the Mosart 
graphics destinations (channels) or a valid graphics ID.
If the Parameter-field is not empty, and the value given 
is not found among the destinations configured in 
the Viz Mosart OverlayGraphics, then this is 
considered to be a graphics ID. 
In such cases, the destination is searched for in the 
configured destinations from within the 
OverlayGraphics settings based on the value of the 
Render-field (which is the engine ID).
Possible values for the Value-field:

STRICT
The shortcut is executed only if the graphics contain 
continue points.

<empty>: Applies to all the graphics.

PRETAKE NEXT
With this command, the next overlay graphics in the 
timeline are taken in. 
Parameter field can contain a graphics Handler name 
(WALL or DSK etc). This value overrides the value 
in Render.

TAKE LAST OUT
This command takes out the last overlay graphics 
which have been taken in. Render value has no effect. 
In the Parameter field, it is possible to enter a graphics 
Handler name (WALL or DSK etc.).

TAKE MANUAL OUT
This command takes out overlay graphics which have 
been set to wait for a manual take out. 
Parameter field specifies the name of the destination 
to take out the graphics from.

CLEAR
: CTRL 
+ X

CONT
INUE: 
SHIFT
+F11

PRETA
KE 
NEXT:
 CTRL 
+ O

TAKE 
LAST 
OUT: 
HOME

TAKE 
MANU
AL 
OUT:
SHIFT 
+ 
HOME

Note
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•

Command Category 
and Summary

Parameters Default / 
Notes

TAKE ALL OUT
This command takes out all overlay graphics currently 
on air.
Parameter field specifies the name of the destination 
to take out the graphics from.

TAKE NAMED OVERLAY
This command is to take a specific named 
overlay graphic item to air via a keyboard shortcut. 
Parameter field holds ItemId. If blank, use current 
item. 
Value=Slug.

MACRO
For graphics systems that support macro recall, this 
recalls a macro on the defined engine(s).
Parameter field is the name of the macro to execute.

TAKE 
NAME
D 
OVER
LAY:
If 
blank, 
use 
curre
nt 
item

Parameter: The Parameter value has varying 
functionality depending on the chosen command, 
specifying the destination to clear the graphics from. 

Value: This field is ignored.

For versions before Viz Mosart 5.5.0, the TAKE 
MANUAL OUT command would also take out 
overlay graphics set to wait for background 
end or story end. If this functionality is 
needed, use the TAKE ALL OUT command 
(below) introduced in Viz Mosart 5.5.0.

•

•

For VIZRT graphics, two special macros are 
available:

INITIALIZE (or INITIALISE): Initialize the 
playlist.
CLEANUP: Clear the playlist.


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Command Category 
and Summary

Parameters Default / 
Notes

SET_AUX_CROSSPOINT

Sets a crosspoint on one 
of the AUX buses on the 
mixer.

Bus: 1-16.

CrossPoint: As defined, for example INP1-6.

SET_CROSSPOINT

Sets a crosspoint on the 
vision mixer.

MixEffect:

PP

ME1

ME2

ME3

ME4

M_RIP

M_OTH

Bus: The ME, bus (A, B, C, D or keyers)

CrossPoint: INP1-6.

SET_CURRENT_ME

Sets a given ME On Air.

MixEffect:

PP

ME1

ME2

ME3

ME4

M_RIP

M_OTH

RUNDOWN_NCS_RESYNC

Initializes a reconnect to 
the NRCS.

-

Buses C and D are used for video switchers 
supporting M/Es effects with 4 layers (for 
example, with vizrt-ips).


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Command Category 
and Summary

Parameters Default / 
Notes

SEQUENCE

Control a sequence as 
defined in a template.

Applies to all secondary items, including lower third 
graphics and accessories. 

Action:

START
Restart a previously stopped sequence.

STOP
Stop a running sequence.

STARTLOOP
Set a running sequence to start looping.

STOPLOOP
Stop running a looped sequence in loop

In a 
rundown 
loaded in 
the Viz 
Mosart UI, 
you can 
perform this 
operation 
with:
Right-click 
on a story > 
Edit > Save 
story as 
sequence.

STUDIOSETUP

Changes the current 
studio setup (template 
set) loaded.

Name: Name of the desired studio setup.

VIDEOWALLMODE

Toggles a mode where 
key parts of production 
are shifted via an ME to 
a connected video wall
(for example, a video 
server ripple but not 
camera switching).

MixEffect:

PP

ME1

ME2

ME3

ME4

M_RIP

M_OTH

It is not 
recommend
ed to use 
this feature 
without 
consulting 
Viz 
Mosart supp
ort.
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Command Category 
and Summary

Parameters Default / 
Notes

TAKE_SERVER_TO_PROGRA
M

Take a video server port 
to Program on a 
selected ME. 

MixEffect:

PP

ME1

ME2

ME3

ME4

M_RIP

M_OTH

Transitionrate: In frames

Example: A 
video clip is 
running on 
a video wall. 
The 
shortcut can 
then be 
used to take 
the last 
used/active 
video server 
to Program.

TRANSITION_TYPE

Sets the transition type 
to use on the next 
transition.

TransitionType: 

CUT
Set the transition to be mix with value = 0
MIX
Set the transition to be mix with the specified value as 
number of frames
WIPE
Set the transition to be wipe with the specified value 
as number of frames
EFFECT
Set the transition to the effect specified by number in 
the Value field
TOGGLE
Toggle between MIX,WIPE,EFFECT

Value: The transition rate in frames, or the effect 
number for the mixer effect transition type.
Not used with TOGGLE or CUT.

(Default)

TransitionTy
pe: TOGGLE
(cycle 
through the 
various 
transition 
types)

WEATHER

Controls the timeline of 
a connected Viz Weather 
system.

Action: 

PLAY
Start the timeline of the weather system.

CONTINUE
When a weather timeline has stop points, send 
Continue commands to the timeline.

GO TO FIRST
Cue the weather scene to its first page/frame.
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Command Category 
and Summary

Parameters Default / 
Notes

ACCESSORIES

Pretakes an accessory. 

Action: 

TAKE_NEXT

Pretake 
requires the 
accessory 
template to 
have 
preload 
enabled and 
a primary 
type to 
trigger the 
defined 
pretake.
Only use 
accessories 
with

in-time= 0 .

SET_VIDEOSERVER_SALVO

Switches to a specified 
video server salvo.

Salvo: Specify the salvo name.

SWITCH_GENLOCK_MOD
E    

Action:
TOGGLE
Toggle genlock mode.

ACTIVATE
Activate genlock mode.

DEACTIVATE
Deactivate genlock mode.

NCS

Specific control for the 
OpenMedia newsroom 
systems.

Action:  
START_STATUS
STOP_STATUS

Parameter:
RUNDOWN
STORY
ITEM
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Command Category 
and Summary

Parameters Default / 
Notes

SWITCH_REHEARSAL_MO
DE

Action:
TOGGLE
Toggle rehearsal mode.

ACTIVATE
Activate rehearsal mode.

DEACTIVATE
Deactivate rehearsal mode.

SWITCH_VIDEOSERVER_MIR
RORING

Switch mirrored video 
ports.

- Toggles a 
switch of 
any 
mirrored 
video ports.

SWITCH_GRAPHICS_MIRROR
ING

Action:
TOGGLE
Toggle mirroring mode for graphics for full screen 
graphics.

ACTIVATE
Activate mirroring mode.

DEACTIVATE
Deactivate mirroring features.
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Command Category 
and Summary

Parameters Default / 
Notes

RECORD

 

Command:

PREPARE
Cue a recording.

START
Start a recording previously PREPAREd.

STOP
Stop a recording previously STARTed.

DELETE

Recorder: A user-defined name to be used for a 
recording, tied to ClipName and PortName.
Set in the PREPARE command and then used by the 
START and STOP commands. A value of Default selects 
the default recorder.

ClipName:
(PREPARE only): The name of the clip to be created.

 PortName (PREPARE only): The name of the video port 
where the recording shall take place. Note that this 
port has to be part of the “Rec” virtual video port 
group.
Default value is “Rec”.

Recorder: A 
value of 
DEFAULT
selects the 
default 
recorder.

PortName 
(PREPARE 
only):
Default 
value is Rec.

Note: It is possible to include the current 
gallery/studio, template set, and time in the 
name of the created clip. For details please 
refer to section Video Server, MAM and 
Database Connection Strings in the Viz Mosart 
Administrator Guide (ClipNamePattern
property).


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Command Category 
and Summary

Parameters Default / 
Notes

Note
: For 
the 
setu
p of 
reco
rdin
g 
port
s, 
plea
se 
refer 
to 
secti
on 
AV 
Auto
mati
on 
Devi
ces 
Vide
o 
Serv
ers i
n 
the 
Viz 
Mos
art 
Adm
inist
rato
r 
Guid
e.



http://docs.vizrt.internal/viz-mosart.html


Viz Mosart User Guide -  5.6

Copyright © 2024  Vizrt                                                          Page  171

Command Category 
and Summary

Parameters Default / 
Notes

QUICKEVENT Command:

NEXT_ITEM
Select the next item (down).

NEXT_GROUP_ITEM
Select the next group-selected item (down).

PREVIOUS_ITEM
Select the previous item (up).

PREVIOUS_GROUP_ITEM
Select the previous pre-selected item (up).

TAKE_SELECTED
Attempt to put the selected item to air.

TAKE_SELECTED_TO_WALL
Takes the selected item to the wall item specified in 
the parameter. See section Template Router.

PREVIEW_SELECTED
Attempt to put the current selected item to preview.

PREVIEW_SELECTED_TO_WALL
Put the selected item to the selected wall salvo 
preview wall item specified in the parameter. See 
section Template Router.

PRELOAD_SELECTED
Attempt to preload the current selected item to the 
preload port/engine if available and configured in AV 
Automation.

FILTER_LEFT
Switch the selected filter to the filter displayed to the 
left of the currently selected filter (this also works in 
the Quick Access Panel, QAP).

FILTER_RIGHT
Switch the selected filter to the filter displayed to the 
right of the currently selected filter (this also works in 
the QAP).

CLEAR_SELECTION
All selected and group-selected marks are removed.

TOGGLE_SELECT
Mark the current item in the list as group-selected. 
The group selected items can be iterated with 
NEXT_GROUP_ITEM and PREVIOUS_GROUP_ITEM.

LOWERTHIRD_ACTION_SELECTED

Put the selected lower third in the Quick Access tab
based on the (mandatory) value of Parameter.
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•
•

•
•
•

Command Category 
and Summary

Parameters Default / 
Notes

Parameter:

DEFAULT: Take in only
AUTO: Take in if not On Air
            Take next continue point if On Air and has 
continue points 
            Take out if On Air and no more continue 
points
CONTINUE: Take next continue point
TAKEIN: Take in only (same as DEFAULT)
TAKEOUT: Take out (even if there are more 
continue points lef

VIDEO_PORT

 
Send a specific 
command directly to a 
specific video port. 

Action: What action to perform on clip assigned to 
port:

PLAY_PAUSE
Play or Pause assigned clip

STOP
Stop assigned clip

CUE
Cue assigned clip

RECUE
ReCue assigned clip

SET_LOOP
Tells the video player to loop the current clip

PLAY_TAIL
Skip to end of clip and start playing. Specify a 
Parameter (see below). 

CUE_TAIL
Same as PLAY_TAIL but does not start to play.

VideoPort: Name of the video port for sending 
commands to.

Parameter: Used for PLAY_TAIL and CUE_TAIL 
commands. 
Specified length from end or start of clip to skip to. 
Use negative number to count from end.
For example, -10 to skip to 10 seconds before end of 
clip. Used for rehearsal.

Not 
applicable 
for all video 
servers, 
behavior 
varies 
depending 
on video 
server type.
Is not visible 
in the 
rundown 
(only visible 
in Template 
Router)

Tip: For additional control possibilities, refer 
to the section Video Port Control Commands.


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Command Category 
and Summary

Parameters Default / 
Notes

DEVICE_PROPERTY

Parameter1:

AUDIO

CAMERACONTROL

Parameter2: String variable

Parameter3: Additional optional control value

USER_MESSAGE

Generate an arbitrary 
logging message

Message:
Insert a simple log message to inject into logging 
when this button is pressed.

When 
activated, 
adds the 
specified 
text string 
to all 
connected 
logs.

This is 
useful for 
the operator 
in fault-
finding 
situations, 
where, a 
known 
message 
string can 
be pushed 
into the log, 
for 
example, at 
the point of 
a 
troublesome 
production 
situation.
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Command Category 
and Summary

Parameters Default / 
Notes

OVERLAY_TO_MANUAL

Convert all lower 
thirds(overlays) to 
manual for the current, 
preview or selected 
story.

The control command OVERLAY_TO_MANUAL has 
three optional parameters:

Target: The type of story to be converted

SELECTED
(default)The selected story in the GUI.

PREVIEW
The next story

ONAIR
The on air story

Handlers: Comma-separated list of handler names.
Empty list means all handlers.
Example: WALL,DSK. 

TakeOutMethod: Method for the converted overlays to 
be taken out.

AUTOMATIC (default)

MANUAL 
Converts all lower-thirds in the specified 
Target with the specified Handlers to MANUAL.
- If no handler name is specified, it converts all
lower-thirds in Target to MANUAL.
If TakeOutMethod is set to MANUAL, the converted 
overlays also have to be taken out manually. 
Otherwise they are taken out (automatically) after 
the specified duration.

Defaults:

Target: 
SELECTED
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Command Category 
and Summary

Parameters Default / 
Notes

STORY_ACTION

Invoke an action on a 
target story. 

Target: The type of story to be converted, either:

SELECTED
(default) The selected story. Used for GUI.

PREVIEW
The next story

ONAIR
The on air story

Action: 

TOGGLE_COUNT_DOWN_TO
(Not available for ONAIR) Toggle the target story count 
down to the target story.

SET_AS_NEXT
(Not available for PREVIEW or ONAIR) Set the target 
story as next.

SET_AS_NEXT_AND_SKIP
(Not available for ONAIR) Set the target story as next 
and skip any remaining items.

TOGGLE_LOCK
Toggle the lock story from NCS update on the target 
story.

REMOVE
(Not available for ONAIR) Remove the target story.

LOOP_START
Set the start loop at the target story.

LOOP_END
Set the end loop at the target story.

LOOP_CLEAR
Clears any loops in the rundown.

APPEND_ITEMS_TO_CURRENT
Take all items of target story and append them after 
the current on air item.

This 
command 
can replace 
functionality 
in the Story 
context 
menu with a 
shortcut.

Can only be 
used from 
the Viz 
Mosart UI.



Viz Mosart User Guide -  5.6

Copyright © 2024  Vizrt                                                          Page  176

•

•
•

•
•
•

Command Category 
and Summary

Parameters Default / 
Notes

ENGINE_SWITCHER Action:

INIT
Reset the Engine Switcher status. Typically used at 
rundown reload.

PRESET_STYLE
Jump back to the previous preset.

GOTO_PREVIOUS_PRESET
Toggle between the last preset applied and the 
previous one.

PresetName:

Name of Preset, created in Viz Engine.

Transition:
CUT

TAKE

STORY_RECORDER See section Story Recorder Mode.

Additional Control Command Actions
In addition to being assigned to shortcut keys, control commands can be:

Set into the Viz Mosart timeline (from the NRCS), using written commands. For example, 
using a textual command, either as a machine command in iNews or like this in ENPS.

This command performs a DVE FORWARD four seconds into the main item:

(**COMMAND=DVE FORWARD <00:04**)

Attached to templates as continue points. See Control Commands in Templates below.
Attached to templates to be automatically performed when a template goes on-air or off-air. 
See Control Commands in Templates below.
Used for changing the template set.
Used for changing the graphics profile .
Used for setting the system in AUTOTAKE-mode.

Parameters with Placeholders
Control command parameters may contain placeholders which can be replaced with values found 
in the fields of the Viz Mosart item which is currently on-air.
Refer to the Viz Mosart Administrator Guide, under section AV Automation > Template Editor > 

http://docs.vizrt.internal/viz-mosart.html
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Working with Templates > Control Commands in Templates, topic Command Values and 
Parameters.

Control Commands in Templates
For further details of the control commands that can be attached to a template, please refer to 
the Viz Mosart Administrator Guide, section AV Automation > Template Editor.

http://docs.vizrt.com/viz-mosart.html
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3.9.5 Timeline Keys
The Timeline Keys comprise basic commands that directly affect the running of a rundown in Viz 
Mosart:

Reload
Start Continue
Skip Next
Un-Skip Next
Skip Next Sub Item
Un-Skip Next Sub Item
Set As Next Story
Set As Next Story And Skip
Hold Video Transition
Hold Audio Transition
Goto Current Story

Reload
Default SHIFT+F12

This command will stop playout and reload the current rundown, cuing the first story in the 
rundown in preview.
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Start Continue
Also known as Take Next.

Default F12

This command will do one of four things:

Start a rundown which is currently not running, either at the top or at a point selected by the 
operator using the Set as Next Story command in the Rundown window.
Take the next template within a story to air.
Take the first template in the story set as next if there are no more templates left in the 
current story.
The Take Next command is also used to take continue points that have been set in a 
template, such as a DVE forward on the mixer. A warning appears in the bottom of 
the Program window to alert the operator that the next F12 will activate the continue point 
rather than take the next primary event.

PARAMETERS: A default transition type for Take Next can be set.
Value: Duration in frames for the parameters MIX and WIPE.
Using the parameter EFFECT, one can assign a button doing a take next with a specific effect 
to be triggered.

Skip Next
Default F9

This command will skip the next item in the rundown. Repeatedly giving this command will skip 
several items.

Un-Skip Next
Default SHIFT+F9

This command will undo skipping performed with the Skip Next command, in reverse order.

Skip Next Sub Item
(No default button)

This command skips the next sub item, for example, a lower-third
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Un-Skip Next Sub Item
(No default button)

This command undoes the latest Skip next sub item command

Set As Next Story
No default button

Sets the selected story as next

Set As Next Story And Skip
(No default button)

Sets the selected story as next and removes (skips) any remaining items in the current story.

Hold Video Transition
(No default button)

Holds the video transition. Same as pressing the HV-button in the transition area (Video Transition 
Area) in the GUI.

Hold Audio Transition
(No default button)

Holds the audio transition. Same as pressing the HA-button in the transition area (Audio Function 
Area) in the GUI.

Goto Current Story
(No default button)

Will move the focus of the rundown scrollbar to the current on air story.
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3.9.6 Layout Keys

Keyboard Layout
Adds a shortcut to change the current keyboard shortcut setup to a user-defined Keyboard Layout.

PARAMETERS: The desired layout can be selected from a pulldown menu.

Workspace
Adds a shortcut to change the GUI layout to a user-defined Workspace.

PARAMETERS: The desired workspace can be selected from a pulldown menu.
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3.9.7 Template Router Keys
You can re-route a template to an alternative end point, through an accessory, often to a new 
crosspoint.

Working with Template Router Buttons

Example Workflow
As an example, you can create a template router keyboard button that re-routes any template that 
is dragged onto it, to a screen in the studio  (This is achieved by defining the crosspoint for the 
studio screen in to the button).

An operator can then drag a template (for example a PACKAGE) on to the new template router 
button. The template is then merged with the Accessory template (here a studio screen) that is 
allocated to the button. The original package content displays on the screen.

Creating a Template Router Button

To Create A Template Router Button

From Viz Mosart main menu, select Tools > Keyboard shortcuts.
Choose which keyboard button (for example F8, or as in this example, R) to work with.
Click the blue arrow (in this example, next to ACCESSORY).

Select the option Template Router Button > Accessory merge.

Note: Template Router is the new name for what was previously called Wall Manager. This 
is a pure name change, the functionality has not changed.


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Attach an Accessory template from the drop-down list of alternatives.

Click Save.

For further details about Accessory templates in the section Template Router.

Note: The section Template Router also describes how you can modify button placement 
inside the Template Router canvas.


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3.9.8 On Air Shortcut Operations

Working On Air with Template Shortcut Keys
You can speed-up access to operations that are defined in a template by assigning the 
template to a Viz Mosart shortcut key, by drag and drop.
All secondary items, including lower thirds and audio files in a template shortcut are are also 
added.

Template Shortcut Key Operations

To Add A Template Element To A Keyboard Shortcut Button

From the Media Pool, drag an element from the Asset, Favorites or the Quick Access tab (see 
illustration above).
Drop on a selected Viz Mosart shortcut key.

The selection is saved in your keyboards setup.

To Clear A Template Element From A Keyboard Shortcut Button

Right-click on the button you wish to clear.
Depending on the defined content either:

From the context menu, choose Clear.
Where secondary items are included (indicated by double triangle icon), choose Clear 
sub items.
Where NRCS-bound keys are included (indicated by single triangle icon), reset them to 
their original state by choosing Reset.

To Share Keyboard Shortcut Buttons Between Viz Mosart Clients

You can share your keyboard shortcuts with other users connected to the same Viz Mosart server.

See Use Public Buttons in the topic Keyboard.

Note: By pressing 
SHIFT
CTLR
ALT
ALT GR
or combinations of these selections, a unique keyboard surface is presented for 
customization.


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See also: Media Pool and General Settings.
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3.9.9 Video Port Control Commands
The video port control commands can be used for manual override control of specific video ports 
from the Viz Mosart GUI. This section explains how to set up the shortcuts.

This section includes the following topics:

Video Port Keyboard Shortcuts
Video Port Groups
Control On Air or Preview Video Port
Video Port Error Messages

Video Port Keyboard Shortcuts

 
To be able to use the video port control commands, you need to add a set of shortcuts for each 
video port. You have to create a new set for each video port A, B, C etc. Here port A is used as an 
example.

For all examples VideoPort = A

PLAY_PAUSE: Viz Mosart begins to play the cued content. If the content is already playing, it 
pauses the content.

Empty Parameter: PAUSE if playing and PLAY if paused.
Parameter: PLAY. Always tries to PLAY channel.
Parameter: PAUSE. Always tries to PAUSE channel.

STOP: Viz Mosart stops the cued content.
Parameter: CUE. Cues the channel after the stop.

RECUE: Viz Mosart recues the port.
Parameter: PLAY. Viz Mosart plays the clip after the recue.

SET_LOOP: Viz Mosart sets the already cued clip to looping.

Note: Not all of video server drivers supports all the command variants described here.
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Parameter: OFF, RESET. Viz Mosart turns off looping.
Parameter: 12-444 (configurable). Viz Mosart sets looping from frame 12 to frame 
444.

CUE_TAIL: Viz Mosart recues the cued clip at a specific time (in seconds).
Parameter: -15 (negative value) - configurable. Viz Mosart cues at the start of the last 
15 seconds of the clip (the clip will have 15 seconds left to play plus Post roll).
Parameter: 15 (positive value) - configurable. Viz Mosart cues 15 seconds into the clip.

PLAY_TAIL: Viz Mosart recues and plays the cued clip at a specific time (in seconds).
Parameter: -15 (negative value) - configurable. Viz Mosart will cue at the start of the 
last 15 seconds of the clip.
Parameter: 15 (positive value) - configurable. Viz Mosart will cue 15 seconds into the 
clip.

Video Port Groups
It is also possible to use the video port group names (A/B, C/D...). If a group is found it by default 
gets the next port. If you want the current port, you have to add “CURRENT” to the Parameter field. 
If you want to have additional parameters for the Action, you can add it after the CURRENT term 
separated by comma.

Examples
In this example, the cued port in the group is recued to be ready to play the last ten seconds of 
the clip.

 
In this example, the playing port is paused.

Control On Air or Preview Video Port
It is also possible to make commands to control the video port that is currently On Air or in 
preview. Just type ONAIR in the VideoPort field to direct the command to the On Air port.
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To control the port in preview, use PREVIEW in the VideoPort field. In this example, the video port 
in preview recues to be ready to play the last ten seconds of the clip.

Video Port Error Messages
If AV Automation is unable to execute the command, an error message displays (e.g. Failed to get 
VIDEO_PORT using ‘c/d’).

Note: For configuration guidelines, refer to the Viz Mosart Administrator Guide, topic 
Control Commands in Templates, section VIDEO_PORT Control Commands in AV 
Automation Template Properties.



http://docs.vizrt.com/viz-mosart.html
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3.10 Status Bar

The Status and Redundancy bar displays connection information for Viz Mosart resources and the 
NRCS and has shortcuts redundancy features.

3.10.1 Connection Names and Status
Left Side
Media Sequencer (MSE)
Crossover Server
Right Side

Left Side

The indicators to the left display connection statuses. From left to right:

The Main Viz Mosart server (indicated by IP addresses, host name, or alias).
The Backup Viz Mosart server (indicated by IP addresses, host name, or alias).
The Main NRCS server (indicated by NRCS type and NRCS IP address or host name).
The Crossover server (indicated by Crossover).
The Media Sequencer (MSE) used for the MSE Playlist Panel (displayed in the format "Mse: + 
IP addresses" or "Host name + Graphics profile").

Color Indicators
Green: The resource is currently in active mode.
Red: The resource is currently not connected.
Yellow: For Mosart servers, the server is currently in idle mode (standby). This server can be 
activated by clicking on it. When doing so, the other (active) server is set to idle mode.

Note: MSE here refers to the MSE Playlist Panel, a panel accessed from the Viz Mosart 
GUI and used exclusively for taking a graphic manually on or off air.
This MSE can be a different MSE from those used for full screen and overlay 
graphics.
The green or red connection status of the MSE Playlist Panel is entirely independent 
of the connection status of AV Automation (AVA) and Overlay Graphics Interface 
(OGI),
AVA or OGI handle their own graphics connections, their status is not displayed here 
in the Viz Mosart GUI.
For further details, refer to the AV Automation and OGI sections of the Viz Mosart 
Administration Guide.



https://docs.vizrt.com/viz-mosart.html
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• Grey: For Mosart servers, the connection to the server is currently either not set up, or it 
experiences a connection error. The MosartRemoteControlService is possibly not running on 
the server.

Clicking the Viz Mosart server currently in standby brings up a pop-up enabling a switch of 
Viz Mosart servers.

Media Sequencer (MSE)
The MSE resource is used by the MSE Playlist Panel. Once an MSE Playlist panel host has been 
configured, the MSE connection icon appears on the status bar. The selected graphics profile is 
shown in parenthesis - by default MOSART is used. 
If the user clicks the connection it is possible to switch to other available profiles.

Crossover Server
The Crossover server tool allows a stand-alone Viz Mosart to take over from another system, either 
according to a planned schedule or on-command from an operator.

The Crossover server executes the rundown templates in auto-take mode.

By letting the Crossover take over and play out, (with, for example back-to-back clip sections), the 
producer can free up some valuable studio time during the live production.
This then opens up for scenarios like producing additional content for live on-tape interviews or 
for verifying stories in the control room/studio, whilst the rundown is live on air.

Right Side

Note: The grey status of the NRCS appears in the GUI if the Viz Mosart server is shut 
down/restarted.



Note: When the MSE Playlist panel is open, this MSE status will not be shown.
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Graphics Controller
For graphics systems supporting graphics control switching, the graphics controller can be 
switched by clicking the Graphics Controller area.

Video server
If multiple video server salvos are set up in AV Automation, the operator can switch between them 
by clicking the Video server area on the menu bar. 
The following dialog appears and the user can select one of the video server salvos.

Directtake
The direct take last activated (see Using Direct Take Templates) is indicated in the Directtake area.

In the far right corner of the GUI, the currently running Viz Mosart version number is shown.
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3.11 General Settings
The Tools > General Settings > Settings menu contains important configuration parameters for 
the Viz Mosart GUI. These settings are localized.
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Hover over a setting to see its description at the bottom of the window.

As there are many configurations under General Settings, we present them on a per-panel basis:

Server
User Interface
Audio Countdown
Miscellaneous
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3.11.1 Server
Under Tools > General settings, the Server settings panel displays details about which Viz 
Mosart servers the GUI is connected to. 

This setting replaces the legacy setting Show the connections menu and controls how the Viz 
Mosart UI can be connected to various control room server pairs (making it possible to use the 
same UI to display/control several control rooms/studios).

This setting is usually performed by a system administrator and is normally not changed after 
initial configuration.

For further details, refer to the Viz Mosart Administrator Guide.

http://docs.vizrt.com/viz-mosart.html
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3.11.2 User Interface
You can configure the appearance of Viz Mosart to suit your workflows, and choose which menu 
items, text descriptions and the logical flow of displayed information will be displayed.

These options are accessed from the GUI toolbar under Tools > General settings.

This section describes the configuration alternatives for each panel:

General
Browse Mode
Story Line
Search Pool
Assets
Preview and Program Windows
Keyboard
Template Router
Sourceview

General 

 

Script filter: Filters script text. The format is 100,50 where the first number is the maximum 
length at the start, and the second number the maximum length at the end. Used to limit 
the size of the script text from the NRCS story in the UI.
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Disable story script autoscroll: Disables the auto-scroll functionality in the story script. This 
functionality keeps the current item at the top of the Script window.
Disable rundown autoscroll: Disables the auto-scroll functionality in the rundown. This 
functionality keeps the view of the rundown in sync with the on air story, and displays the 
current story line according to the value set in 'Scroll into view count'. 
Hide big tooltips in rundown: When selected, there no longer appears a big tool-tip when 
you hover over an item in the rundown.
Lock standby status of devices from toggle on/off: A list of which devices should be locked 
from being manually toggled to standby status. Comma separated list (for example, Video 
server, audiomixer).
Reset autotake on reload: Defines the behavior of the auto-take mode on Reload 
(Default SHIFT+F12). When selected, Viz Mosart reverts to normal mode on reload.
Scroll into view count: Defines how many story lines are auto scrolled into the UI rundown 
window when running a show. 

1 will continuously keep one story above the current on air story, visible (the previous
story to the current). 
2 will keep two story lines visible, above the current one. 

Never lock workspace layout: When selected, it is always be possible to change the size of 
the modules in the workspace. If unselected, the workspace layout will be locked while on 
air.
Confirm reload rundown commands: When selected, a confirmation dialog menu is displayed 
whenever the user issues a Reload Rundown command.
Show resync ncs message: When selected, a popup window asks for confirmation whenever a 
rundown is locked and then unlocked again.
Show vertical timing grid bars: When selected, horizontal lines show to indicate time.
Use Crossover Control: When selected, the UI displays the status of the Viz Mosart which is 
configured on the server.

Browse Mode
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The check boxes under the Browse mode header control various actions whenever a Viz Mosart UI 
is set in browse mode. By default, most are unchecked, rendering the Browse mode UI completely 
“safe”.

Enable switch graphic profile: When enabled, it will be possible to change graphics profile 
while in browse mode.
Enable switch rundown: Change rundown in browse mode.
Enable set devices in standby: Change standby devices in browse mode.
Enable switch studio setup: Change studio setup in browse mode.
Disable autoscroll: Disables the autoscroll functionality in the rundown and in the script view 
in browse mode.
Enable edit buttons: Use the edit buttons in browse mode.
Enable editing of story line Edit story line in browse mode.
Enable unfocused alert: When not enabled, the unfocused alert is not shown in browse mode 
when the application does not have focus. 
Enable browse option in menu: Enables the appearance of the View > Browse mode menu 
item, and makes it possible to turn browse mode off.

Story Line
Story line options control behavior and display characteristics of each story in the rundown.

Count down to live story elements: Enables countdown to stories containing either a LIVE, 
DVE or TELEPHONE template.
See the topic Countdown to a Selected Story.
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Auto scroll long story elements: When selected, long story items (with scrollbars) are 
automatically scrolled horizontally while the story item is played. Makes it easier to see 
when lower thirds appear.
Enable timeline loop: Enables the loop timeline context menu.
Disable overlay graphic type colors: Disables the use of Layer 2 and Layer 3 identification 
(otherwise, user sees Layer 2 overlay graphics is identified by and Layer 3 overlay graphics 
is identified by).
Layer 2 overlay graphics is identified by: Overlay graphics connected with any Handler name 
input here is displayed in the secondary overlay graphics layer. For example, OSG

Layer 3 overlay graphics is identified by: Overlay graphics connected with any Handler name 
input here is displayed in the tertiary overlay graphics layer. For example, WALL
Use grouped stories: When selected, stories with the same prefix are displayed in story 
groups in the UI. All items within each story group are also displayed in the Asset window. 
Can also be used with Quick Access filters.
Number of visible aired manual elements: Number of manual elements already aired that 
should be visible in a story. Use -1 to show all. Default value is 10.

Hide empty stories: When selected, stories without items are not shown in the rundown. 
They are reduced to one straight line.
Ignore overlay graphics with keywords: Overlay graphics connected with any of the specified 
handler names are hidden in the UI. Can be used to remove fixed overlay graphics.
Video clips should be presented with: Select how you want video clips to be displayed to the 
user in the user interface, selecting from the drop-down list.
Show set as next break: When selected, Set As Next Break is available as an option in the 
rundown context menu. Selecting this option causes Viz Mosart to regard the selected story 
line as a Break line for countdown and timing purposes.
Show set as next story: When selected, Set As Next Story is available as an option in the 
rundown context menu. (Right-click.) The user can jump to stories further up or further 
down in the rundown, independently of the NRCS running order. 
Default: On
Show set as next story and skip: When selected, the story line context menu option Set as 
next story (skip) is available. 
For example: The story on air consists of three items, and the current item on air is number 
one of these three. Choosing Set as next story (skip) for another story in the rundown will 
then skip item 2 and 3 of the current on air story and set the first item of the chosen story in 
preview. (Whereas selecting Set as next story keeps the remaining items in the on air story 
as the following items to be played out, before the chosen story is set as next story. Default: 
Off

Note: Showing more than 10 elements in each story may cause performance issues.
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Search Pool
Search pool options affect the Search tab and Quick access tab in the Media Pool, usually displayed 
in the lower right corner.

Default float variant: The float variant that Viz Mosart adds to any video file found in the 
Search or Quick Access tab when dragged to the rundown, a shortcut key or the Favorites
tab. See below for information on the drag and drop feature.
Default package variant: The package variant that Viz Mosart adds to any video file found in 
the Search or Quick Access tab when dragged to the rundown, a shortcut key or the 
Favorites tab. See below for information on the drag and drop feature.
Default voiceover variant: The voiceover variant that Viz Mosart adds to any video file found 
in the Search or Quick Access tab when dragged to the rundown, a shortcut key or the 
Favorites tab. See below for information on the drag and drop feature.
Hide story name in Quick Access Tab: When checked, The Quick Access tab shows the 
filtered items as a list without any story headers.
Media search column: Values entered here define the format of search results displayed 
when searching the video servers. Values can either be entered without name tags, in the 
format: "slug, durationc" or with name tags, in the format: "Name=slug, Dur=durationtc" 



Viz Mosart User Guide -  5.6

Copyright © 2024  Vizrt                                                          Page  201

•

•

•

•

•

This tells Viz Mosart to display results with Name:xxx (found in the slug column on the 
server database) and Dur:xxx (found in the durationtc column on the server database). 
The resulting search window could look like this:

Valid property fields: SLUG, DESCRIPTION, STATUSDESCRIPTION, RIGHTS, DURATION, 
STATUS, STAUSDESCRIPTION
Recue items when reaired: When checked, previously played video items dragged from the 
Assets and Favorites tabs into the rundown are recued.
Template type when drop + CTRL: Typing FLOAT, PACKAGE or VOICEOVER here defines 
which of the three types is connected to material dragged from the Search window when 
holding down the CTRL key.
Template type when dropping: Typing FLOAT, PACKAGE or VOICEOVER defines which of the 
three types is connected to material dragged from the Search window without holding down 
a key.
Template type when drop + SHIFT: Typing FLOAT, PACKAGE or VOICEOVER defines which of 
the three types is connected to material dragged from the Search window when holding 
down the SHIFT key.
Use public pools: When checked, manually updated Favorites Pool tabs are shared between 
GUIs connected to the same server. A shared Favorites tab is indicated by a small symbol in 
the top right hand corner of the tab.

Assets
Asset options are options regarding the asset tab in the media pool usually located in the lower 
right corner.
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Description for ____ templates: Entering a legend syntax description in this field defines the 
format displayed for assets in the Assets Tab, in the same way as with the Media search 
column. The syntax for defining the legend is shown in the User Interface section below. 
Valid parameters are listed in the Assets Properties list further down. The legends used in 
Asset window are customizable for all Viz Mosart template types shown in the table above. 
Legends for other template types are shown using the corresponding slug.
Hide big tooltips in assets window: Normally when you hover over an item in the Asset
window, a big tool-tip appears with the full details of the item. If this is not wanted, the tool-
tip can be disabled by checking this box.
Enable send item to preview when clicked: If selected, clicking on a primary item in the Asset
window immediately sends it to preview (it is inserted as the next item in the story currently 
On Air).

Asset Legend Syntax
Legends for template types in the Asset window are defined as a set of properties divided by the 
pipe (|) character where each property has the following syntax: 

[separator][[Title]]Property[{DefaultValue} , where:

[separator]: Optional separator to separate the property from its predecessor. Using a carat 
(^) as the first character ensures that the first property this the following property. 
Otherwise, all legends start with the slug.
[[Title]]: Optional title. Needs to be defined inside [] brackets.
Property: Named property, see table below.
[{ DefaultValue}]: Optional default value. Needs to be defined inside {} brackets.

Note: If an item was unintentionally sent to preview in this way, this can be undone 
by pressing Skip Next (default F9)


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Examples:

MEDIACONTENT{[MISSING CONTENT]}|, [Duration=]DURATION
Displays Slug + Clip/Graphics description + clip duration. Description shows “[MISSING 
CONTENT]" if the template lacks content. Typically if no content is added in the NCS.
 

^TEMPLATEVARIANT| MEDIACONTENT{[MISSING CONTENT]  } 

Displays template name + Clip/Graphics description (i.e. starts with template name).

Assets Properties
Various template properties are available for use in asset legends:

CLIPDESCRIPTION: Normally clip slug (slug).
CLIPHIRESPATH: Clip reference. Normally clip slug (clip_hirespath).
CLIPREFID: Clip reference id. Normally clip server identity number (metadata_lookuppath).
CONTINUECOUNT: Continue count for fullscreen graphics (continuecount).
DESCRIPTION: Item's description (clip_hirespath).
DURATION: Clip duration in mm:ss.
GRAPHICSDESCRIPTION: Graphics description. Normally name of full-screen graphics 
(graphics_description).
GRAPHICSID: Graphics id. Normally graphics id used by graphics system (graphics_id).
ITEMIN: In-time in hh:mm:ss for secondary objects (like accessories and CGs).
LEGEND: Equals SLUG if present. Otherwise set to DESCRIPTION.
MEDIACONTENT: Equals CLIPDESCRIPTION for clips and GRAPHICSDESCRIPTION for fullscreen 
graphics.
SLUG: Textual description of the element. Normally as entered in NCS (slug).
TEMPLATEVARIANT: Template variant name (templatetype).
TRANSITION: Transition given as [CUT|MIX|EFFECT](duration|effectno) (transitions(rate)).

Default Value

The slug is implicitly used as the first value. This is the same as entering ^SLUG  as the description 

(if the carat (^) is not present as the first character then the slug is used as the first value). 
To use other properties as the first value, the description should start with the carat (^) character.

Note: In the syntax above [] is also used to denote optional content
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Preview and Program Windows

Program

Show onair overlay graphics: When selected, overlay graphics are displayed in the Program
window when they go on air.
Program video source url: Specifies which source to use for the program video feed. Can be 
an html page or NDI source url. Keep empty if not to be used.
Hide video preview types in program: List of template types that should not display the 
preview video. Only applicable when producing with NDI video streams. Default: all available 
types.
Clip visual countdown: If this has a value above 0, the countdown of PACKAGE and 
VOICEOVER change color to alert the user if the countdown reaches this value. 
See also Timing Information and Countdown of Video Wall Elements.

End Phrase Bar
Also called out words, these configurations enable the user to define which Viz Mosart types 
should have Last Words functionality. 
When selected, the last words in the NRCS script (or the last words defined through a command in 
the script, depending on NRCS and Viz Mosart type) are displayed in a black box in the UI Program 
Window.
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Show end phrase on VOICEOVER templates: When selected, the last words in the script of 
VOICEOVER templates are displayed in a black box in the UI Program window.
Show end phrase on FULLSCREEN GRAPHICS: When selected, the last words in the script of 
full-screen graphics templates are displayed in a black box in the UI Program window.
Show end phrase on LIVE templates: When selected, the last words in the script of LIVE 
templates are displayed in a black box in the UI Program window.
Show end phrase on FLOAT templates: When selected, the last words in the script of 
FLOATtemplates are displayed in a black box in the UI Program window.
Show end phrase on CAMERA templates: When selected, the last words in the script of 
CAMERA templates are displayed in a black box in the UI Program window.
Show end phrase on TELEPHONE templates: When selected, the last words in the script of 
TELEPHONE templates are displayed in a black box in the UI Program window.
Show out word on DVE templates: When selected, the last words in the script of DVE 
templates are displayed in a black box in the UI Program window.
Show out word on PACKAGE templates: When selected, the last words in the script of 
PACKAGE templates are displayed in a black box in the UI Program window.

Transition Control
Allows the user to hide some of the transition controls located between the Program and 
Preview windows. Can be used to save some space in the UI.

Hide effect transition controls: Hides the transition controls
Hide video/audio transition controls: Hides the video/audio transition controls

Preview

Always hide mark in/out control: Hides the mark in/mark out selector that is displayed when 
a clip is in preview. (If unchecked, these selectors will be shown when a clip is in preview, 
otherwise not.)
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Show next item update: When selected, a warning is displayed in the Preview window if the 
story in preview is updated from the NRCS.

Always hide alternative source option: Hides the combo-boxes that are displayed on top of 
the template previews in Preview (and Program). Selected this to only see the source.
Preview video source url: Specifies which source to use for the preview video feed. Can be an 
html page or NDI source url. Keep unselected if not to be used. 
Hide video preview types in preview: List of template types that should not display the 
preview video. Only applicable when producing with NDI video streams.  Default: All
available types

Keyboard

Fill manual lowerthirds only: When selected, only NRCS-bound lower thirds fill keyboard 
shortcuts with manual lower third. When unchecked, all lower thirds fill any keyboard lower 
third. 
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Import keyboard shortcuts on startup: When selected, the UI attempts import of keyboard 
settings from the server every time the UI restarts.

To export a keyboard settings file to the server, select LAYOUT - EXPORT in the 
keyboard shortcuts window.

Save keyboard changes on exit: When selected, all changes to the keyboard layout (for 
example, unassigned keys) are saved on exit.
Set last selected keyboard layout as default: When selected, the last used keyboard layout 
opens the next time the UI is started.
Show keyboard layout name: When selected, the currently selected keyboard layout name is 
displayed in the menu bar at the top of the Keyboard shortcuts window of the UI.
Use extended keyboard keys: When selected, some special keys like Enter/Return are treated 
differently. The extended variant is shown with an asterisk (*) in the keyboard editor.
Use public buttons: When selected, manually updated shortcut buttons are shared between 

all UIs connected to the same server. A shared button is indicated by a small symbol in 
the top right-hand corner of the button (see Button Details in the section Keyboard 
Shortcuts).

Template Router

Use compact Template Router view: When enabled the Template Router will only show the 
on-air part of the Template Router. Saves a lot of screen real estate.
Template Router button size (1-3): Option to select the size of the Template Router button. 
Can save some screen space. Depends on screen size and resolution.

Sourceview

Hide action buttons: When unchecked, the three action buttons Sel, Prg, Prw are shown in 
the upper right corner of the Sourceview. These can be used to send the clicked items to 
preview or program or to enable select. If checked, only Select mode will be used and the 
buttons are hidden.

Note: Template Router is the new name for the Wall Manager.
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• SourceView background url: http: based background for sourceview. Can be used to provide 
live video using the http protocol.
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3.11.3 Audio Countdown

 

Audio file directory: Tells Viz Mosart where to find the audio countdown files. Files must be 
in PCM WAV format (16 bit, 48 kHz).
File naming must adhere to a strict standard. As examples:

60_sec.wav
30_sec.wav
10_sec.wav
5_4_3_2_1.wav

These are only examples. The Viz Mosart GUI countdown feature accepts and plays any file of 
the above format. 
For example, a file named 30_sec can be played when 30 seconds remain of a given event. 
Similarly, a file named 5_4_3_2_1.wav will play at the 5 second mark. The voice on the wav 
could either count "5,4,3,2,1" or just announce "5", or what ever you require.

Countdown to next BREAK template, file naming follows the standard of:

Note: For setting-up your Timing Display, see the section Timing Display.
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180_sec_Next_Break
120_sec_Next_Break
60_sec_Next_Break
30_sec_Next_Break
10_sec_Next_Break
5_4_3_2_1_Next_Break

Countdown story duration, file naming follows the standard of:
180_sec_End_Of_All_Stories
120_sec_End_Of_All_Stories
60_sec_End_Of_All_Stories
30_sec_End_Of_All_Stories
10_sec_End_Of_All_Stories
5_4_3_2_1_End_Of_All_Stories

Countdown LIVE story duration, file naming follows the standard of:
180_sec_End_Of_Live_Story
120_sec_End_Of_Live_Story
60_sec_End_Of_Live_Story
30_sec_End_Of_Live_Story
10_sec_End_Of_Live_Story
5_4_3_2_1_End_Of_Live_Story

Countdown FLOAT templates: Toggles an audio countdown file to be played from the Viz 
Mosart GUI PC when 3 minutes, 2 minutes, 1 minute, 30, 10 and 5 seconds remain until an 
adlibpix\float element with server\video content.
Countdown BREAK templates: Toggles an audio countdown file to be played from the Viz 
Mosart GUI PC when 3 minutes, 2 minutes, 1 minute, 30, 10 and 5 seconds remain until a 
designated Break line.
Countdown PACKAGE templates: Toggles an audio countdown file to be played from the Viz 
Mosart GUI PC when 3 minute, 2 minutes, 1 minute, 30, 10 and 5 seconds remain of the 
Package template.
Countdown story duration: Toggles an audio countdown file to be played from the Viz 
Mosart GUI PC when 3 minute, 2 minutes, 1 minute, 30, 10 and 5 seconds remain until the 
next story.
Count down to autostart rundown: Toggles an audio countdown file to be played from 
the Viz Mosart GUI PC when 3 minute, 2 minutes, 1 minute, 30, 10 and 5 
seconds remain until the rundown will autostart.
Countdown LIVE story duration: Toggles an audio countdown file to be played from the Viz 
Mosart GUI PC when 1 minute, 30, 10 and 5 seconds remain until the editorial duration end 
of a live story.
Countdown to next BREAK template: Toggles an audio countdown file to be played from the 
Viz Mosart GUI PC when 3, 2 and 1 minute, as well as 30, 10 and 5 seconds remain until the 
next break.
Countdown VOICE OVER templates: Toggles an audio countdown file to be played from the 
Viz Mosart GUI PC when 1 minute, 30, 10 and 5 seconds remain of voiceover templates.
Offset countdown to next break: Defines an offset in seconds for the countdown to next 
Break feature.
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• Enable audio countdown: Plays audio when counting down.
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3.11.4 Miscellaneous

Enable auto start: When this setting is selected, loaded rundowns with planned start will auto start. 
It can also be manually set in the GUI. It will also work during Break templates. 

Vizrt Preview Server: The address of the Vizrt-supplied server. See section AV Automation Devices 
Graphics in the Viz Mosart Administration Guide.
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3.12 Arrange Rundowns
In the Arrange rundowns panel, you can select which rundowns will be shown in the Viz Mosart 
timeline and which rundowns to put on air.

From the menu bar, navigate to Tools > Arrange rundowns. You can also find this window 
through Rundowns > Arrange.

From here, you can create or modify a rundown list which contains multiple rundowns.
Changes can be made before going on air or while on air.
The left pane lists the Mosart Active Rundowns, while the right pane lists the Available 
Rundowns.
- Drag items between the lists, or select an item and use the Add/Remove buttons.
- Clear empties the Active Rundowns list.
- Reorder items in the Active Rundowns list using the Move up or Move down buttons.
Click Confirm.
The items in the Mosart Active Rundowns list are loaded and visible in the Rundown window 
in the defined order.



Viz Mosart User Guide -  5.6

Copyright © 2024  Vizrt                                                          Page  214

3.13 Managing Your Workspace
By accessing the View > Manage Workspaces menu, the Manage workspaces window opens where 
the layout of an instance of the Viz Mosart GUI can be customized.

3.13.1 Customizing the Layout
The Viz Mosart GUI is highly flexible and can be changed to suit the particular needs of the 
individual station/channel/show/operator. To modify the visual appearance and layout of the GUI, 
the Workspace Manager can be used.

In the Workspace Manager, the various windows in the GUI can be removed or added by checking 
and unchecking the eye icon next to the Control menu. The sections can also be adjusted using 
the buttons - , + and arrows as shown in the timeline window in the image underneath. - and + 
changes the column span and row span, whereas the arrows moves the highlighted section to the 
section the arrow points towards. 

This might be useful for an instance of the GUI which is only used for monitoring purposes. Items 
like the keyboard window and Assets/Search/Favorites Tabs can be removed to give more space to 
the rundown.

Note: To add or modify keyboard shortcuts, the Keyboard Shortcut Editor is used.
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3.13.2 Resizing Elements

The elements can also be resized by dragging the grid borders. Any given layout can be saved as a 
workspace, and can later be recalled through the View menu or through a designated shortcut 
command.

3.13.3 Export/Import
To conveniently copy a given layout across several GUI installations, the Export/Import selections 
in the Workspaces menu can be used.
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3.14 Robotic Cameras

3.14.1 Working with Robotic Cameras

The Camera Robot Controller
The Viz Mosart UI includes a selectable control panel that displays the status of allocated robotic 
cameras.
By pressing the button for a camera robot, you can change its operational mode. 

To open the robotic camera control panel
From the menu bar select View > Floating windows > Robotic cameras.

Operational Status
The state of the camera robot is indicated by the button color 

GREEN: Camera robot is in operation and controllable from Viz Mosart.
ORANGE: Camera robot set in stand-by (disabled), and no longer controlled by Viz Mosart.
LIGHT GRAY: The camera robot has not been allocated to this Viz Mosart setup by the Mosart 
Media Router (MMR).
RED: Error communicating with the camera robot. The camera robot is inactive and not 
controllable from Viz Mosart.

To change camera robot operation mode
You can change the operation mode for the camera robots by pressing the button for the camera 
robot.

Pressing a green button places the selected active camera robot into standby, the button 
color changes to orange.
Pressing an orange button when the camera robot is connected, switches the selected 
camera robot from standby to active, the button color changes to green. If the camera robot 
is not connected, the button color changes to red. 
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Pressing a red button switches the selected camera robot from inactive to standby, the 
button color changes to orange.

Initial Setup
If you have enabled robotic camera control from Mosart Media Router (MMR), the system 
administrator needs to allocate each camera robot using a Virtual Studio manager (VSM) panel 
interfacing with the MMR, as described in (1) below.

If you don't use MMR for this, the allocated robotic cameras are configured in AV Automation 
Device Properties, as described in (2) below.

Refer to

The Viz Mosart Media Router Guide.
The Viz Mosart Administration Guide, section AV Automation > AV Automation Device 
Properties >AV Automation Devices Camera Robotics.

http://docs.vizrt.com/viz-mosart.html
http://docs.vizrt.com/viz-mosart.html
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3.15 Quick Access Panel
Viz Mosart provides several ways of controlling a newscast show. Stories gathered from an NRCS 
system are displayed as a rundown, as planned by the Director. But a Producer/Mosart operator 
can divert from this plan by skipping stories or items in the rundown or bring in new elements. 
This is done with keyboard shortcuts or browsing through the rundown. The Quick Access Panel 
(QAP) provides a compact view of the rundown content, with button sizes optimized for touch 
screens.

The Quick Access Panel

Makes it easier for a Producer making a dynamic rundown. It can also be a convenient way 
for Co-producers or Co-pilots to add more content to a rundown, while the Producer runs 
the show.
Shows all the executable control elements of the entire rundown, as buttons grouped by 
their originating stories.
Includes modifiable Story Filters, in the example above Cam, Vid and All.
The Producer or Co-pilot can filter to find specific elements, for example only 
cameras, which they can then modify in a running rundown.

The Quick Access panel can be displayed and operated separately from a second Viz Mosart client 
or as an standalone panel on the primary Viz Mosart client. The button size can be changed to suit 
typical screen sizes setups.

This section contains the following topics:

Changing the Appearance of the QAP
Modifying the QAP Display

Story Item
Story Control
Primary Elements
Secondary Elements
Story Status
Story Timing Information
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5.

•

Quick Access Panel Context Menu
Command Modes

Sel - Select Mode
Prw - Preview Mode
Prg - Program Mode
Vpl - View Preload Mode

Story Filters
Filter Bar Context Menu
Example Filters

Pool Favorites
Working with Pool Favorites

3.15.1 Changing the Appearance of the QAP

Modifying the QAP Display

To View the QAP Standalone
To keep all details on the buttons visible, you can have the QAP in its own window.

Start a new Viz Mosart client
Create a new workspace
Float the QAP with View > Floating windows > Quick Access Panel
Select View > Save workspace
to save the new layout.
(Optional) Create shortcuts to switch between workspaces.

To Change the Size of QAP Buttons
The size of the boxes can be modified individually in the right-click context menu of the top 
template group button, under Box width.
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3.15.2 Story Item

Story Control 

 
The Quick Access Panel shows each story as a rectangular box. Within the story box, each element 
and sub-element appear as a button. The story type is indicated in the story box header by color, 
corresponding to the type of story element. 
The type of the story is determined by the elements it contains. Beneath the story box the user can 
add a description by clicking Add Note.

The story item is always displayed within a story.
The background of the button indicates the template type.
The heading indicates template variant.
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A white text and red background as the template variant text indicates an unavailable
template.
The transparent text shows the slug.

You can take items (e.g. lower third, accessories, sound elements) On Air by clicking the button. 
The button gets a red border and appears in the program window. Take it Off Air by clicking the 
button again. Notice that if the item has a fixed time, it goes Off Air autonomously.

Primary Elements

CAM: Camera
PACKAGE: Video
VO: Voice over
LIVE: Live element
GRAPHICS: Full screen graphic element
DVE: Butterfly/DVE
FLOAT

Secondary Elements
Secondary elements are shown with a gray background.

LOWERTHIRD
SOUND
ACCESSORY

Story Status
If a story is On Air, its frame becomes red with a white font. The item that is On Air also gets a red 
frame. When the story or story item has been On Air, it gets a denser color.

Note: Clicking an item that already has gone Off Air, puts it back On Air again.
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If a lower-third has continue points, a bubble appears on the right, indicating remaining continue 
points.

Story Timing Information
Timing information is shown on top of stories.

Duration (normal): How long the story is planned to last.
Planned (on air): The same as duration.
Elapsed: How long the story has been On Air.
Duration (off air): How long the story lasted.
Countdown (black box): Time until story is planned to go On Air.
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Quick Access Panel Context Menu
Clicking in an item title bar displays a context menu:

Set as next story: This story is set as next.
Insert items: Inserts all visible items (except floats) in the current order after the running 
item in the current story. If the command mode is Air Mode, the first item is taken directly.
Insert all items: Inserts all items (except floats) in the story after the running item in the 
current story. If the command mode is Air Mode, the first item is taken directly.
Count down to: Starts counting down to the first visible item in the story.

3.15.3 Command Modes
The result of pressing the Quick Access Panel buttons in the list varies depending on which  
Command Mode button is active.

You select which command buttons are displayed by right-clicking any of the displayed 
buttons.

Sel - Select Mode
The selected item becomes the focused item. 
This item can then be sent to preview, program or wall by selecting within the dotted line on 
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the relevant control.

Prw - Preview Mode
The selected item is added to Preview.

Prg - Program Mode
The selected item goes directly On Air. 
If the user holds while clicking any of the boxed buttons, the boxed item is sent-to-preview 
(as with the story items in the rundown).

Vpl - View Preload Mode
If selected item is a video clip or graphic, it is sent to the configured preload/preview server/
engine.

3.15.4 Story Filters
An important part of the Quick Access Panel are the filters. By selecting various filters, you switch 
between different views. For example, you may have one for Cameras, one for Videos, one for Live
and DVEs.

Note: This mode is hidden by default, activate it from the context menu by right 
clicking on any of the buttons:


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Filter Bar Context Menu
Right-clicking in the filter bar opens a context menu, for filter operations.

Rename: Changes the name of the filter.
Add: Adds another filter.
Remove: Removes this filter.
Move Left: Changes the order of the filter left.
Move Right: Changes the order of the filter right.
Items (header): Applies filters below to the items within each story.
Show Templatetypes: Selects which kind of template types that are visible when this filter is 
applied
Show items with status: Selects which statuses the visible items can have: Valid, Invalid
(missing content etc), Aired (has been On Air), OnAir (currently On Air), Other.
Show items with templatestatus: Selects if items with Valid or Unavailable templates are 
allowed; or both.
Slug filter > Add: Adds a slug filter.
Slug filter > Delete: Removes a slug filter by selecting from a list.
Template variant filter > Add: Adds a template variant, within the selected template group.
Template variant filter > Delete: Deletes a template variant, within the selected template 
group. 
Story (header): Applies the filters below to each story.
Story > Show story types: Selects which kind of story types that are visible when this filter is 
applied. Lists all primary and secondary templates.
Story > Show story with status: Selects if items with the different statuses are visible when 
this filter is applied: Valid, Aired (has been On Air), OnAir (currently On Air), Preview (story is 
next), Other.
Story > Add slug filter: Adds a filter of the story slug/title.
Story > Delete slug filter: Removes a filter of the story slug/title.
Show operator items: Displays elements added within the GUI when checked. If not, all 
elements added by the GUI operator are not visible, only the NCS content is shown.
Hide story headers: When checked, only items in a list without story headers are shown, e.g. 
to save space.
Show only ad-lib items: Shows only items that do not have a planned in-time in the rundown 
show. Applies to ad-libpix templates and manual lower thirds.
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Box width: (1x, 2x, 3x, 4x): Specify the size of the item boxes. 4x is largest box, useful for 
viewing full clip names or long lower third slugs.

Distinct: Removes any duplicate item templates from the list. This selection also 
automatically enables Hide story headers.

To Add a New Filter
In the filter button row, alongside but not on the filters, right-click and select Add.
Enter a name for the filter. 
The first three letters of this name will appear on the filter button. The name must be 
unique.

The Quick Access Tab in the Media Pool shows the same filtered elements, grouped by stories.

Example Filters

For more operations, refer to the section Quick Access Panel.
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Displaying Missing Clips and Graphics
You can filter to display the checkered clips or graphics in the rundown. This is useful during a 
show to quickly verify if clips and graphics are available. 
It can also be very useful to add countdowns to these clips. The countdown displays how long until 
the clip has to be ready.

Show template types > [PACKAGE | VO | GRAPHICS]
Show items with status > [InValid]

The countdown shown in the upper right corner can be set by right clicking the title bar of a story 
and selecting Count down to.

Show Missing Templates: The filters can also be used to display missing templates. By applying the 
filter Show items with template status > Unavailable, the producer (or anyone using a GUI) can 
quickly spot any elements missing a proper template.

Show a Slug Filter: If the NCS Stories has a naming convention, it can be easy to create container 
stories. For instance all highlights from a soccer match can be added to a specific story. Then by 
applying the slug filter “SOCCER_HIGHLIGHTS*”, all of these clips become available to the producer 
very quickly without having to scroll up and down the rundown. This approach also works very well 
with FLOATS (Adlibs) - clips.

Show Valid Floats: If the producer wants to have valid floats in the current On Air story readily 
available, this filter can be used.

Show items with status > Valid
Show template types > FLOAT
Show items with template status > Valid
Show story with status > On-air Story Items.
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3.15.5 Pool Favorites
The Favorites pool is by default hidden. Enable it by clicking on the bar on the right edge of the 
Quick Access Panel. This expands the pool Favorites section. 

Working with Pool Favorites

To Add an Item to the Favorites Pool
Mark Sel as command mode.
Select an item in the left section.
Click the + icon at the top of the Favorites pool panel.

To Remove a Favorite from the Pool

Mark Sel as command mode.
Select an item in the pool.
Click on the big trashcan button bar at the bottom of the favorites pool.

The items in the Media Pool are the same as in the Quick Access Panel pool.
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3.16 Template Router

 
The Viz Mosart Template Router provides a convenient method of controlling what appears on the 
studio wall or on other AUX devices.

This is achieved by merging an Accessory template with the taken template, causing the signal to 
divert to, in this example, the wall.

Template Router is optimized for a touch screen.

This section contains the following topics:

Prerequisites
Creating a template router accessory in AV Automation
Template Router User Interface
Configuring the Appearance of Template Router
The Accessory Merge Shortcut
Creating a Template Router Shortcut
Countdown of Template Router Elements
Direct Take Route Shortcut
Salvo
Video Clip Playout Use Cases

3.16.1 Prerequisites
The procedure of preparing keyboard shortcut-driven template (re-)routing, assumes that the 
relevant Accessory templates have already been created.

Note: In earlier versions of Viz Mosart, the Template Router was referred to as Wall 
Manager.


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The wall accessory template is created as a normal template in AVAutomation.

You can create a new accessory template with a variant name of for instance “wall2”

3.16.2 Creating a template router accessory in AV Automation
When creating a wall item you have to create a new shortcut. But before you can do that you need 
to create a wall accessory in Av Automation. The accessory will merge with the taken template 
causing the signal to go to the wall. The accessory can contain settings for cross points, video 
server port, graphics engine and aux. (In the following example the accessory is called ‘wall1’).

Switcher cross point

To change switcher crosspoints enable «Switcher crosspoint» in the template editor. The Switcher 
XPoints will appear. Here you can set the ME-step you want for the wall taken template.

The ME-step will show as a mix effect in the template editor xpoint tooltip.

Video server port
If a video clip is taken; another video server should be used. This can be changed in the accessory.

Note: For guidelines on creating Accessory templates (in AV Automation), specifically when 
using the Template Router, refer to the Viz Mosart Administrator Guide, section Accessory 
Templates under Building Viz Mosart Templates.



Note: When the template is set to the wall item it will use this ME step instead of the one 
specified in the template.


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Make sure the video clips are available through this port.

AUX
The AUX is controlled by the template but should be added to the accessory template. The setting
will be replaced by the wall taken template.

Graphics

To avoid conflict with other graphic elements you may want the wall to run on its own engine. This 
can be changed in the accessory.

A wall taken graphic element will then use this engine.

3.16.3 Template Router User Interface
The Template Router enables sending of content (clips or graphics) to specific destinations in the 
studio, typically video monitors (walls).
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Compact View

Template Router can be viewed in either Compact or Salvo view. See Configuring the Appearance 
of Template Router.

Salvo View

In the top area (red) the on-air wall templates are shown. In the bottom preview area (yellow) 
the selected salvo is shown.
The TAKE SALVO button takes the wall items in the preview area on air. It is also possible to 
take templates directly on air without using the salvos.
During a show you can change templates on preset video wall salvos by selecting a salvo 
and then pressing Take Salvo.

3.16.4 Configuring the Appearance of Template Router

Compact View or Salvo View
The Template Router can be viewed in the GUI in either Compact view or Salvo view. In addition, 
you can choose a button size that presents sufficient details within the Template Router panel.

To Change the View Setting
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Go to Tools > General settings > User interface  > Template Router.
Select the Use compact Template Router view option.

In Compact mode, the Template Router only shows the on air salvo section. This view works well 
when placed above the Quick Access Panel and/or Media Pool, so you can drag elements from the 
Media Pool or select an item in the Quick Access panel and tap a wall item to execute the template.

To Change Button Size

Go to Tools > General settings > User interface  > Template Router.
Select the Template Router button size, select a value between 1 (smallest) and 3 (largest) 
button size.

3.16.5 The Accessory Merge Shortcut
A accessory merge (aka Wall Button) item in Viz Mosart GUI is defined as a shortcut of 
type Template Router Button. This item can be modified very quickly and taken on air using 
a Direct Take Wall Shortcut or a Salvo.

3.16.6 Creating a Template Router Shortcut
This example uses Template Router to divert taken content to a video wall. It assumes that one 
Accessory template has been created for each wall you want to control.

You create a Template Router wall shortcut, using the Keyboard Shortcuts editor on the Viz 
Mosart menu bar.
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Select Tools  >  Keyboard shortcuts editor.
Click Add new shortcut.

Select Template Router Button > Accessory merge.
Select the accessory template for the wall you want to control.

Type in a name for the wall. It is recommended that you call the wall shortcut the same as 
the Accessory, but this is not mandatory.
If you are using several wall elements you have to drag and drop them to the wall canvas in 
the Keyboard shortcuts editor. 

If not visible, reveal the Template Router panel with View > Floating windows > 
Template Router.
Click the tools Cogwheel and select Edit mode.

 
While in this mode it is possible to drag the wall items around and make it easier to 
recognize the different elements during production.
When ready, click Edit mode again, to exit.

When you have added all the wall items you want to use, click Save and close the editor.

3.16.7 Countdown of Template Router Elements
When a video clip is played on a wall using the methods described in Creating a Template Router 
Shortcut above, the Template Router will display a countdown of the clip in the element in the on 
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air canvas. 
When the video clip is stopped, the countdown square is not shown.

For example, the image below shows a clip with a duration of 12 seconds, and 4 seconds 
remaining.

 
The clip can be controlled by sending control commands from the GUI with some parameters. 
When the clip is taken on a wall item, it will be cued and played. The countdown will start 
immediately. By using Video Port Control Commands, the clip can be paused, stopped, re-cued and 
other additional operations.

The Video Wall countdown states are:

Playing
Cued
Paused
Playing but time remaining is low (the value is specified in Settings > User Interface - 
Preview/Program Window > Clip visual countdown)
Playing and Looping
Cued and ready to begin looping
Paused while looping

Post Roll Frames
The media administrator has Post roll frames, which will not be used when counting down. For 
example, if a post roll of 75 frames is used, then there will still be 3 seconds left of the clip. 
Set the Post roll frames to 0 if you want to see the actual countdown.
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3.16.8 Direct Take Route Shortcut
A Direct take route shortcut allows you to take a template directly to air on e.g a wall, quick and 
easy.

To Direct Take Route using a Keyboard Shortcut
Choose a selectable keyboard shortcut. (It will be highlighted in the keyboard buttons panel)

Select the element to take it on air

To Direct Take Route using Quick Access Panel Shortcut 
Make sure the Quick Access Panel Command Mode is Sel - Select Mode.
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Select a Story Item 

Select the element to take on air

To Direct Take Route by dragging from Media Pool
Any item from the Media Pool can be dragged and dropped directly on a Template Router 
Accessory Merge shortcut item. This also applies for video clips located with the Search Tab. These 
clips will then use the template as defined in Tools > General settings >  User interface  >  Search 
pool.

3.16.9 Salvo
A salvo is a set of templates that will be sent to some elements. When taking a salvo all the items 
in the salvo will be taken on air. The Template Router UI encourages the use of salvos when 
working with wall elements.

To Add a Salvo

To add a new salvo click the New button, type in a name of the salvo and press OK.
You also have the option to Remove or Rename the selected/previewing salvo.

To Fill a Salvo
To fill a salvo with routed templates, you use a procedure similar to that for Direct Take Route 
Shortcut.
The only difference is that you click the items in the Preview canvas instead of the items in the On 
air canvas, as follows:
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To Fill a Salvo Shortcut Using a Keyboard shortcut
Choose a selectable keyboard shortcut. (It will be highlighted in the keyboard buttons panel)
Select the element to fill in the preview canvas

To Fill Wall Shortcut using Quick Access Panel
Make sure the Quick Access Panel control is in Sel - Select Mode
Select a Story Item
Select the element to be filled in the preview canvas

To Clear Existing Salvo Items
To remove a item from the preview canvas you can select another item from the keyboard 
buttons or Quick Access panel and click the item you wish to replace.
To clear a item, open the context menu and select Clear.

To Send Items to Wall using Quick Access Tab

Note: The QUICKEVENT control commands use WALL terms since the Template Router used 
to be named Wall Manager. For backwards compatibility the command name has not been 
changed.


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Select the item you want to send to wall using the QUICKEVENT commands.
The Quick Access Tab (QAT) can be used with the QUICKEVENT Control Command 
TAKE_SELECTED_TO_WALL. If you want to use the selected preview wall salvo then use the 
PREVIEW_SELECTED_TO_WALL control command.
Click the keyboard button with the defined shortcut with the QUICKEVENT variant 
TAKE_SELECTED_TO_WALL and the name of the accessory used by the wall item as the 
parameter.

 
You can also drag and drop items from the Media Pool to any wall.

To Send Items to Template Router using Source View
Select the source you want by clicking on the Source view template to select it (does not 
work for other source view types).
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Select the element to fill in the item.

3.16.10 Video Clip Playout Use Cases

Independent Video Port Control
To play cover pictures from independent video ports, so that the director can choose to air 
these clips across live events, studio discussions or as-live clips, use the Template Router, as 
well as Quick Access Panel.

It is important that a separate port if used for this. This can be set up in the accessory 
template.

Combining Quick Access Panel and Template Router for Video Clip Playout
In combination, these elements become a “clip router” – enabling the operator to select any clip 
from the Quick Access panel and send it to cue and play in the port of their choice.

If available, the Quick Access panel and Template Router can be set up on a touch screen – making 
it even more user friendly.

With this configured it is now possible to manually assign clips to play in these four ports 
simultaneously - outside the timeline of Viz Mosart. As long as the selected mode in Quick 
Access panel is Sel - Select Mode. These routings are entirely independent of the A/B roll. Ensuring 
that the primary clips will not be interrupted by the playout of cover pictures.

In the example below, the LVO clip “A30” has been sent to play in Server Port C.
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Sourceview with Template Router.
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3.17 Recording

3.17.1 Recording a Viz Mosart Feed
Viz Mosart can be configured to record the feed to PGM. This is a 'dirty feed' that includes all 
onscreen graphics etc.

Creating a Recording
The Recording panel is used to prepare a new recording.

To create a recording
Go to Main menu > Tools > Record.
The name of the current salvo appears in the dialog menu bar (in the example above, 
Omneon).
Press Add (+).
A unique filename is automatically created, comprising a combination of clip 
name, gallery, template set and a timestamp. For details, please search section Video Server 
and MAM Connection Strings, in the Viz Mosart Administrator Guide for property 
ClipNamePattern.

Note: Viz Mosart also offers recording with versatile retake features. See the topic Story 
Recorder Mode for details about creating a single clip for transmission, composed of 
multiple rundown-driven stories.



Note: The Recording window is only available if AV Automation has been configured to 
allow recording. See the procedure To Add Recording Ports in section AV Automation 
Devices Video Servers (Working with Mosart Port Configuration) in the Viz Mosart 
Administrator Guide.



http://docs.vizrt.com/viz-mosart
http://docs.vizrt.com/viz-mosart
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3.18 Sourceview

3.18.1 Introduction
Sourceview presents a customizable view of sources, laid out on a configurable canvas.

Supports live streams using NDI sources within the same subnet.
You can set an HTML page or a NDI stream with a live video feed from a multiviewer as 
background of the entire Sourceview and create transparent source boxes on the top layer.
Sourceview can be used to select sources and assign them to either Program or Preview 
Window or to Template Router destinations. 
Sourceview harmonizes with the Template panel, which can be configured for specific 
templates requiring a source input.

3.18.2 Working with Sourceview

To Open Sourceview
Open Sourceview as a floating window by selecting View > Floating windows > Sourceview. 

Tip: You can also have Sourceview as a part of a defined work space.
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To add a new source
Open Sourceview
Click the gear icon to start editing. Editing is not available while the timeline is running.

Click the + icon.
Select a source type from the drop-down menu.
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(Optional) If Camera, Graphic or Live is selected, you are prompted for a variant. 
Select the template variant that shall be used on the destination where this template is 
assigned when selected.

(Optional) If Stream is selected, you can select a xpoint (crosspoint). 
This xpoint is used if used to assign a source in the template panel.

NDI Stream

Any available NDI streams are selectable the drop-down. A Sourceview item has the same 
workflow without an NDI stream.
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When selected the NDI stream is shown inside the Sourceview source box.

If Program or Preview is selected, clicking Apply to Program will assign the NDI stream to the 
program window. 
The same applies to Preview. The program and preview source should be a NDI stream of 
the program and preview mixer output.

Press the Eye icon to end editing and save the new source. 

Reload Sources
If there are any problems with any of the sources it is possible to reload all sources by selecting 
the top menu option Tools> Sourceview > Refresh.

Note: It is also possible to use a static html page to show the output. This can be 
configured in General settings


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Resizing and Moving

To resize the Sourceview item, ensure the Resize icon   is enabled and drag the edges of 
the Sourceview item to the desired size.
To move it, click and drag it to the desired position. 
If the resize icon is disabled the items are selectable, but they cannot be moved or change 
size. 

Assigning a Source to Program or Preview
While not in edit mode, click a source in the sourceview to select it.
A selected source has a solid color as title background instead of the otherwise white 
background. Program and Preview have a dotted line to indicate that the selected source can 
be assigned.

Click either Preview or Program to put the template of the selected source in preview or 
directly On Air. 
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Below the template is taken into preview.

For assigning a source to a wall, see Template Router.
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3.19 MSE Playlist Panel
Media Sequencer (MSE), is a Vizrt graphics server.
The MSE Playlist panel offers active (touch or click-sensitive) thumbnails of graphics held on 
an MSE.
Each thumbnail behaves as a toggle switch, by clicking the thumbnail you set items from an 
MSE playlist on and off air to a Viz Engine.
The panel is designed for touch but also works with mouse.
All available playlists can be browsed.

Opening the MSE Playlist Panel
Browsing Playlist Graphics
Taking a Graphic to Air
Deleting a Graphic
Selecting Graphics Profile
Advanced Topics

Warning Messages
Connection to MSE
Current Rundown Graphics Source

3.19.1 Opening the MSE Playlist Panel
The MSE Playlist Panel can be viewed as a floating window or as a docked window.

Select  View > Floating windows > Playlist Panel. 

Note: To be able to see thumbnails in the MSE Playlist, Viz Mosart must first be configured 
to find the MSE. The Connection to MSE section below also covers the basics of this topic.
See also the Viz Mosart Administrator Guide, section Configuring the MSE Playlist Panel for 
more details.


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3.19.2 Browsing Playlist Graphics
You can browse the playlist folders that hold available graphics.

Click the folder's icon to open it.

A folder can contain additional folders, as well as playlist elements which can be played out

Use the scrollbar and arrows to navigate all folders.
The squares in the lower right indicate where you are in a long list.
Use Hide folders to make more room for items.
Use the Left or Right arrows or page number for playlists with a lot of content.
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3.19.3 Taking a Graphic to Air
Select required playlist (touch or mouse).

A red filler indicates the item has been taken to air.

3.19.4 Deleting a Graphic
Graphics can't be deleted from Playlist panel directly.
If the graphics is deleted from rundown in the NRCS, it is automatically deleted from the Viz 
Mosart rundown, Overlay Graphics list, MSE and Playlist panel.

3.19.5 Selecting Graphics Profile
The MOSART profile is used by default. You can switch to other graphics profiles.

Click the MSE status icon on the task bar to open the Select profile dialogue. 

The same red indication is used when another system takes the graphic out.
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Select a new graphics profile by clicking one of the named rows.

3.19.6 Advanced Topics

Warning Messages
Warnings are displayed when things don't go as expected. For example, when a profile does not 
exist.

See Selecting Graphics Profile or contact your support organization for assistance.

Connection to MSE
If when browsing the Playlist panel, you get the warning MSE Playlist Host is not configured, 
you can add the host address of the Media Sequencer directly.

Both computer name and IP can be entered.
Click Connect

Contact your system administrator for further assistance.
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The graphics in the current rundown loaded from NRCS are in the Playlist panel folder as 
configured in
Overlay Graphics > Properties > Controller Properties> >Playlist.
For example- If the value configured in Overlay Graphics is as "Mosart_Overlays" 

  .
Then the graphics in rundown can be found in the Playlist panel at the folder:

Current Rundown Graphics Source
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3.20 Story Recorder Panel
The Story Recorder panel displays all controls and management features for recording and 
retaking a show.

Det
ail

Description

1 Name of the final clip show and the associated EDL files: By default, this is the rundown 
name or provided from NRCS. The user can edit as required.

2 Recording Time/ Show Countdown

Recording Time: When timeline is running, this is continuously growing, equal to the sum 
of the already recorded sections plus the duration of the current recording. When 
timeline is paused, this is static, equal to the sum of the recordings prior to the selected 
retake point.

Show Countdown: Displays the difference between the planned duration as defined in 
NRCS and the Recording Time.
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Det
ail

Description

3 Story name: This name is fetched from the NRCS slug.

4 Start time: Timestamp when the item was taken to PGM (wall-time) HH:MM:SS .

5 Notification: Operational information and warning/errors.

6 Broadcast: Send the stitched show to one or several pre-configured destinations for 
transcoding (consolidation).

7 Broadcast count: Number of successful broadcasts.

8 Duration: Story item onair time in HH:MM:SS:FF (frame count only shown after the item is 
paused/ recorded).

9 Separator: Indicates a retake.

10 Selected row: The row with focus is colored gray-on-black.

11 Pre-roll duration: Number of seconds count in, after a pause is restarted.

12 Retake point selector: Arbitrary retake point. This button is displayed when the row is 
selected and when clicked, it changes the retake point.

13 Pause indicator: Displays which story item is currently paused

14 Blue border: Retake point indicator. The item that will be taken after pause has a blue 
border.

15 Cut review player: Play button is displayed when a snippet clip around the cut point 
becomes available for review.

16 Retake marker: Indicates where an item has been retaken.

17 Item name: The item name, that corresponds to a Viz Mosart template and variant

18 Record | Pause: Story recorder record and pause button and status indicator.

19 Switch: Story recorder activation switch.

For further details, see Story Recorder Mode.
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4 Templates
Behind each operation displayed on the timeline in the Rundown window, is a Viz Mosart template.

A Viz Mosart template is the key element of controlling external devices and events handled by Viz 
Mosart. A template can send simultaneous control commands to multiple studio devices.

Typically, the actions defined on a template are either:

Automatic
Either invoked from another template or at a given time as part of the rundown
Preconfigured 
Configured in the newsroom control system (NRCS or NCS) as part of a rundown, and then 
manually executed by the Viz Mosart operator
Manual
The operator initiates the template-driven operation, usually from a keyboard shortcut or 
touch panel.

Some template features are introduced below:

Template Sets
Working with Templates
Template Terms and Definitions

4.1 Template Sets
Templates are organized in template sets. Typically, there will be a template set for each show/
program. As Viz Mosart runs, one template set will be current, meaning templates that will be 
executed during the show are drawn from this set. 
An alternative set can be selected as the new current set, see Current template set below.

4.1.1 Standalone
Traditionally, Viz Mosart template sets are treated individually, with no connection to each other.

For example, a template set is created for each show or program. This is usually combined with 
automatically selecting the template set through the associated NRCS rundown. In addition, 
startup commands for preparing the studio (lights, sound etc.) for running the show are included 
in the template set.

When creating a template set for a new program, it is based upon a copy of an existing template 
set, with small adjustments according to the functionality needed by the program.

When this new template set is created (by copying an existing set), a copy of all templates is made, 
and no references are made between the original and copied templates. Each template set is 
classified as ‘standalone’.

Disadvantages with this approach:

Many duplicates are created. Normally only a few of the templates in the set need to be 
adjusted for meeting the needs of a new program.
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With an ever-growing bank of templates being created for each new show, the amount of 
stored templates in Viz Mosart can exceed system norms. This results in long response 
times when saving templates and increases the memory footprint of both the Mosart Server 
and Viz Mosart client workstations.
Maintenance of templates becomes cumbersome and error prone. When a change is made in 
a template that is common for all template sets, the same change has to be applied 
individually to every template set. This is a time consuming task across numerous template 
sets.

4.1.2 Hierarchical
An alternative approach to standalone is hierarchical template sets. This method also enables 
a new template set to be created, based on the logic of an existing template set. However, to begin 
with, no templates are copied from the existing template set.
Only when a change is made to an existing template, or when a new template created, is a 
template created and stored in the new template set.
The hierarchical approach can be adopted with all existing (standalone) template sets, to optimize 
machine capacity and introduce a more efficient workflow.

Referring to the background discussion in Working with Template Sets above, when you copy a 
template set, it is more efficient to use a hierarchical approach. These operations are usually 
performed by a system administrator, as outlined in Creating Hierarchic Template Sets below.

4.1.3 Direct Take
In addition to standard show-related template sets, there is a special template set 
called Directtakes.

Unlike standard templates, templates in this set are not intended to be executed as part of the 
rundown.
Instead, they are usually manually executed during a running show immediately in an ad-hoc 
fashion.

Often a unique numeric value is assigned to each direct take. The operator enters executes the 
direct take template by entering its number on a numeric keypad.

4.2 Working With Templates
You create and edit individual templates and template sets (standalone and hierarchic) in the  AV 
Automation application, Template Editor.

4.2.1 Creating a Hierarchic Template Set
Templates are created and customized during the 'show design' phase of a Viz Mosart 
system setup.

This is a specialist operation, described in section AV Automation > Template Editor of the Viz 
Mosart Administrator Guide (can be browsed from Viz Mosart UI menu bar Help > Viz Mosart 
Administrator Guide).
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4.2.2 Templates in the AV Automation Application

To create and modify show templates
With a combination of mouse-over and contextual menus, an administrator can create and 
modify the templates that comprise a Viz Mosart-driven show.

This is a specialist operation, described in section AV Automation > Template Editor of the Viz 
Mosart Administrator Guide (can be browsed from Viz Mosart UI menu bar Help > Viz Mosart 
Administrator Guide).

To browse your show templates
From the AV Automation console program (running on the Viz Mosart server), navigate 
to Main menu > Devices > Template editor.
Templates displayed in Template Editor provide detailed information about their origin, 
purpose and control settings.

4.3 Template Terms And Definitions
Some common terminology used in template design and execution:
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Base template set: The start point for a show design.
For example, if a template set TS2 is based upon template set TS1 then TS1 is defined as the 
base template set of TS2. Programmatically, this relation can be written in short notation as 
TS2 > TS1
Current template set: The active template set in Viz Mosart. Changing the current template 
set is normally done from either:

The Viz Mosart client, from the Studio setups menu.
The NRCS (for example, ENPS or iNEWS) using the Viz Mosart control command [STUDIO 
SETUP]
The Viz Mosart server application Av Automation, from the the Studio setups menu.

Directtakes: A special template set, where templates in this set are intended to be manually 
executed in an ad-hoc fashion.
Empty template: An undefined, non-operative template. An empty template does nothing 
when executed. Note that empty templates are not displayed in the Viz Mosart client.
Gallery: Corresponds to a Viz Mosart installation. Typically a gallery has a dedicated Viz 
Mosart server, with configured utilities and a Viz Mosart client.
Inherited template set: A template set based on another template set. 
For example, if TS2 > TS1 then TS2 is classified as an inherited template set.
Missing template: A template that does not exist in the current template set. The operator is 
alerted to a missing template in the Viz Mosart client, where it is displayed with red text.
Shared template set: The template set shared among all Viz Mosart installations that are 
connected to the same Viz Mosart template database. 
Show design: The background task of creating a set of templates, in a logical and 
programmatically valid order, for controlling a scheduled, rundown-driven, studio 
transmission.
Stand alone template set: A template set not based on any other template set. All template 
sets in a current installation of Viz Mosart are classified as 
standalone. Programmatically, this relation can be written in short notation as TS1 > () 
Template description: The template properties common for all Viz Mosart installations in a 
shared template set. This description uniquely identifies and describes the template.
Template implementation: Contains the behavior or device control aspects of the template. 
The template implementation is related to the Viz Mosart installation. For a shared template 
set, each Viz Mosart installation will implement the template set differently, according to 
local studio setup.
Template set:  Viz Mosart templates are always contained in a template set. There may exist 
multiple versions of the same template but in different template sets. A template is uniquely 
defined by its type and variant name within its corresponding template set.
Template type: Template type or category. Viz Mosart has a predefined set of template 
types. Each are displayed with a distinct visual appearance in Viz Mosart. 
Examples of template types are CAMERA, PACKAGE, VOICEOVER, LIVE, GRAPHIC and DVE.
Template variant: Unique identifier of a template for given template type within a template 
set.
For example, camera1 and camera2 are two variants of a camera template.
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1.

2.

3.

4.

5 Audio Panel
The Audio Panel is a standalone utility that visualizes a Behringer BCF2000 or JL Cooper MXL audio 
mixer, connected to the Viz Mosart Server, replicating faders, on air faders and faders in preview.

Setting-up the Audio Panel
Server Settings
Panel Settings
User interface

Fader Configuration
Fader Edit Menu
Selecting a Source
Assign Function Keys
Update After Viz Mosart Server Switching

As a software solution, the Audio Panel controls data transmission between the physical hardware 
panel and the AV Automation component on the Viz Mosart Server.

5.1 Setting-Up The Audio Panel
There are some once-only setup steps to get the Audio Panel working.

Install the Audio Panel software from the Viz Mosart installer directory, named something 

like VizMosartAudioPanel-5.0.2.32414.msi .

Start the Audio Panel from the Windows start menu.

(It resides in the Viz Mosart folder  C:\Program Files (x86)\Mosart Medialab\Mosart 

Audio Panel\AudioPanel.exe).
From the Audio Panel's menu bar, select Tools > Settings > General Settings > Server.
Here are the Viz Mosart UI's connection settings that you will also use for the Audio Panel.
This is where you configure the Audio Panel to find the server for Viz Mosart.
Use the same settings as the Viz Mosart UI.
(Must be the same as for a GUI connected to that server). 
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The Audio Panel requires Manus Administrator and AV Automation to run, as well as a green 
connection to that Viz Mosart server in the bottom left corner.
Configuration file is located in C:\ProgramData\Mosart Medialab\ConfigurationFiles\ or C:
\channeltemplates\. The configuration file is created on startup of Audio Panel if it does not 
exist.

Below are a selection of options to help you set up an audio fader panel.

5.1.1 Server Settings

Item Description

Connection name This is the name used by the Audio Panel GUI.

Main This can either be 
- server name or 
- IP address + port number.

Backup Same as Main, used for the backup server.

Note: The configuration file is located in C:\ProgramData\Mosart 
Medialab\ConfigurationFiles\ or C:\channeltemplates\.
This configuration file is created on startup of Audio Panel, if it does not already exist.


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5.1.2 Panel Settings

Item Description

PanelName A self-chosen name for the Audio Panel.

Panel Type The type of connection used for the Audio Panel (for example, 
MIDI, RS422, RS232).

Panel Port The specific port used in the above connection (for example, 
COM3).

Panel Index You can utilize several panels, so each shall have a unique 
number.

Set Labels Check if you wish to send label information back to the panel 
(only for panels with LCD label buttons).

5.1.3 User interface
Use these settings to Bank faders on the JLCooper Panel.

Midi Bank Commands: Specifies MIDI controls on the JL Cooper Panel. Default values 
correspond to F1, F2, F3 and F4 keys.
Show Banks: Shows the bank associated with each fader in Audio Panel GUI on the top side 
for each fader if enabled. The bank for each fader can be changed by right clicking on the 

General
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fader label and selecting the bank from the displayed pop-up list.

In the Show menu there are options to show MIDI commands and to highlight in orange the 
selected bank on the faders.

5.2 Fader Configuration
Configure fader operation properties by right-clicking on any fader, and selecting Edit.
(the box with the numbers indicating the level of the fader).
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5.2.1 Fader Edit Menu

Menu 
Item

Description

MIDI 
Learn

Assigns any physical fader on the Audio Remote panel to the selected fader in the Audio 
Panel. 
After selecting this function, move the fader on the physical mixer so Audio Panel learns 
and memorizes this function.

MIDI 
Clear

Deletes the assigned physical fader from the Audio Panel.

Fader
Mode

Selects whether the logical fader should work in Preview, Program or as a Generic fader 
which is constantly in use. 
Program: Retrieves the active faders from the template in the program. The virtual fader 
becomes visible, and can be adjusted when On Air.
Preview: Retrieves the active faders from the template in preview. It permits you to 
change the levels while it is in preview before it is taken On Air.
Generic: Simple remote operation of a physical fader on an audio mixer.
Constantly connected from the same source. Locks the fader to the same source (for 
example, Mic 4) always remains static in the Audio Panel and does not change based on 
current story in Viz Mosart. 
See Also Selecting a Source.

Fader
Type

Select a text that you wish to display as label information in the panel.
Only for panels with LCD label buttons.

Move Moves the selected fader UP or Down in the Audio Panel

5.2.2 Selecting a Source
If you are using the GENERIC fader mode, a source from the source list can be selected by right-
clicking in the area where labels are listed. Check the default number of faders. Input selection can 
be configured by right-clicking the fader header and selecting fader names.
You can select a fader label by right-clicking on the label (the black area just below the fader 
header) and selecting the appropriate function in coordination with your audio mixer.

Note: Selecting ANY could remove the label. If no label is present, then an ANY function is 
the selected label.
To change the label again, right-click in the required fader, Edit > FaderType then select a 
new label.


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5.2.3 Assign Function Keys

Any function buttons below the GUI faders can be assigned to any of the function keys on a 
physical audio panel.
The function of the button is set under the Function menu.
The name can be changed using Rename.

Menu Item Description

MIDI Learn Assigns any physical button on the audio remote panel to the 
selected button in the Viz Mosart Audio Panel. 
After selecting this function, click the button on the physical 
mixer so Audio Panel learns and memorizes this function.

MIDI Clear Deletes the assigned physical button from the Audio Panel.
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Menu Item Description

Function Select a function for the button. Will be triggered on the fader 
in AV Automation. 

PFL: Activates the pfl mode on the fader.

MUTE: Activates the mute mode on the fader.

STANDBY: Activates the standby mode on the fader.

MANUAL: Activates the manual mode on the fader.

AUDIO GPI - ON OFF: Toggles the Audio GPI for a specific GPI 
number on the mixer.

AUDIO GPI - ON: Turns the Audio GPI for a specific GPI number 
ON.

AUDIO GPI - OFF: Turns the Audio GPI for a specific GPI number 
OFF.

Rename Renames the button label

5.2.4 Update After Viz Mosart Server Switching
The server that the Audio Panel GUI is connected to follows the Viz Mosart GUI. Switching between 
a main and backup server in the Viz Mosart GUI automatically configures the selected server in the 
Audio Panel GUI accordingly.

AUDIO GPI functionality is only available for Studer 
3000 and Lawo RMNOPL drivers





Viz Mosart User Guide -  5.6

Copyright © 2024  Vizrt                                                          Page  267

•
•
•
•

1.

2.

6 Playing Audio
An Audio Player is included as standard in Viz Mosart. You can use it to play out audio files located 
on the file system. This is useful, for example, to play out audio files that are used regularly, like 
openers and audio-beds.

Initial Configuration
Supported Formats
Audio Player UI
Audio Player Settings

6.1 Working With The Audio Player

6.1.1 Initial Configuration
This is performed by a system administrator and is described in the Viz Mosart Administrator 
Guide, section AV Automation Device Properties.

6.1.2 Supported Formats
mp3, wav, wma, aac, m4a, mp4, aiff, avi.

6.1.3 Audio Player UI

Open the Audio Player by clicking its desktop icon .
If there is no icon, you can start the program from
C:\Program Files (x86)\Mosart Medialab\Mosart Audio Player\Mosart Audio Player.exe

If you need to make any changes, for example show a Testing panel for previewing your 
audio files
from the menu bar select Settings as described below.

Note: The Audio Player replaces the discontinued Soundfile Player.

http://docs.vizrt.com/viz-mosart.html
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6.1.4 Audio Player Settings
These are advanced settings that for most users, need not be changed.

Testing Panel
Select this option to display a player at the foot of the Audio Player panel.

To select the directory containing your audio files that you wish to test, click Change 
Directory.
Click the double-arrow to list and select your files for play.
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a.
b.
c.

Behavior when file is already playing

In this panel, you can determine what action the Audio Player will take when a new file is 
played and a file is already playing.

Outputs
A list on the left shows all outputs. The list on the right shows all available playback devices on the 
computer.
The line between them shows which playback device the output uses to play the audio file.

To select audio device for an output
Click an Output.
The panel below displays a drop-down menu of available devices.

Choose from the displayed devices to associate one of your computer's playback devices 
with the selected output.
(Other operations) Here you can also

Rename
Delete
Create a New
output

Help
When working with settings, a tooltip box at the bottom of the panel displays additional 
information about the current operation.
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• Mouse-over a setting to see the tooltip.
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7 Timing Display
The Timing Display provides timing information for the studio control room and studio floor. The 
timing display is synchronized with the current rundown in Viz Mosart and can be configured to 
display details only relevant to the user.

You can run as many customized Timing Display applications as required. For example, the Timing 
Display can be running on the studio floor and be connected to the in house intercom system to 
provide an audible count to the presenter’s earpiece. An additional Timing Display can be running 
in the control room with a monitor speaker for counting down packages, so the producer is 
updated on the current production.

7.1 Customizing The Timing Display
The Timing Display can be modified to suit your specific studio requirements and workflows.

Grid lines
Selecting Timing Display panels
Audio Countdown

Note: From Viz Mosart 5.0.3, a convenient web-based Timing Display is offered as an 
optional web application. For details, see the Mosart Web Applications Guide.



http://docs.vizrt.internal/viz-mosart.html
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7.1.1 Grid lines
Enabling grid lines, makes it easier to add/remove Timing Display panels.

To Enable grid lines
 Right-click anywhere in the window and select Show Gridlines And Panel Names. 
Information about the individual sections are presented in the Timing Display.

7.1.2 Selecting Timing Display panels
Each panel is selectable from a dropdown list.
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• Right-click > Show

Explanation of the Selectable Timers



Viz Mosart User Guide -  5.6

Copyright © 2024  Vizrt                                                          Page  274

•

•

•
•

•

•
•

•

•

•

•

Element Description

Current

Current item Countdown: Countdown to the end of current 
on-air template.
Current item Slug: Name of the current item, as media 
content name or Mosart template name (if media content 
name is unavailable).
Current Rundown out: TBC
Current Story count Down: Countdown to the end of the 
current story, as defined by planned story duration given in 
the NRCS.
Current Story count Down - Background: Background color 
for the "Current Story count Down" timer.
When the countdown reaches 00:00 it changes to red color 
(indicating a story going over time). To be used in the same 
position/frame as the "Current Story count Down". The 
Background has to be added first, and then the actual Story 
countdown.
Current Story Name: Name of the story currently on-air.
Current story planned Duration: The editorial story time 
entered in the NRCS. Also shown in the rundown as a small 
tick: 

Current item Time: How long the current item has been on-
air.
Current Story Time: How long the current story has been on 
air.
Current video server Channel: When a clip is on-air, this is 
the name of the video server port in use, as given in the 
Alias field in Video server port configuration in AV 
Automation (or Name if Alias is empty).
Current graphics Channel: When a full screen graphic is on-
air, this is the Engine number used, from the list of Engines 
enabled in 'Graphics configuration' in AV Automation.
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Element Description

Next Next Break Time: Clock time for the next Break story in 
the on-air rundown, as defined in the NRCS (as "back-
time", "hard hit time" or equivalent for the Break story).
Next item Duration: The duration of the next item to go 
on-air, currently cued in preview.
Next item Slug: Same as "Current item Slug", but for the 
item in preview. 
Next Story Name: Name of the next story to go on-air.
Next video server Channel: If the next template includes a 
clip, this will indicate on what video server channel it is 
cued. Channel details are provided in the Alias field in 
'Video server port configuration' in AV Automation (or 
from Name if Alias is empty).
Next graphics Channel: If the next template includes a 
full screen graphic, this will show what Engine number 
the graphic is cued on, from the list of Engines enabled in 
'Graphics configuration' in AV Automation.
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Element Description

Rundown Rundown elapsed Time: How long the show has been 
running, counting up since the first Take Next after 
loading/re-loading the rundown.
Rundown Name: For a MOS-based NRCS, the rundown 
name comes from the NRCS. For iNews the name comes 
from the Name column in the Edit rundowns editor in the 
Viz Mosart GUI.
Rundown Over/Under: How much the current rundown is 
either over or under time to match the clock time given in 
the NRCS for the next Break in the rundown.
Remaining content time is calculated from the sum of all 
planned story durations as given in the NRCS (see Current 
story planned Duration above), for all stories before the 
next scheduled Break story.
"Under time" is indicated as a negative time (for example, 
-01:23).
"Over time" is indicated with a plus (for example, 
+01:23). 
Rundown Over/Under - Background: Background color for 
the "Rundown Over/Under" timer. When the rundown is 
under on time, the background will be grey, while it will 
be red when the rundown is over on time.
To be used in the same position/frame as the "Rundown 
Over/Under". The Background has to be added first, and 
then the actual "Rundown Over/Under" timer.
Rundown Out Over/Under: TBC

Story Recorder Story Recorder - Preroll countdown: Time (in seconds) 
after a paused show will begin recording again.
Story Recorder - Recording Time: Total duration of 
recorded show, so far. Grows from the first taken item, 
and does not include any initial Break items.
Story Recorder countdown: Remaining time of show, 
based on planned show duration provided from the NRCS.
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Element Description

Other Time of Day: Current time of day, coming from the active 
Mosart server's local time.
Time to next break: Count down to next break calculated 
from current Time of Day and defined Time of Day for 
next break, as provided by the NRCS (this last can also be 
a calculation of in-time plus show duration).
The story defined as Break story must hold a Mosart 
Break template for this time to be correct.
Time to rundown out: TBC
Duration to next Break: Countdown to next break, as 
accumulated time of all planned story durations between 
current position and the story defined as Next Break.
Duration to current rundown out: Countdown to the last 
break of current active rundown, as accumulated time of 
all planned story durations, between the current position 
and the story defined as last break.
Server Description: The server description setting in 
Manus Admin settings for the current, active Mosart 
server.

7.1.3 Audio Countdown
The Timing Display also has a customizable audio countdown utility.

Can be connected to an in house intercom system or a direct monitor speaker in the control 
room or studio floor. 
Can be enabled to count on certain events. 
Viz Mosart provides an English voice set for use with the Timing Display.
You may decide to localize the voice set by recording your own.
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